[lfs-fr] r6756 - in trunk/blfs: general/genlib general/genutils general/graphlib general/prog general/sysutils introduction/welcome lxde/apps multimedia/libdriv multimedia/videoutils networking/connect networking/netprogs networking/netutils postlfs/config postlfs/editors postlfs/filesystems postlfs/security pst/printing pst/ps pst/typesetting server/databases server/mail server/major x/installing x/lib x/wm xfce/core xsoft/graphweb xsoft/office xsoft/other

myou72 at orange.fr myou72 at orange.fr
Jeu 19 Fév 04:15:49 PST 2015


Author: myou72
Date: 2015-02-19 04:15:49 -0800 (Thu, 19 Feb 2015)
New Revision: 6756

Modified:
   trunk/blfs/general/genlib/dbus-glib.xml
   trunk/blfs/general/genlib/glib2.xml
   trunk/blfs/general/genlib/libiodbc.xml
   trunk/blfs/general/genlib/libxml2.xml
   trunk/blfs/general/genlib/lzo.xml
   trunk/blfs/general/genlib/nspr.xml
   trunk/blfs/general/genutils/tree.xml
   trunk/blfs/general/graphlib/babl.xml
   trunk/blfs/general/graphlib/jasper.xml
   trunk/blfs/general/graphlib/librsvg.xml
   trunk/blfs/general/graphlib/poppler.xml
   trunk/blfs/general/prog/cmake.xml
   trunk/blfs/general/prog/dejagnu.xml
   trunk/blfs/general/prog/gdb.xml
   trunk/blfs/general/prog/git.xml
   trunk/blfs/general/prog/llvm.xml
   trunk/blfs/general/prog/lua.xml
   trunk/blfs/general/prog/mercurial.xml
   trunk/blfs/general/prog/openjdk.xml
   trunk/blfs/general/prog/php.xml
   trunk/blfs/general/prog/swig.xml
   trunk/blfs/general/sysutils/bluez.xml
   trunk/blfs/general/sysutils/colord.xml
   trunk/blfs/general/sysutils/dbus.xml
   trunk/blfs/introduction/welcome/changelog.xml
   trunk/blfs/lxde/apps/lxterminal.xml
   trunk/blfs/multimedia/libdriv/alsa-lib.xml
   trunk/blfs/multimedia/libdriv/alsa-plugins.xml
   trunk/blfs/multimedia/libdriv/libdvdnav.xml
   trunk/blfs/multimedia/libdriv/libdvdread.xml
   trunk/blfs/multimedia/libdriv/pulseaudio.xml
   trunk/blfs/multimedia/libdriv/sdl.xml
   trunk/blfs/multimedia/libdriv/xine-lib.xml
   trunk/blfs/multimedia/videoutils/ffmpeg.xml
   trunk/blfs/multimedia/videoutils/vlc.xml
   trunk/blfs/networking/connect/dhcpcd.xml
   trunk/blfs/networking/netprogs/bridgeutils.xml
   trunk/blfs/networking/netprogs/cifsutils.xml
   trunk/blfs/networking/netprogs/nfs-utils.xml
   trunk/blfs/networking/netprogs/ntp.xml
   trunk/blfs/networking/netprogs/rsync.xml
   trunk/blfs/networking/netprogs/samba.xml
   trunk/blfs/networking/netutils/avahi.xml
   trunk/blfs/networking/netutils/mod_dnssd.xml
   trunk/blfs/networking/netutils/nmap.xml
   trunk/blfs/networking/netutils/wicd.xml
   trunk/blfs/networking/netutils/wireshark.xml
   trunk/blfs/postlfs/config/profile.xml
   trunk/blfs/postlfs/editors/bluefish.xml
   trunk/blfs/postlfs/editors/vim.xml
   trunk/blfs/postlfs/filesystems/lvm2.xml
   trunk/blfs/postlfs/filesystems/mdadm.xml
   trunk/blfs/postlfs/security/consolekit.xml
   trunk/blfs/postlfs/security/gnutls.xml
   trunk/blfs/postlfs/security/mitkrb.xml
   trunk/blfs/postlfs/security/nss.xml
   trunk/blfs/postlfs/security/openssl.xml
   trunk/blfs/postlfs/security/stunnel.xml
   trunk/blfs/postlfs/security/sudo.xml
   trunk/blfs/pst/printing/cups-filters.xml
   trunk/blfs/pst/printing/cups.xml
   trunk/blfs/pst/ps/enscript.xml
   trunk/blfs/pst/typesetting/texlive-pass1.xml
   trunk/blfs/pst/typesetting/texlive.xml
   trunk/blfs/pst/typesetting/typesetting.xml
   trunk/blfs/pst/typesetting/xindy.xml
   trunk/blfs/server/databases/mariadb.xml
   trunk/blfs/server/databases/postgresql.xml
   trunk/blfs/server/databases/sqlite.xml
   trunk/blfs/server/mail/exim.xml
   trunk/blfs/server/mail/postfix.xml
   trunk/blfs/server/major/apache.xml
   trunk/blfs/x/installing/mesalib.xml
   trunk/blfs/x/installing/x7app.xml
   trunk/blfs/x/installing/x7driver-ati.xml
   trunk/blfs/x/installing/x7driver-intel.xml
   trunk/blfs/x/installing/x7driver-vmware.xml
   trunk/blfs/x/installing/x7driver.xml
   trunk/blfs/x/installing/x7lib.xml
   trunk/blfs/x/installing/xorg-server.xml
   trunk/blfs/x/lib/cairo.xml
   trunk/blfs/x/lib/fltk.xml
   trunk/blfs/x/lib/gtk+3.xml
   trunk/blfs/x/lib/libnotify.xml
   trunk/blfs/x/lib/qt5.xml
   trunk/blfs/x/lib/webkitgtk26.xml
   trunk/blfs/x/wm/fluxbox.xml
   trunk/blfs/x/wm/openbox.xml
   trunk/blfs/xfce/core/thunar.xml
   trunk/blfs/xsoft/graphweb/firefox.xml
   trunk/blfs/xsoft/graphweb/seamonkey.xml
   trunk/blfs/xsoft/office/libreoffice.xml
   trunk/blfs/xsoft/other/asymptote.xml
   trunk/blfs/xsoft/other/feh.xml
   trunk/blfs/xsoft/other/fontforge.xml
   trunk/blfs/xsoft/other/gparted.xml
   trunk/blfs/xsoft/other/hexchat.xml
   trunk/blfs/xsoft/other/inkscape.xml
   trunk/blfs/xsoft/other/other.xml
   trunk/blfs/xsoft/other/thunderbird.xml
   trunk/blfs/xsoft/other/tigervnc.xml
Log:
synchro screen

Modified: trunk/blfs/general/genlib/dbus-glib.xml
===================================================================
--- trunk/blfs/general/genlib/dbus-glib.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/genlib/dbus-glib.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -83,7 +83,9 @@
        
     </para>
 <screen>
-<userinput>./configure --prefix=/usr                 --sysconfdir=/etc             --disable-static &&
+<userinput>./configure --prefix=/usr     \
+            --sysconfdir=/etc \
+            --disable-static &&
 make</userinput>
 </screen>
     <para>

Modified: trunk/blfs/general/genlib/glib2.xml
===================================================================
--- trunk/blfs/general/genlib/glib2.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/genlib/glib2.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -113,8 +113,6 @@
       <option>--with-python=python3</option>: Ajoutez ce paramètre si vous voulez que
      GLib utilise Python3 au lieu de Python2.
     </para>
-
-
   </sect2>
   <sect2 role="content">
     <title>Contenu</title>

Modified: trunk/blfs/general/genlib/libiodbc.xml
===================================================================
--- trunk/blfs/general/genlib/libiodbc.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/genlib/libiodbc.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -59,7 +59,11 @@
     <para>Installez <application>libiodbc</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr                               --with-iodbc-inidir=/etc/iodbc              --includedir=/usr/include/iodbc             --disable-libodbc                           --disable-static                &&
+<userinput>./configure --prefix=/usr                   \
+            --with-iodbc-inidir=/etc/iodbc  \
+            --includedir=/usr/include/iodbc \
+            --disable-libodbc               \
+            --disable-static                &&
 make</userinput>
 </screen>
     <para>Ce paquet n'a pas de suite de tests</para>

Modified: trunk/blfs/general/genlib/libxml2.xml
===================================================================
--- trunk/blfs/general/genlib/libxml2.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/genlib/libxml2.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -116,7 +116,6 @@
       <option>--with-python=/usr/bin/python3</option>: Ajoutez ce paramètre si vous voulez que 
       libxml2 utilise Python3 au lieu de Python2.
     </para>
-
   </sect2>
   <sect2 role="content">
     <title>Contenu</title>

Modified: trunk/blfs/general/genlib/lzo.xml
===================================================================
--- trunk/blfs/general/genlib/lzo.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/genlib/lzo.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -55,7 +55,10 @@
     <para>Installez <application>lzo</application> en lançant
     les commandes suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr                                --enable-shared                              --disable-static                             --docdir=/usr/share/doc/lzo-&lzo-version; &&
+<userinput>./configure --prefix=/usr                    \
+            --enable-shared                  \
+            --disable-static                 \
+            --docdir=/usr/share/doc/lzo-&lzo-version; &&
 make</userinput>
 </screen>
     <para>Pour tester les résultats, lancez : <command>make check</command>. Tous les

Modified: trunk/blfs/general/genlib/nspr.xml
===================================================================
--- trunk/blfs/general/genlib/nspr.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/genlib/nspr.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -56,9 +56,12 @@
     suivantes :</para>
 <screen>
 <userinput>cd nspr                                                     &&
-sed -ri 's#^(RELEASE_BINS =).*#1#' pr/src/misc/Makefile.in &&
+sed -ri 's#^(RELEASE_BINS =).*#\1#' pr/src/misc/Makefile.in &&
 sed -i 's#$(LIBRARY) ##' config/rules.mk                    &&
-./configure --prefix=/usr             --with-mozilla             --with-pthreads             $([ $(uname -m) = x86_64 ] && echo --enable-64bit) &&
+./configure --prefix=/usr \
+            --with-mozilla \
+            --with-pthreads \
+            $([ $(uname -m) = x86_64 ] && echo --enable-64bit) &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>

Modified: trunk/blfs/general/genutils/tree.xml
===================================================================
--- trunk/blfs/general/genutils/tree.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/genutils/tree.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -59,7 +59,8 @@
     <para>Ce paquet n'a pas de suite de tests.</para>
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
-<userinput>make MANDIR=/usr/share/man/man1 install</userinput>
+<userinput>make MANDIR=/usr/share/man/man1 install &&
+chmod -v 644 /usr/share/man/man1/tree.1</userinput>
 </screen>
   </sect2>
   <sect2 role="content">

Modified: trunk/blfs/general/graphlib/babl.xml
===================================================================
--- trunk/blfs/general/graphlib/babl.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/graphlib/babl.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -6,8 +6,6 @@
   <!ENTITY babl-download-http
   "http://download.gimp.org/pub/babl/0.1/babl-&babl-version;.tar.bz2">
   <!ENTITY babl-download-ftp " ">
-<!--  <!ENTITY babl-download-ftp
-  "ftp://ftp.gimp.org/pub/babl/0.1/babl-&babl-version;.tar.bz2">-->
   <!ENTITY babl-md5sum        "50c8d12cdf5b3991590fa6cba16218a0">
   <!ENTITY babl-size          "628 Ko">
   <!ENTITY babl-buildsize     "12 Mo">
@@ -61,7 +59,7 @@
     <para>Installez <application>babl</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr &&
+<userinput>./configure --prefix=/usr --disable-docs &&
 make</userinput>
 </screen>
     <para>Pour tester les résultats, lancez : <command>make check</command>.</para>
@@ -99,7 +97,6 @@
           /usr/lib/babl-0.1 et
           /usr/share/gtk-doc/html/babl
         </seg>
-
       </seglistitem>
     </segmentedlist>
     <variablelist>

Modified: trunk/blfs/general/graphlib/jasper.xml
===================================================================
--- trunk/blfs/general/graphlib/jasper.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/graphlib/jasper.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -77,7 +77,7 @@
 répertoire jasper-&jasper-version; quand vous le dézipperez.</para>
 </note>
 <screen>
-<userinput>patch -Np1 -i ../jasper-&jasper-version;-security_fixes-1.patch &&
+<userinput>patch -Np1 -i ../jasper-&jasper-version;-security_fixes-2.patch &&
 ./configure --prefix=/usr    \
             --enable-shared  \
             --disable-static \

Modified: trunk/blfs/general/graphlib/librsvg.xml
===================================================================
--- trunk/blfs/general/graphlib/librsvg.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/graphlib/librsvg.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -76,8 +76,7 @@
     <para>Installez <application>librsvg</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr \
-            --enable-vala \
+<userinput>./configure --prefix=/usr    \
             --disable-static &&
 make</userinput>
 </screen>
@@ -91,8 +90,6 @@
     <title>Explication des commandes</title>
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/static-libraries.xml"/>
-
-
     <para>
       <option>--enable-vala</option>: Ce paramètre active
       la construction des liaisons Vala. utilisez ce paramètre si vous avez installé

Modified: trunk/blfs/general/graphlib/poppler.xml
===================================================================
--- trunk/blfs/general/graphlib/poppler.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/graphlib/poppler.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -107,7 +107,8 @@
       pas de répertoire  ../test.
     </para>
 <screen>
-<userinput>git clone git://git.freedesktop.org/git/poppler/test ../test</userinput>
+<userinput>rm -rf testfiles &&
+git clone git://git.freedesktop.org/git/poppler/test testfiles</userinput>
 </screen>
     <note>
       <para>
@@ -116,10 +117,15 @@
       versions de Qt d'installées, vous devez spécifier laquelle utiliser avant
       d'exécuter la commande <command>configure</command> donnée avant. Utiliser cette commande
       pour lier à Qt4.
-      <screen><userinput>source /usr/bin/setqt4</userinput></screen>
-
+      
+<screen>
+<userinput>source /usr/bin/setqt4</userinput>
+</screen>
     ou pour utiliser Qt5:
-      <screen><userinput>source /usr/bin/setqt5</userinput></screen>
+      
+<screen>
+<userinput>source /usr/bin/setqt5</userinput>
+</screen>
       si vous voulez que <application>Poppler</application> soit lié aux deux versions de Qt, 
       vous devez le construire deux fois.
     </para></note>
@@ -129,8 +135,11 @@
       suivantes :
     </para>
 <screen>
-<userinput>[ -e /usr/bin/setqt4 ] && source setqt4 || [ ! -e /usr/bin/setqt5 ] &&
-./configure --prefix=/usr                 --sysconfdir=/etc             --disable-static              --enable-xpdf-headers &&
+<userinput>./configure --prefix=/usr         \
+            --sysconfdir=/etc     \
+            --disable-static      \
+            --enable-xpdf-headers \
+            --with-testdatadir=$PWD/testfiles &&
 make</userinput>
 </screen>
     <para>Pour tester les résultats, tapez : <command>make check</command>.
@@ -146,27 +155,24 @@
       Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem>:
     </para>
 <screen role="root">
-<userinput>make install</userinput>
+<userinput>install -v -m755 -d        /usr/share/doc/poppler-&poppler-version; &&
+install -v -m644 README*   /usr/share/doc/poppler-&poppler-version; &&
+cp -vr glib/reference/html /usr/share/doc/poppler-&poppler-version;</userinput>
 </screen>
     <para>
      Pour installer la documentaiton, lancez les commandes suivantes en tant que  <systemitem class="username">root</systemitem>:
     </para>
-<screen role="root">
-<userinput>install -v -m755 -d        /usr/share/doc/poppler-&poppler-version; &&
-install -v -m644 README*   /usr/share/doc/poppler-&poppler-version; &&
-cp -vr glib/reference/html /usr/share/doc/poppler-&poppler-version;</userinput>
+<screen>
+<userinput>tar -xf ../poppler-data-&poppler-data-version;.tar.gz &&
+cd poppler-data-&poppler-data-version;</userinput>
 </screen>
 <bridgehead renderas="sect3">Donnée Poppler</bridgehead>
     <para>Si vous avez téléchargé le paquet d'encodage de données supplémentaires,
     installez-le en utilisant les commandes suivantes  en tant qu'utilisateur  <systemitem class="username">root</systemitem>:</para>
-<screen>
-<userinput>tar -xf ../poppler-data-&poppler-data-version;.tar.gz &&
-cd poppler-data-&poppler-data-version;</userinput>
-</screen>
-    <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
 <userinput>make prefix=/usr install</userinput>
 </screen>
+    <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
   </sect2>
   <sect2 role="commands">
     <title>Explication des commandes</title>
@@ -182,19 +188,15 @@
       <option>--with-testdatadir=$PWD/testfiles</option>: Indique aux programmes de tests
       ou les fichiers auxiliaires sont placés.
     </para>
-
     <para>
       <option>--enable-libcurl</option>: Utilise libcurl pour le support HTTP.
     </para>
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/gtk-doc-rebuild.xml"/>
-
     <para>
       <command>LC_ALL=en_US.UTF-8 make check</command>: Lance la suite de tests. La variable d'environnement
       LC_ALL=en_US.UTF-8 est seulement nécessaire si la locale par défaut n'inclus pas l'UTF-8.
     </para>
-
-
   </sect2>
   <sect2 role="content">
     <title>Contenu</title>

Modified: trunk/blfs/general/prog/cmake.xml
===================================================================
--- trunk/blfs/general/prog/cmake.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/prog/cmake.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -79,7 +79,10 @@
     <para>Installez <application>CMake</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./bootstrap --prefix=/usr                   --system-libs                   --mandir=/share/man             --docdir=/share/doc/cmake-&cmake-version;   &&
+<userinput>./bootstrap --prefix=/usr       \
+            --system-libs       \
+            --mandir=/share/man \
+            --docdir=/share/doc/cmake-&cmake-version; &&
 make</userinput>
 </screen>
     <para>

Modified: trunk/blfs/general/prog/dejagnu.xml
===================================================================
--- trunk/blfs/general/prog/dejagnu.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/prog/dejagnu.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -76,7 +76,8 @@
 <screen role="root">
 <userinput>make install &&
 install -v -dm755   /usr/share/doc/dejagnu-&dejagnu-version; &&
-install -v -m644    doc/dejagnu.{html,txt}                     /usr/share/doc/dejagnu-&dejagnu-version;</userinput>
+install -v -m644    doc/dejagnu.{html,txt} \
+                    /usr/share/doc/dejagnu-&dejagnu-version;</userinput>
 </screen>
   </sect2>
   <sect2 role="content">

Modified: trunk/blfs/general/prog/gdb.xml
===================================================================
--- trunk/blfs/general/prog/gdb.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/prog/gdb.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -68,14 +68,13 @@
 <userinput>./configure --prefix=/usr --with-system-readline &&
 make</userinput>
 </screen>
-
      <para>
       Facultativement, pour construire la documentation de l'API en utilisant
       <xref linkend="doxygen"/>, lancez:
     </para>
-<screen><userinput>make -C gdb/doc doxy</userinput></screen>
-
-
+<screen>
+<userinput>make -C gdb/doc doxy</userinput>
+</screen>
     <para>Pour tester les résultats, lancez : <command>make -k check</command>.
       Il y a beaucoup de problèmes avec la suite de tests. En fonction des compilateurs installés,
       il y a des différences s'ils sont lancés en local ou à distance, un grand nombre de temps dépassés
@@ -87,14 +86,14 @@
 <screen role="root">
 <userinput>make -C gdb install</userinput>
 </screen>
-
     <para>
       si vous avez construit la documentation de l'API, c'est maintenant dans gdb/doc/doxy. Vous pouvez l'installer
      (en tant qu'utilisateur <systemitem class="username">root</systemitem>:)
     </para>
-<screen role="root"><userinput>install -d /usr/share/doc/gdb-&gdb-version; &&
-cp -Rv gdb/doc/doxy /usr/share/doc/gdb-&gdb-version;</userinput></screen>
-
+<screen role="root">
+<userinput>install -d /usr/share/doc/gdb-&gdb-version; &&
+cp -Rv gdb/doc/doxy /usr/share/doc/gdb-&gdb-version;</userinput>
+</screen>
   </sect2>
   <sect2 role="content">
     <title>Contenu</title>

Modified: trunk/blfs/general/prog/git.xml
===================================================================
--- trunk/blfs/general/prog/git.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/prog/git.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -100,7 +100,7 @@
     <para>Installez <application>Git</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr                     --with-gitconfig=/etc/gitconfig &&
+<userinput>./configure --prefix=/usr --with-gitconfig=/etc/gitconfig &&
 make</userinput>
 </screen>
      <para>
@@ -145,15 +145,17 @@
     <para>Si vous avez téléchargé les pages de manuel déballez les en tant qu'utilisateur
     <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
-<userinput>tar -xf ../git-manpages-&git-version;.tar.xz     -C /usr/share/man --no-same-owner --no-overwrite-dir</userinput>
+<userinput>tar -xf ../git-manpages-&git-version;.tar.xz \
+    -C /usr/share/man --no-same-owner --no-overwrite-dir</userinput>
 </screen>
     <para>Si vous avez téléchargé les documentations HTML déballez les en tant qu'utilisateur
     <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
 <userinput>mkdir -vp   /usr/share/doc/git-&git-version; &&
-tar   -xf   ../git-htmldocs-&git-version;.tar.xz       -C    /usr/share/doc/git-&git-version; --no-same-owner --no-overwrite-dir &&
-find        /usr/share/doc/git-&git-version; -type d -exec chmod 755 {} ; &&
-find        /usr/share/doc/git-&git-version; -type f -exec chmod 644 {} ;</userinput>
+tar   -xf   ../git-htmldocs-&git-version;.tar.xz \
+      -C    /usr/share/doc/git-&git-version; --no-same-owner --no-overwrite-dir &&
+find        /usr/share/doc/git-&git-version; -type d -exec chmod 755 {} \; &&
+find        /usr/share/doc/git-&git-version; -type f -exec chmod 644 {} \;</userinput>
 </screen>
    <bridgehead renderas="sect3">Reorganisez les pages de man et.ou les docs html (pour les deux méthodes)</bridgehead>
     <para>

Modified: trunk/blfs/general/prog/llvm.xml
===================================================================
--- trunk/blfs/general/prog/llvm.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/prog/llvm.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -143,8 +143,15 @@
       Installez <application>LLVM</application> en lançant les commandes suivantes :
     </para>
 <screen>
-<userinput>sed -e "s:/docs/llvm:/share/doc/llvm-&llvm-version;:"     -i Makefile.config.in &&
-CC=gcc CXX=g++                         ./configure --prefix=/usr                          --sysconfdir=/etc                      --enable-libffi                        --enable-optimized                     --enable-shared                        --disable-assertions       &&
+<userinput>sed -e "s:/docs/llvm:/share/doc/llvm-&llvm-version;:" \
+    -i Makefile.config.in &&
+CC=gcc CXX=g++                   \
+./configure --prefix=/usr        \
+            --sysconfdir=/etc    \
+            --enable-libffi      \
+            --enable-optimized   \
+            --enable-shared      \
+            --disable-assertions &&
 make</userinput>
 </screen>
     <para>

Modified: trunk/blfs/general/prog/lua.xml
===================================================================
--- trunk/blfs/general/prog/lua.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/prog/lua.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -97,7 +97,8 @@
       Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :
     </para>
 <screen role="root">
-<userinput>make INSTALL_TOP=/usr TO_LIB="liblua.so liblua.so.5.2 liblua.so.&lua-version;"      INSTALL_DATA="cp -d" INSTALL_MAN=/usr/share/man/man1 install &&
+<userinput>make INSTALL_TOP=/usr TO_LIB="liblua.so liblua.so.5.3 liblua.so.&lua-version;" \
+     INSTALL_DATA="cp -d" INSTALL_MAN=/usr/share/man/man1 install &&
 mkdir -pv /usr/share/doc/lua-&lua-version; &&
 cp -v doc/*.{html,css,gif,png} /usr/share/doc/lua-&lua-version;</userinput>
 </screen>
@@ -106,7 +107,7 @@
     <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
 <userinput>cat > /usr/lib/pkgconfig/lua.pc << "EOF"
-<literal>V=5.2
+<literal>V=5.3
 R=&lua-version;
 prefix=/usr
 INSTALL_BIN=${prefix}/bin

Modified: trunk/blfs/general/prog/mercurial.xml
===================================================================
--- trunk/blfs/general/prog/mercurial.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/prog/mercurial.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -97,7 +97,8 @@
   test-parse-date.t</literal>
 EOF
 rm -rf tests/tmp &&
-TESTFLAGS="-j<replaceable><N></replaceable> --tmpdir tmp --blacklist blacklists/failed-tests" make check</userinput>
+TESTFLAGS="-j<replaceable><N></replaceable> --tmpdir tmp --blacklist blacklists/failed-tests" \
+make check</userinput>
 </screen>
     <para>Ou <replaceable><N></replaceable> est un nombre entier entre un et le nombre de  coeurs du processeur.
      Afin de pouvoir investiguer un test échouant en particulier, par exemple <quote>test-parse-date.t</quote>

Modified: trunk/blfs/general/prog/openjdk.xml
===================================================================
--- trunk/blfs/general/prog/openjdk.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/prog/openjdk.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -35,8 +35,6 @@
   <!ENTITY jtreg-version             "4.1-b10">
   <!ENTITY jtreg-download            "https://adopt-openjdk.ci.cloudbees.com/job/jtreg/lastStableBuild/artifact/jtreg&jtreg-version;.tar.gz">
   <!ENTITY jtreg-md5sum              "2e112b5863c777426fbbbadeeb9972e1">
-<!-- The md5sum varies, because people at adopt-openjdk rebuild the package
-without changing the name of the tarball -->
   <!ENTITY jtreg-size                "2.6 Mo">
   <!ENTITY icedtea-web-download      "http://icedtea.classpath.org/download/source/icedtea-web-&icedtea-web-version;.tar.gz">
   <!ENTITY ojdk-buildsize           "3.1 Go (additional 350 Mo for tests)">
@@ -261,14 +259,17 @@
       Corrigez un problème avec la nouvelle API de giflib (depuis 5.1.0):
     </para>
 <screen>
-<userinput>sed -e 's/DGifCloseFile(gif/&, NULL/'     -e '/DGifOpen/s/c)/c, NULL)/'         -i jdk/src/share/native/sun/awt/splashscreen/splashscreen_gif.c</userinput>
+<userinput>sed -e 's/DGifCloseFile(gif/&, NULL/' \
+    -e '/DGifOpen/s/c)/c, NULL)/'     \
+    -i jdk/src/share/native/sun/awt/splashscreen/splashscreen_gif.c</userinput>
 </screen>
     <para>
       corrigez un bogue dans un script shell utilisé pour initialisé les drapeaux pour
       <command>make</command>:
     </para>
 <screen>
-<userinput>sed 's/([ t])]([^])/1I]2/g'     -i hotspot/make/linux/makefiles/adjust-mflags.sh</userinput>
+<userinput>sed 's/\([ \t]\)\]\([^\]\)/\1I]\2/g' \
+    -i hotspot/make/linux/makefiles/adjust-mflags.sh</userinput>
 </screen>
     <note>
       <para>
@@ -287,7 +288,13 @@
     (la valeur --with-milestone peut être modifiée selon les préférences de l'utilisateur):</para>
 <screen>
 <userinput>unset JAVA_HOME               &&
-sh ./configure                   --with-update-version=&ojdk-upd;      --with-build-number=&ojdk-bd;       --with-milestone=BLFS         --enable-unlimited-crypto     --with-zlib=system            --with-giflib=system       &&
+sh ./configure                \
+   --with-update-version=&ojdk-upd;   \
+   --with-build-number=&ojdk-bd;    \
+   --with-milestone=BLFS      \
+   --enable-unlimited-crypto  \
+   --with-zlib=system         \
+   --with-giflib=system       &&
 make DEBUG_BINARIES=true all</userinput>
 </screen>
     <para>
@@ -301,10 +308,13 @@
   OLD_DISP=$DISPLAY
 fi
 export DISPLAY=:20
-nohup Xvfb $DISPLAY                                         -fbdir $(pwd)                                    -pixdepths 8 16 24 32 > Xvfb.out 2>&1 &
+nohup Xvfb $DISPLAY                              \
+           -fbdir $(pwd)                         \
+           -pixdepths 8 16 24 32 > Xvfb.out 2>&1 &
 echo $! > Xvfb.pid
 echo Waiting for Xvfb to initialize; sleep 1
-nohup twm -display $DISPLAY           -f /dev/null > twm.out 2>&1            &
+nohup twm -display $DISPLAY \
+          -f /dev/null > twm.out 2>&1            &
 echo $! > twm.pid
 echo Waiting for twm to initialize; sleep 1
 xhost +</userinput>
@@ -314,18 +324,19 @@
     </para>
 <screen role='nodump'>
 <userinput>echo -e "
-jdk_all = :jdk_core           \
-          :jdk_svc            \
-          :jdk_beans          \
-          :jdk_imageio        \
-          :jdk_sound          \
-          :jdk_sctp           \
-          com/sun/awt         \
-          javax/accessibility \
-          javax/print         \
-          sun/pisces          \
+jdk_all = :jdk_core           \\
+          :jdk_svc            \\
+          :jdk_beans          \\
+          :jdk_imageio        \\
+          :jdk_sound          \\
+          :jdk_sctp           \\
+          com/sun/awt         \\
+          javax/accessibility \\
+          javax/print         \\
+          sun/pisces          \\
           com/sun/java/swing" >> jdk/test/TEST.groups &&
-sed -e 's/all:.*jck.*/all: jtreg/'     -i langtools/test/Makefile</userinput>
+sed -e 's/all:.*jck.*/all: jtreg/' \
+    -i langtools/test/Makefile</userinput>
 </screen>
     <para>
       Quelques variables doivent être initialisée:
@@ -339,8 +350,15 @@
       Les tests sont lancé comme la suite:
     </para>
 <screen role='nodump'>
-<userinput>LANG=C make -k -C test                                  JT_HOME=${JT_HOME}                          JT_JAVA=${JT_JAVA}                          PRODUCT_HOME=${PRODUCT_HOME} all &&
-LANG=C ${JT_HOME}/linux/bin/jtreg -a -v:fail,error                 -dir:$(pwd)/hotspot/test                    -k:!ignore                                 -jdk:${PRODUCT_HOME}                        :jdk</userinput>
+<userinput>LANG=C make -k -C test                      \
+            JT_HOME=${JT_HOME}              \
+            JT_JAVA=${JT_JAVA}              \
+            PRODUCT_HOME=${PRODUCT_HOME} all
+LANG=C ${JT_HOME}/linux/bin/jtreg -a -v:fail,error \
+                -dir:$(pwd)/hotspot/test    \
+                -k:\!ignore                 \
+                -jdk:${PRODUCT_HOME}        \
+                :jdk</userinput>
 </screen>
     <para>
       Les résultats des tests peuvent être comparé avec ces 
@@ -359,10 +377,10 @@
 <para>Installez le paquet avec les commandes suivantes en tant qu'utilisateur
     <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
-<userinput>find build/*/images/j2sdk-image -iname *.jar -exec chmod a+r {} ; &&
+<userinput>find build/*/images/j2sdk-image -iname \*.jar -exec chmod a+r {} \; &&
 chmod a+r build/*/images/j2sdk-image/lib/ct.sym &&
-find build/*/images/j2sdk-image -iname *.diz -delete &&
-find build/*/images/j2sdk-image -iname *.debuginfo -delete &&
+find build/*/images/j2sdk-image -iname \*.diz -delete &&
+find build/*/images/j2sdk-image -iname \*.debuginfo -delete &&
 cp -R build/*/images/j2sdk-image /opt/OpenJDK-&openjdk-version; &&
 chown -R root:root /opt/OpenJDK-&openjdk-version;</userinput>
 </screen>
@@ -370,7 +388,9 @@
 correspondant à une netrée dans le menu du bureau pour <command>policytool</command>. En premier,
 vous devez obtenir un icone de <xref linkend="icedtea-web"/>:</para>
 <screen>
-<userinput>tar -xf ../icedtea-web-&icedtea-web-version;.tar.gz          icedtea-web-&icedtea-web-version;/javaws.png         --strip-components=1</userinput>
+<userinput>tar -xf ../icedtea-web-&icedtea-web-version;.tar.gz  \
+        icedtea-web-&icedtea-web-version;/javaws.png \
+        --strip-components=1</userinput>
 </screen>
 <para>
 Maintenant, en tant
@@ -501,11 +521,7 @@
 <screen role="root">
 <userinput>cat >> /etc/profile.d/extrapaths.sh << "EOF" &&
 <literal># Begin Java addition
-if ! [ -n "$MANPATH" ]; then
-  export MANPATH=:/opt/jdk/man
-else
-  pathappend /opt/jdk/man       MANPATH
-fi
+pathappend /opt/jdk/man       MANPATH
 # End Java addition</literal>
 EOF
 cat >> /etc/man_db.conf << "EOF" &&
@@ -645,31 +661,31 @@
 # Handle common errors
 if test "${CAFILE}x" == "x" -a "${CADIR}x" == "x" ; then
     echo "ERROR!  You must provide an x509 certificate store!"
-    echo "'$(basename ${0}) --help' for more info."
+    echo "\'$(basename ${0}) --help\' for more info."
     echo ""
     exit 1
 fi
 if test "${CAFILE}x" != "x" -a "${CADIR}x" != "x" ; then
     echo "ERROR!  You cannot provide two x509 certificate stores!"
-    echo "'$(basename ${0}) --help' for more info."
+    echo "\'$(basename ${0}) --help\' for more info."
     echo ""
     exit 1
 fi
 if test "${KEYTOOL}x" == "x" ; then
     echo "ERROR!  You must provide a valid keytool program!"
-    echo "'$(basename ${0}) --help' for more info."
+    echo "\'$(basename ${0}) --help\' for more info."
     echo ""
     exit 1
 fi
 if test "${OPENSSL}x" == "x" ; then
     echo "ERROR!  You must provide a valid path to openssl!"
-    echo "'$(basename ${0}) --help' for more info."
+    echo "\'$(basename ${0}) --help\' for more info."
     echo ""
     exit 1
 fi
 if test "${OUTFILE}x" == "x" ; then
     echo "ERROR!  You must provide a valid output file!"
-    echo "'$(basename ${0}) --help' for more info."
+    echo "\'$(basename ${0}) --help\' for more info."
     echo ""
     exit 1
 fi
@@ -711,7 +727,11 @@
     certbegin=`grep -n "^-----BEGIN" "${cert}" | cut -d ":" -f 1`
     certend=`grep -n "^-----END" "${cert}" | cut -d ":" -f 1`
     sed -n "${certbegin},${certend}p" "${cert}" > "${tempfile}"
-    echo yes | env LC_ALL=C "${KEYTOOL}" -import                                                              -alias `basename "${cert}"`                                          -keystore "${OUTFILE}"                                               -storepass 'changeit'                                                -file "${tempfile}"
+    echo yes | env LC_ALL=C "${KEYTOOL}" -import                     \
+                                         -alias `basename "${cert}"` \
+                                         -keystore "${OUTFILE}"      \
+                                         -storepass 'changeit'       \
+                                         -file "${tempfile}"
     rm "${tempfile}"
 done
 if test "${TEMPDIR}x" != "x" ; then
@@ -733,7 +753,11 @@
     Ensuite vous pouvez en créer un nouveau, en tant qu'utilisateur
     <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
-<userinput>/opt/jdk/bin/mkcacerts                    -d "/etc/ssl/certs/"              -k "/opt/jdk/bin/keytool"         -s "/usr/bin/openssl"             -o "/opt/jdk/jre/lib/security/cacerts"</userinput>
+<userinput>/opt/jdk/bin/mkcacerts            \
+        -d "/etc/ssl/certs/"      \
+        -k "/opt/jdk/bin/keytool" \
+        -s "/usr/bin/openssl"     \
+        -o "/opt/jdk/jre/lib/security/cacerts"</userinput>
 </screen>
     <para>Utilisez les commandes suivantes pour vérifier si le fichier
     <filename>cacerts</filename> a été installé avec succès:</para>

Modified: trunk/blfs/general/prog/php.xml
===================================================================
--- trunk/blfs/general/prog/php.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/prog/php.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -151,7 +151,26 @@
     <para>Installez <application>PHP</application> en
     lançant les commandes suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr                            --sysconfdir=/etc                        --localstatedir=/var                     --datadir=/usr/share/php                 --mandir=/usr/share/man                  --enable-fpm                             --with-fpm-user=apache                   --with-fpm-group=apache                  --with-config-file-path=/etc             --with-zlib                              --enable-bcmath                          --with-bz2                               --enable-calendar                        --enable-dba=shared                      --with-gdbm                              --with-gmp                               --enable-ftp                             --with-gettext                           --enable-mbstring                        --with-readline              &&
+<userinput>./configure --prefix=/usr                \
+            --sysconfdir=/etc            \
+            --localstatedir=/var         \
+            --datadir=/usr/share/php     \
+            --mandir=/usr/share/man      \
+            --enable-fpm                 \
+            --with-fpm-user=apache       \
+            --with-fpm-group=apache      \
+            --with-config-file-path=/etc \
+            --with-zlib                  \
+            --enable-bcmath              \
+            --with-bz2                   \
+            --enable-calendar            \
+            --enable-dba=shared          \
+            --with-gdbm                  \
+            --with-gmp                   \
+            --enable-ftp                 \
+            --with-gettext               \
+            --enable-mbstring            \
+            --with-readline              &&
 make</userinput>
 </screen>
     <para>Pour tester les résultats, lancez : <command>make test</command>.
@@ -164,9 +183,12 @@
 install -v -m644 php.ini-production /etc/php.ini     &&
 mv -v /etc/php-fpm.conf{.default,}                   &&
 install -v -m755 -d /usr/share/doc/php-&php-version; &&
-install -v -m644    CODING_STANDARDS EXTENSIONS INSTALL NEWS README* UPGRADING* php.gif                     /usr/share/doc/php-&php-version; &&
-ln -v -sfn          /usr/lib/php/doc/Archive_Tar/docs/Archive_Tar.txt                     /usr/share/doc/php-&php-version; &&
-ln -v -sfn          /usr/lib/php/doc/Structures_Graph/docs                     /usr/share/doc/php-&php-version;</userinput>
+install -v -m644    CODING_STANDARDS EXTENSIONS INSTALL NEWS README* UPGRADING* php.gif \
+                    /usr/share/doc/php-&php-version; &&
+ln -v -sfn          /usr/lib/php/doc/Archive_Tar/docs/Archive_Tar.txt \
+                    /usr/share/doc/php-&php-version; &&
+ln -v -sfn          /usr/lib/php/doc/Structures_Graph/docs \
+                    /usr/share/doc/php-&php-version;</userinput>
 </screen>
     <para>La documentation HTML précompilée est emballée sous deux formes :
     un archive tar contenant beaucoup de fichiers individuels, utile pour être
@@ -179,12 +201,14 @@
     tar ci-dessous si nécessaire).</para>
     <para>Pour le fichier <quote>Unique en HTML</quote> :</para>
 <screen role="root">
-<userinput>install -v -m644 ../php_manual_en.html.gz     /usr/share/doc/php-&php-version; &&
+<userinput>install -v -m644 ../php_manual_en.html.gz \
+    /usr/share/doc/php-&php-version; &&
 gunzip -v /usr/share/doc/php-&php-version;/php_manual_en.html.gz</userinput>
 </screen>
     <para>Pour l'archive tar <quote>beaucoup de fichiers HTML</quote> :</para>
 <screen role="root">
-<userinput>tar -xvf ../php_manual_en.tar.gz     -C /usr/share/doc/php-&php-version; --no-same-owner</userinput>
+<userinput>tar -xvf ../php_manual_en.tar.gz \
+    -C /usr/share/doc/php-&php-version; --no-same-owner</userinput>
 </screen>
   </sect2>
   <sect2 role="commands">
@@ -264,20 +288,25 @@
       <para>Si désiré, ajoutez l'entrée en utilisant la commande suivante en
       tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
-<userinput>sed -i 's at php/includes"@&ninclude_path = ".:/usr/lib/php"@'     /etc/php.ini</userinput>
+<userinput>sed -i 's at php/includes"@&\ninclude_path = ".:/usr/lib/php"@' \
+    /etc/php.ini</userinput>
 </screen>
       <para>Pour activer le support fastCGI dans un serveur web <application>Apache</application>
       , deux directives de chargement LoadModule doivent être ajoutées dans le fichier
       <filename>httpd.conf</filename>. Elles sont commentées, donc il suffit de taper la commande suivante
       en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
-<userinput>sed -i -e '/proxy_module/s/^#//'             -e '/proxy_fcgi_module/s/^#//'        /etc/httpd/httpd.conf</userinput>
+<userinput>sed -i -e '/proxy_module/s/^#//'      \
+       -e '/proxy_fcgi_module/s/^#//' \
+       /etc/httpd/httpd.conf</userinput>
 </screen>
       <para>Ces modules acceptent différentes directives <command>ProxyPass</command>.
       Une possibilité est (en tant qu'utilisateur
       <systemitem class="username">root</systemitem>):</para>
 <screen role="root">
-<userinput>echo 'ProxyPassMatch ^/(.*.php)$ fcgi://127.0.0.1:9000/srv/www/$1' >> /etc/httpd/httpd.conf</userinput>
+<userinput>echo \
+'ProxyPassMatch ^/(.*\.php)$ fcgi://127.0.0.1:9000/srv/www/$1' >> \
+/etc/httpd/httpd.conf</userinput>
 </screen>
       <para>En outre, il peut être utile d'ajouter une entrée pour
       <filename>index.php</filename> à la ligne DirectoryIndex du fichier

Modified: trunk/blfs/general/prog/swig.xml
===================================================================
--- trunk/blfs/general/prog/swig.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/prog/swig.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -102,14 +102,17 @@
     <para>
       Corrige un problème avec gccgo-4.9.2:
     </para>
-<screen><userinput>sed -i 's/".")/"_")/' -i Source/Modules/go.cxx</userinput></screen>
-
+<screen>
+<userinput>sed -e 's/"\.")/"_")/' -i Source/Modules/go.cxx</userinput>
+</screen>
     <para>
       Installez <application>SWIG</application> en lançant les commandes suivantes :
        
     </para>
 <screen>
-<userinput>./configure --prefix=/usr &&
+<userinput>./configure --prefix=/usr                      \
+            --without-clisp                    \
+            --without-maximum-compile-warnings &&
 make</userinput>
 </screen>
     <para>
@@ -139,8 +142,6 @@
       renforcée ansi du compilateur, qui génère des erreurs dans les entêtes
       <application>Lua</application> (depuis Lua 5.3).
     </para>
-
-
     <para>
       <option>--without-<language></option> : allows disabling the
       building of tests et examples for <language>, but all the

Modified: trunk/blfs/general/sysutils/bluez.xml
===================================================================
--- trunk/blfs/general/sysutils/bluez.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/sysutils/bluez.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -117,7 +117,11 @@
       commands:
     </para>
 <screen>
-<userinput>./configure --prefix=/usr                     --sysconfdir=/etc                 --localstatedir=/var              --enable-library                  --disable-systemd     &&
+<userinput>./configure --prefix=/usr         \
+            --sysconfdir=/etc     \
+            --localstatedir=/var  \
+            --enable-library      \
+            --disable-systemd     &&
 make</userinput>
 </screen>
     <para>

Modified: trunk/blfs/general/sysutils/colord.xml
===================================================================
--- trunk/blfs/general/sysutils/colord.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/sysutils/colord.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -95,12 +95,22 @@
     </para>
 <screen role="root">
 <userinput>groupadd -g 71 colord &&
-useradd -c "Color Daemon Owner" -d /var/lib/colord -u 71         -g colord -s /bin/false colord</userinput>
+useradd -c "Color Daemon Owner" -d /var/lib/colord -u 71 \
+        -g colord -s /bin/false colord</userinput>
 </screen>
     <para>Installez <application>colord</application> en lançant les commandes suivantes :
     </para>
 <screen>
-<userinput>./configure --prefix=/usr                            --sysconfdir=/etc                        --localstatedir=/var                     --with-daemon-user=colord                --enable-vala                            --enable-systemd-login=no                --disable-argyllcms-sensor               --disable-bash-completion                --disable-static                         --with-systemdsystemunitdir=no &&
+<userinput>./configure --prefix=/usr                \
+            --sysconfdir=/etc            \
+            --localstatedir=/var         \
+            --with-daemon-user=colord    \
+            --enable-vala                \
+            --enable-systemd-login=no    \
+            --disable-argyllcms-sensor   \
+            --disable-bash-completion    \
+            --disable-static             \
+            --with-systemdsystemunitdir=no &&
 make</userinput>
 </screen>
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>

Modified: trunk/blfs/general/sysutils/dbus.xml
===================================================================
--- trunk/blfs/general/sysutils/dbus.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/general/sysutils/dbus.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -80,7 +80,8 @@
     messages système :</para>
 <screen role="root">
 <userinput>groupadd -g 18 messagebus &&
-useradd -c "D-Bus Message Daemon User" -d /var/run/dbus         -u 18 -g messagebus -s /bin/false messagebus</userinput>
+useradd -c "D-Bus Message Daemon User" -d /var/run/dbus \
+        -u 18 -g messagebus -s /bin/false messagebus</userinput>
 </screen>
     <para>Installez <application>D-BUS</application> en lançant les commandes
     suivantes (vous pouvez d'abord souhaiter observer la sortie de
@@ -88,7 +89,16 @@
     à la commande <command>configure</command> affichée ci-dessous) :</para>
  
 <screen>
-<userinput>./configure --prefix=/usr                              --sysconfdir=/etc                          --localstatedir=/var                       --disable-doxygen-docs                     --disable-xml-docs                         --disable-static                           --disable-systemd                          --without-systemdsystemunitdir             --with-console-auth-dir=/run/console/             --docdir=/usr/share/doc/dbus-&dbus-version;   &&
+<userinput>./configure --prefix=/usr                  \
+            --sysconfdir=/etc              \
+            --localstatedir=/var           \
+            --disable-doxygen-docs         \
+            --disable-xml-docs             \
+            --disable-static               \
+            --disable-systemd              \
+            --without-systemdsystemunitdir \
+            --with-console-auth-dir=/run/console/ \
+            --docdir=/usr/share/doc/dbus-&dbus-version;   &&
 make</userinput>
 </screen>
     <para>Voir ci-dessous pour les instructions de test.</para>
@@ -125,7 +135,10 @@
     
 <screen>
 <userinput>make distclean                     &&
-./configure --enable-tests                     --enable-asserts                   --disable-doxygen-docs             --disable-xml-docs     &&
+./configure --enable-tests         \
+            --enable-asserts       \
+            --disable-doxygen-docs \
+            --disable-xml-docs     &&
 make                               &&
 make check</userinput>
 </screen>

Modified: trunk/blfs/introduction/welcome/changelog.xml
===================================================================
--- trunk/blfs/introduction/welcome/changelog.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/introduction/welcome/changelog.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -16,7 +16,6 @@
   <para>Version actuelle : &version; – &releasedate;</para>
   <itemizedlist>
     <title>Entrées dans l'historique des changements :</title>
-
     <listitem>
       <para>14 Février 2015</para>
       <itemizedlist>
@@ -58,7 +57,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>12 Février 2015</para>
       <itemizedlist>
@@ -72,7 +70,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>11 Février 2015</para>
       <itemizedlist>
@@ -102,7 +99,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>10 Février 2015</para>
       <itemizedlist>
@@ -220,7 +216,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>5 Février 2015</para>
       <itemizedlist>
@@ -242,7 +237,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>3 Février 2015</para>
       <itemizedlist>
@@ -260,9 +254,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
-
-
    <listitem>
       <para>2 Février 2015</para>
       <itemizedlist>
@@ -282,7 +273,6 @@
           <para>[fernando] - Passage à dhcpcd-6.7.1. Corrige
           <ulink url="&blfs-ticket-root;5970">#5970</ulink>.</para>
         </listitem>
-
         <listitem>
           <para>[fernando] - xine-lib-1.2.6: ajout de libdvdnav-5.0.3 en recommendée.</para>
         </listitem>
@@ -292,7 +282,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>1er Février 2015</para>
       <itemizedlist>
@@ -315,7 +304,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
    <listitem>
       <para>31 janvier 2015</para>
       <itemizedlist>
@@ -367,7 +355,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
    <listitem>
       <para>29 Janvier 2015</para>
       <itemizedlist>
@@ -381,7 +368,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>28 Janvier 2015</para>
       <itemizedlist>
@@ -436,8 +422,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
-
     <listitem>
       <para>26 Janvier 2015</para>
       <itemizedlist>
@@ -481,7 +465,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>25 Janvier 2015</para>
       <itemizedlist>
@@ -531,7 +514,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>22 Janvier 2015</para>
       <itemizedlist>
@@ -541,7 +523,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>21 Janvier 2015</para>
       <itemizedlist>
@@ -563,7 +544,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>19 Janvier 2015</para>
       <itemizedlist>
@@ -602,7 +582,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>17 Janvier 2015</para>
       <itemizedlist>
@@ -649,7 +628,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>16 Janvier 2015</para>
       <itemizedlist>
@@ -659,7 +637,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>15 Janvier 2015</para>
       <itemizedlist>
@@ -673,7 +650,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
   <listitem>
       <para>12 Janvier 2015</para>
       <itemizedlist>
@@ -684,7 +660,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
     <listitem>
       <para>11 Janvier 2015</para>
       <itemizedlist>
@@ -713,8 +688,6 @@
         </listitem>
       </itemizedlist>
     </listitem>
-
-
    <listitem>
       <para>10 Janvier 2015</para>
       <itemizedlist>

Modified: trunk/blfs/lxde/apps/lxterminal.xml
===================================================================
--- trunk/blfs/lxde/apps/lxterminal.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/lxde/apps/lxterminal.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -82,17 +82,16 @@
       Par défaut,  <application>LXTerminal</application> installe ses menus
       dans la catégorie Systeme. Si vous le souhaitez, changer cela pour la catégorie utilitaire:
       :</para>
-<screen><userinput>sed -i 's/System/Utility/' data/lxterminal.desktop.in</userinput></screen>
+<screen>
+<userinput>sed -i 's/System/Utility/' data/lxterminal.desktop.in</userinput>
+</screen>
     </note>
-
-
     <para>
       Installez <application>LXTerminal</application> en lançant les commandes suivantes :
        
     </para>
 <screen>
-<userinput>sed -i 's/System/Utility/' data/lxterminal.desktop.in &&
-./configure --prefix=/usr &&
+<userinput>./configure --prefix=/usr &&
 make</userinput>
 </screen>
     <para>

Modified: trunk/blfs/multimedia/libdriv/alsa-lib.xml
===================================================================
--- trunk/blfs/multimedia/libdriv/alsa-lib.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/multimedia/libdriv/alsa-lib.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -95,15 +95,15 @@
      la documentation de l'API, lancez les commandes suivantes depuis le répertoire supérieur de l'arborescence
      des sources:
    </para>
-<screen><userinput>make doc</userinput></screen>
-
+<screen>
+<userinput>make doc</userinput>
+</screen>
     <para>Pour tester les résultas, tapez : <command>make check</command>.</para>
        <para>Maintenant, en tant qu'utilisateur
     <systemitem class="username">root</systemitem> : </para>
 <screen role="root">
 <userinput>make install</userinput>
 </screen>
-
         <para>Maintenant, pour installer la documentation de l'API, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
 <userinput>install -v -d -m755 /usr/share/doc/alsa-lib-&alsa-lib-version;/html/search &&

Modified: trunk/blfs/multimedia/libdriv/alsa-plugins.xml
===================================================================
--- trunk/blfs/multimedia/libdriv/alsa-plugins.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/multimedia/libdriv/alsa-plugins.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -67,7 +67,8 @@
     <para>Installez <application>ALSA Plugins</application> en
     lançant les commandes suivantes :</para>
 <screen>
-<userinput>./configure &&
+<userinput>sed -i "/speex_preprocess/i#include <stdint.h>" speex/pcm_speex.c &&
+./configure &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>
@@ -83,7 +84,6 @@
       speex1.2rc2 est installé.
     </para>
   </sect2>
-
   <sect2 role="content">
     <title>Contenu</title>
     <segmentedlist>

Modified: trunk/blfs/multimedia/libdriv/libdvdnav.xml
===================================================================
--- trunk/blfs/multimedia/libdriv/libdvdnav.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/multimedia/libdriv/libdvdnav.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -59,7 +59,9 @@
     <para>Installez <application>libdvdnav</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr --docdir=/usr/share/doc/libdvdnav-&libdvdnav-version; &&
+<userinput>./configure --prefix=/usr    \
+            --disable-static \
+            --docdir=/usr/share/doc/libdvdnav-&libdvdnav-version; &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>
@@ -74,9 +76,6 @@
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/static-libraries.xml"/>
   </sect2>
-
-
-
   <sect2 role="content">
     <title>Contenu</title>
     <segmentedlist>

Modified: trunk/blfs/multimedia/libdriv/libdvdread.xml
===================================================================
--- trunk/blfs/multimedia/libdriv/libdvdread.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/multimedia/libdriv/libdvdread.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -54,7 +54,9 @@
     <para>Installez <application>libdvdread</application> en lançant les
     commandes suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr                --disable-static             --docdir=/usr/share/doc/libdvdread-&libdvdread-version; &&
+<userinput>./configure --prefix=/usr    \
+            --disable-static \
+            --docdir=/usr/share/doc/libdvdread-&libdvdread-version; &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>
@@ -68,7 +70,6 @@
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/static-libraries.xml"/>
   </sect2>
-
   <sect2 role="content">
     <title>Contenu</title>
     <segmentedlist>

Modified: trunk/blfs/multimedia/libdriv/pulseaudio.xml
===================================================================
--- trunk/blfs/multimedia/libdriv/pulseaudio.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/multimedia/libdriv/pulseaudio.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -101,7 +101,14 @@
     suivantes :</para>
 <screen>
 <userinput>find . -name "Makefile.in" | xargs sed -i "s|(libdir)/@PACKAGE@|(libdir)/pulse|" &&
-./configure --prefix=/usr                     --sysconfdir=/etc                 --localstatedir=/var              --disable-bluez4                  --disable-rpath                   --with-module-dir=/usr/lib/pulse/modules &&
+./configure --prefix=/usr            \
+            --sysconfdir=/etc        \
+            --localstatedir=/var     \
+            --disable-bluez4         \
+            --disable-rpath          \
+            --disable-systemd-daemon \
+            --disable-systemd-login  \
+            --with-module-dir=/usr/lib/pulse/modules &&
 make</userinput>
 </screen>
     <para>Pour tester les résultats, lancez : <command>make check</command>.</para>
@@ -191,7 +198,8 @@
         <systemitem class="username">root</systemitem>:
      </para>
 <screen role="root">
-<userinput>sed '/load-module module-console-kit/s/^/#/'                     -i /etc/pulse/default.pa</userinput>
+<userinput>sed '/load-module module-console-kit/s/^/#/' \
+                    -i /etc/pulse/default.pa</userinput>
 </screen>
       <para>
         Vous pouvez également configurer le système audio. Vous devez

Modified: trunk/blfs/multimedia/libdriv/sdl.xml
===================================================================
--- trunk/blfs/multimedia/libdriv/sdl.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/multimedia/libdriv/sdl.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -76,7 +76,7 @@
     suivantes :</para>
 <screen>
 <userinput>sed -i '/_XData32/s:register long:register _Xconst long:' src/video/x11/SDL_x11sym.h &&
-./configure --prefix=/usr --disable-static &&
+./configure --prefix=/usr --disable-static --disable-sdl-dlopen &&
 make</userinput>
 </screen>
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
@@ -111,8 +111,6 @@
       href="../../xincludes/static-libraries.xml"/>
     <para><parameter>--disable-sdl-dlopen</parameter>: Ce paramètre désactive l'utilisation de
     dlopen pour le chargement des objets partagés.</para>
-
-
   </sect2>
   <sect2 role="configuration">
     <title>Configuration de SDL</title>

Modified: trunk/blfs/multimedia/libdriv/xine-lib.xml
===================================================================
--- trunk/blfs/multimedia/libdriv/xine-lib.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/multimedia/libdriv/xine-lib.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -103,8 +103,9 @@
     <para>Installez <application>xine Libraries</application> en lançant les
     commandes suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr     \
-            --disable-vcd     \
+<userinput>./configure --prefix=/usr          \
+            --disable-vcd          \
+            --with-external-dvdnav \
             --docdir=/usr/share/doc/xine-lib-&xine-lib-version; &&
 make</userinput>
 </screen>
@@ -146,7 +147,6 @@
       <parameter>--with-external-dvdnav</parameter>: Ce paramètre est requis car les bibliothèques internes ne 
       peuvent pas décoder les DVD.
      </para>
-
     <para>
      <parameter>--docdir=/usr/share/xine-lib-&xine-lib-version;</parameter> :
     Ce paramètre provoque l'installation de la documentation dans un

Modified: trunk/blfs/multimedia/videoutils/ffmpeg.xml
===================================================================
--- trunk/blfs/multimedia/videoutils/ffmpeg.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/multimedia/videoutils/ffmpeg.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -130,7 +130,22 @@
     
 <screen>
 <userinput>sed -i 's/-lflite"/-lflite -lasound"/' configure &&
-./configure --prefix=/usr                    --enable-gpl                     --enable-version3                --enable-nonfree                 --disable-static                 --enable-shared                  --disable-debug                  --enable-libass                  --enable-libfdk-aac              --enable-libmp3lame              --enable-libtheora               --enable-libvorbis               --enable-libvpx                  --enable-libx264                 --enable-x11grab                 --docdir=/usr/share/doc/ffmpeg-&ffmpeg-version; &&
+./configure --prefix=/usr       \
+            --enable-gpl        \
+            --enable-version3   \
+            --enable-nonfree    \
+            --disable-static    \
+            --enable-shared     \
+            --disable-debug     \
+            --enable-libass     \
+            --enable-libfdk-aac \
+            --enable-libmp3lame \
+            --enable-libtheora  \
+            --enable-libvorbis  \
+            --enable-libvpx     \
+            --enable-libx264    \
+            --enable-x11grab    \
+            --docdir=/usr/share/doc/ffmpeg-&ffmpeg-version; &&
 make &&
 gcc tools/qt-faststart.c -o tools/qt-faststart</userinput>
 </screen>
@@ -141,14 +156,15 @@
       Postscript de la documentation, tapez les commandes suivantes:
     </para>
 <screen>
-<userinput>sed -i '$s/$/nn at bye/' doc/{git-howto,nut,fate}.texi             &&
-sed -i '/machine:i386/ s//@backslashchar{}/g' doc/platform.texi &&
+<userinput>sed -i '$s/$/\n\n at bye/' doc/{git-howto,nut,fate}.texi             &&
+sed -i '/machine:i386/ s/\\/@backslashchar{}/g' doc/platform.texi &&
 pushd doc &&
 for DOCNAME in `basename -s .html *.html`
 do
     texi2pdf -b $DOCNAME.texi &&
     texi2dvi -b $DOCNAME.texi &&
-    dvips -o    $DOCNAME.ps                   $DOCNAME.dvi
+    dvips -o    $DOCNAME.ps   \
+                $DOCNAME.dvi
 done                          &&
 popd                          &&
 unset DOCNAME</userinput>
@@ -165,15 +181,18 @@
 <screen role="root">
 <userinput>make install &&
 install -v -m755    tools/qt-faststart /usr/bin &&
-install -v -m644    doc/*.txt                     /usr/share/doc/ffmpeg-&ffmpeg-version;</userinput>
+install -v -m644    doc/*.txt \
+                    /usr/share/doc/ffmpeg-&ffmpeg-version;</userinput>
 </screen>
     <para>
 	Si les documentations PDF et Postscript sont construites, tapez les commandes suivantes , en 
         tant qu'utilisateur <systemitem class="username">root</systemitem> pour l'installer:
     </para>
 <screen role="root">
-<userinput>install -v -m644 doc/*.pdf                  /usr/share/doc/ffmpeg-&ffmpeg-version; &&
-install -v -m644 doc/*.ps                   /usr/share/doc/ffmpeg-&ffmpeg-version;</userinput>
+<userinput>install -v -m644 doc/*.pdf \
+                 /usr/share/doc/ffmpeg-&ffmpeg-version; &&
+install -v -m644 doc/*.ps  \
+                 /usr/share/doc/ffmpeg-&ffmpeg-version;</userinput>
 </screen>
     <para>Si vous avez utilisé <command>doxygen</command> pour créer la 
     documentation de l'API, installez-la (300 Mo d'espace en plus) en
@@ -208,7 +227,8 @@
       précédents, lancez la commande suivante:
     </para>
 <screen>
-<userinput><command>rsync -vrltLW  --delete --timeout=60 --contimeout=60       rsync://fate-suite.ffmpeg.org/fate-suite/ fate-suite/</command></userinput>
+<userinput><command>rsync -vrltLW  --delete --timeout=60 --contimeout=60 \
+      rsync://fate-suite.ffmpeg.org/fate-suite/ fate-suite/</command></userinput>
 </screen>
    </sect2>
   <sect2 role="commands">

Modified: trunk/blfs/multimedia/videoutils/vlc.xml
===================================================================
--- trunk/blfs/multimedia/videoutils/vlc.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/multimedia/videoutils/vlc.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -170,9 +170,12 @@
     </para>
 <screen>
 <userinput>sed -i 's:libsmbclient.h:samba-4.0/&:' modules/access/smb.c &&
-./bootstrap                                                 &&
-sed "s:< 56:< 57:g" -i configure                            &&
-./configure --prefix=/usr                                   &&
+./bootstrap &&
+sed "s:< 56:< 57:g" -i configure &&
+./configure --prefix=/usr        &&
+sed -i 's/luaL_optint/(int)&eger/'         modules/lua/libs/{net,osd,volume}.c             &&
+sed -i 's/luaL_checkint(/(int)luaL_checkinteger(/' \
+       modules/lua/{demux,libs/{configuration,net,osd,playlist,stream,variables,volume}}.c &&
 make</userinput>
 </screen>
     <para>Pour tester le résultat, tapez : <command>make check</command></para>
@@ -205,7 +208,6 @@
       <command>sed ... configure</command>: ce sed corrige la compilation avec
       <application>ffmpeg</application> 2.4.
     </para>
-
      <para>
       <command>sed -i ... {net,osd,volume}.c</command>: Cette commande corrige la construction avec  <application>lua</application> 5.3
 .
@@ -213,7 +215,6 @@
     <para>
       <command>sed -i ... variables,volume}}.c</command>: cette commande corrige la construction avec  <application>lua</application> 5.3.
     </para>
-
     <para>
        <option>--disable-lua</option> : Utilisez cette commande si vous n'avez pas installé
        <application>Lua</application>.</para>

Modified: trunk/blfs/networking/connect/dhcpcd.xml
===================================================================
--- trunk/blfs/networking/connect/dhcpcd.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/connect/dhcpcd.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -5,7 +5,7 @@
   %general-entities;
   <!ENTITY dhcpcd-download-http "http://roy.marples.name/downloads/dhcpcd/dhcpcd-&dhcpcd-version;.tar.bz2">
   <!ENTITY dhcpcd-download-ftp  "ftp://roy.marples.name/pub/dhcpcd/dhcpcd-&dhcpcd-version;.tar.bz2">
-  <!--<!ENTITY dhcpcd-download-ftp  "ftp://ftp.osuosl.org/pub/gentoo/distfiles/dhcpcd-&dhcpcd-version;.tar.bz2">-->
+  
   <!ENTITY dhcpcd-md5sum        "ffb716b0e9327968e7200d519e1d4c0d">
   <!ENTITY dhcpcd-size          "160 Ko">
   <!ENTITY dhcpcd-buildsize     "2.2 Mo">
@@ -62,7 +62,8 @@
     <para>Installez <application>dhcpcd</application> en lançant
     les commandes suivantes :</para>
 <screen>
-<userinput>./configure --libexecdir=/lib/dhcpcd             --dbdir=/var/tmp         &&
+<userinput>./configure --libexecdir=/lib/dhcpcd \
+            --dbdir=/var/tmp         &&
 make</userinput>
 </screen>
     <para>Ce paquet est fourni sans suite de tests.</para>

Modified: trunk/blfs/networking/netprogs/bridgeutils.xml
===================================================================
--- trunk/blfs/networking/netprogs/bridgeutils.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netprogs/bridgeutils.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -69,8 +69,7 @@
     <para>Activez les options suivantes dans la configuration du noyau et
     recompilez le noyau si nécessaire :</para>
 <screen>
-<literal>
-[*] Networking support --->            [CONFIG_NET]
+<literal>[*] Networking support --->            [CONFIG_NET]
       Networking options --->
         <*/M> 802.1d Ethernet Bridging [CONFIG_BRIDGE]</literal>
 </screen>

Modified: trunk/blfs/networking/netprogs/cifsutils.xml
===================================================================
--- trunk/blfs/networking/netprogs/cifsutils.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netprogs/cifsutils.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -81,7 +81,9 @@
     <para>Installez <application>cifs-utils</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr             --disable-pam             --disable-systemd &&
+<userinput>./configure --prefix=/usr \
+            --disable-pam \
+            --disable-systemd &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>

Modified: trunk/blfs/networking/netprogs/nfs-utils.xml
===================================================================
--- trunk/blfs/networking/netprogs/nfs-utils.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netprogs/nfs-utils.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -94,7 +94,8 @@
     <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
 <userinput>groupadd -g 99 nogroup &&
-useradd -c "Unprivileged Nobody" -d /dev/null -g nogroup     -s /bin/false -u 99 nobody</userinput>
+useradd -c "Unprivileged Nobody" -d /dev/null -g nogroup \
+    -s /bin/false -u 99 nobody</userinput>
 </screen>
     <note>
       <para>Les valeurs d'uid et de gid classiques sont 65534, ce qui signifie
@@ -113,7 +114,11 @@
     <para>Installez <application>NFS Utilities</application> en lançant 
     les commandes suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr                      --sysconfdir=/etc                  --without-tcp-wrappers             --disable-nfsv4                    --disable-gss &&
+<userinput>./configure --prefix=/usr          \
+            --sysconfdir=/etc      \
+            --without-tcp-wrappers \
+            --disable-nfsv4        \
+            --disable-gss &&
 make</userinput>
 </screen>
     <para>Si votre répertoire <filename class="directory">/usr</filename> est
@@ -150,12 +155,11 @@
       <filename class="directory">/home</filename> via le réseau local,
       vous pouvez ajouter la ligne suivante :</para>
 <screen role="root">
-<userinput>/home <replaceable><192.168.0.0/24></replaceable>(rw,subtree_check,anonuid=99,anongid=99)</userinput>
+<userinput>/home <replaceable>192.168.0.0/24</replaceable>(rw,subtree_check,anonuid=99,anongid=99)</userinput>
 </screen>
       <note><para>Soyez certain de remplacer le répertoire, l'adresse réseau et le préfixe pour correspondre à
       votre réseau. Le seul espace dans la ligne dessus doit être entre le répertoire et l'adresse réseau.
      </para></note>
-
       <indexterm zone="nfs-utils nfs-utils-server-config">
         <primary sortas="e-etc-exportfs">/etc/exportfs</primary>
       </indexterm>

Modified: trunk/blfs/networking/netprogs/ntp.xml
===================================================================
--- trunk/blfs/networking/netprogs/ntp.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netprogs/ntp.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -4,7 +4,6 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
   <!ENTITY ntp-download-http "https://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/ntp-&ntp-version;.tar.gz">
-<!--  <!ENTITY ntp-download-ftp  "&gentoo-ftp-repo;/ntp-&ntp-version;.tar.gz">-->
   <!ENTITY ntp-download-ftp  " ">
   <!ENTITY ntp-md5sum        "65d8cdfae4722226fbe29863477641ed">
   <!ENTITY ntp-size          "6.5 Mo">
@@ -70,13 +69,19 @@
     </para>
 <screen role="root">
 <userinput>groupadd -g 87 ntp &&
-useradd -c "Network Time Protocol" -d /var/lib/ntp -u 87         -g ntp -s /bin/false ntp</userinput>
+useradd -c "Network Time Protocol" -d /var/lib/ntp -u 87 \
+        -g ntp -s /bin/false ntp</userinput>
 </screen>
  
     <para>Installez <application>ntp</application> en lançant
     les commandes suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr                     --bindir=/usr/sbin                --sysconfdir=/etc                 --enable-linuxcaps                --with-lineeditlibs=readline             --docdir=/usr/share/doc/ntp-&ntp-version; &&
+<userinput>./configure --prefix=/usr         \
+            --bindir=/usr/sbin    \
+            --sysconfdir=/etc     \
+            --enable-linuxcaps    \
+            --with-lineeditlibs=readline \
+            --docdir=/usr/share/doc/ntp-&ntp-version; &&
 make</userinput>
 </screen>
     <para>Pour tester les résultats, lancez : <command>make check</command>.</para>

Modified: trunk/blfs/networking/netprogs/rsync.xml
===================================================================
--- trunk/blfs/networking/netprogs/rsync.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netprogs/rsync.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -66,7 +66,8 @@
     <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
 <userinput>groupadd -g 48 rsyncd &&
-useradd -c "rsyncd Daemon" -d /home/rsync -g rsyncd     -s /bin/false -u 48 rsyncd</userinput>
+useradd -c "rsyncd Daemon" -d /home/rsync -g rsyncd \
+    -s /bin/false -u 48 rsyncd</userinput>
 </screen>
     <para>Installez <application>rsync</application> en lançant les commandes
     suivantes :</para>

Modified: trunk/blfs/networking/netprogs/samba.xml
===================================================================
--- trunk/blfs/networking/netprogs/samba.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netprogs/samba.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -93,12 +93,20 @@
 	suivantes :</para>
       
 <screen>
-<userinput>./configure                                 --prefix=/usr                           --sysconfdir=/etc                       --localstatedir=/var                    --with-piddir=/run/samba                --with-pammodulesdir=/lib/security      --without-systemd                       --enable-fhs                            --enable-nss-wrapper                &&
+<userinput>./configure                             \
+    --prefix=/usr                       \
+    --sysconfdir=/etc                   \
+    --localstatedir=/var                \
+    --with-piddir=/run/samba            \
+    --with-pammodulesdir=/lib/security  \
+    --without-systemd                   \
+    --enable-fhs                        \
+    --enable-nss-wrapper                &&
 make</userinput>
 </screen>
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem>:</para>
 <screen>
-<userinput>sed -i "/samba3.blackbox.failure.failure/i ^samba3.raw.eas" selftest/knownfail</userinput>
+<userinput>sed -i "/samba3.blackbox.failure.failure/i \^samba3.raw.eas" selftest/knownfail</userinput>
 </screen>
       
       </sect2>
@@ -153,13 +161,17 @@
 ln -v -sf ../../lib/libnss_wins.so.2    /usr/lib/libnss_wins.so    &&
 install -v -m644    examples/smb.conf.default /etc/samba &&
 mkdir -pv /etc/openldap/schema                        &&
-install -v -m644    examples/LDAP/README                                  /etc/openldap/schema/README.LDAP  &&
+install -v -m644    examples/LDAP/README              \
+                    /etc/openldap/schema/README.LDAP  &&
                     
-install -v -m644    examples/LDAP/samba*                                  /etc/openldap/schema              &&
+install -v -m644    examples/LDAP/samba*              \
+                    /etc/openldap/schema              &&
                     
-install -v -m755    examples/LDAP/{get*,ol*}                     /etc/openldap/schema              &&
+install -v -m755    examples/LDAP/{get*,ol*} \
+                    /etc/openldap/schema              &&
 install -v -m755 -d /usr/share/doc/samba-&samba-version; &&
-install -v -m644    lib/ntdb/doc/design.pdf                     /usr/share/doc/samba-&samba-version;</userinput>
+install -v -m644    lib/ntdb/doc/design.pdf \
+                    /usr/share/doc/samba-&samba-version;</userinput>
 </screen>
 	</sect3>
 	<sect3>
@@ -348,7 +360,8 @@
 		
 <screen role="root">
 <userinput>groupadd -g 99 nogroup &&
-useradd -c "Unprivileged Nobody" -d /dev/null -g nogroup     -s /bin/false -u 99 nobody</userinput>
+useradd -c "Unprivileged Nobody" -d /dev/null -g nogroup \
+    -s /bin/false -u 99 nobody</userinput>
 </screen>
 		<para>Si vous avez aussi besoin du script <filename>winbind</filename> pour résoudre les
 		  noms depuis les clients Windows, lancez:</para>

Modified: trunk/blfs/networking/netutils/avahi.xml
===================================================================
--- trunk/blfs/networking/netutils/avahi.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netutils/avahi.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -76,7 +76,8 @@
     <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
 <userinput>groupadd -fg 84 avahi &&
-useradd -c "Avahi Daemon Owner" -d /var/run/avahi-daemon -u 84         -g avahi -s /bin/false avahi</userinput>
+useradd -c "Avahi Daemon Owner" -d /var/run/avahi-daemon -u 84 \
+        -g avahi -s /bin/false avahi</userinput>
 </screen>
     <para>Il doit y avoir un groupe d'accès dédiés pour les clients
     <application>Avahi</application> . Taper les commandes suivantes en tant
@@ -87,9 +88,21 @@
     <para>Installez <application>avahi</application> en lançant les commandes 
     suivantes:</para>
 <screen>
-<userinput>sed -i 's/(CFLAGS=.*)-Werror (.*)/12/' configure &&
-sed -i -e 's/-DG_DISABLE_DEPRECATED=1//'  -e '/-DGDK_DISABLE_DEPRECATED/d' avahi-ui/Makefile.in &&
-./configure --prefix=/usr                    --sysconfdir=/etc                --localstatedir=/var             --disable-static                 --disable-mono                   --disable-monodoc                --disable-python                 --disable-qt3                    --disable-qt4                    --enable-core-docs               --with-distro=none               --with-systemdsystemunitdir=no &&
+<userinput>sed -i 's/\(CFLAGS=.*\)-Werror \(.*\)/\1\2/' configure &&
+sed -i -e 's/-DG_DISABLE_DEPRECATED=1//' \
+ -e '/-DGDK_DISABLE_DEPRECATED/d' avahi-ui/Makefile.in &&
+./configure --prefix=/usr        \
+            --sysconfdir=/etc    \
+            --localstatedir=/var \
+            --disable-static     \
+            --disable-mono       \
+            --disable-monodoc    \
+            --disable-python     \
+            --disable-qt3        \
+            --disable-qt4        \
+            --enable-core-docs   \
+            --with-distro=none   \
+            --with-systemdsystemunitdir=no &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas livré avec une suite de tests.</para>

Modified: trunk/blfs/networking/netutils/mod_dnssd.xml
===================================================================
--- trunk/blfs/networking/netutils/mod_dnssd.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netutils/mod_dnssd.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -64,7 +64,8 @@
     suivantes:</para>
 <screen>
 <userinput>sed -i 's/unixd_setup_child/ap_&/' src/mod_dnssd.c &&
-./configure --prefix=/usr             --disable-lynx &&
+./configure --prefix=/usr \
+            --disable-lynx &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas livré avec une suite de tests.</para>

Modified: trunk/blfs/networking/netutils/nmap.xml
===================================================================
--- trunk/blfs/networking/netutils/nmap.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netutils/nmap.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -78,7 +78,7 @@
 <para>Installez <application>Nmap</application> en exécutant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr &&
+<userinput>./configure --prefix=/usr --with-liblua=included &&
 make -j1</userinput>
 </screen>
     <para>Si vous voulez lancer la suite de tests, lancer la commande suivante:</para>
@@ -98,8 +98,6 @@
     <para><parameter>--with-liblua=included</parameter>: Ce paramètre est requis pour corriger la compilation
      avec <application>lua</application> 5.3.</para>
   </sect2>
-
-
   <sect2 role="content">
     <title>Contenu</title>
     <segmentedlist>

Modified: trunk/blfs/networking/netutils/wicd.xml
===================================================================
--- trunk/blfs/networking/netutils/wicd.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netutils/wicd.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -92,7 +92,7 @@
     <para>Installez <application>Wicd</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>sed -e "/wpath.logrotate\|wpath.systemd/d' \
+<userinput>sed -e "/wpath.logrotate\|wpath.systemd/d" \
     -e "/detection failed/ a\                self.init=\'init\/default\/wicd\'" \
     -i setup.py                                     &&
 rm po/*.po                                          &&

Modified: trunk/blfs/networking/netutils/wireshark.xml
===================================================================
--- trunk/blfs/networking/netutils/wireshark.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/networking/netutils/wireshark.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -170,7 +170,8 @@
     <para>Continuez à installer <application>Wireshark</application> en lançant
     les commandes suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr     \
+<userinput>patch -Np1 -i wireshark-&wireshark-version;-lua_5_3_0-1.patch  &&
+./configure --prefix=/usr     \
             --with-gtk3=yes   \
             --with-qt=no      \
             --sysconfdir=/etc &&

Modified: trunk/blfs/postlfs/config/profile.xml
===================================================================
--- trunk/blfs/postlfs/config/profile.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/config/profile.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -169,10 +169,10 @@
 <literal># Setup for /bin/ls and /bin/grep to support color, the alias is in /etc/bashrc.
 if [ -f "/etc/dircolors" ] ; then
         eval $(dircolors -b /etc/dircolors)
-        if [ -f "$HOME/.dircolors" ] ; then
-                eval $(dircolors -b $HOME/.dircolors)
-        fi
 fi
+if [ -f "$HOME/.dircolors" ] ; then
+        eval $(dircolors -b $HOME/.dircolors)
+fi
 alias ls='ls --color=auto'
 alias grep='grep --color=auto'</literal>
 EOF</userinput>

Modified: trunk/blfs/postlfs/editors/bluefish.xml
===================================================================
--- trunk/blfs/postlfs/editors/bluefish.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/editors/bluefish.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -98,11 +98,11 @@
         en tant qu'utilisateur
         <systemitem class="username">root</systemitem> :
       </para>
-<screen role="root"><userinput>
-gtk-update-icon-cache -t -f --include-image-data /usr/share/icons/hicolor &&
-update-desktop-database</userinput></screen>
+<screen role="root">
+<userinput>gtk-update-icon-cache -t -f --include-image-data /usr/share/icons/hicolor &&
+update-desktop-database</userinput>
+</screen>
     </note>
-
   </sect2>
   
   <sect2 role="content">

Modified: trunk/blfs/postlfs/editors/vim.xml
===================================================================
--- trunk/blfs/postlfs/editors/vim.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/editors/vim.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -91,6 +91,7 @@
 <screen>
 <userinput>echo '#define SYS_VIMRC_FILE  "/etc/vimrc"' >>  src/feature.h &&
 echo '#define SYS_GVIMRC_FILE "/etc/gvimrc"' >> src/feature.h &&
+sed -i 's/luaL_optlong/(long)luaL_optinteger/' src/if_lua.c   &&
 ./configure --prefix=/usr --with-features=huge                &&
 make</userinput>
 </screen>
@@ -134,7 +135,6 @@
   <sect2 role="commands">
     <title>Explication des commandes</title>
     
-
     <para><command>sed -i ... src/if_lua.c</command>: Cette commande corrige la construction avec
     <application>lua</application> 5.3.</para>
     <para><parameter>--with-features=huge</parameter> : Ce correctif active

Modified: trunk/blfs/postlfs/filesystems/lvm2.xml
===================================================================
--- trunk/blfs/postlfs/filesystems/lvm2.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/filesystems/lvm2.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -85,7 +85,13 @@
     <para>Installez <application>lvm2</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr                   --exec-prefix=                  --with-confdir=/etc             --enable-applib                 --enable-cmdlib                 --enable-pkgconfig              --enable-udev_sync  &&
+<userinput>./configure --prefix=/usr       \
+            --exec-prefix=      \
+            --with-confdir=/etc \
+            --enable-applib     \
+            --enable-cmdlib     \
+            --enable-pkgconfig  \
+            --enable-udev_sync  &&
 make</userinput>
 </screen>
     

Modified: trunk/blfs/postlfs/filesystems/mdadm.xml
===================================================================
--- trunk/blfs/postlfs/filesystems/mdadm.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/filesystems/mdadm.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -54,16 +54,15 @@
     <para>Autoriser les options suivantes dans la configuration du noyau
     et recompiler le noyau, si nécéssaire. Seulement le type de RAID souhaité est nécéssaire.  </para>
 <screen>
-<literal>File Systems --->
-  Device Drivers --->
-    [*] Multiple devices driver support (RAID and LVM) ---> [CONFIG_MD]
-      <*> RAID support                                      [CONFIG_BLK_DEV_MD]
-      [*]   Autodetect RAID arrays during kernel boot       [CONFIG_MD_AUTODETECT]
-      <*/M>  Linear (append) mode                           [CONFIG_MD_LINEAR]
-      <*/M>  RAID-0 (striping) mode                         [CONFIG_MD_RAID0]
-      <*/M>  RAID-1 (mirroring) mode                        [CONFIG_MD_RAID1]
-      <*/M>  RAID-10 (mirrored striping) mode               [CONFIG_MD_RAID10]
-      <*/M>  RAID-4/RAID-5/RAID-6 mode                      [CONFIG_MD_RAID456]</literal>
+<literal>Device Drivers --->
+  [*] Multiple devices driver support (RAID and LVM) ---> [CONFIG_MD]
+    <*> RAID support                                      [CONFIG_BLK_DEV_MD]
+    [*]   Autodetect RAID arrays during kernel boot       [CONFIG_MD_AUTODETECT]
+    <*/M>  Linear (append) mode                           [CONFIG_MD_LINEAR]
+    <*/M>  RAID-0 (striping) mode                         [CONFIG_MD_RAID0]
+    <*/M>  RAID-1 (mirroring) mode                        [CONFIG_MD_RAID1]
+    <*/M>  RAID-10 (mirrored striping) mode               [CONFIG_MD_RAID10]
+    <*/M>  RAID-4/RAID-5/RAID-6 mode                      [CONFIG_MD_RAID456]</literal>
 </screen>
     <indexterm zone="mdadm mdadm-kernel">
       <primary sortas="d-mdadm">mdadm</primary>

Modified: trunk/blfs/postlfs/security/consolekit.xml
===================================================================
--- trunk/blfs/postlfs/security/consolekit.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/security/consolekit.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -107,7 +107,6 @@
       <parameter>--with-systemdsystemunitdir=no</parameter>: Désactive la construction avec les bibliothèques
        systemd.
     </para>
-
     <para><option>--enable-docbook-docs</option> : Utilisez ce paramètre si
     <application>xmlto</application> est installé et si vous souhaitez construire
     la documentation de l'API.</para>

Modified: trunk/blfs/postlfs/security/gnutls.xml
===================================================================
--- trunk/blfs/postlfs/security/gnutls.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/security/gnutls.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -91,7 +91,8 @@
     <para>Installez <application>GnuTLS</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr             --with-default-trust-store-file=/etc/ssl/ca-bundle.crt &&
+<userinput>./configure --prefix=/usr \
+            --with-default-trust-store-file=/etc/ssl/ca-bundle.crt &&
 make</userinput>
 </screen>
     <para>Pour tester les résultats, lancez : <command>make check</command>.</para>

Modified: trunk/blfs/postlfs/security/mitkrb.xml
===================================================================
--- trunk/blfs/postlfs/security/mitkrb.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/security/mitkrb.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -104,10 +104,19 @@
     </para>
 <screen>
 <userinput>cd src &&
-sed -e "s at python2.5/Python.h@& python2.7/Python.h at g"     -e "s at -lpython2.5]@&,n  AC_CHECK_LIB(python2.7,main,[PYTHON_LIB=-lpython2.7])@g"     -i configure.in &&
-sed -e 's@^u}@^u cols 300}@'     -i tests/dejagnu/config/default.exp &&
+sed -e "s at python2.5/Python.h@& python2.7/Python.h at g" \
+    -e "s at -lpython2.5]@&,\n  AC_CHECK_LIB(python2.7,main,[PYTHON_LIB=-lpython2.7])@g" \
+    -i configure.in &&
+sed -e 's@\^u}@^u cols 300}@' \
+    -i tests/dejagnu/config/default.exp &&
 autoconf &&
-./configure --prefix=/usr                        --sysconfdir=/etc                    --localstatedir=/var/lib             --with-system-et                     --with-system-ss                     --with-system-verto=no               --enable-dns-for-realm &&
+./configure --prefix=/usr            \
+            --sysconfdir=/etc        \
+            --localstatedir=/var/lib \
+            --with-system-et         \
+            --with-system-ss         \
+            --with-system-verto=no   \
+            --enable-dns-for-realm &&
 make</userinput>
 </screen>
     <para>
@@ -121,7 +130,8 @@
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
 <userinput>make install &&
-for LIBRARY in gssapi_krb5 gssrpc k5crypto kadm5clnt kadm5srv                kdb5 kdb_ldap krad krb5 krb5support verto ; do
+for LIBRARY in gssapi_krb5 gssrpc k5crypto kadm5clnt kadm5srv \
+               kdb5 kdb_ldap krad krb5 krb5support verto ; do
     chmod -v 755 /usr/lib/lib$LIBRARY.so
 done          &&
 unset LIBRARY &&

Modified: trunk/blfs/postlfs/security/nss.xml
===================================================================
--- trunk/blfs/postlfs/security/nss.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/security/nss.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -3,14 +3,9 @@
    "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
-<!-- for when .0 is not part of the new tarball name -->
   <!ENTITY nss-url "ftp.mozilla.org/pub/mozilla.org/security/nss/releases">
   <!ENTITY nss-download-http "https://&nss-url;/NSS_3_&nss-minor-version;_&nss-micro-version;_RTM/src/nss-&nss-version;.tar.gz">
   <!ENTITY nss-download-ftp "ftp://&nss-url;/NSS_3_&nss-minor-version;_&nss-micro-version;_RTM/src/nss-&nss-version;.tar.gz">
-<!-- no micro versions
-  <!ENTITY nss-download-http "https://&nss-url;/NSS_3_&nss-minor-version;_RTM/src/nss-&nss-version;.tar.gz">
-  <!ENTITY nss-download-ftp "ftp://&nss-url;/NSS_3_&nss-minor-version;_RTM/src/nss-&nss-version;.tar.gz">
--->
   <!ENTITY nss-md5sum        "a77df26072cabf8afb26911b6fa9b755">
   <!ENTITY nss-size          "6.7 Mo">
   <!ENTITY nss-buildsize     "81 Mo">
@@ -89,7 +84,12 @@
 <screen>
 <userinput>patch -Np1 -i ../nss-&nss-version;-standalone-1.patch &&
 cd nss &&
-make BUILD_OPT=1                        NSPR_INCLUDE_DIR=/usr/include/nspr    USE_SYSTEM_ZLIB=1                     ZLIB_LIBS=-lz                         $([ $(uname -m) = x86_64 ] && echo USE_64=1)   $([ -f /usr/include/sqlite3.h ] && echo NSS_USE_SYSTEM_SQLITE=1) -j1</userinput>
+make BUILD_OPT=1                      \
+  NSPR_INCLUDE_DIR=/usr/include/nspr  \
+  USE_SYSTEM_ZLIB=1                   \
+  ZLIB_LIBS=-lz                       \
+  $([ $(uname -m) = x86_64 ] && echo USE_64=1) \
+  $([ -f /usr/include/sqlite3.h ] && echo NSS_USE_SYSTEM_SQLITE=1) -j1</userinput>
 </screen>
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>
    <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>

Modified: trunk/blfs/postlfs/security/openssl.xml
===================================================================
--- trunk/blfs/postlfs/security/openssl.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/security/openssl.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -76,7 +76,11 @@
     commandes suivantes :</para>
 <screen>
 <userinput>patch -Np1 -i ../openssl-&openssl-version;-fix_parallel_build-1.patch &&
-./config --prefix=/usr                  --openssldir=/etc/ssl          --libdir=lib                   shared                         zlib-dynamic &&
+./config --prefix=/usr         \
+         --openssldir=/etc/ssl \
+         --libdir=lib          \
+         shared                \
+         zlib-dynamic &&
 make</userinput>
 </screen>
     <para>Pour tester les résultats, lancez : <command>make test</command>.</para>

Modified: trunk/blfs/postlfs/security/stunnel.xml
===================================================================
--- trunk/blfs/postlfs/security/stunnel.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/security/stunnel.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -72,7 +72,8 @@
     tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
 <userinput>groupadd -g 51 stunnel &&
-useradd -c "stunnel Daemon" -d /var/lib/stunnel         -g stunnel -s /bin/false -u 51 stunnel</userinput>
+useradd -c "stunnel Daemon" -d /var/lib/stunnel \
+        -g stunnel -s /bin/false -u 51 stunnel</userinput>
 </screen>
     <note>
       <para>Un certificat SSL signé et une clé privée sont nécessaires pour lancer
@@ -96,22 +97,23 @@
 -----END DH PARAMETERS-----</literal>
 </screen>
     </note>
-
     <para>Installez <application>Stunnel</application> en lançant les commandes
     suivantes :</para>
-
     <note><para>Pour certains sytèmes avec une version de <application>binutils</application> inférieure à
     2.25, <command>configure</command> peut échouer. Si nécessaire, corrigez le avec:</para>
-<screen><userinput>sed -i '/LDFLAGS.*static_flag/ s/^/#/' configure</userinput></screen>
+<screen>
+<userinput>sed -i '/LDFLAGS.*static_flag/ s/^/#/' configure</userinput>
+</screen>
     <para>ou, si <xref linkend="llvm"/> est installé avec Clang, vous pouvez remplacer
     <command>./configure ... </command> avec <command>CC=clang
     ./configure ... </command> dans la première commande dessous.</para></note>
-
-
     <para>Installez <application>Stunnel</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr                    --sysconfdir=/etc                --localstatedir=/var             --disable-systemd    &&
+<userinput>./configure --prefix=/usr        \
+            --sysconfdir=/etc    \
+            --localstatedir=/var \
+            --disable-systemd    &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>

Modified: trunk/blfs/postlfs/security/sudo.xml
===================================================================
--- trunk/blfs/postlfs/security/sudo.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/postlfs/security/sudo.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -72,7 +72,13 @@
     <para>Installez <application>sudo</application> en lançant
     les commandes suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr                          --libexecdir=/usr/lib                  --with-all-insults                     --with-env-editor                      --docdir=/usr/share/doc/sudo-&sudo-version;             --with-passprompt="[sudo] password for %p" &&
+<userinput>./configure --prefix=/usr              \
+            --libexecdir=/usr/lib      \
+            --with-secure-path         \
+            --with-all-insults         \
+            --with-env-editor          \
+            --docdir=/usr/share/doc/sudo-&sudo-version; \
+            --with-passprompt="[sudo] password for %p" &&
 make</userinput>
 </screen>
     <para> Pour tester les résultats, tapez: <command>env LC_ALL=C make check  2>&1
@@ -81,7 +87,8 @@
    </para>
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
-<userinput>make install</userinput>
+<userinput>make install &&
+ln -sfv libsudo_util.so.0.0.0 /usr/lib/sudo/libsudo_util.so.0</userinput>
 </screen>
   </sect2>
   <sect2 role="commands">
@@ -98,7 +105,6 @@
       class="directory">/usr/sbin</filename> dans la variable d'environnement
       <envar>PATH</envar>.
     </para>
-
     <para>
      <parameter>--with-all-insults</parameter> : Ce paramètre inclut tous
     les paramètres d'insultes de <application>sudo</application>.</para>
@@ -123,8 +129,6 @@
       <command>ln -sfv libsudo_util...</command>: contourne un bogue dans le process d'installation,
       qui lie à la version précédement installé (si elle est la) aulieu de la dernière.
     </para>
-
-
   </sect2>
   <sect2 role="configuration">
     <title>Configuration de Sudo</title>

Modified: trunk/blfs/pst/printing/cups-filters.xml
===================================================================
--- trunk/blfs/pst/printing/cups-filters.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/pst/printing/cups-filters.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -72,8 +72,6 @@
         </para>
       </listitem>
     </itemizedlist>
-
-
     <bridgehead renderas="sect3">Dépendances de CUPS Filters</bridgehead>
     <bridgehead renderas="sect4">Requises</bridgehead>
     <para role="required">
@@ -113,7 +111,15 @@
       commands:
     </para>
 <screen>
-<userinput>./configure --prefix=/usr                                           --sysconfdir=/etc                                       --localstatedir=/var                                    --docdir=/usr/share/doc/cups-filters-&cups-filters-version;             --without-rcdir                                         --with-gs-path=/usr/bin/gs                              --with-pdftops-path=/usr/bin/gs                         --disable-static                            &&
+<userinput>patch -Np1 -i ../cups-filters-&cups-filters-version;-poppler_fix-1.patch &&
+./configure --prefix=/usr                   \
+            --sysconfdir=/etc               \
+            --localstatedir=/var            \
+            --without-rcdir                 \
+            --disable-static                \
+            --with-gs-path=/usr/bin/gs      \
+            --with-pdftops-path=/usr/bin/gs \
+            --docdir=/usr/share/doc/cups-filters-&cups-filters-version; &&
 make</userinput>
 </screen>
     <para>

Modified: trunk/blfs/pst/printing/cups.xml
===================================================================
--- trunk/blfs/pst/printing/cups.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/pst/printing/cups.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -169,13 +169,17 @@
        Construisez <application>Cups</application> en lançant les commandes suivantes:
      </para>
 <screen>
-<userinput>sed -i 's:555:755:g;s:444:644:g' Makedefs.in           &&
-sed -i '/MAN.*.EXT/s:.gz::g'        configure config-scripts/cups-manpages.m4       &&
-sed -i '/LIBGCRYPTCONFIG/d' config-scripts/cups-ssl.m4 &&
-sed -i 's at else /* HAVE_AVAHI */@elif defined(HAVE_AVAHI)@'        test/ippserver.c                                &&
+<userinput>sed -i 's:555:755:g;s:444:644:g' Makedefs.in                                  &&
+sed -i '/MAN.EXT/s:.gz::g' configure config-scripts/cups-manpages.m4          &&
+sed -i '/LIBGCRYPTCONFIG/d' config-scripts/cups-ssl.m4                        &&
+sed -i 's at else /\* HAVE_AVAHI \*/@elif defined(HAVE_AVAHI)@' test/ippserver.c &&
 aclocal  -I config-scripts &&
 autoconf -I config-scripts &&
-./configure --libdir=/usr/lib                        --disable-systemd                        --with-rcdir=/tmp/cupsinit               --with-system-groups=lpadmin             --with-docdir=/usr/share/cups/doc-&cups-version; &&
+./configure --libdir=/usr/lib            \
+            --disable-systemd            \
+            --with-rcdir=/tmp/cupsinit   \
+            --with-system-groups=lpadmin \
+            --with-docdir=/usr/share/cups/doc-&cups-version; &&
 make</userinput>
 </screen>
     <para>Pour tester les résultats, tapez :  <command>make -k check</command>. Un session graphique déjà

Modified: trunk/blfs/pst/ps/enscript.xml
===================================================================
--- trunk/blfs/pst/ps/enscript.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/pst/ps/enscript.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -55,14 +55,11 @@
         <para>Estimation du temps de construction : &enscript-time;</para>
       </listitem>
     </itemizedlist>
-
     <bridgehead renderas="sect3">Dépendances de Enscript</bridgehead>
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional">
       <xref linkend="texlive"/> (ou <xref linkend="tl-installer"/>)
     </para>
-
-
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/Enscript"/></para>
   </sect2>

Modified: trunk/blfs/pst/typesetting/texlive-pass1.xml
===================================================================
(Binary files differ)

Modified: trunk/blfs/pst/typesetting/texlive.xml
===================================================================
--- trunk/blfs/pst/typesetting/texlive.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/pst/typesetting/texlive.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -3,40 +3,29 @@
    "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
-
   <!ENTITY texlive-download-http " ">
   <!ENTITY texlive-download-ftp  "ftp://tug.org/texlive/historic/&texlive-year;/texlive-&texlive-version;-source.tar.xz">
   <!ENTITY texlive-md5sum        "09ee265ff51637827559affc7304078c">
   <!ENTITY texlive-size          "40 Mo">
-
   <!ENTITY texlive-buildsize      "3.6 GB including the additional download">
   <!ENTITY texlive-time           "8.2 SBU including the additional download">
-
   <!ENTITY texlive-texmf-download-http " ">
   <!ENTITY texlive-texmf-download-ftp  "ftp://tug.org/texlive/historic/&texlive-year;/texlive-&texlive-version;-texmf.tar.xz">
   <!ENTITY texlive-texmf-md5sum        "645a6f1d3a0ef4a9c279dae02588eab7">
   <!ENTITY texlive-texmf-size          "1.7 GB">
-
 ]>
-
-
 <sect1 id="texlive" xreflabel="texlive-&texlive-version;">
   <?dbhtml filename="texlive.html"?>
-
   <sect1info>
     <othername>$LastChangedBy: ken $</othername>
     <date>$Date: 2015-01-11 22:13:35 +0100 (dim. 11 janv. 2015) $</date>
   </sect1info>
-
   <title>texlive-&texlive-version;-source</title>
-
   <indexterm zone="texlive">
     <primary sortas="a-texlive">texlive</primary>
   </indexterm>
-
   <sect2 role="package">
     <title>Introduction à TeX Live from source</title>
-
     <para>La plupart de TeX Live peut être construit depuis les sources sans une installation
     pré-existante, mais
     <application>xindy</application> (pour l'indexage) demande des versions en fonctionnement de
@@ -45,13 +34,10 @@
     <command>asy</command> (pour les graphiques vectoriels) échoueront si TeX n'a pas déjà été installé.
     En supplément, <application>biber</application> n'est pas fournit dans les sources de
     <application>texlive</application>.</para>
-
     <para>L'ensemble de ses paquets sont expliqués dans leurs propres pages et peuvent être construit
     après l'installation de ce paquet et en ayant fait
     <xref linkend="tex-path"/>.</para>
-
     &lfs76_checked;
-
     <bridgehead renderas="sect3">Information sur le paquet </bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
@@ -73,21 +59,17 @@
         <para>Estimation du temps de construction : &texlive-time;</para>
       </listitem>
     </itemizedlist>
-
     <bridgehead renderas="sect3">Téléchargement supplémentaire requis</bridgehead>
-
       <para>Beaucoup de l'environnement texlive (incluant scripts, documentation,
       polices et différents autres fichiers) ne sont pas dans l'archive des sources. Vous devez les
       télécharger séparément. Cela vous donnera tous les fichiers supplémentaires qui sont fournis
       par une isntallation complète de la version binaire, ce n'est pas réaliste de limiter
       les parties à installer.
       </para>
-
        <para>
         A cause de la taille de ce paquet, il n'est pas en mirroir sur les mirroirs BLFS. En cas de problème, 
         allez sur http://www.ctan.org/mirrors/ pour trouver un mirroir plus accessible.
       </para>
-
     <itemizedlist spacing="compact">
        <listitem>
         <para>Téléchargement (HTTP): <ulink url="&texlive-texmf-download-http;"/></para>
@@ -102,48 +84,36 @@
         <para>Taille du téléchargement : &texlive-texmf-size;</para>
       </listitem>
     </itemizedlist>
-
     <bridgehead renderas="sect3">Dépendances de TeX Live depuis les sources</bridgehead>
-
     <bridgehead renderas="sect4">Recommandées</bridgehead>
     <para role="recommended">
       <xref linkend="gs"/> (pour dvisvgm - utilisé par asymptote qui fournit une boite à outils basée sur
       les coordonnées mathématiques pour les déssins techniques),
       <xref linkend="x-window-system"/>
     </para>
-
-    <!-- text for recommended libraries, shared with texlive itself -->
+    
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
      href="../../xincludes/texrecommendlibs.xml"/>
-
     <bridgehead renderas="sect4">Facultative</bridgehead>
-    <!-- text for optional deps, shared with texlive itself -->
+    
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
      href="../../xincludes/texoptional.xml"/>
-
     <bridgehead renderas="sect4">Dépendances d'exécution</bridgehead>
-    <!-- text for runtime deps, shared with tl-installer -->
+    
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
      href="../../xincludes/texruntime.xml"/>
-
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/texlive"/></para>
-
   </sect2>
-
   <sect2 role="installation">
     <title>Installation de TeX Live</title>
-
     <para>
       Installez TeX Live en lançant la suite  
     </para>
-
-<!-- the configure switches should be identical to those in the
- first part of texlive itself -->
-<screen role="root"><userinput>export TEXARCH=$(uname -m | sed -e 's/i.86/i386/' -e 's/$/-linux/') &&
+<screen>
+<userinput>TEXARCH=$(uname -m | sed -e 's/i.86/i386/' -e 's/$/-linux/') &&
 mkdir texlive-build &&
 cd texlive-build    &&
-
 ../configure                                        \
     --prefix=/opt/texlive/&texlive-year;                      \
     --bindir=/opt/texlive/&texlive-year;/bin/$TEXARCH         \
@@ -161,6 +131,7 @@
     --with-system-harfbuzz                          \
     --with-system-icu                               \
     --with-system-libgs                             \
+    --with-system-libpaper                          \
     --with-system-libpng                            \
     --with-system-pixman                            \
     --with-system-poppler                           \
@@ -168,60 +139,41 @@
     --with-system-zlib                              \
     --with-banner-add=" - BLFS" &&
 unset TEXARCH &&
-
-make</userinput></screen>
-
+make</userinput>
+</screen>
     <para>Pour tester le résultat, tapez : <command>make -k check</command>
     Un test de web2c, dvipng et ttf2pk2 seront passé ("SKIP") car kpathsea
     n'est pas encore installé.</para>
-
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem>:</para>
-
-<screen><userinput role="root">make install &&
-make texlinks</userinput></screen>
-
+<screen role="root">
+<userinput>make install &&
+make texlinks</userinput>
+</screen>
     <para>Et maintenant, installez les fichiers supplémentaires en tant qu'utilisateur
     <systemitem class="username">root</systemitem>:</para>
-
-<screen><userinput role="root">mkdir -pv /opt/texlive/&texlive-year; &&
-tar -xf texlive-&texlive-version;-texmf.tar.xz -C /opt/texlive/&texlive-year; --strip-components=1</userinput></screen>
-
+<screen role="root">
+<userinput>mkdir -pv /opt/texlive/&texlive-year; &&
+tar -xf ../../texlive-&texlive-version;-texmf.tar.xz -C /opt/texlive/&texlive-year; --strip-components=1</userinput>
+</screen>
     <para>Maintenant effectuez <xref linkend="tex-path"/>.</para>
-
   </sect2>
-
   <sect2 role="commands">
     <title>Explications des commandes</title>
-
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
      href="../../xincludes/tex-prefix.xml"/>
-
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
      href="../../xincludes/tex-lib.xml"/>
-
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/static-libraries.xml"/>
-
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/tex-shared.xml"/>
-
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/tex-system.xml"/>
-
-<!--    <para>
-      <parameter>\-\-with-system-xpdf</parameter> : Uniquely, this parameter has
-      a non-standard meaning, it tells <command>configure</command> to use the
-      system-installed <application>poppler</application> headers et library.
-      Again, omit this if you have not installed
-      <application>poppler</application>.
-    </para> -->
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
       href="../../xincludes/tex-xpdf.xml"/>
-
     <para>
       <option>--without-x</option> : utilisez cela si vous n'avez pas installé Xorg.
     </para>
-
     <para>
       <parameter>make texlinks</parameter> : cela lance le script texlinks.sh pour créer (ou recréer) les liens
       symboliques depuis les formats du moteur. En pratique, plusieurs des cibles comme
@@ -232,17 +184,13 @@
       L'archive contient les fichiers pour le répertoire texmf-dist, et à cause de sa taille nous ne voulons pas
       gaspiller de temps et d'espace à le déballer et ensuite copier les fichiers.
     </para>
-
   </sect2>
-
   <sect2 role="content">
     <title>Contenu</title>
-
     <segmentedlist>
       <segtitle>Programmes installés</segtitle>
       <segtitle>Bibliothèques installées</segtitle>
       <segtitle>Répertoires installés</segtitle>
-
       <seglistitem>
         <seg>Plus de 300 binaires et liens symboliques vers des scripts</seg>
         <seg>libkpathsea.so, libptexenc.so</seg>
@@ -250,12 +198,10 @@
         /usr/include/kpathsea, /usr/include/ptexenc</seg>
       </seglistitem>
     </segmentedlist>
-
     <variablelist>
       <bridgehead renderas="sect3">Description courte</bridgehead>
       <?dbfo list-presentation="list"?>
       <?dbhtml list-presentation="table"?>
-
       <varlistentry id="texlive-programs">
         <term><command>Programmes de TeX </command></term>
         <listitem>
@@ -266,7 +212,6 @@
           </indexterm>
         </listitem>
       </varlistentry>
-
       <varlistentry id="libkpathsea">
         <term><filename class="libraryfile">libkpathsea.so</filename></term>
         <listitem>
@@ -278,7 +223,6 @@
           </indexterm>
         </listitem>
       </varlistentry>
-
       <varlistentry id="libptexenc">
         <term><filename class="libraryfile">libptexenc.so</filename></term>
         <listitem>
@@ -291,7 +235,5 @@
         </listitem>
       </varlistentry>
     </variablelist>
-
   </sect2>
-
 </sect1>

Modified: trunk/blfs/pst/typesetting/typesetting.xml
===================================================================
--- trunk/blfs/pst/typesetting/typesetting.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/pst/typesetting/typesetting.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -36,12 +36,9 @@
   <filename class="directory">/opt/texlive/&texlive-year;</filename> avec une seule exception
   pour deux bibliothèques qui sont installées dans
   <filename class="directory">/usr/lib</filename> pour la cohérence.</para> 
-
-
  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="tl-installer.xml"/>
 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="texlive.xml"/>
 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="tex-path.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="biber.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="xindy.xml"/>
-
 </chapter>

Modified: trunk/blfs/pst/typesetting/xindy.xml
===================================================================
(Binary files differ)

Modified: trunk/blfs/server/databases/mariadb.xml
===================================================================
--- trunk/blfs/server/databases/mariadb.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/server/databases/mariadb.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -120,11 +120,28 @@
       Installez <application>MariaDB</application> en lançant la suite  
     </para>
 <screen>
-<userinput>sed -i "s at data/test@${INSTALL_MYSQLTESTDIR}@g" sql/CMakeLists.txt &&
-sed -i "s/srv_buf_size/srv_sort_buf_size/" storage/innobase/row/row0log.cc &&
+<userinput>sed -i "s at data/test@\${INSTALL_MYSQLTESTDIR}@g"        sql/CMakeLists.txt       &&
+sed -i "s/srv_buf_size/srv_sort_buf_size/"      storage/innobase/row/row0log.cc &&
 mkdir build &&
-cd build &&
-cmake -DCMAKE_BUILD_TYPE=Release                             -DCMAKE_INSTALL_PREFIX=/usr                            -DINSTALL_DOCDIR=share/doc/mariadb-&mariadb-version;             -DINSTALL_DOCREADMEDIR=share/doc/mariadb-&mariadb-version;       -DINSTALL_MANDIR=share/man                             -DINSTALL_MYSQLSHAREDIR=share/mysql                    -DINSTALL_MYSQLTESTDIR=share/mysql/test                -DINSTALL_PLUGINDIR=lib/mysql/plugin                   -DINSTALL_SBINDIR=sbin                                 -DINSTALL_SCRIPTDIR=bin                                -DINSTALL_SQLBENCHDIR=share/mysql/bench                -DINSTALL_SUPPORTFILESDIR=share/mysql                  -DMYSQL_DATADIR=/srv/mysql                             -DMYSQL_UNIX_ADDR=/run/mysqld/mysqld.sock              -DWITH_EXTRA_CHARSETS=complex                          -DWITH_EMBEDDED_SERVER=ON                              -DTOKUDB_OK=0                                          .. &&
+cd build    &&
+cmake -DCMAKE_BUILD_TYPE=Release                       \
+      -DCMAKE_INSTALL_PREFIX=/usr                      \
+      -DINSTALL_DOCDIR=share/doc/mariadb-&mariadb-version;       \
+      -DINSTALL_DOCREADMEDIR=share/doc/mariadb-&mariadb-version; \
+      -DINSTALL_MANDIR=share/man                       \
+      -DINSTALL_MYSQLSHAREDIR=share/mysql              \
+      -DINSTALL_MYSQLTESTDIR=share/mysql/test          \
+      -DINSTALL_PLUGINDIR=lib/mysql/plugin             \
+      -DINSTALL_SBINDIR=sbin                           \
+      -DINSTALL_SCRIPTDIR=bin                          \
+      -DINSTALL_SQLBENCHDIR=share/mysql/bench          \
+      -DINSTALL_SUPPORTFILESDIR=share/mysql            \
+      -DMYSQL_DATADIR=/srv/mysql                       \
+      -DMYSQL_UNIX_ADDR=/run/mysqld/mysqld.sock        \
+      -DWITH_EXTRA_CHARSETS=complex                    \
+      -DWITH_EMBEDDED_SERVER=ON                        \
+      -DTOKUDB_OK=0                                    \
+      .. &&
 make</userinput>
 </screen>
     <para>

Modified: trunk/blfs/server/databases/postgresql.xml
===================================================================
--- trunk/blfs/server/databases/postgresql.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/server/databases/postgresql.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -74,7 +74,9 @@
     suivantes : </para>
 <screen>
 <userinput>sed -i '/DEFAULT_PGSOCKET_DIR/s@/tmp@/run/postgresql@' src/include/pg_config_manual.h &&
-./configure --prefix=/usr                      --enable-thread-safety             --docdir=/usr/share/doc/postgresql-&postgresql-version; &&
+./configure --prefix=/usr          \
+            --enable-thread-safety \
+            --docdir=/usr/share/doc/postgresql-&postgresql-version; &&
 make</userinput>
 </screen>
     <para>Il y a de nombreux programmes dans le répertoire
@@ -114,23 +116,29 @@
 <userinput>install -v -dm700 /srv/pgsql/data &&
 install -v -dm755 /run/postgresql &&
 groupadd -g 41 postgres &&
-useradd -c "PostgreSQL Server" -g postgres -d /srv/pgsql/data         -u 41 postgres &&
+useradd -c "PostgreSQL Server" -g postgres -d /srv/pgsql/data \
+        -u 41 postgres &&
 chown -Rv postgres:postgres /srv/pgsql /run/postgresql &&
 su - postgres -c '/usr/bin/initdb -D /srv/pgsql/data'</userinput>
 </screen>
     <para>En tant qu'utilisateur <systemitem class="username">root</systemitem>, 
     démarrez le serveur de base de données avec la commande suivante :</para>
 <screen role="root">
-<userinput>su - postgres -c '/usr/bin/postmaster -D /srv/pgsql/data >     /srv/pgsql/data/logfile 2>&1 &'</userinput>
+<userinput>su - postgres -c '/usr/bin/postmaster -D /srv/pgsql/data > \
+    /srv/pgsql/data/logfile 2>&1 &'</userinput>
 </screen>
     <para>Toujours en tant qu'utilisateur <systemitem class="username">root</systemitem>, 
     créez une base de données et vérifiez l'installation :</para>
 <screen role="root">
 <userinput>su - postgres -c '/usr/bin/createdb test' &&
-echo "create table t1 ( name varchar(20), state_province varchar(20) );"     | (su - postgres -c '/usr/bin/psql test ') &&
-echo "insert into t1 values ('Billy', 'NewYork');"     | (su - postgres -c '/usr/bin/psql test ') &&
-echo "insert into t1 values ('Evanidus', 'Quebec');"     | (su - postgres -c '/usr/bin/psql test ') &&
-echo "insert into t1 values ('Jesse', 'Ontario');"     | (su - postgres -c '/usr/bin/psql test ') &&
+echo "create table t1 ( name varchar(20), state_province varchar(20) );" \
+    | (su - postgres -c '/usr/bin/psql test ') &&
+echo "insert into t1 values ('Billy', 'NewYork');" \
+    | (su - postgres -c '/usr/bin/psql test ') &&
+echo "insert into t1 values ('Evanidus', 'Quebec');" \
+    | (su - postgres -c '/usr/bin/psql test ') &&
+echo "insert into t1 values ('Jesse', 'Ontario');" \
+    | (su - postgres -c '/usr/bin/psql test ') &&
 echo "select * from t1;" | (su - postgres -c '/usr/bin/psql test')</userinput>
 </screen>
   </sect2>

Modified: trunk/blfs/server/databases/sqlite.xml
===================================================================
--- trunk/blfs/server/databases/sqlite.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/server/databases/sqlite.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -83,7 +83,11 @@
     <para>Installer <application>SQLite</application> en exécutant les commandes
     suivantes:</para>
 <screen>
-<userinput>./configure --prefix=/usr --disable-static                    CFLAGS="-g -O2 -DSQLITE_ENABLE_FTS3=1             -DSQLITE_ENABLE_COLUMN_METADATA=1                 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1                   -DSQLITE_SECURE_DELETE=1" &&
+<userinput>./configure --prefix=/usr --disable-static        \
+            CFLAGS="-g -O2 -DSQLITE_ENABLE_FTS3=1 \
+            -DSQLITE_ENABLE_COLUMN_METADATA=1     \
+            -DSQLITE_ENABLE_UNLOCK_NOTIFY=1       \
+            -DSQLITE_SECURE_DELETE=1" &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas livré avec une suite de tests.</para>

Modified: trunk/blfs/server/mail/exim.xml
===================================================================
--- trunk/blfs/server/mail/exim.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/server/mail/exim.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -5,8 +5,7 @@
   %general-entities;
   <!ENTITY exim-download-http   "http://ftp.exim.org/pub/exim/exim4/exim-&exim-version;.tar.bz2">
   <!ENTITY exim-download-ftp    "ftp://ftp.exim.org/pub/exim/exim4/exim-&exim-version;.tar.bz2">
-  <!-- if above don't work, please use one of the official mirrors at
-       http://www.exim.org/mirmon/ftp_mirrors.html -->
+  
   <!ENTITY exim-md5sum          "ebae28762b6f125726283dc9434e8709">
   <!ENTITY exim-size            "1.7 Mo">
   <!ENTITY exim-buildsize       "14 Mo">
@@ -96,8 +95,11 @@
     <para>Installez <application>Exim</application> avec les commandes
     suivantes :</para>
 <screen>
-<userinput>sed -e 's,^BIN_DIR.*$,BIN_DIRECTORY=/usr/sbin,'     -e 's,^CONF.*$,CONFIGURE_FILE=/etc/exim.conf,'     -e 's,^EXIM_USER.*$,EXIM_USER=exim,'     -e 's,^EXIM_MONITOR,#EXIM_MONITOR,' src/EDITME > Local/Makefile &&
-echo -e "USE_GDBM = yesnDBMLIB = -lgdbm" >> Local/Makefile &&
+<userinput>sed -e 's,^BIN_DIR.*$,BIN_DIRECTORY=/usr/sbin,' \
+    -e 's,^CONF.*$,CONFIGURE_FILE=/etc/exim.conf,' \
+    -e 's,^EXIM_USER.*$,EXIM_USER=exim,' \
+    -e 's,^EXIM_MONITOR,#EXIM_MONITOR,' src/EDITME > Local/Makefile &&
+printf "USE_GDBM = yes\nDBMLIB = -lgdbm\n" >> Local/Makefile &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>

Modified: trunk/blfs/server/mail/postfix.xml
===================================================================
--- trunk/blfs/server/mail/postfix.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/server/mail/postfix.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -93,7 +93,8 @@
 <screen role="root">
 <userinput>groupadd -g 32 postfix &&
 groupadd -g 33 postdrop &&
-useradd -c "Postfix Daemon User" -d /var/spool/postfix -g postfix         -s /bin/false -u 32 postfix &&
+useradd -c "Postfix Daemon User" -d /var/spool/postfix -g postfix \
+        -s /bin/false -u 32 postfix &&
 chown -v postfix:postfix /var/mail</userinput>
 </screen>
     </sect3>
@@ -107,7 +108,7 @@
         le sed suivant  :
       </para>
 <screen>
-<userinput>sed -i 's/.x08//g' README_FILES/*</userinput>
+<userinput>sed -i 's/.\x08//g' README_FILES/*</userinput>
 </screen>
       <para>
         L'arborescence des sources de <application>Postfix</application> ne contient pas
@@ -198,14 +199,21 @@
         <application>Postfix</application> en lançant les commandes suivantes :
       </para>
 <screen>
-<userinput>make CCARGS="-DUSE_TLS -I/usr/include/openssl/                                  -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl"      AUXLIBS="-lssl -lcrypto -lsasl2"                                   makefiles &&
+<userinput>make CCARGS="-DUSE_TLS -I/usr/include/openssl/                     \
+             -DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl" \
+     AUXLIBS="-lssl -lcrypto -lsasl2"                              \
+     makefiles &&
 make</userinput>
 </screen>
     
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
-<userinput>sh postfix-install -non-interactive    daemon_directory=/usr/lib/postfix    manpage_directory=/usr/share/man    html_directory=/usr/share/doc/postfix-&postfix-version;/html    readme_directory=/usr/share/doc/postfix-&postfix-version;/readme</userinput>
+<userinput>sh postfix-install -non-interactive \
+   daemon_directory=/usr/lib/postfix \
+   manpage_directory=/usr/share/man \
+   html_directory=/usr/share/doc/postfix-&postfix-version;/html \
+   readme_directory=/usr/share/doc/postfix-&postfix-version;/readme</userinput>
 </screen>
     </sect3>
   </sect2>

Modified: trunk/blfs/server/major/apache.xml
===================================================================
--- trunk/blfs/server/major/apache.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/server/major/apache.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -90,14 +90,28 @@
     tant qu'utilisateur <systemitem class="username">root</systemitem>) :</para>
 <screen role="root">
 <userinput>groupadd -g 25 apache &&
-useradd -c "Apache Server" -d /srv/www -g apache         -s /bin/false -u 25 apache</userinput>
+useradd -c "Apache Server" -d /srv/www -g apache \
+        -s /bin/false -u 25 apache</userinput>
 </screen>
     <para>Construisez et installez <application>Apache HTTPD</application> en lançant
     les commandes suivantes :</para>
 <screen>
-<userinput>patch -Np1 -i ../httpd-&apache-version;-blfs_layout-1.patch &&
-sed '/dir.*CFG_PREFIX/s@^@#@' -i support/apxs.in &&
-./configure --enable-authnz-fcgi                                        --enable-layout=BLFS                                        --enable-mods-shared="all cgi"                              --enable-mpms-shared=all                                    --enable-suexec=shared                                      --with-apr=/usr/bin/apr-1-config                            --with-apr-util=/usr/bin/apu-1-config                       --with-suexec-bin=/usr/lib/httpd/suexec                     --with-suexec-caller=apache                                 --with-suexec-docroot=/srv/www                              --with-suexec-logfile=/var/log/httpd/suexec.log             --with-suexec-uidmin=100                                    --with-suexec-userdir=public_html               &&
+<userinput>patch -Np1 -i ../httpd-&apache-version;-blfs_layout-1.patch           &&
+sed 's/ldump_writer, &b/&, NULL/' -i modules/lua/mod_lua.c  &&
+sed '/dir.*CFG_PREFIX/s@^@#@'     -i support/apxs.in        &&
+./configure --enable-authnz-fcgi                            \
+            --enable-layout=BLFS                            \
+            --enable-mods-shared="all cgi"                  \
+            --enable-mpms-shared=all                        \
+            --enable-suexec=shared                          \
+            --with-apr=/usr/bin/apr-1-config                \
+            --with-apr-util=/usr/bin/apu-1-config           \
+            --with-suexec-bin=/usr/lib/httpd/suexec         \
+            --with-suexec-caller=apache                     \
+            --with-suexec-docroot=/srv/www                  \
+            --with-suexec-logfile=/var/log/httpd/suexec.log \
+            --with-suexec-uidmin=100                        \
+            --with-suexec-userdir=public_html               &&
 make</userinput>
 </screen>
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>
@@ -113,12 +127,10 @@
   </sect2>
   <sect2 role="commands">
     <title>Explication des commandes</title>
-
      <para>
        <command>sed 's/ldump_writer, &b/&, NULL/'...</command>: Ce sed corrige la compilation
        avec <application>lua</application> 5.3.
     </para>
-
     <para>
       <command>sed '/dir.*CFG_PREFIX/s@^@#@'...</command>: Force l'utilitaire
       <application>apxs</application> à utiliser les chemins absolus pour les modules quand les instructions le font.

Modified: trunk/blfs/x/installing/mesalib.xml
===================================================================
--- trunk/blfs/x/installing/mesalib.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/installing/mesalib.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -117,9 +117,20 @@
     <para>
      Installez <application>MesaLib</application> en lançant les commandes
     suivantes :</para>
-
 <screen>
-<userinput>./autogen.sh CFLAGS="-O2" CXXFLAGS="-O2"               --prefix=$XORG_PREFIX                      --sysconfdir=/etc                          --enable-texture-float                     --enable-gles1                             --enable-gles2                             --enable-osmesa                            --enable-xa                                --enable-gbm                               --enable-glx-tls                           --with-egl-platforms="drm,x11"             --with-gallium-drivers="nouveau,r300,r600,radeonsi,svga,swrast" &&
+<userinput>autoreconf -f -i &&
+./configure CFLAGS='-O2' CXXFLAGS='-O2'    \
+            --prefix=$XORG_PREFIX          \
+            --sysconfdir=/etc              \
+            --enable-texture-float         \
+            --enable-gles1                 \
+            --enable-gles2                 \
+            --enable-osmesa                \
+            --enable-xa                    \
+            --enable-gbm                   \
+            --enable-glx-tls               \
+            --with-egl-platforms="drm,x11" \
+            --with-gallium-drivers="nouveau,r300,r600,radeonsi,svga,swrast" &&
 make</userinput>
 </screen>
     <para>

Modified: trunk/blfs/x/installing/x7app.xml
===================================================================
--- trunk/blfs/x/installing/x7app.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/installing/x7app.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -189,7 +189,8 @@
 <screen>
 <userinput>mkdir app &&
 cd app &&
-grep -v '^#' ../app-&xorg-version;.md5 | awk '{print $2}' | wget -i- -c     -B http://xorg.freedesktop.org/releases/individual/app/ &&
+grep -v '^#' ../app-&xorg-version;.md5 | awk '{print $2}' | wget -i- -c \
+    -B http://xorg.freedesktop.org/releases/individual/app/ &&
 md5sum -c ../app-&xorg-version;.md5</userinput>
 </screen>
   </sect2>
@@ -216,7 +217,7 @@
       line3="#  define _XOPEN_SOURCE 600"
       line4="#endif"
  
-      sed -i -e "s@#ifdef HAVE_CONFIG_H@$line1n$line2n$line3n$line4nn&@" sys.c
+      sed -i -e "s@#ifdef HAVE_CONFIG_H@$line1\n$line2\n$line3\n$line4\n\n&@" sys.c
       unset line1 line2 line3 line4
     ;;
   esac

Modified: trunk/blfs/x/installing/x7driver-ati.xml
===================================================================
--- trunk/blfs/x/installing/x7driver-ati.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/installing/x7driver-ati.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -176,14 +176,10 @@
         <systemitem class="username">root</systemitem> :
      </para>
 <screen role="root">
-<userinput>cat >> /etc/X11/xorg.conf << "EOF"
-<literal>Section "Module"
-        Load "dri2"
-        Load "glamoregl"
-EndSection
-Section "Device"
+<userinput>cat >> ${XORG_PREFIX}/share/X11/xorg.conf.d/20-glamor.conf << "EOF"
+<literal>Section "Device"
         Identifier "radeon"
-        Driver "radeon"
+        Driver "ati"
         Option "AccelMethod" "glamor"
 EndSection</literal>
 EOF</userinput>

Modified: trunk/blfs/x/installing/x7driver-intel.xml
===================================================================
--- trunk/blfs/x/installing/x7driver-intel.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/installing/x7driver-intel.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -97,7 +97,7 @@
          
       </para>
 <screen>
-<userinput>./configure $XORG_CONFIG                  --enable-kms-only             --enable-uxa                  --enable-glamor   &&
+<userinput>./configure $XORG_CONFIG --enable-kms-only &&
 make</userinput>
 </screen>
       <para>

Modified: trunk/blfs/x/installing/x7driver-vmware.xml
===================================================================
--- trunk/blfs/x/installing/x7driver-vmware.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/installing/x7driver-vmware.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -89,8 +89,7 @@
          
       </para>
 <screen>
-<userinput>sed -i "/xf86xv.h/i #include <xorg-server.h>" vmwgfx/vmwgfx_overlay.c &&
-./configure $XORG_CONFIG &&
+<userinput>./configure $XORG_CONFIG &&
 make</userinput>
 </screen>
       <para>

Modified: trunk/blfs/x/installing/x7driver.xml
===================================================================
--- trunk/blfs/x/installing/x7driver.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/installing/x7driver.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -32,7 +32,6 @@
       fonctionnant sous
       <application>qemu</application>.
     </para>
-
 <note>
 <para>
 Si vous connaissez le matériel vidéo que vous avez, vous pouvez utiliser

Modified: trunk/blfs/x/installing/x7lib.xml
===================================================================
--- trunk/blfs/x/installing/x7lib.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/installing/x7lib.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -169,7 +169,8 @@
 <screen>
 <userinput>mkdir lib &&
 cd lib &&
-grep -v '^#' ../lib-&xorg-version;.md5 | awk '{print $2}' | wget -i- -c     -B http://xorg.freedesktop.org/releases/individual/lib/ &&
+grep -v '^#' ../lib-&xorg-version;.md5 | awk '{print $2}' | wget -i- -c \
+    -B http://xorg.freedesktop.org/releases/individual/lib/ &&
 md5sum -c ../lib-&xorg-version;.md5</userinput>
 </screen>
   </sect2>
@@ -207,7 +208,8 @@
       ./configure $XORG_CONFIG --disable-devel-docs
     ;;
     libXt-[0-9]* )
-      ./configure $XORG_CONFIG                   --with-appdefaultdir=/etc/X11/app-defaults
+      ./configure $XORG_CONFIG \
+                  --with-appdefaultdir=/etc/X11/app-defaults
     ;;
     * )
       ./configure $XORG_CONFIG

Modified: trunk/blfs/x/installing/xorg-server.xml
===================================================================
--- trunk/blfs/x/installing/xorg-server.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/installing/xorg-server.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -69,7 +69,6 @@
       <xref linkend="libepoxy"/> (requise pour glamor, voir l'explication des commandes
       dessous)
         <xref linkend="xcb-util-keysyms"/> (utilisé par Xnest)
-
     </para>
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional">
@@ -96,7 +95,11 @@
 <userinput>patch -Np1 -i ../xorg-server-&xorg-server-version;-add_prime_support-1.patch</userinput>
 </screen>
 <screen>
-<userinput>./configure $XORG_CONFIG                               --with-xkb-output=/var/lib/xkb              --enable-dmx                                --enable-glamor                             --enable-install-setuid                     --enable-suid-wrapper            &&
+<userinput>./configure $XORG_CONFIG                    \
+           --with-xkb-output=/var/lib/xkb   \
+           --enable-glamor                  \
+           --enable-install-setuid          \
+           --enable-suid-wrapper            &&
 make</userinput>
 </screen>
     <para>Pour tester la construction, tapez : <command>make check</command>.</para>
@@ -138,9 +141,6 @@
       <option>--enable-kdrive</option>: Cette option permet au script
       <command>configure</command> d'activer Xephyr si ses dépendances sont présentes.
     </para>
-
-
-
   </sect2>
   <sect2 role="content">
     <title>Contenu</title>
@@ -226,7 +226,6 @@
           </indexterm>
         </listitem>
       </varlistentry>
-
       <varlistentry id="Xnest-x7">
         <term><command>Xnest</command></term>
         <listitem>

Modified: trunk/blfs/x/lib/cairo.xml
===================================================================
--- trunk/blfs/x/lib/cairo.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/lib/cairo.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -69,8 +69,6 @@
         </para>
       </listitem>
     </itemizedlist>
-
-
 <bridgehead renderas="sect3">Dépendances de Cairo</bridgehead>
     <bridgehead renderas="sect4">Requises</bridgehead>
     <para role="required">
@@ -105,7 +103,8 @@
     <para>Installez <application>Cairo</application> en lançant les commandes
     suivantes :</para>
 <screen>
-<userinput>./configure --prefix=/usr    \
+<userinput>patch -Np1 -i ../cairo-&cairo-version;-upstream_fixes-2.patch &&
+./configure --prefix=/usr    \
             --disable-static \
             --enable-tee &&
 make</userinput>

Modified: trunk/blfs/x/lib/fltk.xml
===================================================================
(Binary files differ)

Modified: trunk/blfs/x/lib/gtk+3.xml
===================================================================
--- trunk/blfs/x/lib/gtk+3.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/lib/gtk+3.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -106,7 +106,11 @@
       suivantes :
     </para>
 <screen>
-<userinput>./configure --prefix=/usr                         --sysconfdir=/etc                     --enable-broadway-backend             --enable-x11-backend                  --disable-wayland-backend &&
+<userinput>./configure --prefix=/usr             \
+            --sysconfdir=/etc         \
+            --enable-broadway-backend \
+            --enable-x11-backend      \
+            --disable-wayland-backend &&
 make</userinput>
 </screen>
      <para>

Modified: trunk/blfs/x/lib/libnotify.xml
===================================================================
--- trunk/blfs/x/lib/libnotify.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/lib/libnotify.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -50,7 +50,6 @@
       </listitem>
     </itemizedlist>
     <bridgehead renderas="sect3">Dépendances de libnotify</bridgehead>
-
     <bridgehead renderas="sect4">Facultatives (Requises pour la construction de GNOME)</bridgehead>
     <para role="optional">
       <xref linkend="gobject-introspection"/>

Modified: trunk/blfs/x/lib/qt5.xml
===================================================================
--- trunk/blfs/x/lib/qt5.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/lib/qt5.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -3,7 +3,7 @@
    "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
-  <!-- Change for new minor releases !!! -->
+  
   <!ENTITY qt5-major "5.4">
   <!ENTITY qt5-url   "http://download.qt-project.org/official_releases/qt/&qt5-major;/&qt5-version;/single">
   <!ENTITY qt5-download-http "&qt5-url;/qt-everywhere-opensource-src-&qt5-version;.tar.xz">
@@ -144,7 +144,24 @@
     </para>
 <screen>
 <userinput>export QT5LINK=/usr
-./configure -prefix         /usr                           -sysconfdir     /etc/xdg                       -bindir         /usr/bin                       -headerdir      /usr/include/qt5               -archdatadir    /usr/lib/qt5                   -datadir        /usr/share/qt5                 -docdir         /usr/share/doc/qt5             -translationdir /usr/share/qt5/translations             -examplesdir    /usr/share/doc/qt5/examples             -confirm-license               -opensource                    -dbus-linked                   -openssl-linked                -system-sqlite                 -no-nis                        -nomake examples               -optimized-qmake   &&
+./configure -prefix         /usr               \
+            -sysconfdir     /etc/xdg           \
+            -bindir         /usr/bin           \
+            -headerdir      /usr/include/qt5   \
+            -archdatadir    /usr/lib/qt5       \
+            -datadir        /usr/share/qt5     \
+            -docdir         /usr/share/doc/qt5 \
+            -translationdir /usr/share/qt5/translations \
+            -examplesdir    /usr/share/doc/qt5/examples \
+            -confirm-license   \
+            -opensource        \
+            -dbus-linked       \
+            -openssl-linked    \
+            -system-sqlite     \
+            -no-nis            \
+            -skip qtwebengine  \
+            -nomake examples   \
+            -optimized-qmake   &&
 make</userinput>
 </screen>
     <para>
@@ -155,7 +172,7 @@
       en lançant la commande suivante:
     </para>
 <screen>
-<userinput>find . -name "*.pc" -exec perl -pi -e "s, -L$PWD/?S+,,g" {} ;</userinput>
+<userinput>find . -name "*.pc" -exec perl -pi -e "s, -L$PWD/?\S+,,g" {} \;</userinput>
 </screen>
     <para>
       Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :
@@ -169,8 +186,10 @@
       <systemitem class="username">root</systemitem>:
     </para>
 <screen role="root">
-<userinput>sed -e "s:$PWD/qtbase:/usr/lib/qt5:g"     -i /usr/lib/qt5/mkspecs/modules/qt_lib_bootstrap_private.pri &&
-find /usr/lib/lib{qgsttools_p,Qt5*}.prl -exec sed -i -r      '/^QMAKE_PRL_BUILD_DIR/d;s/(QMAKE_PRL_LIBS =).*/1/' {} ;</userinput>
+<userinput>sed -e "s:$PWD/qtbase:/usr/lib/qt5:g" \
+    -i /usr/lib/qt5/mkspecs/modules/qt_lib_bootstrap_private.pri &&
+find /usr/lib/lib{qgsttools_p,Qt5*}.prl -exec sed -i -r \
+     '/^QMAKE_PRL_BUILD_DIR/d;s/(QMAKE_PRL_LIBS =).*/\1/' {} \;</userinput>
 </screen>
  <bridgehead renderas="sect3">Methode 2: Installation dans /opt/qt-&qt5-version;</bridgehead>
     <para>
@@ -180,7 +199,17 @@
 <screen>
 <userinput>export QT5DIR=/opt/qt-&qt5-version; &&
 export QT5LINK=/opt/qt5 &&
-./configure -prefix     $QT5DIR              -sysconfdir /etc/xdg             -confirm-license                 -opensource                      -dbus-linked                     -openssl-linked                  -system-sqlite                   -no-nis                          -nomake examples                 -optimized-qmake     &&
+./configure -prefix     $QT5DIR  \
+            -sysconfdir /etc/xdg \
+            -confirm-license     \
+            -opensource          \
+            -dbus-linked         \
+            -openssl-linked      \
+            -system-sqlite       \
+            -no-nis              \
+            -nomake examples     \
+            -skip qtwebengine    \
+            -optimized-qmake     &&
 make</userinput>
 </screen>
     <para>
@@ -196,8 +225,10 @@
       <systemitem class="username">root</systemitem>:
     </para>
 <screen role="root">
-<userinput>find $QT5DIR -name qt_lib_bootstrap_private.pri    -exec sed -i -e "s:$PWD/qtbase:/$QT5DIR/lib/:g" {} ; &&
-find $QT5DIR -name *.prl    -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} ;</userinput>
+<userinput>find $QT5DIR -name qt_lib_bootstrap_private.pri \
+   -exec sed -i -e "s:$PWD/qtbase:/$QT5DIR/lib/:g" {} \; &&
+find $QT5DIR -name \*.prl \
+   -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;</userinput>
 </screen>
     <bridgehead renderas="sect3">Suite pour les deux méthodes</bridgehead>
     <para>
@@ -208,10 +239,14 @@
     </para>
 <screen role="root">
 <userinput>install -v -dm755 /usr/share/pixmaps/                  &&
-install -v -Dm644 qttools/src/assistant/assistant/images/assistant-128.png                   /usr/share/pixmaps/assistant-qt5.png &&
-install -v -Dm644 qttools/src/designer/src/designer/images/designer.png                   /usr/share/pixmaps/designer-qt5.png  &&
-install -v -Dm644 qttools/src/linguist/linguist/images/icons/linguist-128-32.png                   /usr/share/pixmaps/linguist-qt5.png  &&
-install -v -Dm644 qttools/src/qdbus/qdbusviewer/images/qdbusviewer-128.png                   /usr/share/pixmaps/qdbusviewer-qt5.png &&
+install -v -Dm644 qttools/src/assistant/assistant/images/assistant-128.png \
+                  /usr/share/pixmaps/assistant-qt5.png &&
+install -v -Dm644 qttools/src/designer/src/designer/images/designer.png \
+                  /usr/share/pixmaps/designer-qt5.png  &&
+install -v -Dm644 qttools/src/linguist/linguist/images/icons/linguist-128-32.png \
+                  /usr/share/pixmaps/linguist-qt5.png  &&
+install -v -Dm644 qttools/src/qdbus/qdbusviewer/images/qdbusviewer-128.png \
+                  /usr/share/pixmaps/qdbusviewer-qt5.png &&
 install -dm755 /usr/share/applications &&
 cat > /usr/share/applications/assistant-qt5.desktop << EOF
 <literal>[Desktop Entry]
@@ -297,16 +332,15 @@
       <application>Qt5</application> au lieu de les
       <command>dlopen()</command>-itiser.
     </para>
-
      <para>
       <parameter>-skip qtwebengine</parameter>: ce paramètre désactive la construction
       du moteur Web Qt. Il n'est pas présentement utilisé par des application. Si c'est option est enlevée, 
       corrigez un problème de construction avec :
-<screen><userinput>sed -i '$ a !contains(QT_CONFIG, pulseaudio): GYP_CONFIG += use_pulseaudio=0' \
-       qtwebengine/src/core/config/desktop_linux.pri</userinput></screen>
+<screen>
+<userinput>sed -i '$ a !contains(QT_CONFIG, pulseaudio): GYP_CONFIG += use_pulseaudio=0' \
+       qtwebengine/src/core/config/desktop_linux.pri</userinput>
+</screen>
     </para>
-
-
     <para>
       <parameter>-optimized-qmake</parameter>: Ce paramètre active
       la construction du programme optimisé <command>qmake</command>.
@@ -317,8 +351,6 @@
       qui corrige quelques problèmes de rendu de police dans les applications
       <application>Qt5</application> mais n'a pas toutes les fonctionnalités que la version incluse a.
     </para>
-
-
   </sect2>
   <sect2 role="configuration">
     <title>Configuration de Qt5</title>

Modified: trunk/blfs/x/lib/webkitgtk26.xml
===================================================================
(Binary files differ)

Modified: trunk/blfs/x/wm/fluxbox.xml
===================================================================
--- trunk/blfs/x/wm/fluxbox.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/wm/fluxbox.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -153,7 +153,7 @@
       formats d'image.</para>
 <screen>
 <userinput>cp /usr/share/fluxbox/styles/<theme> ~/.fluxbox/theme &&
-sed -i 's,(session.styleFile:).*,1 ~/.fluxbox/theme,' ~/.fluxbox/init &&
+sed -i 's,\(session.styleFile:\).*,\1 ~/.fluxbox/theme,' ~/.fluxbox/init &&
 [ -f ~/.fluxbox/theme ] &&
 echo "background.pixmap: </path/to/nice/image.ext>" >> ~/.fluxbox/theme ||
 [ -d ~/.fluxbox/theme ] &&

Modified: trunk/blfs/x/wm/openbox.xml
===================================================================
--- trunk/blfs/x/wm/openbox.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/x/wm/openbox.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -84,13 +84,12 @@
 <userinput>export LIBRARY_PATH=$XORG_PREFIX/lib</userinput>
 </screen>
     </note>
-
     <para>Si vous installez seulement le module Python 3 PyXDG convertissez l'un des scripts pour
  Python 3:</para>
-<screen><userinput>2to3 -w data/autostart/openbox-xdg-autostart &&
-sed 's/python/python3/' -i data/autostart/openbox-xdg-autostart</userinput></screen>
-
-
+<screen>
+<userinput>2to3 -w data/autostart/openbox-xdg-autostart &&
+sed 's/python/python3/' -i data/autostart/openbox-xdg-autostart</userinput>
+</screen>
    <para>
       Installez <application>Openbox</application> en lançant les commandes
       commands:

Modified: trunk/blfs/xfce/core/thunar.xml
===================================================================
--- trunk/blfs/xfce/core/thunar.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/xfce/core/thunar.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -96,17 +96,16 @@
       Par défaut,  <application>Thunar</application> installe ses menus dans la catégorie System. si vous le souhaitez,
 changez cela pour le catégorie Utilities:
      </para>
-<screen><userinput>sed -i 's/System;//' Thunar.desktop.in.in</userinput></screen>
+<screen>
+<userinput>sed -i 's/System;//' Thunar.desktop.in.in</userinput>
+</screen>
     </note>
-
-
     <para>
       Installez <application>Thunar</application> en lançant les commandes
       suivantes :
     </para>
 <screen>
-<userinput>sed -i 's/System;//' Thunar.desktop.in.in &&
-./configure --prefix=/usr \
+<userinput>./configure --prefix=/usr \
             --sysconfdir=/etc \
             --docdir=/usr/share/doc/Thunar-&thunar-version; &&
 make</userinput>

Modified: trunk/blfs/xsoft/graphweb/firefox.xml
===================================================================
--- trunk/blfs/xsoft/graphweb/firefox.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/xsoft/graphweb/firefox.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -139,8 +139,8 @@
 ac_add_options --disable-libnotify
 # GStreamer is necessary for H.264 video playback in HTML5 Video Player;
 # to be enabled, also remember to set "media.gstreamer.enabled" to "true"
-# in about:config. If you do *not* have GStreamer 0.x.y, uncomment this line:
-#ac_add_options --disable-gstreamer
+# in about:config. If you have GStreamer 0.x.y, comment out this line:
+ac_add_options --disable-gstreamer
 # or uncomment this line, if you have GStreamer 1.x.y
 #ac_add_options --enable-gstreamer=1.0
 # Uncomment these lines if you have installed optional dependencies:
@@ -205,7 +205,8 @@
      </para></note>
  
 <screen>
-<userinput>MOZ_MAKE_FLAGS='-j<replaceable><number></replaceable>' make -f client.mk</userinput>
+<userinput>MOZ_MAKE_FLAGS='-j<replaceable><number></replaceable>' \
+make -f client.mk</userinput>
 </screen>
      <para>
       where <replaceable><number></replaceable> est un entier compris entre 1
@@ -220,7 +221,8 @@
       Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :
     </para>
 <screen role="root">
-<userinput>MOZ_MAKE_FLAGS='-j<replaceable><number></replaceable>' make -f client.mk install INSTALL_SDK= &&
+<userinput>MOZ_MAKE_FLAGS='-j<replaceable><number></replaceable>' \
+make -f client.mk install INSTALL_SDK= &&
 mkdir -pv /usr/lib/mozilla/plugins &&
 ln -sfv ../../mozilla/plugins /usr/lib/firefox-&firefox-version;/browser</userinput>
 </screen>
@@ -289,7 +291,8 @@
 MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
 StartupNotify=true</literal>
 EOF
-ln -sfv /usr/lib/firefox-&firefox-version;/browser/icons/mozicon128.png         /usr/share/pixmaps/firefox.png</userinput>
+ln -sfv /usr/lib/firefox-&firefox-version;/browser/icons/mozicon128.png \
+        /usr/share/pixmaps/firefox.png</userinput>
 </screen>
   </sect2>
   <sect2 role="content">

Modified: trunk/blfs/xsoft/graphweb/seamonkey.xml
===================================================================
--- trunk/blfs/xsoft/graphweb/seamonkey.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/xsoft/graphweb/seamonkey.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -235,8 +235,9 @@
     <para>Installez <application>SeaMonkey</application> en lançant les
     commandes suivantes en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 <screen role="root">
-<userinput>make -f client.mk install INSTALL_SDK= &&
-cp -v moz-build-dir/dist/man/man1/seamonkey.1 /usr/share/man/man1</userinput>
+<userinput>make  -f client.mk install INSTALL_SDK= &&
+chown -R 0:0 /usr/lib/seamonkey-&seamonkey-version;  &&
+cp    -v moz-build-dir/dist/man/man1/seamonkey.1 /usr/share/man/man1</userinput>
 </screen>
  
     <bridgehead renderas="sect3" id="devel-seamonkey" xreflabel="Seamonkey">
@@ -322,7 +323,8 @@
 StartupNotify=true
 Terminal=false
 EOF
-ln -sfv /usr/lib/seamonkey-&seamonkey-version;/chrome/icons/default/seamonkey.png         /usr/share/pixmaps</userinput>
+ln -sfv /usr/lib/seamonkey-&seamonkey-version;/chrome/icons/default/seamonkey.png \
+        /usr/share/pixmaps</userinput>
 </screen>
   </sect2>
   <sect2 role="content">

Modified: trunk/blfs/xsoft/office/libreoffice.xml
===================================================================
--- trunk/blfs/xsoft/office/libreoffice.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/xsoft/office/libreoffice.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -16,21 +16,12 @@
   <!ENTITY libreoffice-translations-download-http "&libreoffice-dl;/libreoffice-translations-&libreoffice-dlversion;.tar.xz">
   <!ENTITY libreoffice-translations-md5sum        "064605fe0695dcf0b461036c07e75c7a">
   <!ENTITY libreoffice-translations-size          "122 Mo">
-  <!-- This package has some peculiarities, some discussed in the text.
-  Two values for SBU and buildsize are given due to the large difference
-  measured by editors, depending on architecture and sometimes installé
-  dependencies (with-system... -->
+  
   <!ENTITY libreoffice-buildsize          "8.6 Go (538 Mo installé), with translations">
   <!ENTITY libreoffice-time               "70 SBU (using parallelism=4), with translations">
-  <!-- [bdubbs]  For version 4.3.2.2 Built on x86_64 using -\-with-parallelism=4 -->
-  <!-- [fo] For version 4.3.1.2 I've got, for i686, statistcs over the upper
-  boundaries for x86_64 of previous versions, thus, temporarily, decided to use
-  single statistcs, instead of a range.
-  -->
-  <!-- This package has some peculiarities, some discussed in the text.
-  Two values for SBU and buildsize are given due to the large difference
-  measured by editors, depending on architecture and sometimes installé
-  dependencies (with-system... -->
+  
+  
+  
 ]>
 <sect1 id="libreoffice" xreflabel="libreoffice-&libreoffice-dlversion;">
   <?dbhtml filename="libreoffice.html"?>
@@ -304,11 +295,50 @@
       suivantes:
     </para>
 <screen>
-<userinput>patch -Np1 -i ../libreoffice-&libreoffice-dlversion;-boost_1_56_0-1.patch &&
-sed -e "/gzip -f/d"       -e "s|.1.gz|.1|g"     -i bin/distro-install-desktop-integration &&
+<userinput>sed -e "/gzip -f/d"   \
+    -e "s|.1.gz|.1|g" \
+    -i bin/distro-install-desktop-integration &&
 sed -e "/distro-install-file-lists/d" -i Makefile.in &&
+sed -e "/ustrbuf/a #include <algorithm>" \
+    -i svl/source/misc/gridprinter.cxx   &&
 chmod -v +x bin/unpack-sources &&
-./autogen.sh --prefix=$LO_PREFIX                      --sysconfdir=/etc                        --with-vendor="BLFS"                     --with-lang="en-US pt-BR"                --with-help                              --with-myspell-dicts                     --with-alloc=system                      --without-java                           --without-system-dicts                   --disable-gconf                          --disable-odk                            --disable-postgresql-sdbc                --enable-release-build=yes               --enable-python=system                   --with-system-boost                      --with-system-clucene                    --with-system-cairo                      --with-system-curl                       --with-system-expat                      --with-system-graphite                   --with-system-harfbuzz                   --with-system-icu                        --with-system-jpeg                       --with-system-lcms2                      --with-system-libpng                     --with-system-libxml                     --with-system-mesa-headers               --with-system-neon                       --with-system-npapi-headers              --with-system-nss                        --with-system-odbc                       --with-system-openldap                   --with-system-openssl                    --with-system-poppler                    --with-system-redland                    --with-system-zlib                       --with-parallelism=$(getconf _NPROCESSORS_ONLN)</userinput>
+./autogen.sh --prefix=$LO_PREFIX         \
+             --sysconfdir=/etc           \
+             --with-vendor="BLFS"        \
+             --with-lang="en-US pt-BR"   \
+             --with-help                 \
+             --with-myspell-dicts        \
+             --with-alloc=system         \
+             --without-java              \
+             --without-system-dicts      \
+             --disable-gconf             \
+             --disable-odk               \
+             --disable-postgresql-sdbc   \
+             --enable-release-build=yes  \
+             --enable-python=system      \
+             --with-system-boost         \
+             --with-system-clucene       \
+             --with-system-cairo         \
+             --with-system-curl          \
+             --with-system-expat         \
+             --with-system-graphite      \
+             --with-system-harfbuzz      \
+             --with-system-icu           \
+             --with-system-jpeg          \
+             --with-system-lcms2         \
+             --with-system-libpng        \
+             --with-system-libxml        \
+             --with-system-mesa-headers  \
+             --with-system-neon          \
+             --with-system-npapi-headers \
+             --with-system-nss           \
+             --with-system-odbc          \
+             --with-system-openldap      \
+             --with-system-openssl       \
+             --with-system-poppler       \
+             --with-system-redland       \
+             --with-system-zlib          \
+             --with-parallelism=$(getconf _NPROCESSORS_ONLN)</userinput>
 </screen>
 <para>
    Les instructions suivantes vont seulement construire le paquet sans lancer aucune
@@ -327,7 +357,8 @@
 <screen role="root">
 <userinput>make distro-pack-install                                  &&
 install -v -m755 -d $LO_PREFIX/share/appdata              &&
-install -v -m644    sysui/desktop/appstream-appdata/*.xml                     $LO_PREFIX/share/appdata</userinput>
+install -v -m644    sysui/desktop/appstream-appdata/*.xml \
+                    $LO_PREFIX/share/appdata</userinput>
 </screen>
     <para>
        Si vous avez installé dans <filename class="directory">/opt/libreoffice-&libreoffice-dlversion;</filename>
@@ -337,13 +368,26 @@
     </para>
 <screen role="root">
 <userinput>if [ "$LO_PREFIX" != "/usr" ]; then
-   mkdir -pv /usr/share/pixmaps 
-   for i in writer base calc draw impress math startcenter writer
-   do
-     ln -svf $LO_PREFIX/share/icons/hicolor/32x32/apps/libreoffice-$i.png              /usr/share/pixmaps/
-   done
-   unset i
-fi</userinput>
+  # This symlink is necessary for the desktop menu entries
+  ln -sv -f $LO_PREFIX/lib/libreoffice/program/soffice \
+            /usr/bin/libreoffice &&
+  # Icons
+  for i in $LO_PREFIX/share/icons/hicolor/32x32/apps/*; do
+    ln -svf $i /usr/share/pixmaps
+  done; unset i &&
+  # Desktop menu entries
+  pushd $LO_PREFIX/lib/libreoffice/share/xdg &&
+  for i in *; do
+    ln -svf $LO_PREFIX/lib/libreoffice/share/xdg/$i \
+            /usr/share/applications/libreoffice-$i
+  done; unset i &&
+  popd &&
+  # Man pages
+  for i in $LO_PREFIX/share/man/man1/*; do
+     ln -svf $i /usr/share/man/man1/
+  done; unset i
+fi &&
+update-desktop-database</userinput>
 </screen>
     <para>
        Si vous installez dans <filename
@@ -351,14 +395,6 @@
        créez les liens vers les pages de manuel. Soyez certain que la variable d'environnement
        LO_PREFIX est définie pour l'utilisateur root.
     </para>
-<screen role="root">
-<userinput>if [ "$LO_PREFIX" != "/usr" ]; then
-   for i in $LO_PREFIX/share/man/man1/*; do
-      ln -svf $i /usr/share/man/man1/
-   done
-   unset i
-fi</userinput>
-</screen>
 </sect2>
   <sect2 role="commands">
     <title>Explications des commandes</title>

Modified: trunk/blfs/xsoft/other/asymptote.xml
===================================================================
(Binary files differ)

Modified: trunk/blfs/xsoft/other/feh.xml
===================================================================
(Binary files differ)

Modified: trunk/blfs/xsoft/other/fontforge.xml
===================================================================
(Binary files differ)

Modified: trunk/blfs/xsoft/other/gparted.xml
===================================================================
--- trunk/blfs/xsoft/other/gparted.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/xsoft/other/gparted.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -85,7 +85,9 @@
       commands:
     </para>
 <screen>
-<userinput>./configure --prefix=/usr                --disable-doc                --disable-static &&
+<userinput>./configure --prefix=/usr    \
+            --disable-doc    \
+            --disable-static &&
 make</userinput>
 </screen>
     <para>
@@ -166,8 +168,10 @@
           configurez <xref linkend="gparted"/> et <xref linkend="polkit"/> avec les commandes suivantes:
         </para>
 <screen role="root">
-<userinput>cp -v /usr/share/applications/gparted.desktop                                      /usr/share/applications/gparted.desktop.back &&
-sed -i 's:/usr/sbin/gparted:/usr/sbin/gparted_polkit:'                                      /usr/share/applications/gparted.desktop      &&
+<userinput>cp -v /usr/share/applications/gparted.desktop \
+                                     /usr/share/applications/gparted.desktop.back &&
+sed -i 's:/usr/sbin/gparted:/usr/sbin/gparted_polkit:' \
+                                     /usr/share/applications/gparted.desktop      &&
 cat > /usr/sbin/gparted_polkit << "EOF" &&
 <literal>#!/bin/bash
 pkexec /usr/sbin/gparted $@</literal>

Modified: trunk/blfs/xsoft/other/hexchat.xml
===================================================================
(Binary files differ)

Modified: trunk/blfs/xsoft/other/inkscape.xml
===================================================================
--- trunk/blfs/xsoft/other/inkscape.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/xsoft/other/inkscape.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -3,7 +3,7 @@
    "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
-  <!-- inkscape.org appears to point to launchpad, sf is out of date -->
+  
   <!ENTITY inkscape-download-http "https://launchpad.net/inkscape/0.91.x/0.91/+download/inkscape-&inkscape-version;.tar.bz2">
   <!ENTITY inkscape-download-ftp  " ">
   <!ENTITY inkscape-md5sum        "278dfa4514adcde23546370ec2c84581">
@@ -125,17 +125,13 @@
       commands:
     </para>
 <screen>
-<userinput>patch -Np1 -i ../inkscape-&inkscape-version;-poppler-1.patch &&
-autoreconf -vi &&
-sed -ri "s:.*(unsigned GC_version).*:1 = GC_get_version();:" configure &&
+<userinput>patch -Np1 -i ../inkscape-&inkscape-version;-testfiles-1.patch &&
 ./configure --prefix=/usr &&
 make</userinput>
 </screen>
      <para>
        Pour tester le résultat, tapez: <command>make check</command>.
      </para>
-
-
     <para>
       Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :
     </para>

Modified: trunk/blfs/xsoft/other/other.xml
===================================================================
--- trunk/blfs/xsoft/other/other.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/xsoft/other/other.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -9,7 +9,6 @@
   <title>Autres programmes basés sur X</title>
  <para>Ces programmes utilisent le système X et n'ont pas trouvé facilement une place dans les
    autres chapitres.</para>
-
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="asymptote.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="balsa.xml"/>
 <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="ekiga.xml"/>

Modified: trunk/blfs/xsoft/other/thunderbird.xml
===================================================================
--- trunk/blfs/xsoft/other/thunderbird.xml	2015-02-18 12:26:57 UTC (rev 6755)
+++ trunk/blfs/xsoft/other/thunderbird.xml	2015-02-19 12:15:49 UTC (rev 6756)
@@ -280,7 +280,8 @@
 MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;x-scheme-handler/mailto;
 StartupNotify=true</literal>
 EOF
-ln -sfv /usr/lib/thunderbird-&thunderbird-version;/chrome/icons/default/default256.png         /usr/share/pixmaps/thunderbird.png</userinput>
+ln -sfv /usr/lib/thunderbird-&thunderbird-version;/chrome/icons/default/default256.png \
+        /usr/share/pixmaps/thunderbird.png</userinput>
 </screen>
     </sect3>
   </sect2>

Modified: trunk/blfs/xsoft/other/tigervnc.xml
===================================================================
(Binary files differ)



More information about the lfs-traducfr mailing list