[lfs-fr] r5638 - in trunk/lfs: . chapter01 chapter05 chapter06

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Sam 8 Fév 16:45:39 PST 2014


Author: jmengual
Date: 2014-02-09 01:45:39 +0100 (Sun, 09 Feb 2014)
New Revision: 5638

Modified:
   trunk/lfs/chapter01/changelog.xml
   trunk/lfs/chapter01/whatsnew.xml
   trunk/lfs/chapter05/glibc.xml
   trunk/lfs/chapter06/glibc.xml
   trunk/lfs/general.ent
   trunk/lfs/packages.ent
Log:
Mise a jour de Glibc


Modified: trunk/lfs/chapter01/changelog.xml
===================================================================
--- trunk/lfs/chapter01/changelog.xml	2014-02-09 00:10:10 UTC (rev 5637)
+++ trunk/lfs/chapter01/changelog.xml	2014-02-09 00:45:39 UTC (rev 5638)
@@ -37,6 +37,15 @@
     </listitem>
 -->
     <listitem>
+      <para>08-02-2014</para>
+      <itemizedlist>
+        <listitem>
+          <para>[bdubbs] - Passage à glibc-2.19.  Corrige
+          <ulink url="&lfs-ticket-root;3486">#3486</ulink>.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+    <listitem>
       <para>07-02-2014</para>
       <itemizedlist>
         <listitem>

Modified: trunk/lfs/chapter01/whatsnew.xml
===================================================================
--- trunk/lfs/chapter01/whatsnew.xml	2014-02-09 00:10:10 UTC (rev 5637)
+++ trunk/lfs/chapter01/whatsnew.xml	2014-02-09 00:45:39 UTC (rev 5638)
@@ -86,9 +86,9 @@
     <listitem>
       <para>Gettext &gettext-version;</para>
     </listitem>
-    <!--<listitem>
+    <listitem>
       <para>Glibc &glibc-version;</para>
-    </listitem>-->
+    </listitem>
     <listitem>
       <para>GMP &gmp-version;</para>
     </listitem>

Modified: trunk/lfs/chapter05/glibc.xml
===================================================================
--- trunk/lfs/chapter05/glibc.xml	2014-02-09 00:10:10 UTC (rev 5637)
+++ trunk/lfs/chapter05/glibc.xml	2014-02-09 00:45:39 UTC (rev 5638)
@@ -52,14 +52,6 @@
   su -c 'cp -v sunrpc/rpc/*.h /usr/include/rpc'
 fi</userinput></screen>
 
-    <para>Il convient de revenir sur une modification en amont :</para>
-
-<screen><userinput remap="pre">sed -i -e 's/static __m128i/inline &/' sysdeps/x86_64/multiarch/strstr.c</userinput></screen>
-
-    <para>Autorisez Glibc à se construire en utilisant Make-&make-version; :</para>
-
-<screen><userinput remap="pre">sed -r -i 's/(3..89..)/\1 | 4.*/' configure</userinput></screen>
-
    <para>La documentation de Glibc recommande de construire Glibc en dehors du
     répertoire des sources, c'est-à-dire dans un répertoire dédié :</para>
 

Modified: trunk/lfs/chapter06/glibc.xml
===================================================================
--- trunk/lfs/chapter06/glibc.xml	2014-02-09 00:10:10 UTC (rev 5637)
+++ trunk/lfs/chapter06/glibc.xml	2014-02-09 00:45:39 UTC (rev 5638)
@@ -55,6 +55,11 @@
       l'Unicode, du coup libiconv n'est pas requis sur un système LFS.</para>
     </note>
 
+    <para>Tout d'abord, corrigez un petit problème d'installation du script
+     tzselect :</para>
+
+<screen><userinput remap="pre">sed -i 's/\\$$(pwd)/`pwd`/' timezone/Makefile</userinput></screen>
+
     <para>Le système de construction de Glibc est auto-extractible et il
     s'installera parfaitement, même si le fichier specs du compilateur et l'éditeur
     de liens pointent vers <filename class="directory">/tools</filename>. Les specs
@@ -62,14 +67,6 @@
     Glibc, car les tests autoconf de Glibc donneraient de faux résultats, ce qui
     irait à l'encontre du but de faire une construction propre.</para>
 
-    <para>Il convient de revenir sur une modification en amont :</para>
-
-<screen><userinput remap="pre">sed -i -e 's/static __m128i/inline &/' sysdeps/x86_64/multiarch/strstr.c</userinput></screen>
-
-    <para>Autorisez Glibc à se construire en utilisant Make-&make-version; :</para>
-
-<screen><userinput remap="pre">sed -r -i 's/(3..89..)/\1 | 4.*/' configure</userinput></screen>
-
     <para>La documentation de Glibc recommande de construire Glibc en dehors du
     répertoire des sources dans un répertoire de construction dédié :</para>
 
@@ -437,7 +434,7 @@
         pldd, rpcgen, sln, sotruss, sprof, tzselect, xtrace,
         zdump et zic</seg>
         <seg>ld.so, libBrokenLocale.{a,so}, libSegFault.so, libanl.{a,so},
-        libbsd-compat.a, libc.{a,so}, libc_nonshared.a, libcidn.so,
+        libc.{a,so}, libc_nonshared.a, libcidn.so,
         libcrypt.{a,so}, libdl.{a,so}, libg.a, libieee.a, libm.{a,so},
         libmcheck.a, libmemusage.so, libnsl.{a,so}, libnss_compat.so,
         libnss_dns.so, libnss_files.so, libnss_hesiod.so, libnss_nis.so,
@@ -768,17 +765,6 @@
         </listitem>
       </varlistentry>
 
-      <varlistentry id="libbsd-compat">
-        <term><filename class="libraryfile">libbsd-compat</filename></term>
-        <listitem>
-          <para>Fournit la portabilité nécessaire pour faire fonctionner certains
-          programmes BSD (Berkeley Software Distribution) sous Linux</para>
-          <indexterm zone="ch-system-glibc libbsd-compat">
-            <primary sortas="c-libbsd-compat">libbsd-compat</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
       <varlistentry id="libc">
         <term><filename class="libraryfile">libc</filename></term>
         <listitem>

Modified: trunk/lfs/general.ent
===================================================================
--- trunk/lfs/general.ent	2014-02-09 00:10:10 UTC (rev 5637)
+++ trunk/lfs/general.ent	2014-02-09 00:45:39 UTC (rev 5638)
@@ -1,6 +1,6 @@
 <?xml version="1.0" encoding="ISO-8859-1"?>
-<!ENTITY version         "SVN-20140207">
-<!ENTITY releasedate     "7 février 2014">
+<!ENTITY version         "SVN-20140208">
+<!ENTITY releasedate     "8 février 2014">
 <!ENTITY copyrightdate   "1999-2013"><!-- jhalfs needs a literal dash, not – -->
 <!ENTITY milestone       "7.5">
 <!ENTITY generic-version "development"> <!-- Use "development", "testing", or "x.y[-pre{x}]" -->

Modified: trunk/lfs/packages.ent
===================================================================
--- trunk/lfs/packages.ent	2014-02-09 00:10:10 UTC (rev 5637)
+++ trunk/lfs/packages.ent	2014-02-09 00:45:39 UTC (rev 5638)
@@ -206,10 +206,10 @@
 <!ENTITY gettext-ch6-du "199 Mo">
 <!ENTITY gettext-ch6-sbu "2.3 SBU">
 
-<!ENTITY glibc-version "2.18">
-<!ENTITY glibc-size "10,892 Ko">
+<!ENTITY glibc-version "2.19">
+<!ENTITY glibc-size "11,801 Ko">
 <!ENTITY glibc-url "&gnu;glibc/glibc-&glibc-version;.tar.xz">
-<!ENTITY glibc-md5 "88fbbceafee809e82efd52efa1e3c58f">
+<!ENTITY glibc-md5 "e26b8cc666b162f999404b03970f14e4">
 <!ENTITY glibc-home "&gnu-software;libc/">
 <!ENTITY glibc-ch5-du "567 Mo">
 <!ENTITY glibc-ch5-sbu "4.7 SBU">




More information about the lfs-traducfr mailing list