[lfs-fr] r1743 - in trunk/blfs: . general/genlib general/graphlib general/prog general/sysutils introduction/welcome networking/netprogs x/lib xsoft/graphweb xsoft/office xsoft/other

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Mar 27 Mar 17:39:12 PDT 2012


Author: jmengual
Date: 2012-03-28 02:39:12 +0200 (Wed, 28 Mar 2012)
New Revision: 1743

Added:
   trunk/blfs/general/graphlib/openjpeg.xml
Modified:
   trunk/blfs/general.ent
   trunk/blfs/general/genlib/aspell.xml
   trunk/blfs/general/graphlib/babl.xml
   trunk/blfs/general/graphlib/gegl.xml
   trunk/blfs/general/graphlib/graphlib.xml
   trunk/blfs/general/graphlib/poppler.xml
   trunk/blfs/general/prog/tk.xml
   trunk/blfs/general/sysutils/udev.xml
   trunk/blfs/introduction/welcome/changelog.xml
   trunk/blfs/networking/netprogs/ncftp.xml
   trunk/blfs/networking/netprogs/nfs-utils.xml
   trunk/blfs/x/lib/goffice.xml
   trunk/blfs/x/lib/webkitgtk.xml
   trunk/blfs/xsoft/graphweb/firefox.xml
   trunk/blfs/xsoft/graphweb/seamonkey.xml
   trunk/blfs/xsoft/office/abiword.xml
   trunk/blfs/xsoft/other/thunderbird.xml
Log:
9780-9791


Modified: trunk/blfs/general/genlib/aspell.xml
===================================================================
--- trunk/blfs/general/genlib/aspell.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/general/genlib/aspell.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -34,7 +34,7 @@
     <application>Aspell</application>. Vous pouvez utiliser <application>Aspell</application> 
     soit comme une bibliothèque soit comme un vérificateur d'orthographe indépendant.</para>
 
-    &lfs65_checked;
+    &lfs71_checked;
 
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">

Modified: trunk/blfs/general/graphlib/babl.xml
===================================================================
--- trunk/blfs/general/graphlib/babl.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/general/graphlib/babl.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -27,7 +27,7 @@
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction à babl</title>
+    <title>Introduction à Babl</title>
 
     <para>Le paquet <application>babl</application> est une bibliothèque dynamique
     de traduction de format pixel par pixel.</para>
@@ -56,7 +56,7 @@
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">Dépendances de bable</bridgehead>
+    <bridgehead renderas="sect3">Dépendances de Bable</bridgehead>
 
     <bridgehead renderas="sect4">Recommandées</bridgehead>
     <para role="recommended"><xref linkend="pkgconfig"/></para>
@@ -71,12 +71,13 @@
   </sect2>
 
   <sect2 role="installation">
-    <title>Installation de babl</title>
+    <title>Installation de Babl</title>
 
     <para>Installez <application>babl</application> en lançant les commandes
     suivantes :</para>
 
-<screen><userinput>./configure --prefix=/usr &&
+<screen><userinput>sed -i 's#DBABL_IS_BEING_COMPILED#& -lgmodule-2.0#' babl/Makefile.in &&
+./configure --prefix=/usr &&
 make</userinput></screen>
 
     <para>Pour tester les résultats, lancez : <command>make check</command>.</para>
@@ -94,6 +95,12 @@
   <sect2 role="commands">
     <title>Explications de la commande</title>
 
+    <para><command>sed -i 's#DBABL_IS_BEING_COMPILED#& -lgmodule-2.0#'
+      babl/Makefile.in</command> : Ce sed corrige la compilation lorsque
+      <application>Glib-2.32</application> et
+      <xref linkend="gobject-introspection"/> sont tous les deux installés.
+    </para>
+
     <para><parameter>install -v -m755 -d /usr/share/gtk-doc/html/babl/graphics</parameter> :
     Ceci ainsi que les commandes qui en résultent installent la documentation html
     de la bibliothèque dans <filename class="directory">/usr/share/gtk-doc/html</filename> 
@@ -103,18 +110,17 @@
     pour que les programmes <application>vala</application> puissent utiliser
     cette application - désactivé par défaut, peut casser des choses lors de
     la construction d'<application>gegl</application>.</para>
+
   </sect2>
 
   <sect2 role="content">
     <title>Contenu</title>
 
     <segmentedlist>
-      <segtitle>Programmes installés</segtitle>
       <segtitle>Bibliothèques installées</segtitle>
       <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
-        <seg>Aucun</seg>
         <seg>libbabl.so, et libraries in /usr/lib/babl-0.1/</seg>
         <seg>/usr/include/babl-0.1/</seg>
       </seglistitem>

Modified: trunk/blfs/general/graphlib/gegl.xml
===================================================================
--- trunk/blfs/general/graphlib/gegl.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/general/graphlib/gegl.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -4,8 +4,8 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gegl-download-http "http://gd.tuwien.ac.at/graphics/gimp/gegl/0.1//gegl-&gegl-version;.tar.bz2">
-  <!ENTITY gegl-download-ftp  "ftp://ftp.gimp.org/pub/gegl/0.1//gegl-&gegl-version;.tar.bz2">
+  <!ENTITY gegl-download-http "http://gd.tuwien.ac.at/graphics/gimp/gegl/0.1/gegl-&gegl-version;.tar.bz2">
+  <!ENTITY gegl-download-ftp  "ftp://ftp.gimp.org/pub/gegl/0.1/gegl-&gegl-version;.tar.bz2">
   <!ENTITY gegl-md5sum        "c8279b86b3d584ee4f503839fc500425">
   <!ENTITY gegl-size          "5.2 Mio">
   <!ENTITY gegl-buildsize     "48 Mio">
@@ -65,33 +65,32 @@
     <para role="required"><xref linkend="babl"/></para>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional"><ulink
-    url="http://www.methods.co.nz/asciidoc/">AsciiDoc</ulink>,
-    <xref linkend="cairo"/>,
-    <ulink url="http://www.gnu.org/software/enscript/">enscript</ulink>,
-    <xref linkend="exiv2"/>,
-    <xref linkend="ffmpeg"/>,
-    <xref linkend="gdk-pixbuf"/>,
-    <xref linkend="graphviz"/>,
-    <ulink url="http://lensfun.berlios.de/">lensfun</ulink>,
-    <xref linkend="libjpeg"/>,
-    <ulink url="http://libopenraw.freedesktop.org/wiki/">libopenraw</ulink>,
-    <xref linkend="libpng"/>,
-    <xref linkend="librsvg"/>,
-    <ulink url="http://libspiro.sourceforge.net/">libspiro</ulink>,
-    <ulink url="http://www.lua.org/">Lua</ulink>,
-    <ulink url="http://www.openexr.org">OpenEXR</ulink>,
-    <xref linkend="pango"/>,
-    <xref linkend="python2"/>,
-    <xref linkend="ruby"/>,
-    <xref linkend="sdl"/>,
-    <xref linkend="gobject-introspection"/>,
-    <xref linkend="vala"/>,
-    <xref linkend="w3m"/>
-    et <ulink url="http://www.cise.ufl.edu/research/sparse/umfpack/">libumfpack</ulink>
-    </para>
+    <para role="optional">
+      <ulink url="http://www.methods.co.nz/asciidoc/">AsciiDoc</ulink>,
+      <xref linkend="cairo"/>,
+      <ulink url="http://www.gnu.org/software/enscript/">enscript</ulink>,
+      <xref linkend="exiv2"/>,
+      <xref linkend="ffmpeg"/>,
+      <xref linkend="gdk-pixbuf"/>,
+      <xref linkend="graphviz"/>,
+      <ulink url="http://lensfun.berlios.de/">lensfun</ulink>,
+      <xref linkend="libjpeg"/>,
+      <ulink url="http://libopenraw.freedesktop.org/wiki/">libopenraw</ulink>,
+      <xref linkend="libpng"/>,
+      <xref linkend="librsvg"/>,
+      <ulink url="http://libspiro.sourceforge.net/">libspiro</ulink>,
+      <ulink url="http://www.lua.org/">Lua</ulink>,
+      <ulink url="http://www.openexr.org">OpenEXR</ulink>,
+      <xref linkend="pango"/>,
+      <xref linkend="python2"/>,
+      <xref linkend="ruby"/>,
+      <xref linkend="sdl"/>,
+      <xref linkend="gobject-introspection"/>,
+      <xref linkend="vala"/>,
+      <xref linkend="w3m"/> et
+      <ulink url="http://www.cise.ufl.edu/research/sparse/umfpack/">libumfpack</ulink>
+     </para>
 
-
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url='&blfs-wiki;/gegl'/></para>
 
@@ -104,6 +103,7 @@
     suivantes :</para>
 
 <screen><userinput>echo 'Babl-0.1' > gegl/gegl-0.1.deps &&
+sed -i '/INTROSPECTION_SCANNER_ARGS/s#$# -lgmodule-2.0#' gegl/Makefile.in &&
 ./configure --prefix=/usr &&
 make</userinput></screen>
 
@@ -120,13 +120,17 @@
   <sect2 role="commands">
     <title>Explications de la commande</title>
 
-    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/gtk-doc-rebuild.xml"/>
-
     <para><command>echo 'Babl-0.1' > gegl/gegl-0.1.deps</command> : Cette commande
     corrige la compilation de <application>Gegl</application> si vous avez installé
     <application>Gobject Introspection</application>.</para>
  
+    <para>
+      <command>sed -i '/INTROSPECTION_SCANNER_ARGS/s#$# -lgmodule-2.0#'
+      gegl/Makefile.in</command> : Ce sed corrige la compilation de
+      <application>Gegl</application> si vous avez installé
+      <application>Glib-2.32</application> et
+      <xref linkend="gobject-introspection"/>.
+    </para>
 
     <para><parameter>install -v -m644 docs/*.{css,html} /usr/share/gtk-doc/html/gegl
     </parameter> : La commande '<command>make install</command>' n'installe
@@ -138,6 +142,9 @@
     <application>vala</application> - utilisez ceci si <command>vapigen</command>
     casse la construction.</para>
 
+    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+    href="../../xincludes/gtk-doc-rebuild.xml"/>
+
   </sect2>
 
   <sect2 role="content">

Modified: trunk/blfs/general/graphlib/graphlib.xml
===================================================================
--- trunk/blfs/general/graphlib/graphlib.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/general/graphlib/graphlib.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -39,6 +39,7 @@
   <!-- <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="poppler-014.xml"/> -->
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="poppler.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="jasper.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="openjpeg.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="pixman.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="clutter.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="clutter-gst.xml"/>

Added: trunk/blfs/general/graphlib/openjpeg.xml
===================================================================
--- trunk/blfs/general/graphlib/openjpeg.xml	                        (rev 0)
+++ trunk/blfs/general/graphlib/openjpeg.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -0,0 +1,178 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY openjpeg-download-http "http://openjpeg.googlecode.com/files/openjpeg-&openjpeg-version;.tar.gz">
+  <!ENTITY openjpeg-download-ftp  " ">
+  <!ENTITY openjpeg-md5sum        "e5d66193ddfa59a87da1eb08ea86293b">
+  <!ENTITY openjpeg-size          "2.0 Mio">
+  <!ENTITY openjpeg-buildsize     "12.1 Mio">
+  <!ENTITY openjpeg-time          "0.2 SBU">
+]>
+
+<sect1 id="openjpeg" xreflabel="OpenJPEG-&openjpeg-version;">
+  <?dbhtml filename="openjpeg.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy> : rthomsen $</othername>
+    <date>$Date> : 2012-03-27 23:22:01 +0200 (mar 27 mar 2012) $</date>
+  </sect1info>
+
+  <title>OpenJPEG-&openjpeg-version;</title>
+
+  <indexterm zone="openjpeg">
+    <primary sortas="a-openjpeg">OpenJPEG</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction à OpenJPEG</title>
+
+    <para><application>OpenJPEG</application> est une implémentation open-source
+    du standard JPEG-2000. OpenJPEG respecte entièrement les spécifications
+    JPEG-2000 et il peut compresser/dédecompresser des images de 16 bits.</para>
+
+    &lfs70_checked;
+
+    <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Téléchargement (HTTP) : <ulink url="&openjpeg-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Téléchargement (FTP) : <ulink url="&openjpeg-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Somme de contrôle MD5 du téléchargement : &openjpeg-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Taille du téléchargement : &openjpeg-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimation de l'espace disque requis : &openjpeg-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimation du temps de construction : &openjpeg-time;</para>
+      </listitem>
+    </itemizedlist>
+<!--
+    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Required patch> : <ulink
+        url="&patch-root;/openjpeg-&openjpeg-version;-security_fixes-1.patch"/></para>
+      </listitem>
+    </itemizedlist>
+-->
+    <bridgehead renderas="sect3">Dépendances d'OpenJPEG</bridgehead>
+
+    <bridgehead renderas="sect4">Recommandées</bridgehead>
+    <para role="recommended">
+    <xref linkend="pkgconfig"/>
+    </para>
+
+    <bridgehead renderas="sect4">Facultatives</bridgehead>
+    <para role="optional">
+    <xref linkend="lcms2"/>,
+    <xref linkend="libpng"/>,
+    <xref linkend="libtiff"/> et
+    <xref linkend="doxygen"/> (to build the API documentation)
+    </para>
+
+    <para condition="html" role="usernotes">Notes utilisateur :
+    <ulink url="&blfs-wiki;/openjpeg"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation de OpenJPEG</title>
+
+<screen><userinput>./configure --prefix=/usr --disable-static &&
+make</userinput></screen>
+
+    <para>Ce paquet n'est pas fourni avec une suite de tests.</para>
+
+    <para>Maintenant, en tant qu'utilisateur the <systemitem class="username">root</systemitem> :</para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Explications des commandes</title>
+
+    <para><option>--disable-static</option> : Ceci empêche la bibliothèque
+    statique de se construire.</para>
+
+  </sect2>
+
+  <!-- 
+  <sect2 role="configuration">
+    <title>Configuration d'OpenJPEG</title>
+
+    <sect3>
+      <title>Informations de configuration</title>
+
+    </sect3>
+
+  </sect2>
+  -->
+
+  <sect2 role="content">
+    <title>Contenu</title>
+
+    <segmentedlist>
+      <segtitle>Programmes installés</segtitle>
+      <segtitle>Bibliothèques installées</segtitle>
+      <segtitle>Répertoires installés</segtitle>
+
+      <seglistitem>
+        <seg>image_to_j2k, j2k_dump et j2k_to_image</seg>
+        <seg>libopenjpeg.so</seg>
+        <seg>/usr/include/openjpeg-1.5 et /usr/share/doc/openjpeg-1.5</seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Descriptions courtes</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="image_to_j2k">
+        <term><command>image_to_j2k</command></term>
+        <listitem>
+          <para>convertit plusieurs formats d'images en format
+          jpeg2000.</para>
+          <indexterm zone="openjpeg image_to_j2k">
+            <primary sortas="b-image_to_j2k">image_to_j2k</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="j2k_dump">
+        <term><command>j2k_dump</command></term>
+        <listitem>
+          <para>lit à l'intérieur d'une imagejpeg2000 et envoie le contenu sur
+          la sortie standard.</para>
+          <indexterm zone="openjpeg j2k_dump">
+            <primary sortas="b-j2k_dump">j2k_dump</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="j2k_to_image">
+        <term><command>j2k_to_image</command></term>
+        <listitem>
+          <para>convertit des images jpeg2000 en d'autres types d'images.</para>
+          <indexterm zone="openjpeg j2k_to_image">
+            <primary sortas="b-j2k_to_image">j2k_to_image</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+    </variablelist>
+
+  </sect2>
+
+</sect1>

Modified: trunk/blfs/general/graphlib/poppler.xml
===================================================================
--- trunk/blfs/general/graphlib/poppler.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/general/graphlib/poppler.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -93,8 +93,8 @@
     <xref linkend="pkgconfig"/></para>
 
     <bridgehead renderas="sect4">Recommandées</bridgehead>
-    <para role="recommended"><xref linkend="libjpeg"/>, <xref linkend="cairo"/>,
-    et <ulink url="http://www.openjpeg.org">OpenJPEG</ulink>
+    <para role="recommended"><xref linkend="libjpeg"/>, <xref linkend="cairo"/>
+     et <xref linkend="openjpeg"/>
     </para>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
@@ -124,7 +124,8 @@
     </caution>
 
 <screen><userinput>./configure --prefix=/usr \
-            --sysconfdir=/etc --disable-static  &&
+            --sysconfdir=/etc \
+            --disable-static  &&
 make</userinput></screen>
 
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>

Modified: trunk/blfs/general/prog/tk.xml
===================================================================
--- trunk/blfs/general/prog/tk.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/general/prog/tk.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -35,6 +35,8 @@
     <para>Le paquet <application>Tk</application> contient un outil
     graphique TCL.</para>
 
+    &lfs71_checked;
+
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>

Modified: trunk/blfs/general/sysutils/udev.xml
===================================================================
--- trunk/blfs/general/sysutils/udev.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/general/sysutils/udev.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -50,11 +50,22 @@
     savoir la version d'<application>Udev</application> utilisée actuellement
     sur votre ordinateur, lancez <command>/sbin/udevadm --version</command>.</para>
 
+    <para>Vous devriez lire les instructions de LFS pour la version que vous
+    avez utilisée, pour vérifier que vous utilisez les bons fichiers de test (pour
+    certaines versions, c'était une archive tar distincte extraite dans le répertoire
+    d'udev avec --strip-components=1) et pour comparer les options de configure
+    que vous êtes sur le point d'utiliser avec celles utilisées pour construire
+    la version que vous avez actuellement (il arrive que les options changent).
+    </para>
+
     <para>Ce paquet est connu pour se construire et fonctionner correctement en
     utilisant une plateforme LFS-6.5 (qui utilise Udev-151)</para>
 
     <para>&lfssvn_checked;20101029&lfssvn_checked2; (Using Udev-164)</para>
 
+    <para>Ce paquet est connu pour se construire et fonctionner correctement avec
+    une plateforme LFS-7.0 (qui utilise  Udev-173)</para>
+
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>

Modified: trunk/blfs/general.ent
===================================================================
--- trunk/blfs/general.ent	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/general.ent	2012-03-28 00:39:12 UTC (rev 1743)
@@ -3,7 +3,7 @@
 $Date: 2012-02-20 18:29:32 +0100 (lun 20 fév 2012) $
 -->
 
-<!ENTITY day          "26">                   <!-- Always 2 digits -->
+<!ENTITY day          "27">                   <!-- Always 2 digits -->
 <!ENTITY month        "03">                   <!-- Always 2 digits -->
 <!ENTITY year         "2012">
 <!ENTITY copyrightdate "2001-&year;">
@@ -272,6 +272,7 @@
 <!ENTITY poppler-014-version          "0.14.4">
 <!ENTITY poppler-version              "0.18.4">
 <!ENTITY jasper-version               "1.900.1">
+<!ENTITY openjpeg-version             "1.5.0">
 <!ENTITY pixman-version               "0.24.4">
 <!ENTITY clutter-version              "1.8.2">
 <!ENTITY clutter-gst-version          "1.4.4">

Modified: trunk/blfs/introduction/welcome/changelog.xml
===================================================================
--- trunk/blfs/introduction/welcome/changelog.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/introduction/welcome/changelog.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -45,7 +45,23 @@
     </listitem>
 
 -->
+ 
     <listitem>
+      <para>27 mars 2012</para>
+      <itemizedlist>
+       <listitem>
+          <para>[rthomsen] - Ajout d'OpenJPEG 1.5.0. Corrige
+          <ulink url="&blfs-ticket-root;3126">#3126</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[bdubbs] - Ajout d'une option pour construire sans les
+          enveloppes TCP NFS-Utils. Corrige
+          <ulink url="&blfs-ticket-root;3283">#3283</ulink>.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>26 mars 2012</para>
       <itemizedlist>
         <listitem>

Modified: trunk/blfs/networking/netprogs/ncftp.xml
===================================================================
--- trunk/blfs/networking/netprogs/ncftp.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/networking/netprogs/ncftp.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -34,7 +34,7 @@
     Protocol</foreignphrase>.  Il vise à remplacer ou compléter le programme de stockage
     <command>ftp</command>.</para>
 
-    &lfs65_checked;
+    &lfs71_checked;
 
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">

Modified: trunk/blfs/networking/netprogs/nfs-utils.xml
===================================================================
--- trunk/blfs/networking/netprogs/nfs-utils.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/networking/netprogs/nfs-utils.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -149,10 +149,11 @@
     <para>Installez <application>NFS Utilities</application> en lançant 
     les commandes suivantes :</para>
 
-<screen><userinput>LIBS=-lpthread ./configure --prefix=/usr     \
-                           --sysconfdir=/etc \
-                           --disable-nfsv4   \
-                           --disable-nfsv41  \
+<screen><userinput>LIBS=-lpthread ./configure --prefix=/usr          \
+                           --sysconfdir=/etc      \
+                           --without-tcp-wrappers \
+                           --disable-nfsv4        \
+                           --disable-nfsv41       \
                            --disable-gss && 
 make</userinput></screen>
 
@@ -180,6 +181,10 @@
     <para><parameter>--disable-gss</parameter> : Désactive le support de
     RPCSEC GSS (RPC Security).</para>
 
+    <para><parameter>--without-tcp-wrappers</parameter> : Cette option n'est
+    nécessaire que si vous n'avez pas installé la dépendance facultative
+    <xref linkend="tcpwrappers"/>.</para>
+
   </sect2>
 
   <sect2 role="configuration">

Modified: trunk/blfs/x/lib/goffice.xml
===================================================================
--- trunk/blfs/x/lib/goffice.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/x/lib/goffice.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -40,7 +40,7 @@
     le chargement/enregistrement des routines pour les documents d'application
     et l'annulation/répédition des fonctions.</para>
 
-    &lfs70_checked;
+    &lfs71_checked;
 
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -87,7 +87,8 @@
     <para>Installez <application>GOffice</application> en lançant les commandes
     suivantes :</para>
 
-<screen><userinput>./configure --prefix=/usr &&
+<screen><userinput>sed -i 's#info (r, NULL#full&, 0#' goffice/utils/regutf8.c &&
+./configure --prefix=/usr --disable-static &&
 make</userinput></screen>
 
     <para>Si vous souhaitez exécuter les tests, tapez> : <command>make check</command>.
@@ -105,6 +106,13 @@
     <para><option>--disable-static</option>>:nbsp;: Ce paramètre empèche les bibliothèques
     statiques de ce paquet d'être construites et installées.</para>
 
+    <para>
+      <command>sed -i 's#info (r, NULL#full&, 0#'
+      goffice/utils/regutf8.c</command> : Ce sed supprime une référence à
+      pcre_info, une fonction obsolète supprimée
+      de <application>PCRE-8.30</application>.
+    </para>
+
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
     href="../../xincludes/gtk-doc-rebuild.xml"/>
 
@@ -114,16 +122,17 @@
     <title>Contenu</title>
 
     <segmentedlist>
-      <segtitle>Programmes installés</segtitle>
       <segtitle>Bibliothèques installées</segtitle>
       <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
-        <seg>Aucun</seg>
-        <seg>libgoffice-08.{so,a} et numerous support plugins</seg>
-        <seg>/usr/include/libgoffice-0.8,
-        /usr/lib/goffice,
-        /usr/share/{gtk-doc/html/goffice-0.8,{pixmaps/}goffice}</seg>
+        <seg>libgoffice-08.so et numerous support plugins</seg>
+        <seg>
+          /usr/include/libgoffice-0.8,
+          /usr/lib/goffice,
+          /usr/share/gtk-doc/html/goffice-0.8 et
+          /usr/share/pixmaps/goffice.
+        </seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/blfs/x/lib/webkitgtk.xml
===================================================================
--- trunk/blfs/x/lib/webkitgtk.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/x/lib/webkitgtk.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -57,23 +57,42 @@
       </listitem>
     </itemizedlist>
 
+    <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Correctif requis si vous utilisez <application>GCC-4.7</application> :
+          <ulink url="&patch-root;/webkitgtk-&webkitgtk-version;_gcc-4.7-1.patch"/>
+        </para>
+      </listitem>
+    </itemizedlist>
+
     <bridgehead renderas="sect3">Dépendances WebKitGTK+</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
-    <para role="required"><xref linkend="gperf"/>, <xref linkend="libjpeg"/>,
-    <xref linkend="libpng"/>, <xref linkend="icu"/>, <xref linkend="libxslt"/>,
-    <xref linkend="gtk2"/> ou <xref linkend="gtk3"/> (si les deux sont isntallés
-    configurez par défaut pour utiliser gtk+-3), <xref linkend="libsoup"/>,
-    <xref linkend="gst-plugins-base"/>, <xref linkend="which"/>
-    et <xref linkend="sqlite"/></para>
+    <para role="required">
+      <xref linkend="gperf"/>,
+      <xref linkend="libjpeg"/>,
+      <xref linkend="libpng"/>,
+      <xref linkend="icu"/>,
+      <xref linkend="libxslt"/>,
+      <xref linkend="gtk2"/> or <xref linkend="gtk3"/> (configuration par défaut
+      pour utiliser gtk+-3),
+      <xref linkend="libsoup"/>,
+      <xref linkend="gst-plugins-base"/>,
+      <xref linkend="which"/> et
+      <xref linkend="sqlite"/>.
+    </para>
 
     <bridgehead renderas="sect4">Optional</bridgehead>
-    <para role="optional"><xref linkend="curl"/>, <xref linkend="enchant"/>,
-    <ulink
-    url="http://www.freedesktop.org/wiki/Software/GeoClue">GeoClue</ulink>,
-    <xref linkend="gobject-introspection"/> (requis pour construire
-    <application>epiphany</application>), <xref linkend="gtk-doc"/> et
-    <ulink url="http://xsltml.sourceforge.net/">MathML</ulink>.</para>
+    <para role="optional">+      <xref linkend="curl"/>,
+      <xref linkend="enchant"/>,
+      <ulink url="http://www.freedesktop.org/wiki/Software/GeoClue">GeoClue</ulink>,
+      <xref linkend="gobject-introspection"/> (required if building
+      <application>epiphany</application>),
+      <xref linkend="gtk-doc"/> et
+      <ulink url="http://xsltml.sourceforge.net/">MathML</ulink>.
+    </para>
 
     <para condition="html" role="usernotes">User Notes:
     <ulink url="&blfs-wiki;/webkitgtk"/></para>
@@ -91,8 +110,8 @@
     <para>Installer <application>WebKitGTK+</application> en exécutant les commandes
 	suivantes:</para>
 
-<screen><userinput>./configure --prefix=/usr --with-gtk=3.0 \
-            --enable-introspection &&
+<screen><userinput>patch -p1 < ../webkitgtk-&webkitgtk-version;_gcc-4.7-1.patch &&
+./configure --prefix=/usr --enable-introspection &&
 make</userinput></screen>
 
     <para>Pour tester le résultat, taper: <command>make check</command> (vous devez être
@@ -107,21 +126,14 @@
   <sect2 role="commands">
     <title>Explications des commandes</title>
 
-    <para><parameter>--with-gtk=3.0</parameter> : Ce paramètre oblige
+    <para><parameter>--with-gtk=2.0</parameter> : Ce paramètre oblige
     <application>Webkit</application> à se compiler contre
-    <application>Gtk+-3</application> et il est nécessaire pour le bureau
-    <application>GNOME</application>.</para>
+    <application>Gtk+-2</application>, même si <application>Gtk+-3</application>
+    est aussi installé. Avec <application>Gtk+-2</application>, tout ce qu'installe
+    <application>Webkit</application> a un 1.0 pour suffixe. Lorsque vous le
+    compilez contre <application>Gtk+-3</application>, tout a pour suffixe 3.0.
+    Les deux versions peuvent être installées simultanément sans conflit de noms.</para>
     
-    <para><option>--with-gtk=2.0</option> : Cette option force
-    <application>Webkit</application> à compiler de nouveau
-    <application>Gtk+-2</application>, même si
-    <application>Gtk+-3</application> est déja installé. Avec
-    <application>Gtk+-2</application>, toutes les installations de
-    <application>Webkit</application> sont suffixées avec 1.0. Quand il est
-    compilé avec <application>GTK+-3</application> tout ce qu'il installe 
-    est suffixé par 3,0. Les deux versions peuvent être installées côte à côte,
-    sans conflits d'espace.</para>
-
     <para><option>--enable-introspection</option> : Cette option active le 
     support pour gobject-introspection et il est requis pour le bureau
 	<application>GNOME</application>.</para>
@@ -140,14 +152,20 @@
       <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
-        <seg>jsc-1 ou jsc-3 (selon si vous avez installé la version gtk+-2 ou
-        gtk+-3 de webkit)</seg>
-        <seg>libwebkit-1.0.so et libjavascriptcoregtk-1.0.so ou
-        libwebkit-3.0.so et libjavascriptcoregtk-3.0.so (selon si vous avez
-        installé la version gtk+-2 ou gtk+-3 de webkit)</seg>
-        <seg>/usr/include/webkit-1.0 et /usr/share/webkit-1.0 ou
-        /usr/include/webkit-3.0 et /usr/share/webkit-3.0 (selon si vous avez
-        installé la version gtk+-2 ou gtk+-3 de webkit)</seg>
+        <seg>
+          jsc-1 ou jsc-3 (selon que vous ayez installé la version gtk+-2 ou
+          gtk+-3 de webkit)
+        </seg>
+        <seg>
+          libwebkit-1.0.so et libjavascriptcoregtk-1.0.so ou libwebkit-3.0.so
+          et libjavascriptcoregtk-3.0.so (selon que vous ayez installé la version
+          gtk+-2 ou gtk+-3 de webkit)
+        </seg>
+        <seg>
+          /usr/include/webkit-1.0 and /usr/share/webkit-1.0 ou
+          /usr/include/webkit-3.0 and /usr/share/webkit-3.0 (selon que vous ayez
+          installé la version gtk+-2 ou gtk+-3 de webkit)
+        </seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/blfs/xsoft/graphweb/firefox.xml
===================================================================
--- trunk/blfs/xsoft/graphweb/firefox.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/xsoft/graphweb/firefox.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -58,6 +58,16 @@
       </listitem>
     </itemizedlist>
 
+    <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Correctif requis si vous utilisez <application>GCC-4.7</application> :
+          <ulink url="&patch-root;/firefox-&firefox-version;_gcc-4.7-1.patch"/>
+        </para>
+      </listitem>
+    </itemizedlist>
+
     <bridgehead renderas="sect3">Dépendances de Firefox</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
@@ -179,7 +189,8 @@
     <para>Compilez <application>Firefox</application> en lançant les commandes
     suivantes :</para>
 
-<screen><userinput>sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' configure &&
+<screen><userinput>patch -p1 < ../firefox-&firefox-version;_gcc-4.7-1.patch &&
+sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' configure &&
 sed -i 's# ""##' browser/base/Makefile.in &&
 make -f client.mk</userinput></screen>
 

Modified: trunk/blfs/xsoft/graphweb/seamonkey.xml
===================================================================
--- trunk/blfs/xsoft/graphweb/seamonkey.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/xsoft/graphweb/seamonkey.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -68,6 +68,16 @@
       </listitem>
     </itemizedlist>
 
+    <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Correctif requis si vous utilisez <application>GCC-4.7</application> :
+          <ulink url="&patch-root;/seamonkey-&seamonkey-version;_gcc-4.7-1.patch"/>
+        </para>
+      </listitem>
+    </itemizedlist>
+
     <bridgehead renderas="sect3">Dépendances de SeaMonkey</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
@@ -182,7 +192,8 @@
     <para>Compilez <application>SeaMonkey</application> en lançant la commande
     suivante :</para>
 
-<screen><userinput>sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' \
+<screen><userinput>patch -p1 < ../seamonkey-&seamonkey-version;_gcc-4.7-1.patch &&
+sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' \
   mozilla/configure &&
 make -f client.mk</userinput></screen>
 

Modified: trunk/blfs/xsoft/office/abiword.xml
===================================================================
--- trunk/blfs/xsoft/office/abiword.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/xsoft/office/abiword.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -8,11 +8,10 @@
   <!ENTITY AbiWord-download-ftp  " ">
   <!ENTITY AbiWord-md5sum        "f883b0a7f26229a9c66fd6a1a94381aa">
   <!ENTITY AbiWord-size          "9 Mio">
-  <!ENTITY AbiWord-buildsize     "684 Mio (without collab or plugins except OpenDocument, additional 8 Mio to install local HTML docs)">
+  <!ENTITY AbiWord-buildsize     "684 Mio">
   <!ENTITY AbiWord-time          "6.6 SBU">
   <!ENTITY AbiWordDocs-download-http "http://www.abisource.com/downloads/abiword/&AbiWord-version;/source/abiword-docs-&AbiWord-version;.tar.gz">
   <!ENTITY AbiWord-minor-version "2.8">
-  <!--<!ENTITY AbiWord-under-version "2_4">-->
 ]>
 
 <sect1 id="abiword" xreflabel="AbiWord-&AbiWord-version;">
@@ -32,11 +31,11 @@
   <sect2 role="package">
     <title>Introduction à AbiWord</title>
 
-    <para>Le paquet <application>AbiWord</application> contient une
+    <para><application>AbiWord</application> est une
     application de traitement de texte. C'est utile pour rédiger des rapports, 
     des lettres et d'autres documents formatés.</para>
 
-    &lfs70_checked;
+    &lfs71_checked;
 
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -78,39 +77,49 @@
     <bridgehead renderas="sect3">Dépendances d'AbiWord</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
-    <para role="required"><xref linkend="fribidi"/>,
-    <xref linkend="libjpeg"/>,
-    <xref linkend="libpng"/>,
-    <xref linkend="librsvg"/> et
-    <xref linkend="wv"/></para>
+    <para role="required">
+      <xref linkend="fribidi"/>,
+      <xref linkend="libjpeg"/>,
+     <xref linkend="libpng"/>,
+      <xref linkend="librsvg"/> et
+      <xref linkend="wv"/>
+    </para>
 
+    <bridgehead renderas="sect4">Recommandées</bridgehead>
+    <para role="recommended">
+      <xref linkend="enchant"/> (pour la vérification orthographique)
+    </para>
+
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional">
-    <ulink url="http://aiksaurus.sourceforge.net/">Aiksaurus</ulink>,
-    <xref linkend="boost"/> (requis pour collab),
-    <xref linkend="dbus-glib"/> (pour le collab sugar backend),
-    <xref linkend="enchant"/>,
-    <xref linkend="goffice"/>),
-    <ulink url="http://helm.cs.unibo.it/mml-widget/">GtkMathView</ulink> (demande
-    <ulink url="http://www.gnome-db.org/">libgnomedb version <1.3.0</ulink>*
-    ce qui nécessite
-    <ulink url="http://www.gnome-db.org/">libgda version <1.3.0</ulink>),
-    <ulink url="http://sourceforge.net/projects/mission-control/files/">libmissioncontrol</ulink>,
-    <xref linkend="empathy"/> et
-    <xref linkend="telepathy-glib"/> (for the collab telepathy backend),
-    <ulink url="http://ftp.imendio.com/pub/imendio/loudmouth/src/">loudmouth</ulink>
-    (for the collab xmpp backend),
-    <xref linkend="gnutls"/> et
-    <xref linkend="libsoup"/> (for the collab service),
-    <ulink url="http://sourceforge.net/projects/wvware">libwmf</ulink>,
-    <ulink url="http://helm.cs.unibo.it/mml-widget/">GtkMathView</ulink> (demande
-    <ulink url="http://sourceforge.net/projects/gmetadom/">Gnome DOM Bindings</ulink> ce qui nécéssite
-    <ulink url="http://gdome2.cs.unibo.it/">gdome2</ulink>),
-    <ulink url="http://libwpd.sourceforge.net/">libwpd</ulink>,
-    <ulink url="http://libots.sourceforge.net/">OTS</ulink> et
-    <ulink url="http://software.frodo.looijaard.name/psiconv/">Psiconv</ulink>
-    Certains ceux la ne sont pas automatiquement détectés et auront besoin d'être indiqué dans
-	le script de configuration.</para>
+      <ulink url="http://www.abisource.com/projects/link-grammar/">Link Grammar Parser</ulink>,
+      <ulink url="http://aiksaurus.sourceforge.net/">Aiksaurus</ulink>,
+      <xref linkend="boost"/> (required for the collab and openxml/docx plugins),
+      <xref linkend="dbus-glib"/> (pour la fondation collab sugar),
+      <xref linkend="goffice"/>),
+      <ulink url="http://helm.cs.unibo.it/mml-widget/">GtkMathView</ulink>
+      (exige
+      <ulink url="http://www.gnome-db.org/">libgnomedb version <1.3.0</ulink>*
+      qui exige
+      <ulink url="http://www.gnome-db.org/">libgda version <1.3.0</ulink>),
+      <ulink url="http://sourceforge.net/projects/mission-control/files/">libmissioncontrol</ulink>,
+      <xref linkend="empathy"/> and
+      <xref linkend="telepathy-glib"/> (for the collab telepathy backend),
+      <ulink url="http://ftp.imendio.com/pub/imendio/loudmouth/src/">loudmouth</ulink>
+      (pour la fondation collab xmpp),
+      <xref linkend="gnutls"/> and
+      <xref linkend="libsoup"/> (for the collab service),
+      <ulink url="http://sourceforge.net/projects/wvware">libwmf</ulink>,
+      <ulink url="http://helm.cs.unibo.it/mml-widget/">GtkMathView</ulink> (requires
+      <ulink url="http://sourceforge.net/projects/gmetadom/">Gnome DOM Bindings</ulink>
+      qui exige
+      <ulink url="http://gdome2.cs.unibo.it/">gdome2</ulink>),
+      <ulink url="http://libwpd.sourceforge.net/">libwpd</ulink>,
+      <ulink url="http://libots.sourceforge.net/">OTS</ulink>, and
+      <ulink url="http://software.frodo.looijaard.name/psiconv/">Psiconv</ulink>
+      Certaines d'entre elles ne sont pas automatiquement détectées et doivent
+      être spécifiées au script configure.
+    </para>
  
     <para>* La pile
     <application>libgda</application>/<application>libgnomedb</application>
@@ -136,16 +145,17 @@
     <para>Installez <application>AbiWord</application> en lançant les commandes
     suivantes :</para>
 
-<screen><userinput>sed -i 's/ptr->jmpbuf/jmpbuf(png_ptr)/' src/af/util/xp/ut_png.cpp &&
+<screen><userinput>sed -i '/#include <glib\/gerror.h>/d' src/af/util/xp/ut_go_file.h &&
+sed -i 's/ptr->jmpbuf/jmpbuf(png_ptr)/' src/af/util/xp/ut_png.cpp &&
 sed -i 's/\(m_pPNG\)->\(jmpbuf\)/png_\2(\1)/' \
     src/wp/impexp/gtk/ie_impGraphic_GdkPixbuf.cpp &&
 sed -i 's/--no-undefined //' src/Makefile* &&
-./configure --prefix=/usr &&
+./configure --prefix=/usr --disable-static &&
 make</userinput></screen>
 
     <para>Si vous souhaitez exécuter les tests, tapez> : <command>make check</command>.
     </para>
-	
+
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
 <screen role="root"><userinput>make install</userinput></screen>
@@ -163,6 +173,13 @@
   <sect2 role="commands">
     <title>Explication des commandes</title>
 
+    <para>
+      <command>sed -i '/#include <glib\/gerror.h>/d'
+      src/af/util/xp/ut_go_file.h</command> : Ce sed corrige la compilation
+      d'<application>Abiword</application> quand
+      <application>Glib-2.32</application> est installé.
+    </para>
+
     <para><command>sed -i 's/ptr->jmpbuf...</command> et
     <command>sed -i 's/\(m_pPNG\)...</command> : Ces seds corrigent
     la compilation d'Abiword avec libpng-1.5.</para>
@@ -179,14 +196,14 @@
 	bibliothèques statiques. Sur x86_64 il économise beaucoup de time de construction.
     </para>
 
-    <para><option>--enable-plugins=collab</option>> :nbsp;: Construit quelqu'un ou tous les plugins
-    collab.</para>
+    <para><option>--enable-plugins=collab</option>> : Construit tout ou
+    partie des greffons collab. Le greffon openxml permet à <application>Abiword</application> 
+    d'ouvrir certains fichiers .docx (exige <xref linkend="boost"/>). Le 
+    greffon grammar exige 
+      <ulink url="http://www.abisource.com/projects/link-grammar/">Link Grammar
+      Parser</ulink> (analyseur de grammaire)
+    </para>
 
-<!--    <para><command>sed -i '...' tools/ots/xp/AbiOts.cpp </command> :
-    Cette commande est utilisée pour corriger une incompatibilité avec
-    <application>GCC</application> et le paquet
-    <application>libots</application>.</para>-->
-
    </sect2>
 
   <sect2 role="configuration">
@@ -273,11 +290,11 @@
       </varlistentry>
 
       <varlistentry id="libabiword">
-        <term><filename class='libraryfile'>libabiword-&AbiWord-minor-version;.{so,a}</filename></term>
+        <term><filename class='libraryfile'>libabiword-&AbiWord-minor-version;.so</filename></term>
         <listitem>
           <para>fourni les fonctions pour ouvrir les documents MS Word.</para>
           <indexterm zone="abiword libabiword">
-            <primary sortas="c-libabiword">libabiword-&AbiWord-minor-version;.{so,a}</primary>
+            <primary sortas="c-libabiword">libabiword-&AbiWord-minor-version;.so</primary>
  
           </indexterm>
         </listitem>

Modified: trunk/blfs/xsoft/other/thunderbird.xml
===================================================================
--- trunk/blfs/xsoft/other/thunderbird.xml	2012-03-27 23:01:14 UTC (rev 1742)
+++ trunk/blfs/xsoft/other/thunderbird.xml	2012-03-28 00:39:12 UTC (rev 1743)
@@ -61,6 +61,16 @@
       </listitem>
     </itemizedlist>
 
+    <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Correctif requis  :
+          <ulink url="&patch-root;/thunderbird-&thunderbird-version;_gcc-4.7-1.patch"/>
+        </para>
+      </listitem>
+    </itemizedlist>
+
     <bridgehead renderas="sect3">Dépendances de Thunderbird</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
@@ -161,7 +171,8 @@
 
     <para>Compiler <application>Thunderbird</application> en tapant les commandes suivantes:</para>
 
-<screen><userinput>sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' \
+<screen><userinput>patch -p1 < ../thunderbird-&thunderbird-version;_gcc-4.7-1.patch &&
+sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' \
   mozilla/configure &&
 make -f client.mk &&
 make -C thunderbuild/mail/installer</userinput></screen>




More information about the lfs-traducfr mailing list