[lfs-fr] r1729 - in trunk/blfs: . gnome/core introduction/welcome networking/netutils

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Dim 25 Mar 15:48:32 PDT 2012


Author: jmengual
Date: 2012-03-26 00:48:32 +0200 (Mon, 26 Mar 2012)
New Revision: 1729

Modified:
   trunk/blfs/general.ent
   trunk/blfs/gnome/core/eog.xml
   trunk/blfs/introduction/welcome/changelog.xml
   trunk/blfs/networking/netutils/avahi.xml
Log:
9762-9763


Modified: trunk/blfs/general.ent
===================================================================
--- trunk/blfs/general.ent	2012-03-25 20:36:19 UTC (rev 1728)
+++ trunk/blfs/general.ent	2012-03-25 22:48:32 UTC (rev 1729)
@@ -501,7 +501,7 @@
 <!ENTITY whois-version                "5.0.12">
 <!ENTITY bind-version                 "9.8.1-P1">
 <!ENTITY wireshark-version            "0.99.6">
-<!ENTITY avahi-version                "0.6.28">
+<!ENTITY avahi-version                "0.6.31">
 <!ENTITY mod_dnssd-version            "0.6">
 <!ENTITY NetworkManager-version       "0.9.2.0">
 

Modified: trunk/blfs/gnome/core/eog.xml
===================================================================
--- trunk/blfs/gnome/core/eog.xml	2012-03-25 20:36:19 UTC (rev 1728)
+++ trunk/blfs/gnome/core/eog.xml	2012-03-25 22:48:32 UTC (rev 1729)
@@ -8,8 +8,8 @@
   <!ENTITY eog-download-ftp  "&gnome-download-ftp;/eog/&gnome-version;/eog-&eog-version;.tar.xz">
   <!ENTITY eog-md5sum        "66d2c1d8d250a37e18f3fbf696642214">
   <!ENTITY eog-size          "?3.1 Mio">
-  <!ENTITY eog-buildsize     "?? Mio">
-  <!ENTITY eog-time          "?? SBU">
+  <!ENTITY eog-buildsize     "51 Mio">
+  <!ENTITY eog-time          "1.2 SBU">
 ]>
 
 <sect1 id="eog" xreflabel="EOG-&eog-version;">
@@ -33,7 +33,7 @@
     <application>GNOME</application> (l'oeil de Gnome). C'est utile pour voir et
     cataloguer des fichiers images.</para>
 
-    <!-- &lfs65_checked;-->
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -61,20 +61,21 @@
 
     <bridgehead renderas="sect4">Requises</bridgehead>
     <para role="required"><xref linkend="gnome-desktop"/>
+    <xref linkend="gnome-doc-utils"/>,
     <xref linkend="gnome-icon-theme"/>,
     <xref linkend="libpeas"/>, et
     <xref linkend="shared-mime-info"/></para>
 
     <bridgehead renderas="sect4">Recommandées</bridgehead>
-    <para role="recommended"><xref linkend="libjpeg"/></para>
+    <para role="recommended"><xref linkend="libjpeg"/> et
+    <xref linkend="rarian"/></para>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional"><xref linkend="exempi"/>,
-    <xref linkend="libexif"/>,
-    <xref linkend="lcms"/>, et
-    <xref linkend="pygtk"/></para>
+    <xref linkend="lcms2"/>,
+    <xref linkend="libexif"/> et
+    <xref linkend="librsvg"/></para>
 
-
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/eog"/></para>
 
@@ -86,9 +87,7 @@
     <para>Installez <application>EOG</application> en lançant les commandes
     suivantes :</para>
 
-<screen><userinput>./configure --prefix=$GNOME_PREFIX \
-            --sysconfdir=$GNOME_SYSCONFDIR \
-            --localstatedir=/var/lib &&
+<screen><userinput>./configure --prefix=$GNOME_PREFIX &&
 make</userinput></screen>
 
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>
@@ -106,11 +105,8 @@
    href="../../xincludes/gnome-prefix.xml"/>
 
     <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-   href="../../xincludes/gnome-sysconfdir.xml"/>
+   href="../../xincludes/gtk-doc-rebuild.xml"/>
 
-    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-   href="../../xincludes/scrollkeeper-dir.xml"/>
-
     <para><option>--without-libjpeg</option> : Cette option désactive le support JPEG
     spécial.</para>
 
@@ -127,13 +123,8 @@
 
       <seglistitem>
         <seg>eog</seg>
-        <seg>libfullscreen.so et libreload.so (plugins)</seg>
-        <seg><envar>$GNOME_PREFIX</envar>/{include/eog-2.20/eog,lib/eog/plugins,
-        share/{eog/{icons/hicolor/{16x16/actions,22x22/actions,24x24/actions,
-        32x32/actions,48x48/actions,scalable/actions},pixmaps},gnome/help/eog/*,
-        gtk-doc/html/eog,omf/eog}}</seg>
- 
-
+        <seg>libfullscreen.so, libreload.so et libstatusbar-date.so (greffons)</seg>
+        <seg><envar>$GNOME_PREFIX</envar>/{include/eog-3.0, lib/eog, share/eog}</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/blfs/introduction/welcome/changelog.xml
===================================================================
--- trunk/blfs/introduction/welcome/changelog.xml	2012-03-25 20:36:19 UTC (rev 1728)
+++ trunk/blfs/introduction/welcome/changelog.xml	2012-03-25 22:48:32 UTC (rev 1729)
@@ -70,6 +70,9 @@
         <listitem>
           <para>[krejzi] - pidgin 2.10.2.</para>
         </listitem>
+        <listitem>
+          <para>[ken] - update to avahi-0.6.31 and fix the build instructions.</para>
+        </listitem>
       </itemizedlist>
     </listitem>
 

Modified: trunk/blfs/networking/netutils/avahi.xml
===================================================================
--- trunk/blfs/networking/netutils/avahi.xml	2012-03-25 20:36:19 UTC (rev 1728)
+++ trunk/blfs/networking/netutils/avahi.xml	2012-03-25 22:48:32 UTC (rev 1729)
@@ -6,9 +6,9 @@
 
   <!ENTITY avahi-download-http "http://avahi.org/download/avahi-&avahi-version;.tar.gz">
   <!ENTITY avahi-download-ftp  " ">
-  <!ENTITY avahi-md5sum        "d0143a5aa3265019072e53ab497818d0">
-  <!ENTITY avahi-size          "1.2 Mio">
-  <!ENTITY avahi-buildsize     "41 Mio">
+  <!ENTITY avahi-md5sum        "2f22745b8f7368ad5a0a3fddac343f2d">
+  <!ENTITY avahi-size          "1.3 Mio">
+  <!ENTITY avahi-buildsize     "23 Mio">
   <!ENTITY avahi-time          "0.4 SBU">
 ]>
 
@@ -32,7 +32,7 @@
     <para>Le paquet <application>avahi</application> est un système qui
     facilite la découverte des services dans un réseau local.</para>
 
-    &lfs68_built;
+    &lfs70_built;
 
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -70,7 +70,7 @@
     <para role="required"><xref linkend="intltool"/> et
     <xref linkend="pkgconfig"/></para>
 
-    <bridgehead renderas="sect4">Facultatives</bridgehead>
+    <bridgehead renderas="sect4">Facultatives, mais recommandées pour un bureau GNOME</bridgehead>
     <para role="optional"><xref linkend="dbus-python"/>,
     <xref linkend="gobject-introspection"/>,
     <xref linkend="gtk2"/>,
@@ -80,6 +80,14 @@
     <xref linkend="python2"/>,
     <xref linkend="pygtk"/>,
     <xref linkend="qt"/>, et
+    <xref linkend="libglade"/>,
+    <xref linkend="python2"/>
+    <!--<xref linkend="pygtk"/>,--></para>
+
+    <bridgehead renderas="sect4">Facultatives</bridgehead>
+    <para role="optional">
+    <xref linkend="libdaemon"/>,
+    <xref linkend="qt"/> et
     <xref linkend="qt4"/></para>
 
     <para condition="html" role="usernotes">Notes utilisateur:
@@ -112,15 +120,13 @@
 autoreconf -i -v &&-->./configure --prefix=/usr \
             --sysconfdir=/etc \
             --localstatedir=/var \
-            --disable-gtk \
-            --disable-gtk3 \
-            --disable-qt3 \
-            --disable-qt4 \
+            --disable-static \
+            --disable-libdaemon \
             --disable-mono \
             --disable-monodoc \
             --disable-python \
-            --disable-dbus \
-            --disable-libdaemon \
+            --disable-qt3 \
+            --disable-qt4 \
             --enable-core-docs \
             --with-distro=lfs &&
 make</userinput></screen>
@@ -136,18 +142,12 @@
   <sect2 role="commands">
     <title>Explications des commandes</title>
 
-    <para><parameter>--disable-gtk</parameter> : Ce paramètre désactive l'utilisation de
-    <application>GTK+2</application>.</para>
+    <para><option>--disable-static</option> : Ce paramètre empêche les
+    bibliothèques statiques de s'installer.</para>
  
-    <para><parameter>--disable-gtk3</parameter> : Ce paramètre désactive l'utilisation de
-    <application>GTK+3</application>.</para>
+    <para><parameter>--disable-libdaemon</parameter> : Ce paramètre
+    désactive l'utilisation de libdaemon.</para>
 
-    <para><parameter>--disable-qt3</parameter> : Ce paramètre désactive la construction
-    de l'intégration de <application>Qt3</application>.</para>
-
-    <para><parameter>--disable-qt4</parameter> : Ce paramètre désactive la construction 
-    de l'intégration de <application>Qt4Core</application>.</para>
-
     <para><parameter>--disable-mono</parameter> : Ce paramètre désactive la construction 
     de l'intégration de <application>Mono</application>.</para>
  
@@ -155,13 +155,15 @@
     la documentation pour l'intégration de <application>Mono</application>.</para>
 
     <para><parameter>--disable-python</parameter> : Ce paramètre désactive les
-    scriptes qui dépendent de <application>Python</application>.</para>
+    scriptes qui dépendent de <application>Python</application>. Il permet
+    aussi à une installation régulière (sans destdir) de réussir entièrement.</para>
 
-    <para><parameter>--disable-dbus</parameter> : Ce paramètre désactive l'utilisation
-    de <application>D-Bus</application>.</para>
+    <para><parameter>--disable-qt3</parameter> : Ce paramètre désactive
+    la construction de l'intégration mainloop <application>Qt3</application>.</para>
 
-    <para><parameter>--disable-libdaemon</parameter> : Ce paramètre désactive
-    l'utilisation de libdaemon.</para>
+    <para><parameter>--disable-qt4</parameter> : Ce paramètre désactive la
+    construction de l'intégration mainloop <application>Qt4Core</application>
+    Ne mettez pas cela si vous avez installé <application>Qt4</application>.</para>
 
     <para><parameter>--enable-core-docs</parameter> : Ce paramètre active la 
     construction de la documentation.</para>
@@ -169,6 +171,18 @@
     <para><parameter>--with-distro=lfs</parameter> : Ce paramètre spécifie
     la distribution cible.</para>
 
+    <para><option>--disable-dbus</option> : Ce paramètre désactive
+    l'utilisation de <application>D-Bus</application>. N'utilisez pas cette
+    option si vous comptez aonstruire <xref linkend="gnome-disk-utility"/>.</para>
+
+    <para><option>--disable-gtk</option> : Ce paramètre désactive
+    l'utilisation de <application>GTK+2</application>. N'utilisez pas cette
+    option si vous comptez construire <xref linkend="gnome-disk-utility"/>.</para>
+
+    <para><option>--disable-gtk3</option>:  Ce paramètre désactive
+    l'utilisation de <application>GTK+3</application>. N'utilisez pas cette
+    option si vous comptez construire <xref linkend="gnome-disk-utility"/>.</para>
+
     <para><option>--enable-tests</option> : Cette option active la construction des
     tests et des exemples.</para>
 
@@ -215,10 +229,10 @@
         avahi-publish, avahi-publish-address, avahi-publish-service,
         avahi-resolve, avahi-resolve-address, avahi-resolve-host-name,
         avahi-set-host-name, bshell, bssh, and bvnc</seg>
-        <seg>libavahi-client.{so,a}, libavahi-common.{so,a},
-        libavahi-core.{so,a}, libavahi-glib.{so,a}, libavahi-gobject.{so,a},
-        libavahi-ui-gtk3.{so,a}, libavahi-ui.{so,a}, libdns_sd.{so,a}, and
-        libhowl.{so,a}</seg>
+        <seg>libavahi-client.so, libavahi-common.so,
+        libavahi-core.so, libavahi-glib.so, libavahi-gobject.so,
+        libavahi-ui-gtk3.so,, libavahi-ui.so, libdns_sd.so et
+        libhowl.so,</seg>
         <seg>/etc/avahi/services, /usr/{include/{avahi-client,avahi-common,
         avahi-compat-howl/{corby,discovery,rendezvous,salt},
         avahi-compat-libdns_sd,avahi-core,avahi-glib,avahi-gobject,avahi-ui},




More information about the lfs-traducfr mailing list