[lfs-fr] r1647 - in trunk/blfs: . general/prog introduction/welcome kde4/core server/major

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Jeu 1 Mar 17:07:11 PST 2012


Author: jmengual
Date: 2012-03-02 02:07:11 +0100 (Fri, 02 Mar 2012)
New Revision: 1647

Modified:
   trunk/blfs/general.ent
   trunk/blfs/general/prog/subversion.xml
   trunk/blfs/introduction/welcome/changelog.xml
   trunk/blfs/kde4/core/akonadi.xml
   trunk/blfs/kde4/core/attica.xml
   trunk/blfs/kde4/core/polkit-qt.xml
   trunk/blfs/kde4/core/qimageblitz.xml
   trunk/blfs/kde4/core/shrdesktopontologies.xml
   trunk/blfs/server/major/apache.xml
Log:
Jusqu'a la revision 9564.


Modified: trunk/blfs/general/prog/subversion.xml
===================================================================
--- trunk/blfs/general/prog/subversion.xml	2012-03-01 13:01:43 UTC (rev 1646)
+++ trunk/blfs/general/prog/subversion.xml	2012-03-02 01:07:11 UTC (rev 1647)
@@ -4,15 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY subversion-download-http "http://subversion.tigris.org/downloads/subversion-&subversion-version;.tar.bz2">
-  <!ENTITY subversion-download-ftp  " ">
-  <!ENTITY subversion-md5sum        "8a4fa74385df85a9702141b6b68b8307">
-  <!ENTITY subversion-size          "5.7 Mio">
-
-  <!ENTITY subversion-buildsize     "153 Mio (119 Mio supplémentaires pour installer tous les bindings et
-  750 Mio pour lancer toutes les suites de test)">
-  <!ENTITY subversion-time          "1.6 SBU (ajoutez 2.7 SBU pour les bindings et 7.1 SBU pour lancer les suites de tests)">
-
+  <!ENTITY subversion-download-http "http://archive.apache.org/dist/subversion/subversion-&subversion-version;.tar.bz2">
+  <!ENTITY subversion-download-ftp " ">
+  <!ENTITY subversion-md5sum        "867fb0a5db00710cf8dce0bdfa094b3b">
+  <!ENTITY subversion-size     "5.7 Mio">
+  <!ENTITY subversion-buildsize     "131 Mio">
+  <!ENTITY subversion-time          "1.1 SBU">
 ]>
 
 <sect1 id="subversion" xreflabel="Subversion-&subversion-version;">
@@ -69,38 +66,46 @@
     <bridgehead renderas="sect3">Dépendances de Subversion</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
-    <para role="required"><xref linkend="sqlite"/> and
-    <xref linkend="apr-util"/></para>
+    <para role="required">
+      <xref linkend="sqlite"/>, <xref linkend="apr-util"/> et
+      <xref linkend="neon"/> ou
+      <ulink url="http://code.google.com/p/serf/">serf</ulink>.
+    </para>
 
     <para>Si vous avez besoin des scripts de base de <application>Berkeley DB</application>
     dans <application>Subversion</application> pour construire ou supporter les
-    dépôts basés sur BDB, vous devez avoir lié <application>Berkeley DB</application>
-    à la bibliothèque <application>APR-util</application>.</para>
+    dépôts basés sur BDB, vous devez avoir lié
+    <application>APR-util</application> à la bibliothèque 
+    <application>Berkeley DB</application>.</para>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional"><xref linkend="python2"/> (required to run the test suite),
-    <xref linkend="db"/>,
-    <xref linkend="sqlite"/>,
-    <xref linkend="cyrus-sasl"/>,
-    <xref linkend="openssl"/>,
-    <xref linkend="dbus-glib"/>,
-    <xref linkend="gnome-keyring"/>,
-    KWallet de KDE4,
-    <xref linkend="apache"/> et
-    <xref linkend="neon"/> ou
-     <ulink url="http://code.google.com/p/serf/">serf</ulink></para>
+    <para role="optional">
+      <xref linkend="python2"/> (nécessaire pour lancer la suite de tests),
+      <xref linkend="db"/>,
+      <xref linkend="sqlite"/>,
+      <xref linkend="cyrus-sasl"/>,
+      <xref linkend="openssl"/>,
+      <xref linkend="dbus-glib"/>,
+      <xref linkend="gnome-keyring"/>,
+      KWallet de KDE4 et
+      <xref linkend="apache"/>.
+    </para>
 
-    <bridgehead renderas="sect4">Facultatives pour construire les bindings Java</bridgehead>
-    <para role="optional">One of <xref linkend="icedtea6"/>, 
-    <xref linkend="jdk"/>,
-    <ulink url="http://www.inet.no/dante/">Dante</ulink>, ou
-    <ulink url="http://oss.software.ibm.com/developerworks/opensource/jikes/">Jikes</ulink>,
-    et <xref linkend="junit"/> (to test the Java bindings)</para>
+    <bridgehead renderas="sect4">Facultatives (pour les bindings Java)</bridgehead>
+    <para role="optional">
+      One of <xref linkend="icedtea6"/>, 
+      <xref linkend="jdk"/>,
+      <ulink url="http://www.inet.no/dante/">Dante</ulink>, or
+      <ulink url="http://oss.software.ibm.com/developerworks/opensource/jikes/">Jikes</ulink>,
+      et <xref linkend="junit"/> (pour tester les bindings Java)
+    </para>
 
-    <bridgehead renderas="sect4">Facultatives to Build the SWIG Bindings</bridgehead>
-    <para role="optional"><ulink url="http://www.swig.org">SWIG</ulink>**,
-    <xref linkend="python2"/> et
-    <xref linkend="ruby"/></para>
+    <bridgehead renderas="sect4">Facultatives (pour les bindings SWIG)</bridgehead>
+    <para role="optional">
+      <ulink url="http://www.swig.org">SWIG</ulink> and
+      <xref linkend="python2"/>.
+      <!-- <xref linkend="ruby"/> broken just now -->
+    </para>
 
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/subversion"/></para>
@@ -110,10 +115,22 @@
   <sect2 role="installation">
     <title>Installation de Subversion</title>
 
-    <para>Installez <application>Subversion</application> en lançant
-    les commandes suivantes :</para>
+    <para>
+      Si vous avez installé la version actuelle d'<application>Apache</application>
+      <application>Subversion</application> essaiera de compiler
+      <filename class="libraryfile">mod_dav_svn.so</filename> pour l'utiliser
+      avec <xref linkend="apache"/> et la construction échouera. Corrigez le bogue 
+      avec le sed suivant (inutile avec <application>Apache 2.2</application>) :
+    </para>
 
-<screen><userinput>./configure --prefix=/usr &&
+<screen><userinput>sed -i 's#save_errno#aprerr#' subversion/mod_dav_svn/util.c</userinput></screen>
+
+    <para>
+      Installez <application>Subversion</application> en lançant les commandes
+      suivantes :
+    </para>
+
+<screen><userinput>./configure --prefix=/usr --disable-static &&
 make</userinput></screen>
 
     <para>Si vous avez installé <xref linkend="doxygen"/> et si vous souhaitez construire la
@@ -126,15 +143,29 @@
 
 <screen><userinput>make javahl</userinput></screen>
 
-    <para>Si vous avez installé les dépendances nécessaires et si vous souhaitez
-    construire les bindings <application>Perl</application>,
-    <application>Python</application> et/ou
-    <application>Ruby</application>, lancez certaines ou toutes les commandes
-    suivantes :</para>
+    <para>
+      <application>Perl</application> et/ou <application>Python</application>
+      <!-- ruby is currently b0rken <application>Ruby</application> -->
+    </para>
 
+    <para>
+      Si vous avez un processeur multicœur et si 'kus lancz généralement
+      <command>make</command> avec plusieurs tâches (comme
+      <command>make -j4</command>), un bogue dans le <filename>Makefile</filename> 
+      empêchera les bindings <application>Perl</application> de se construire
+      corectemnt. Corqgez le
+      <filename>Makefile</filename> avec ce sed :
+    </para>
+
+<screen><userinput>sed -i 's#Makefile.PL.in$#& libsvn_swig_perl#' Makefile.in &&</userinput></screen>
+
+    <para>
+      Pour compiler les bindings <application>Perl</application> et/ou
+      <application>Python</application>, lancez tout ou partie des
+      commandes suivantes :</para>
+
 <screen><userinput>make swig-pl &&
-make swig-py &&
-make swig-rb</userinput></screen>
+make swig-py</userinput></screen>
 
     <para>Pour tester les résultats, lancez : <command>make check</command>.</para>
 
@@ -147,12 +178,11 @@
     suivantes :</para>
 
 <screen><userinput>make check-swig-pl &&
-make check-swig-py &&
-make check-swig-rb</userinput></screen>
+make check-swig-py</userinput></screen>
 
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
-<screen role='root'><userinput>make install &&
+<screen role="root"><userinput>make install &&
 install -v -m755 -d /usr/share/doc/subversion-&subversion-version; &&
 cp      -v -R       doc/* \
                     /usr/share/doc/subversion-&subversion-version;</userinput></screen>
@@ -161,23 +191,44 @@
     en tant qu'utilisateur <systemitem class="username">root</systemitem> pour les
     installer :</para>
 
-<screen role='root'><userinput>make install-javahl</userinput></screen>
+<screen role="root"><userinput>make install-javahl</userinput></screen>
 
     <para>Si vous avez construit un des bindings <application>SWIG</application>,
     faites certaines ou toutes les commandes suivantes en tant qu'utilisateur
     <systemitem class="username">root</systemitem> pour les installer :</para>
 
-<screen role='root'><userinput>make install-swig-pl &&
-make install-swig-rb</userinput></screen>
+<screen role="root"><userinput>make install-swig-pl &&
+make install-swig-py</userinput></screen>
 
     <para>Pour que <application>Python</application> voie automatiquement les
     bindings, ajoutez 
-    <filename class='directory'>/usr/lib/svn-python</filename> à la variable
+    <filename class="directory">/usr/lib/svn-python</filename> à la variable
     d'environnement <envar>PYTHONPATH</envar> du système ou aux profils
     personnels.</para>
 
   </sect2>
 
+  <sect2 role="commands">
+    <title>Explication des commandes</title>
+
+    <para>
+      <option>--disable-static</option> : Ceci arrête l'installation des
+      versions statiques des bibliothèques.
+    </para>
+
+    <para>
+      <parameter>CC="gcc -std=gnu99"</parameter> : Si vous voulez compiler
+      <filename class="libraryfile">mod_dav_svn.so</filename> pour l'utiliser
+      avec <application>Apache</application>, configure se plaindra que votre 
+      compilateur C que celui qui a compilé 
+      <application>Apache</application>. Pour empêcher cela, vous pouvez 
+      ajouter 
+      <parameter>CC="gcc -std=gnu99"</parameter> (ou n'importe quel
+      <application>Apache</application> utilisé) aux options de
+      <command>configure</command>.
+    </para>
+  </sect2>
+
   <sect2 role="configuration">
     <title>Configuration de Subversion</title>
 
@@ -222,19 +273,26 @@
       <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
-        <seg>svn, svnadmin, svndumpfilter, svnlook, svnserve, svnsync et
-        svnversion</seg>
-        <seg>libsvn*.{so,a} et optionally, a Java library, the mod_dav_svn.so,
-        et mod_authz_svn.so <application>Apache HTTP</application>
-        DSO modules et various <application>Perl</application>,
-        <application>Python</application> et modules <application>Ruby</application></seg>
-        <seg>/usr/include/subversion-1,
-        /usr/lib/perl5/site_perl/&lfs-perl-version;/i686-linux/auto/SVN (optional),
-        /usr/lib/perl5/site_perl/&lfs-perl-version;/i686-linux/SVN (optional),
-        /usr/lib/ruby/site_ruby/x.x/i686-linux/svn (facultatif),
-        /usr/lib/svn-javahl (optional),
-        /usr/lib/svn-python (optional) et
-        /usr/share/doc/subversion-&subversion-version;</seg>
+        <seg>
+          svn, svnadmin, svndumpfilter, svnlook, svnserve, svnsync and
+          svnversion
+        </seg>
+        <seg>
+          libsvn*.so et éventuellement une bibliothèque Java, mod_dav_svn.so
+          et mod_authz_svn.so <application>Apache HTTP</application> modules DSO
+          et divers modules <application>Perl</application> et
+          <application>Python</application>
+          <!-- <application>Ruby</application> --> modules.
+        </seg>
+        <seg>
+          /usr/include/subversion-1,
+          /usr/lib/perl5/site_perl/&lfs-perl-version;/i686-linux/auto/SVN (optional),
+          /usr/lib/perl5/site_perl/&lfs-perl-version;/i686-linux/SVN (optional),
+          /usr/lib/ruby/site_ruby/x.x/i686-linux/svn (optional),
+          /usr/lib/svn-javahl (optional),
+          /usr/lib/svn-python (optional) and
+          /usr/share/doc/subversion-&subversion-version;
+        </seg>
       </seglistitem>
     </segmentedlist>
 
@@ -287,6 +345,19 @@
         </listitem>
       </varlistentry>
 
+      <varlistentry id="svnrdump">
+        <term><command>svnrdump</command></term>
+        <listitem>
+          <para>
+            est un outil pour écrire ou charger un dépôt
+            <application>Subversion</application>.
+          </para>
+          <indexterm zone="subversion svnrdump">
+            <primary sortas="b-svnrdump">svnrdump</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+       
       <varlistentry id="svnserve">
         <term><command>svnserve</command></term>
         <listitem>
@@ -299,22 +370,22 @@
         </listitem>
       </varlistentry>
 
-      <varlistentry id="svnversion">
-        <term><command>svnversion</command></term>
+      <varlistentry id="svnsync">
+        <term><command>svnsync</command></term>
         <listitem>
-          <para>est utilisé pour signaler le numéro de version et l'état
-          de la copie d'un dépôt <application>Subversion</application> courante.</para>
-          <indexterm zone="subversion svnversion">
-            <primary sortas="b-svnversion">svnversion</primary>
+          <para>est un outil de synchronisation de dépôts
+          <application>Subversion</application>.</para>
+          <indexterm zone="subversion svnsync">
+            <primary sortas="b-svnsync">svnsync</primary>
           </indexterm>
         </listitem>
       </varlistentry>
 
-      <varlistentry id="neon-config-svn">
-        <term><command>neon-config</command></term>
+      <varlistentry id="svnversion">
+        <term><command>svnversion</command></term>
         <listitem>
-          <para>est un script qui fournit des informations à propos de la copie installée d'une
-          bibliothèque <application>neon</application>.</para>
+          <para>est utilisé pour signaler le numéro de version et l'état de la 
+          copie d'un dépôt <application>Subversion</application>.</para>
           <indexterm zone="subversion neon-config">
             <primary sortas="b-neon-config">neon-config</primary>
           </indexterm>
@@ -322,29 +393,18 @@
       </varlistentry>
 
       <varlistentry id="libsvn_star">
-        <term><filename class='libraryfile'>libsvn_*.{so,a}</filename></term>
+        <term><filename class='libraryfile'>libsvn_*.so</filename></term>
         <listitem>
           <para>sont les bibliothèques de support utilisées par les programmes
           <application>Subversion</application>.</para>
           <indexterm zone="subversion libsvn_star">
-            <primary sortas="c-libsvn_star">libsvn_*.{so,a}</primary>
+            <primary sortas="c-libsvn_star">libsvn_*.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>
 
-      <varlistentry id="libneon-svn">
-        <term><filename class='libraryfile'>libneon.{so,a}</filename></term>
-        <listitem>
-          <para>est utilisé comme une interface de haut niveau avec les méthodes 
-          habituelles HTTP et WebDAV.</para>
-          <indexterm zone="subversion libneon">
-            <primary sortas="c-libneon">libneon.{so,a}</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
       <varlistentry id="mod_authz_svn">
-        <term><filename class='libraryfile'>mod_authz_svn.so</filename></term>
+        <term><filename class="libraryfile">mod_authz_svn.so</filename></term>
         <listitem>
           <para>est un module plug-in pour le serveur HTTP <application>Apache</application>,
           utilisé pour authentifier les utilisateurs sur un dépôt
@@ -357,7 +417,7 @@
       </varlistentry>
 
       <varlistentry id="mod_dav_svn">
-        <term><filename class='libraryfile'>mod_dav_svn.so</filename></term>
+        <term><filename class="libraryfile">mod_dav_svn.so</filename></term>
         <listitem>
           <para>est un module plug-in pour le serveur HTTP <application>Apache</application>,
           utilisé pour rendre un dépôt <application>Subversion</application> disponible pour autrui à travers

Modified: trunk/blfs/general.ent
===================================================================
--- trunk/blfs/general.ent	2012-03-01 13:01:43 UTC (rev 1646)
+++ trunk/blfs/general.ent	2012-03-02 01:07:11 UTC (rev 1647)
@@ -3,8 +3,8 @@
 $Date: 2012-02-20 18:29:32 +0100 (lun 20 fév 2012) $
 -->
 
-<!ENTITY day          "29">                   <!-- Always 2 digits -->
-<!ENTITY month        "02">                   <!-- Always 2 digits -->
+<!ENTITY day          "01">                   <!-- Always 2 digits -->
+<!ENTITY month        "03">                   <!-- Always 2 digits -->
 <!ENTITY year         "2012">
 <!ENTITY copyrightdate "2001-&year;">
 <!ENTITY copyholder   "L'équipe de développement de BLFS">
@@ -379,7 +379,7 @@
 <!ENTITY python3-majorver             "3.2">
 <!ENTITY dbus-python-version          "0.84.0">
 <!ENTITY ruby-version                 "1.9.2-p290">
-<!ENTITY subversion-version           "1.7.1">
+<!ENTITY subversion-version           "1.7.3">
 <!ENTITY slang-version                "2.2.4">
 <!ENTITY spidermonkey-version         "1.0.0">
 <!ENTITY tcl-version                  "8.5.10">
@@ -669,11 +669,11 @@
 <!ENTITY phonon-version               "4.6.0">
 <!ENTITY phonon-backend-gstreamer-version "&phonon-version;">
 <!ENTITY phonon-backend-vlc-version  "0.5.0">
-<!ENTITY attica-version               "0.2.0">
-<!ENTITY akonadi-version              "1.5.0">
+<!ENTITY attica-version               "0.3.0">
+<!ENTITY akonadi-version              "1.7.0">
 <!ENTITY qimageblitz-version          "0.0.6">
-<!ENTITY shared-desktop-ontologies-version "0.5">
-<!ENTITY polkit-qt-version            "0.99.0">
+<!ENTITY shared-desktop-ontologies-version "0.9.0">
+<!ENTITY polkit-qt-version            "0.103.0">
 <!ENTITY kde4pim-version              "4.4.10">
 <!ENTITY kde4-download-http-pim       "http://mirrors.isc.org/pub/kde/&kde4-branch;/kdepim-&kde4pim-version;/src">
 <!ENTITY kde4-download-ftp-pim        "ftp://ftp.kde.org/pub/kde/&kde4-branch;/kdepim-&kde4pim-version;/src">

Modified: trunk/blfs/introduction/welcome/changelog.xml
===================================================================
--- trunk/blfs/introduction/welcome/changelog.xml	2012-03-01 13:01:43 UTC (rev 1646)
+++ trunk/blfs/introduction/welcome/changelog.xml	2012-03-02 01:07:11 UTC (rev 1647)
@@ -42,6 +42,27 @@
 
 -->
     <listitem>
+      <para>1er mars 2012</para>
+      <itemizedlist>
+        <listitem>
+          <para>[rthomsen] - passage à shared-desktop-ontologies 0.9.0.</para>
+        </listitem>
+        <listitem>
+          <para>[rthomsen] - passage à attica 0.3.0.</para>
+        </listitem>
+        <listitem>
+          <para>[rthomsen] - passage à akonadi 1.7.0.</para>
+        </listitem>
+        <listitem>
+          <para>[abenton] - passage à Subversion 1.7.3.</para>
+        </listitem>
+        <listitem>
+          <para>[rthomsen] - passage à polkit-qt 0.103.0.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>28 février 2012</para>
       <itemizedlist>
        <listitem>

Modified: trunk/blfs/kde4/core/akonadi.xml
===================================================================
--- trunk/blfs/kde4/core/akonadi.xml	2012-03-01 13:01:43 UTC (rev 1646)
+++ trunk/blfs/kde4/core/akonadi.xml	2012-03-02 01:07:11 UTC (rev 1647)
@@ -4,12 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY akonadi-download-http "http://download.akonadi-project.org/akonadi-&akonadi-version;.tar.bz2">
-  <!ENTITY akonadi-download-ftp  " ">
-  <!ENTITY akonadi-md5sum        "8b0d43b0e947b876a461d90f4b877f54">
-  <!ENTITY akonadi-size          "192 Kio">
-  <!ENTITY akonadi-buildsize     "22 Mio">
-  <!ENTITY akonadi-time          "1.2 SBU">
+  <!ENTITY akonadi-download-http "">
+  <!ENTITY akonadi-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/akonadi/src/akonadi-&akonadi-version;.tar.bz2">
+  <!ENTITY akonadi-md5sum        "804309dca70ede35b4a654ab764e9079">
+  <!ENTITY akonadi-size          "206 Kio">
+  <!ENTITY akonadi-buildsize     "31 Mio">
+  <!ENTITY akonadi-time          "2.0 SBU">
 ]>
 
 <sect1 id="akonadi" xreflabel="akonadi-&akonadi-version;">
@@ -33,7 +33,7 @@
 	pour les données et méta données PIM fournissant simultanément l'accès au requête en lecture et écriture.
 	Il fournira l'identification unique des objets et la récupération de bureau.</para>
 
-    &lfs67_checked;
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Information sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -70,6 +70,7 @@
 
     <bridgehead renderas="sect4">Requises</bridgehead>
     <para role="required">
+    <xref linkend="qt4"/>, 
     <xref linkend="shared-mime-info"/>, 
     <xref linkend="boost"/>, 
     <xref linkend="soprano"/>
@@ -118,14 +119,14 @@
 
     <segmentedlist>
       <segtitle>Programmes installés</segtitle>
-      <segtitle>Bibliothèque installée</segtitle>
-      <segtitle>Répertoire installé</segtitle>
+      <segtitle>Bibliothèques installées</segtitle>
+      <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
         <seg>akonadi_agent_server, akonadi_agent_launcher, akonadiserver, 
-        akonadictl, akonadi_control, akonadi_rds</seg>
-        <seg>libakonadiprotocolinternals.so, libqsqlite3.so</seg>
-        <seg>none</seg>
+        akonadictl, akonadi_control et akonadi_rds</seg>
+        <seg>libakonadiprotocolinternals.so et libqsqlite3.so</seg>
+       <seg>$KDE4_PREFIX/share/config/akonadi et $KDE4_PREFIX/include/akonadi</seg>
       </seglistitem>
     </segmentedlist>
 <!--

Modified: trunk/blfs/kde4/core/attica.xml
===================================================================
--- trunk/blfs/kde4/core/attica.xml	2012-03-01 13:01:43 UTC (rev 1646)
+++ trunk/blfs/kde4/core/attica.xml	2012-03-02 01:07:11 UTC (rev 1647)
@@ -6,10 +6,10 @@
 
   <!ENTITY attica-download-http " ">
   <!ENTITY attica-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/attica/attica-&attica-version;.tar.bz2">
-  <!ENTITY attica-md5sum        "df3dcea0229cfa31539bdd427976e15b">
-  <!ENTITY attica-size          "0.9 Mio">
-  <!ENTITY attica-buildsize     "3.7 Mio">
-  <!ENTITY attica-time          "0.2 SBU">
+  <!ENTITY attica-md5sum        "5a77f678422e7a52e3a3abb2d7ad0499">
+  <!ENTITY attica-size          "54 Kio">
+  <!ENTITY attica-buildsize     "5.0 Mio">
+  <!ENTITY attica-time          "0.5 SBU">
 ]>
 
 <sect1 id="attica" xreflabel="attica-&attica-version;">
@@ -32,7 +32,7 @@
     <para><application>Attica</application> est une bibliothèque pour accéder 
     aux fournisseurs "Open Collaboration Service".</para>
 
-    &lfs67_checked;
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Information sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -70,7 +70,7 @@
 
     <bridgehead renderas="sect4">Requises</bridgehead>
     <para role="required">
-    <xref linkend="cmake"/>, <xref linkend="qt4"/>
+    <xref linkend="qt4"/>
     </para>
 
     <para condition="html" role="usernotes">Notes utilisateur :
@@ -109,14 +109,14 @@
     <title>Contenu</title>
 
     <segmentedlist>
-      <segtitle>Programme installé</segtitle>
-      <segtitle>Bibliothèque installée</segtitle>
-      <segtitle>Répertoire installé</segtitle>
+      <segtitle>Programmes installés</segtitle>
+      <segtitle>Bibliothèques installées</segtitle>
+      <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
         <seg>None</seg>
         <seg>libattica.so</seg>
-        <seg>None</seg>
+        <seg>$KDE4_PREFIX/include/attica</seg>
       </seglistitem>
     </segmentedlist>
 <!--

Modified: trunk/blfs/kde4/core/polkit-qt.xml
===================================================================
--- trunk/blfs/kde4/core/polkit-qt.xml	2012-03-01 13:01:43 UTC (rev 1646)
+++ trunk/blfs/kde4/core/polkit-qt.xml	2012-03-02 01:07:11 UTC (rev 1647)
@@ -6,10 +6,10 @@
 
   <!ENTITY polkit-qt-download-http " ">
   <!ENTITY polkit-qt-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/apps/KDE4.x/admin/polkit-qt-1-&polkit-qt-version;.tar.bz2">
-  <!ENTITY polkit-qt-md5sum        "1c5b4113a2a167624b5f716b4f03a219">
+  <!ENTITY polkit-qt-md5sum        "a105e233e6733fb072c9080cd7ae1af2">
   <!ENTITY polkit-qt-size          "67 Kio">
-  <!ENTITY polkit-qt-buildsize     "X Mio">
-  <!ENTITY polkit-qt-time          "X SBU">
+  <!ENTITY polkit-qt-buildsize     "2.5 Mio">
+  <!ENTITY polkit-qt-time          "0.1 SBU">
 ]>
 
 <sect1 id="polkit-qt" xreflabel="polkit-qt-&polkit-qt-version;">
@@ -29,10 +29,10 @@
   <sect2 role="package">
     <title>Introduction à Polkit-Qt</title>
 
-    <para><application>Polkit-Qt</application> fournit l'API <application>polkit</application>
+    <para><application>Polkit-Qt</application> fournit une API <application>polkit</application>
     dans l'environnement Qt.</para>
 
-    &lfs67_checked;
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Information sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -69,7 +69,9 @@
 
     <bridgehead renderas="sect4">Requises</bridgehead>
     <para role="required">
-    <xref linkend="polkit"/>, 
+    <xref linkend="qt4"/>, 
+    <xref linkend="polkit"/> et
+    <xref linkend="glib2"/>
     </para>
 
     <para condition="html" role="usernotes">Notes utilisateur :
@@ -110,13 +112,13 @@
 
     <segmentedlist>
       <segtitle>Programmes installés</segtitle>
-      <segtitle>Bibliothèque installée</segtitle>
-      <segtitle>Répertoire installé</segtitle>
+      <segtitle>Bibliothèques installées</segtitle>
+      <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
         <seg>None</seg>
-        <seg>libpolkit-qt-agent-1.so, libpolkit-qt-core-1.so, libpolkit-qt-gui-1.so</seg>
-        <seg>None</seg>
+        <seg>libpolkit-qt-agent-1.so, libpolkit-qt-core-1.so et libpolkit-qt-gui-1.so</seg>
+       <seg>$KDE4_PREFIX/include/polkit-qt-1</seg>
       </seglistitem>
     </segmentedlist>
 <!--

Modified: trunk/blfs/kde4/core/qimageblitz.xml
===================================================================
--- trunk/blfs/kde4/core/qimageblitz.xml	2012-03-01 13:01:43 UTC (rev 1646)
+++ trunk/blfs/kde4/core/qimageblitz.xml	2012-03-02 01:07:11 UTC (rev 1647)
@@ -4,11 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY qimageblitz-download-http "&sourceforge-repo;/qimageblitz/qimageblitz-&qimageblitz-version;.tar.bz2">
-  <!ENTITY qimageblitz-download-ftp  " ">
+  <!ENTITY qimageblitz-download-http " ">
+  <!ENTITY qimageblitz-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/qimageblitz/qimageblitz-&qimageblitz-version;.tar.bz2">
   <!ENTITY qimageblitz-md5sum        "0ae2f7d4e0876764a97ca73799f61df4">
   <!ENTITY qimageblitz-size          "57 Kio">
-  <!ENTITY qimageblitz-buildsize     "1.5 Mio">
+  <!ENTITY qimageblitz-buildsize     "1.4 Mio">
   <!ENTITY qimageblitz-time          "0.1 SBU">
 ]>
 
@@ -32,7 +32,7 @@
     <para><application>QImageblitz</application> est un effet graphique et une bibliothèque 
     de filtres pour <application>KDE4</application>.</para>
 
-    &lfs67_checked;
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Information sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -70,21 +70,9 @@
 
     <bridgehead renderas="sect4">Requises</bridgehead>
     <para role="required">
-    <xref linkend="qt4"/>,
-    <xref linkend="glib2"/>
+    <xref linkend="qt4"/>
     </para>
 
-    <bridgehead renderas="sect4">Recommandées</bridgehead>
-    <para role="recommended">
-    <xref linkend="xine-lib"/>, 
-    <xref linkend="gstreamer"/>
-    </para>
-
-    <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional">
-      <xref linkend='pulseaudio'/>
-    </para>
-
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/qimageblitz"/></para>
 
@@ -121,14 +109,14 @@
     <title>Contenu</title>
 
     <segmentedlist>
-      <segtitle>Programme installé</segtitle>
-      <segtitle>Bibliothèque installée</segtitle>
-      <segtitle>Répertoire installé</segtitle>
+      <segtitle>Programmes installés</segtitle>
+      <segtitle>Bibliothèques installées</segtitle>
+      <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
         <seg>blitztest</seg>
         <seg>libqimageblitz.so</seg>
-        <seg>none</seg>
+        <seg>$KDE4_PREFIX/include/qimageblitz</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/blfs/kde4/core/shrdesktopontologies.xml
===================================================================
--- trunk/blfs/kde4/core/shrdesktopontologies.xml	2012-03-01 13:01:43 UTC (rev 1646)
+++ trunk/blfs/kde4/core/shrdesktopontologies.xml	2012-03-02 01:07:11 UTC (rev 1647)
@@ -6,9 +6,9 @@
 
   <!ENTITY shared-desktop-ontologies-download-http "&sourceforge-repo;/oscaf/shared-desktop-ontologies-&shared-desktop-ontologies-version;.tar.bz2">
   <!ENTITY shared-desktop-ontologies-download-ftp  " ">
-  <!ENTITY shared-desktop-ontologies-md5sum        "067ec9023c4a48e0d53fb15484d78971">
-  <!ENTITY shared-desktop-ontologies-size          "90 Kio">
-  <!ENTITY shared-desktop-ontologies-buildsize     "1.5 Mio">
+  <!ENTITY shared-desktop-ontologies-md5sum        "8cd0950dc66eb5fbe560ac7fdb416e04">
+  <!ENTITY shared-desktop-ontologies-size          "3.8 Mio">
+  <!ENTITY shared-desktop-ontologies-buildsize     "6.7 Mio">
   <!ENTITY shared-desktop-ontologies-time          "<0.1 SBU">
 ]>
 
@@ -27,12 +27,15 @@
   </indexterm>
 
   <sect2 role="package">
-    <title>Introduction à Shared-desktop-ontologies</title>
+    <title>Introduction à Shared-Desktop-Ontologies</title>
 
-    <para>La fondation OSCA rassemble des organisations et des personnes intéressées
-     d'assurer l'interopérabilité entre les ordinateurs de bureau et les environnements collaboratifs.</para>
+    <para>Les Shared desktop ontologies (ontologies de bureau partagé) fournissent 
+    des vocabulaires RDF au bureau sémantique (Semantic Desktop). Cela comprend
+    les mots de base comme RDF et RDFS et toutes les ontologies Nepomuk comme
+    NRL, NIE, ou NFO, qui sont aussi maintenues et développées dans ce projet
+    libre.</para>
 
-    &lfs67_checked;
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Information sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -70,8 +73,7 @@
 
     <bridgehead renderas="sect4">Requises</bridgehead>
     <para role="required">
-    <xref linkend="qt4"/>,
-    <xref linkend="glib2"/>
+    <xref linkend="docbook-xsl"/>,
     </para>
 
     <bridgehead renderas="sect4">Recommandées</bridgehead>
@@ -101,8 +103,7 @@
 
     <para>Préparation du paquet pour la compilation:</para>
        
-<screen><userinput>cmake -DCMAKE_INSTALL_PREFIX=$KDE4_PREFIX .. &&
-make</userinput></screen>
+<screen><userinput>cmake -DCMAKE_INSTALL_PREFIX=$KDE4_PREFIX ..</userinput></screen>
 
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 

Modified: trunk/blfs/server/major/apache.xml
===================================================================
--- trunk/blfs/server/major/apache.xml	2012-03-01 13:01:43 UTC (rev 1646)
+++ trunk/blfs/server/major/apache.xml	2012-03-02 01:07:11 UTC (rev 1647)
@@ -6,10 +6,10 @@
 
   <!ENTITY apache-download-http "http://archive.apache.org/dist/httpd/httpd-&apache-version;.tar.bz2">
   <!ENTITY apache-download-ftp  "ftp://apache.mirrors.pair.com/httpd/httpd-&apache-version;.tar.bz2">
-  <!ENTITY apache-md5sum        "1696ae62cd879ab1d4dd9ff021a470f2">
-  <!ENTITY apache-size          "6.8 Mio">
-  <!ENTITY apache-buildsize     "105 Mio (en construisant tous les modules DSO disponibles)">
-  <!ENTITY apache-time          "1.2 SBU (en construisant tous les modules DSO disponibles)">
+  <!ENTITY apache-md5sum        "7d3001c7a26b985d17caa367a868f11c">
+  <!ENTITY apache-size          "3.9 Mio">
+  <!ENTITY apache-buildsize     "94 Mio (en construisant tous les modules DSO disponibles)">
+  <!ENTITY apache-time          "0.8 SBU (en construisant tous les modules DSO disponibles)">
 ]>
 
 <sect1 id="apache" xreflabel="Apache-&apache-version;">




More information about the lfs-traducfr mailing list