[lfs-fr] r1645 - in trunk/blfs: . general/genlib general/genutils general/prog introduction/welcome kde4/core postlfs/security server/major xsoft/office

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Mer 29 Fév 19:06:22 PST 2012


Author: jmengual
Date: 2012-03-01 04:06:22 +0100 (Thu, 01 Mar 2012)
New Revision: 1645

Added:
   trunk/blfs/general/genlib/apr.xml
   trunk/blfs/general/genutils/apr-util.xml
   trunk/blfs/kde4/core/phonon-backend-vlc.xml
Removed:
   trunk/blfs/kde4/core/phonon-backend-xine.xml
Modified:
   trunk/blfs/general.ent
   trunk/blfs/general/genlib/genlib.xml
   trunk/blfs/general/genlib/slib.xml
   trunk/blfs/general/genutils/genutils.xml
   trunk/blfs/general/prog/subversion.xml
   trunk/blfs/introduction/welcome/changelog.xml
   trunk/blfs/kde4/core/core.xml
   trunk/blfs/kde4/core/phonon-backend-gstreamer.xml
   trunk/blfs/kde4/core/phonon.xml
   trunk/blfs/postlfs/security/stunnel.xml
   trunk/blfs/server/major/apache.xml
   trunk/blfs/xsoft/office/gnucash.xml
Log:
9551-9559, a deboguer.


Added: trunk/blfs/general/genlib/apr.xml
===================================================================
--- trunk/blfs/general/genlib/apr.xml	                        (rev 0)
+++ trunk/blfs/general/genlib/apr.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -0,0 +1,170 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY apr-download-http
+  "http://archive.apache.org/dist/apr/apr-&apr-version;.tar.bz2">
+  <!ENTITY apr-download-ftp "ftp://ftp.mirrorservice.org/sites/ftp.apache.org/apr/apr-&apr-version;.tar.bz2">
+  <!ENTITY apr-md5sum        "ffee70a111fd07372982b0550bbb14b7">
+  <!ENTITY apr-size          "768 Kio">
+  <!ENTITY apr-buildsize     "11 Mio">
+  <!ENTITY apr-time          "0.2 SBU">
+]>
+
+<sect1 id="apr" xreflabel="Apr-&apr-version;">
+  <?dbhtml filename="apr.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy> : ety $</othername>
+    <date>$Date> : 2012-02-29 16:30:34 +0100 (mer 29 fév 2012) $</date>
+  </sect1info>
+
+  <title>Apr-&apr-version;</title>
+
+  <indexterm zone="apr">
+    <primary sortas="a-apr">Apr</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction à Apr</title>
+
+    <para>
+      Le <foreignphrase>Apache Portable Runtime</foreignphrase> (APR) est une
+      bibliothèque de support du serveur web Apache. Il offre un ensemble 
+      d'interfaces de programmation d'application (APIs) qui correspondent au
+      système d'exploitation sous-jacent. Quand le système d'exploitation ne
+      supporte pas une fonction en particulier, APR fournira une émulation. Ainsi,
+      les programmeurs peuvent utiliser l'APR pour rendre un programme portable
+      sur différentes plateformes.
+    </para>
+
+    &lfs70_checked;
+
+    <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Téléchargement (HTTP) : <ulink url="&apr-download-http;"/>
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Téléchargement (FTP) : <ulink url="&apr-download-ftp;"/>
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Somme de contrôle MD5 du téléchargement : &apr-md5sum;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Taille du téléchargement : &apr-size;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Estimation de l'espace disque requis : &apr-buildsize;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Estimation du temps de construction : &apr-time;
+        </para>
+      </listitem>
+    </itemizedlist>
+
+    <para condition="html" role="usernotes">
+      Notes utilisateur : <ulink url="&blfs-wiki;/apr"/>
+    </para>
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation de Apr</title>
+
+    <para>
+      Installez <application>Apr</application> en lançant les commandes 
+      suivantes :
+    </para>
+
+<screen><userinput>./configure --prefix=/usr --disable-static \
+  --with-installbuilddir=/usr/libexec/apache/build &&
+make</userinput></screen>
+
+    <para>
+      Pour tester les résultats, lancez : <command>make test</command>.
+    </para>
+
+    <para>
+      Maintenant, en tant qu'utilisateur the <systemitem class="username">root</systemitem> :
+    </para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Explications des commandes</title>
+
+    <para>
+      <option>--disable-static</option> : Ceci arrête la compilation d'une
+      version statique de <filename class="libraryfile">libapr-1</filename>.
+    </para>
+
+    <para>
+      <option>--with-installbuilddir=/usr/libexec/apache/build</option> :
+      Cette option met ces exécutables privés dans
+      <filename class="directory">/usr/libexec/apache/build</filename> au lieu
+      de <filename class="directory">/usr/build-1</filename> par défaut.
+     </para>
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contenu</title>
+
+    <segmentedlist>
+      <segtitle>Programme installé</segtitle>
+      <segtitle>Bibliothèque installée</segtitle>
+      <segtitle>Répertoires installés</segtitle>
+
+      <seglistitem>
+        <seg>apr-1-config</seg>
+        <seg>libapr-1.so</seg>
+        <seg>/usr/include/apr et /usr/libexec/apache/build</seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Descriptions courtes</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="apr-1-config">
+        <term><command>apr-1-config</command></term>
+        <listitem>
+          <para>
+            est un script shell utilisé pour récupérer des informations sur la
+            bibliothèque apr du système. On l'utilise généralement pour compiler
+            et lier quelque chose à la bibliothèque.
+          </para>
+          <indexterm zone="apr apr-1-config">
+            <primary sortas="b-apr-1-config">apr-1-config</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="libapr-1">
+        <term><filename class="libraryfile">libapr-1.so</filename></term>
+        <listitem>
+          <para>
+            est la bibliothèque Apache Portable Runtime.
+          </para>
+          <indexterm zone="apr libapr-1">
+            <primary sortas="c-libapr-1">libapr-1.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+    </variablelist>
+  </sect2>
+</sect1>

Modified: trunk/blfs/general/genlib/genlib.xml
===================================================================
--- trunk/blfs/general/genlib/genlib.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/general/genlib/genlib.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -108,6 +108,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libunistring.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="json-glib.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="exempi.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="apr.xml"/>
   <!--  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libxml.xml"/> -->
   <!-- <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="ispell.xml"/> -->
   <!-- <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="fam.xml"/> -->

Modified: trunk/blfs/general/genlib/slib.xml
===================================================================
--- trunk/blfs/general/genlib/slib.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/general/genlib/slib.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -6,7 +6,7 @@
 
   <!ENTITY slib-download-http "http://groups.csail.mit.edu/mac/ftpdir/scm/slib-&slib-version;.tar.gz">
   <!ENTITY slib-download-ftp  " ">
-  <!ENTITY slib-md5sum        "850f48ad933e2fe8bb03b1e994ed4407">
+  <!ENTITY slib-md5sum        "11626eef380de4f56d3082514559beb6">
   <!ENTITY slib-size          "948 Kio">
   <!ENTITY slib-buildsize     "31 Mio (includes building et installing docs)">
   <!ENTITY slib-time          "moins de 0.5 SBU">

Added: trunk/blfs/general/genutils/apr-util.xml
===================================================================
--- trunk/blfs/general/genutils/apr-util.xml	                        (rev 0)
+++ trunk/blfs/general/genutils/apr-util.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -0,0 +1,190 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY apr-util-download-http "http://archive.apache.org/dist/apr/apr-util-&apr-util-version;.tar.bz2">
+  <!ENTITY apr-util-download-ftp "ftp://ftp.mirrorservice.org/sites/ftp.apache.org/apr/apr-util-&apr-util-version;.tar.bz2">
+  <!ENTITY apr-util-md5sum        "52b31b33fb1aa16e65ddaefc76e41151">
+  <!ENTITY apr-util-size          "624 Kio">
+  <!ENTITY apr-util-buildsize     "8.3 Mio">
+  <!ENTITY apr-util-time          "0.1 SBU">
+]>
+
+<sect1 id="apr-util" xreflabel="Apr-Util-&apr-util-version;">
+  <?dbhtml filename="apr-util.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy> : ety $</othername>
+    <date>$Date> : 2012-02-29 16:30:34 +0100 (mer 29 fév 2012) $</date>
+  </sect1info>
+
+  <title>Apr-Util-&apr-util-version;</title>
+
+  <indexterm zone="apr-util">
+    <primary sortas="a-apr-util">Apr-Util</primary>
+  </indexterm>
+
+  <!--Required section-->
+  <sect2 role="package">
+    <title>Introduction à Apr-Util</title>
+
+    <para>
+      La bibliothèque <foreignphrase>Apache Portable Runtime Utility</foreignphrase>
+      fournit une interface prévisible et cohérente avec des interfaces de
+      bibliothèques clients sous-jacentes. Cette interface de programmation
+      d'application assure la prévisibilité d'un comportement s'il n'est pas
+      identique en fonction des bibliothèques disponibles sur une plateforme
+      donnée. 
+    </para>
+
+    &lfs70_checked;
+
+    <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>
+          Téléchargement (HTTP) : <ulink url="&apr-util-download-http;"/>
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Téléchargement (FTP) : <ulink url="&apr-util-download-ftp;"/>
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Somme de contrôle MD5 du téléchargement : &apr-util-md5sum;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Taille du téléchargement : &apr-util-size;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Estimation de l'espace disque requis : &apr-util-buildsize;
+        </para>
+      </listitem>
+      <listitem>
+        <para>
+          Estimation du temps de construction : &apr-util-time;
+        </para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">Dépendances d'Apr-Util</bridgehead>
+
+    <bridgehead renderas="sect4">Requises</bridgehead>
+    <para role="required"><xref linkend="apr"/>.</para>
+
+    <bridgehead renderas="sect4">Facultatives</bridgehead>
+    <para role="optional">
+      <xref linkend="openldap"/>,
+      <xref linkend="openssl"/>,
+      <xref linkend="expat"/>,
+      <xref linkend="unixodbc"/>,
+      <xref linkend="mysql"/>,
+      <xref linkend="postgresql"/>,
+      <ulink url="http://www.oracle.com/us/products/database/index.html">Oracle 11g</ulink>,
+      <ulink url="http://www.freetds.org/">FreeTDS</ulink>
+      <xref linkend="sqlite"/> et <xref linkend="db"/>.
+    </para>
+
+    <para condition="html" role="usernotes">
+      Notes utilisateur : <ulink url="&blfs-wiki;/apr-util"/>
+    </para>
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation de Apr-Util</title>
+
+    <para>
+      Installez <application>Apr-Util</application> en lançant les commandes
+      suivantes :
+    </para>
+
+<screen><userinput>./configure --prefix=/usr --with-apr=/usr --with-gdbm=/usr &&
+make</userinput></screen>
+
+    <para>
+      Pour tester les résultats, lancez : <command>make test</command>.
+    </para>
+
+    <para>
+      Maintenant, en tant qu'utilisateur the <systemitem class="username">root</systemitem> :
+    </para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Explications des commandes</title>
+
+    <para>
+      <option>--with-gdbm=/usr</option> : Cette option entraîne la
+      compilation du greffon <filename class="libraryfile">apr_dbm_gdbm-1.so</filename>.
+    </para>
+
+    <para>
+      <option>--with-berkeley-db=/usr</option> : Si vous avez installé
+      <xref linkend="db"/>, utilisez cette option pour compiler le greffon
+      <filename class="libraryfile">apr_dbm_db-1.so</filename>.
+    </para>
+
+    <para>
+      <option>--with-openssl=/usr</option> : Si vous avez installé
+      <xref linkend="openssl"/> utilisez cette option pour compiler le greffon
+      <filename class="libraryfile">apr_crypto_openssl-1.so</filename>.
+    </para>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contenu</title>
+
+    <segmentedlist>
+      <segtitle>Programme installé</segtitle>
+      <segtitle>Bibliothèque installée</segtitle>
+      <segtitle>Répertoire installé</segtitle>
+
+      <seglistitem>
+        <seg>apu-1-config</seg>
+        <seg>libaprutil-1.so</seg>
+        <seg>/usr/lib/apr-util-1</seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Descriptions courtes</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="apu-1-config">
+        <term><command>apu-1-config</command></term>
+        <listitem>
+          <para>est un script simple qui fournit des informations sur le programme
+          APR-Util installé.</para>
+          <indexterm zone="apache apu-1-config">
+            <primary sortas="b-apu-1-config">apu-1-config</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="libaprutil-1">
+        <term><filename class="libraryfile">libaprutil-1.so</filename></term>
+        <listitem>
+          <para>
+            contient les fonctions pour offrir une interface prévisible et 
+            cohérente avec les interfaces de bibliothèque clientes sous-jacentes.
+          </para>
+          <indexterm zone="apr-util libaprutil-1">
+            <primary sortas="c-libaprutil-1">libaprutil-1.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+    </variablelist>
+  </sect2>
+</sect1>

Modified: trunk/blfs/general/genutils/genutils.xml
===================================================================
--- trunk/blfs/general/genutils/genutils.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/general/genutils/genutils.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -47,6 +47,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gperf.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="rarian.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="ggz-client-libs.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="apr-util.xml"/>
 
 
 </chapter>

Modified: trunk/blfs/general/prog/subversion.xml
===================================================================
--- trunk/blfs/general/prog/subversion.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/general/prog/subversion.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -69,18 +69,13 @@
     <bridgehead renderas="sect3">Dépendances de Subversion</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
-    <para role="required"><xref linkend="apache"/> et <xref linkend="apache"/>
-    (seulement pour
-    <application>APR</application>) ou
-    <ulink url="http://apr.apache.org/">Apache Portable Runtime</ulink></para>
+    <para role="required"><xref linkend="sqlite"/> and
+    <xref linkend="apr-util"/></para>
 
     <para>Si vous avez besoin des scripts de base de <application>Berkeley DB</application>
     dans <application>Subversion</application> pour construire ou supporter les
     dépôts basés sur BDB, vous devez avoir lié <application>Berkeley DB</application>
-    à la bibliothèque <application>APR-util</application>. Il y a des
-    informations dans les instructions d'<xref linkend="apache"/> qui montrent
-    les paramètres qui doivent être passés au script <command>configure</command> lorsque vous
-    construisez un des paquets <application>APR-util</application>.</para>
+    à la bibliothèque <application>APR-util</application>.</para>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional"><xref linkend="python2"/> (required to run the test suite),
@@ -91,8 +86,7 @@
     <xref linkend="dbus-glib"/>,
     <xref linkend="gnome-keyring"/>,
     KWallet de KDE4,
-    <xref linkend="apache"/> (si vous avez installé <application>Apache Portable
-    Runtime</application>), et
+    <xref linkend="apache"/> et
     <xref linkend="neon"/> ou
      <ulink url="http://code.google.com/p/serf/">serf</ulink></para>
 
@@ -184,24 +178,6 @@
 
   </sect2>
 
-  <sect2 role="commands">
-    <title>Explication des commandes</title>
-
-    <para><option>--with-apr=<replaceable><prefix></replaceable>
-    --with-apr-util=<replaceable><prefix></replaceable></option> :
-    Vous devriez utiliser cette option si vous souhaitez utiliser une version installée sur le système
-    de <application>APR</application>. Assurez-vous d'avoir identifié le bon préfixe
-    d'installation.</para>
-
-    <para><option>--with-apxs=/usr/sbin/apxs</option> :
-    Vous devriez utiliser cette option si vous souhaitez utiliser une version installée sur le système
-    de la commande <command>apxs</command>, installée lors de
-    l'installation d'<application>Apache HTTPD</application>, vu que
-    <command>apxs</command> pourrait ne pas se trouver dans le <envar>PATH</envar> de l'utilisateur non privilégié et qu'elle ne
-    sera pas détectée correctement.</para>
-
-  </sect2>
-
   <sect2 role="configuration">
     <title>Configuration de Subversion</title>
 

Modified: trunk/blfs/general.ent
===================================================================
--- trunk/blfs/general.ent	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/general.ent	2012-03-01 03:06:22 UTC (rev 1645)
@@ -135,7 +135,7 @@
 <!ENTITY polkit-version               "0.102">
 <!ENTITY polkit-gnome-version         "0.104">
 <!ENTITY shadow-version               "4.1.4.3">
-<!ENTITY stunnel-version              "4.46">
+<!ENTITY stunnel-version              "4.52">
 <!ENTITY sudo-version                 "1.8.2">
 <!ENTITY tcpwrappers-version          "7.6">
 <!ENTITY tripwire-version             "2.4.2.2">
@@ -234,6 +234,7 @@
 <!ENTITY libunistring-version         "0.9.3">
 <!ENTITY json-glib-version            "0.14.2">
 <!ENTITY exempi-version               "2.1.1">
+<!ENTITY apr-version                  "1.4.6">
 
 <!-- Obsolete
 <!ENTITY fam-version                  "2.7.0">
@@ -309,6 +310,7 @@
 <!ENTITY gperf-version                "3.0.4">
 <!ENTITY rarian-version               "0.8.1">
 <!ENTITY ggz-client-libs-version      "0.0.14.1">
+<!ENTITY apr-util-version             "1.4.1">
 
 <!-- Chapter 11 -->
 <!ENTITY autofs-version               "5.0.5">
@@ -543,7 +545,7 @@
 
 <!-- Part V -->
 <!-- Chapter 19 -->
-<!ENTITY apache-version               "2.2.21">
+<!ENTITY apache-version               "2.4.1">
 <!-- bind (chapter 15) -->
 <!-- openssh (chapter 4) -->
 <!ENTITY proftpd-version              "1.3.0">
@@ -664,9 +666,9 @@
 <!ENTITY kde4-dir-var                 "KDE4_PREFIX">
 <!ENTITY kde4-dir                     "$&kde4-dir-var;">
 <!ENTITY automoc4-version             "0.9.88">
-<!ENTITY phonon-version               "4.4.4">
+<!ENTITY phonon-version               "4.6.0">
 <!ENTITY phonon-backend-gstreamer-version "&phonon-version;">
-<!ENTITY phonon-backend-xine-version  "&phonon-version;">
+<!ENTITY phonon-backend-vlc-version  "0.5.0">
 <!ENTITY attica-version               "0.2.0">
 <!ENTITY akonadi-version              "1.5.0">
 <!ENTITY qimageblitz-version          "0.0.6">

Modified: trunk/blfs/introduction/welcome/changelog.xml
===================================================================
--- trunk/blfs/introduction/welcome/changelog.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/introduction/welcome/changelog.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -44,7 +44,22 @@
     <listitem>
       <para>28 février 2012</para>
       <itemizedlist>
+       <listitem>
+          <para>[rthomsen] - ajout de phonon-backend-vlc 0.5.0.</para>
+       </listitem>
+       <listitem>
+          <para>[rthomsen] - passage à phonon-backend-gstreamer 4.6.0.</para>
+        </listitem>
         <listitem>
+          <para>[bdubbs] - passage à stunnel-4.52.</para>
+        </listitem>
+        <listitem>
+          <para>[rthomsen] - suppression de phonon-backend-xine (obsolète).</para>
+        </listitem>
+        <listitem>
+          <para>[rthomsen] - passage à phonon 4.6.0.</para>
+        </listitem>
+        <listitem>
           <para>[ken] - synchronisation de gtkhtml-4.2.2 par Wayne.</para>
         </listitem>
         <listitem>
@@ -71,7 +86,7 @@
         <listitem>
           <para>[ken] - hamster-applet est commenté. Bien que la dernière version de développement
           est théoriquement une partie de gnome-3.2, et des constructions, elle demande divers
-	  modules Python anciens et/ou inconnus, dépendant de quelle commande vous souhaitez lancer.</para>
+          modules Python anciens et/ou inconnus, dépendant de quelle commande vous souhaitez lancer.</para>
         </listitem>
         <listitem>
           <para>[ken] - ajout de nemiver-0.9.0 par Wayne.</para>
@@ -85,12 +100,21 @@
         <listitem>
           <para>[ken] - syydfronisation de seahorse-3.2.2 par Wayne.</para>
         </listitem>
-       <listitem>
+        <listitem>
           <para>[ken] - synchronisation de totem-3.2.1 par Wayne.</para>
         </listitem>
         <listitem>
           <para>[ken] - ajout de vinagre-3.2.2 par Wayne.</para>
         </listitem>
+        <listitem>
+          <para>[abenton] - ajout d'Apr 1.4.6.</para>
+        </listitem>
+        <listitem>
+          <para>[abenton] - ajout d'Apr Util 1.4.1.</para>
+        </listitem>
+        <listitem>
+          <para>[abenton] - Apache 2.4.1.</para>
+        </listitem>
       </itemizedlist>
     </listitem>
     <listitem>

Modified: trunk/blfs/kde4/core/core.xml
===================================================================
--- trunk/blfs/kde4/core/core.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/kde4/core/core.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -17,8 +17,7 @@
 
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="automoc4.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-xine.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-gstreamer.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="phonon-backend-vlc.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="akonadi.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="attica.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="qimageblitz.xml"/>

Modified: trunk/blfs/kde4/core/phonon-backend-gstreamer.xml
===================================================================
--- trunk/blfs/kde4/core/phonon-backend-gstreamer.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/kde4/core/phonon-backend-gstreamer.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -5,10 +5,10 @@
   %general-entities;
 
   <!ENTITY phonon-backend-gstreamer-download-http " ">
-  <!ENTITY phonon-backend-gstreamer-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/phonon/phonon-backend-gstreamer/&phonon-backend-gstreamer-version;/src/phonon-backend-gstreamer-&phonon-backend-gstreamer-version;.tar.bz2">
-  <!ENTITY phonon-backend-gstreamer-md5sum        "fa313a77db3da9df20bc8991352378cb">
-  <!ENTITY phonon-backend-gstreamer-size          "78 Kio">
-  <!ENTITY phonon-backend-gstreamer-buildsize     "322 Mio">
+  <!ENTITY phonon-backend-gstreamer-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/phonon/phonon-backend-gstreamer/&phonon-backend-gstreamer-version;/src/phonon-backend-gstreamer-&phonon-backend-gstreamer-version;.tar.xz">
+  <!ENTITY phonon-backend-gstreamer-md5sum        "cc380c7612aaaa87294185ded702f88a">
+  <!ENTITY phonon-backend-gstreamer-size          "70 Kio">
+  <!ENTITY phonon-backend-gstreamer-buildsize     "3.1 Mio">
   <!ENTITY phonon-backend-gstreamer-time          "0.3 SBU">
 ]>
 
@@ -32,7 +32,7 @@
     <para>Ce paquet fournit un backend <application>Phonon</application> qui utilise le 
     framework <application>GStreamer</application>.</para>
 
-    &lfs67_checked;
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Information sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -56,18 +56,8 @@
       </listitem>
     </itemizedlist>
 
-<!--
-    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing='compact'>
-      <listitem>
-        <para>Required patch> : <ulink
-        url="&patch-root;/phonon-backend-gstreamer-&phonon-backend-gstreamer-version;-fixes-1.patch"/></para>
-      </listitem>
-    </itemizedlist>
--->
+    <bridgehead renderas="sect3">Dépendances de Phonon GStreamer Backend</bridgehead>
 
-    <bridgehead renderas="sect3">Dependances de Phonon</bridgehead>
-
     <bridgehead renderas="sect4">Requises</bridgehead>
     <para role="required">
     <xref linkend="qt4"/>,
@@ -75,6 +65,14 @@
     <xref linkend="gstreamer"/> 
     </para>
 
+    
+    <bridgehead renderas="sect4">Recommandées</bridgehead>
+    <para role="recommended">
+    <xref linkend="gst-plugins-good"/> (nécessaire pour la sortie sur PulseAudio),
+    <xref linkend="gst-plugins-bad"/> (nécessaire pour le support AAC/M4A),
+    <xref linkend="gst-plugins-ugly"/> (nécessaire pour le support MP3)
+    </para>
+
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/phonon-backend-gstreamer"/></para>
 
@@ -91,8 +89,8 @@
 
     <para>Préparation du paquet pour la compilation:</para>
        
-<screen><userinput>cmake -DCMAKE_INSTALL_PREFIX=$QT4DIR \
-      .. &&
+<screen><userinput>cmake -DCMAKE_INSTALL_PREFIX=$KDE4_PREFIX \
+    .. &&
 make</userinput></screen>
 
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>

Added: trunk/blfs/kde4/core/phonon-backend-vlc.xml
===================================================================
--- trunk/blfs/kde4/core/phonon-backend-vlc.xml	                        (rev 0)
+++ trunk/blfs/kde4/core/phonon-backend-vlc.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -0,0 +1,145 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY phonon-backend-vlc-download-http " ">
+  <!ENTITY phonon-backend-vlc-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/phonon/phonon-backend-vlc/&phonon-backend-vlc-version;/src/phonon-backend-vlc-&phonon-backend-vlc-version;.tar.xz">
+  <!ENTITY phonon-backend-vlc-md5sum        "fc5dc2b353fa0d9e428ecfc3c485eb66">
+  <!ENTITY phonon-backend-vlc-size          "51 Kio">
+  <!ENTITY phonon-backend-vlc-buildsize     "2.0 Mio">
+  <!ENTITY phonon-backend-vlc-time          "0.2 SBU">
+]>
+
+<sect1 id="phonon-backend-vlc" xreflabel="phonon-backend-vlc-&phonon-backend-vlc-version;">
+  <?dbhtml filename="phonon-backend-vlc.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy> : rthomsen $</othername>
+    <date>$Date> : 2012-02-29 21:56:46 +0100 (mer 29 fév 2012) $</date>
+  </sect1info>
+
+  <title>Phonon Backend VLC &phonon-backend-vlc-version;</title>
+
+  <indexterm zone="phonon-backend-vlc">
+    <primary sortas="a-phonon-backend-vlc">phonon-backend-vlc</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction à the Phonon VLC backend</title>
+
+    <para>Ce paquet fournit une fondation <application>Phonon</application> qui
+    utilise l'environnement du lecteur <application>VLC</application>.</para>
+
+    &lfs70_checked;
+
+    <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Téléchargement (HTTP) : <ulink url="&phonon-backend-vlc-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Téléchargement (FTP) : <ulink url="&phonon-backend-vlc-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Somme de contrôle MD5 du téléchargement : &phonon-backend-vlc-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Taille du téléchargement : &phonon-backend-vlc-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimation de l'espace disque requis : &phonon-backend-vlc-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimation du temps de construction : &phonon-backend-vlc-time;</para>
+      </listitem>
+    </itemizedlist>
+
+<!--
+    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
+    <itemizedlist spacing='compact'>
+      <listitem>
+        <para>Required patch> : <ulink
+        url="&patch-root;/phonon-backend-vlc-&phonon-backend-vlc-version;-fixes-1.patch"/></para>
+      </listitem>
+    </itemizedlist>
+-->
+
+    <bridgehead renderas="sect3">Dépendances de Phonon VLC Backend</bridgehead>
+
+    <bridgehead renderas="sect4">Requises</bridgehead>
+    <para role="required">
+    <xref linkend="qt4"/>,
+    <xref linkend="phonon"/>,
+    <xref linkend="vlc"/>
+    </para>
+
+    <para condition="html" role="usernotes">Notes utilisateur :
+    <ulink url="&blfs-wiki;/phonon-backend-vlc"/></para>
+   
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation de Phonon Backend VLC</title>
+
+    <para>Installez <application>Phonon Backend VLC</application> en lançant les commandes
+    suivantes :</para>
+
+<screen><userinput>mkdir build &&
+cd build</userinput></screen>
+
+    <para>Prepare the package for compilation:</para>
+       
+<screen><userinput>cmake -DCMAKE_INSTALL_PREFIX=$KDE4_PREFIX \
+    .. &&
+make</userinput></screen>
+
+    <para>Maintenant, en tant qu'utilisateur the <systemitem class="username">root</systemitem> :</para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+</sect2>
+<!--
+  <sect2 role="commands">
+    <title>Explications des commandes</title>
+
+    <para><option>- -xyz</option>: This option is set for ...</para>
+
+  </sect2>
+-->
+  <sect2 role="content">
+    <title>Contenu</title>
+
+    <segmentedlist>
+      <segtitle>Programme installé</segtitle>
+      <segtitle>Bibliothèques installées</segtitle>
+      <segtitle>Répertoire installé</segtitle>
+
+      <seglistitem>
+        <seg>aucun</seg>
+        <seg>phonon_vlc.so</seg>
+        <seg>aucun</seg>
+      </seglistitem>
+    </segmentedlist>
+<!--
+    <variablelist>
+      <bridgehead renderas="sect3">Descriptions courtes</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="a-phonon">
+        <term><command>phonon</command></term>
+        <listitem>
+          <para>is a testing utility for phonon-backend-vlc-generated build trees.</para>
+          <indexterm zone="a-phonon phonon">
+            <primary sortas="b-phonon">phonon</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+    </variablelist>
+-->
+  </sect2>
+
+</sect1>

Deleted: trunk/blfs/kde4/core/phonon-backend-xine.xml
===================================================================
--- trunk/blfs/kde4/core/phonon-backend-xine.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/kde4/core/phonon-backend-xine.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -1,145 +0,0 @@
-<?xml version="1.0" encoding="ISO-8859-1"?>
-<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
-   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
-  <!ENTITY % general-entities SYSTEM "../../general.ent">
-  %general-entities;
-
-  <!ENTITY phonon-backend-xine-download-http " ">
-  <!ENTITY phonon-backend-xine-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/phonon/phonon-backend-xine/&phonon-backend-xine-version;/src/phonon-backend-xine-&phonon-backend-xine-version;.tar.bz2">
-  <!ENTITY phonon-backend-xine-md5sum        "b127104e67538e573adeed3b2fb3bf55">
-  <!ENTITY phonon-backend-xine-size          "94 Kio">
-  <!ENTITY phonon-backend-xine-buildsize     "354 Mio">
-  <!ENTITY phonon-backend-xine-time          "0.2 SBU">
-]>
-
-<sect1 id="phonon-backend-xine" xreflabel="phonon-backend-xine-&phonon-backend-xine-version;">
-  <?dbhtml filename="phonon-backend-xine.html"?>
-
-  <sect1info>
-    <othername>$LastChangedBy> : thomas $</othername>
-    <date>$Date: 2011-03-19 19:19:07 +0100 (sam. 19 mars 2011) $</date>
-  </sect1info>
-
-  <title>Phonon Backend Xine &phonon-backend-xine-version;</title>
-
-  <indexterm zone="phonon-backend-xine">
-    <primary sortas="a-phonon-backend-xine">phonon-backend-xine</primary>
-  </indexterm>
-
-  <sect2 role="package">
-    <title>Introduction à the Phonon Xine backend</title>
-
-    <para>Ce paquet fournit un backend <application>Phonon</application> qui utilise
-    le framework <application>Xine</application>.</para>
-
-    &lfs67_checked;
-
-    <bridgehead renderas="sect3">Information sur le paquet</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>Téléchargement (HTTP) : <ulink url="&phonon-backend-xine-download-http;"/></para>
-      </listitem>
-      <listitem>
-        <para>Téléchargement (FTP) : <ulink url="&phonon-backend-xine-download-ftp;"/></para>
-      </listitem>
-      <listitem>
-        <para>Somme de contrôle MD5 du téléchargement : &phonon-backend-xine-md5sum;</para>
-      </listitem>
-      <listitem>
-        <para>Taille du téléchargement : &phonon-backend-xine-size;</para>
-      </listitem>
-      <listitem>
-        <para>Estimation de l'espace disque requis : &phonon-backend-xine-buildsize;</para>
-      </listitem>
-      <listitem>
-        <para>Estimation du temps de construction : &phonon-backend-xine-time;</para>
-      </listitem>
-    </itemizedlist>
-
-<!--
-    <bridgehead renderas="sect3">Additional Downloads</bridgehead>
-    <itemizedlist spacing='compact'>
-      <listitem>
-        <para>Required patch> : <ulink
-        url="&patch-root;/phonon-backend-xine-&phonon-backend-xine-version;-fixes-1.patch"/></para>
-      </listitem>
-    </itemizedlist>
--->
-
-    <bridgehead renderas="sect3">Dépendances de Phonon</bridgehead>
-
-    <bridgehead renderas="sect4">Requises</bridgehead>
-    <para role="required">
-    <xref linkend="qt4"/>,
-    <xref linkend="phonon"/>,
-    <xref linkend="xine-lib"/> 
-    </para>
-
-    <para condition="html" role="usernotes">Notes utilisateur :
-    <ulink url="&blfs-wiki;/phonon-backend-xine"/></para>
-
-  </sect2>
-
-  <sect2 role="installation">
-    <title>Installation de Phonon Backend Xine</title>
-
-    <para>Installez <application>Phonon Backend Xine</application> en lançant les commandes
-    suivantes :</para>
-
-<screen><userinput>mkdir build &&
-cd build</userinput></screen>
-
-    <para>Préparation du paquet pour la compilation:</para>
-       
-<screen><userinput>cmake -DCMAKE_INSTALL_PREFIX=$QT4DIR \
-      .. &&
-make</userinput></screen>
-
-    <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
-
-<screen role="root"><userinput>make install</userinput></screen>
-
-</sect2>
-<!--
-  <sect2 role="commands">
-    <title>Explications des commandes</title>
-
-    <para><option>- -xyz</option>: This option is set for ...</para>
-
-  </sect2>
--->
-  <sect2 role="content">
-    <title>Contenu</title>
-
-    <segmentedlist>
-      <segtitle>Programme installé</segtitle>
-      <segtitle>Bibliothèques installées</segtitle>
-      <segtitle>Répertoire installé</segtitle>
-
-      <seglistitem>
-        <seg>none</seg>
-        <seg>phonon_xine.so</seg>
-        <seg>none</seg>
-      </seglistitem>
-    </segmentedlist>
-<!--
-    <variablelist>
-      <bridgehead renderas="sect3">Descriptions courtes</bridgehead>
-      <?dbfo list-presentation="list"?>
-      <?dbhtml list-presentation="table"?>
-
-      <varlistentry id="a-phonon">
-        <term><command>phonon</command></term>
-        <listitem>
-          <para>is a testing utility for phonon-backend-xine-generated build trees.</para>
-          <indexterm zone="a-phonon phonon">
-            <primary sortas="b-phonon">phonon</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-    </variablelist>
--->
-  </sect2>
-
-</sect1>

Modified: trunk/blfs/kde4/core/phonon.xml
===================================================================
--- trunk/blfs/kde4/core/phonon.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/kde4/core/phonon.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -5,11 +5,11 @@
   %general-entities;
 
   <!ENTITY phonon-download-http " ">
-  <!ENTITY phonon-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/phonon/&phonon-version;/src/phonon-&phonon-version;.tar.bz2">
-  <!ENTITY phonon-md5sum        "1deb14ecb2185e1f2fe2741a0bd46852">
-  <!ENTITY phonon-size          "354 Kio">
-  <!ENTITY phonon-buildsize     "7.7 Mio">
-  <!ENTITY phonon-time          "0.3 SBU">
+  <!ENTITY phonon-download-ftp  "ftp://ftp.kde.org/pub/kde/stable/phonon/&phonon-version;/src/phonon-&phonon-version;.tar.xz">
+  <!ENTITY phonon-md5sum        "bbe0c1c62ed14c31479c4c1a6cf1e173">
+  <!ENTITY phonon-size          "275 Kio">
+  <!ENTITY phonon-buildsize     "7.4 Mio">
+  <!ENTITY phonon-time          "0.5 SBU">
 ]>
 
 <sect1 id="phonon" xreflabel="phonon-&phonon-version;">
@@ -31,9 +31,9 @@
 
     <para><application>Phonon</application> est l'API multimedia de KDE4.
     Il remplace le vieu <application>aRts</application>, qui n'est plus 
-    supporté par KDE. Il supporte des backends comme xine, GStreamer etc.</para>
+    supporté par KDE. Il supporte des backends comme GStreamer et VLC.</para>
 
-    &lfs67_checked;
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Information sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -75,15 +75,10 @@
     <xref linkend="glib2"/>
     </para>
 
-    <bridgehead renderas="sect4">Recommandées</bridgehead>
-    <para role="recommended">
-    <xref linkend="xine-lib"/>, 
-    <xref linkend="gstreamer"/>
-    </para>
-
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional">
-      <xref linkend='pulseaudio'/>
+      <xref linkend='pulseaudio'/>,
+      <ulink url="http://projects.kde.org/projects/kdesupport/libqzeitgeist/">QZeitgeist</ulink>
     </para>
 
     <para condition="html" role="usernotes">Notes utilisateur :
@@ -107,6 +102,7 @@
     <para>Préparation du paquet pour la compilation:</para>
        
 <screen><userinput>cmake -DCMAKE_INSTALL_PREFIX=$QT4DIR \
+      -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=TRUE \
       .. &&
 make</userinput></screen>
 
@@ -122,6 +118,16 @@
           $QT4DIR/lib/pkgconfig/phonon.pc</userinput></screen>
 -->
 </sect2>
+
+  <sect2 role="commands">
+    <title>Explications des commandes</title>
+
+    <para><option>-DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=TRUE</option> :
+    Cette option garantit que le greffon et les fichiers mkspecs s'installent 
+    au bon endroit.</para>
+
+  </sect2>
+
 <!--
   <sect2 role="commands">
     <title>Explications des commandes</title>

Modified: trunk/blfs/postlfs/security/stunnel.xml
===================================================================
--- trunk/blfs/postlfs/security/stunnel.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/postlfs/security/stunnel.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -4,11 +4,11 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY stunnel-download-http "http://www.stunnel.org/download/stunnel/src/stunnel-&stunnel-version;.tar.gz">
-  <!ENTITY stunnel-download-ftp  "ftp://stunnel.mirt.net/stunnel/stunnel-&stunnel-version;.tar.gz">
-  <!ENTITY stunnel-md5sum        "978030ff42f087ec26eb8a095ab69994">
-  <!ENTITY stunnel-size          "516 Kio">
-  <!ENTITY stunnel-buildsize     "5 Mio">
+  <!ENTITY stunnel-download-http "http://mirrors.zerg.biz/stunnel/stunnel-&stunnel-version;.tar.gz">
+  <!ENTITY stunnel-download-ftp  "ftp://ftp.stunnel.org/stunnel/stunnel-&stunnel-version;.tar.gz">
+  <!ENTITY stunnel-md5sum        "f5e713dda0e8efa659f372832ecd0c2c">
+  <!ENTITY stunnel-size          "520 Kio">
+  <!ENTITY stunnel-buildsize     "5.5 Mio">
   <!ENTITY stunnel-time          "0.5 SBU">
 ]>
 

Modified: trunk/blfs/server/major/apache.xml
===================================================================
--- trunk/blfs/server/major/apache.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/server/major/apache.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -4,7 +4,6 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!-- <!ENTITY apache-download-http "http://www.apache.org/dist/httpd/httpd-&apache-version;.tar.bz2"> -->
   <!ENTITY apache-download-http "http://archive.apache.org/dist/httpd/httpd-&apache-version;.tar.bz2">
   <!ENTITY apache-download-ftp  "ftp://apache.mirrors.pair.com/httpd/httpd-&apache-version;.tar.bz2">
   <!ENTITY apache-md5sum        "1696ae62cd879ab1d4dd9ff021a470f2">
@@ -57,47 +56,26 @@
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
-    <itemizedlist spacing='compact'>
-      <listitem>
-        <para>Correctif requis : <ulink
-        url="&patch-root;/httpd-&apache-version;-config-1.patch"/></para>
-      </listitem>
-      <listitem>
-        <para>Correctif requis : <ulink
-        url="&patch-root;/httpd-&apache-version;-pcre-8.30-1.patch"/></para>
-      </listitem>
-    </itemizedlist>
-
     <bridgehead renderas="sect3">Dépendances d'Apache</bridgehead>
 
+    <bridgehead renderas="sect4">Requises</bridgehead>
+    <para role="required">
+      <xref linkend="apr-util"/>
+    </para>
+
     <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional"><xref linkend="openldap"/>,
-    <xref linkend="openssl"/> (aussi utilisé dans APR-util),
-    <xref linkend="pcre"/>,
-	<xref linkend="rsync"/>,
-    <xref linkend="lynx"/>,
-    <ulink url="http://apr.apache.org/">APR</ulink>,
-    <ulink url="http://apr.apache.org/">APR-util</ulink> et
-    <ulink url="http://www.distcache.org/">distcache</ulink></para>
+    <para role="optional">
+      <xref linkend="openldap"/>,
+      <xref linkend="db"/>,
+      <xref linkend="expat"/>,
+      <xref linkend="openssl"/>,
+      <xref linkend="pcre"/>,
+      <xref linkend="rsync"/>,
+      <xref linkend="doxygen"/>,
+      <xref linkend="lynx"/> and
+      <ulink url="http://www.distcache.org/">distcache</ulink>
+    </para>
 
-    <bridgehead renderas="sect4">Facultatives (Only if Using the Bundled
-    APR-util)</bridgehead>
-    <para role="optional"><!-- <xref linkend="pkgconfig"/> -->,
-    <xref linkend="expat"/>,
-    <!-- <xref linkend="gdbm"/>, -->
-    <xref linkend="db"/>,
-    <xref linkend="unixodbc"/>,
-    <xref linkend="mysql"/>,
-    <xref linkend="postgresql"/>,
-    <xref linkend="sqlite"/>,
-    <ulink url="http://www.oracle.com/us/products/database/index.html">Oracle 11g</ulink>, et
-    <ulink url="http://www.freetds.org/">FreeTDS</ulink></para>
-
-    <para>Bien que vous puissiez installer APR et APR-util comme des composants
-    séparés, les versions incluses fournies avec l'archive tar de HTTPD Apache
-    sont recommandées.</para>
-
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/apache"/></para>
 
@@ -123,46 +101,35 @@
     Voir les notes utilisateur pour des détails sur des applications
     spécifiques.</para></note>
 
-    <para>Le correctif suivant modifie l'agencement des répertoires de
-    destination et entre autres, il met le répertoire de construction dans
-    <filename class="directory">/usr/lib/apache/build</filename>. Cela permettra
-    aux modules ajoutés à <application>Apache</application> de se configurer
-    sans erreurs. Appliquez le correctif :</para>
-
-<screen><userinput>patch -p1 < ../httpd-&apache-version;-pcre-8.30-1.patch &&
-patch -Np1 -i ../httpd-&apache-version;-config-1.patch</userinput></screen>
-
-    <note>
-      <para>Il se peut que vous souhaitiez relire la sortie de 
-      <command>./configure --help</command> et ajouter les paramètres 
-      nécessaires à la commande <command>configure</command> ci-dessous pour
-      construire les modules nécessaires à votre installation. Il n'existe pas
-      moins de 65 paramètres supplémentaires que vous pouvez ajouter au à la
-      commande <command>configure</command> pour construire des modules 
-      supplémentaires. Certains paramètres supplémentaires nrn décrits ou non 
-      indiqués dans les informations de <parameter>--help</parameter> sont listés
-      dans la section <quote>Explication des commandes</quote> ci-dessous.</para>
-
-      <para>Si vous utilisez la version intégrée de 
-      <application>APR-util</application> et si vous allez installer
-      <application>Subversion</application> avec le support de la fondation
-      <application>Berkeley DB</application>, assurez-vous d'utiliser les
-      paramètres indiqués dans la section <quote>Explication des commandes</quote>
-      ci-dessous.</para>
-
-      <para>Bien qu'il n'est pas construit par défaut lors de l'utilisation des
-      commandes suivantes, le module ISAPI DSO peut être créé en ajoutant l'option
-      <option>--enable-isapi</option>. Même si le module compilera, s'installera
-      et se chargera très bien, le module n'est supporté et opérationnel
-      <emphasis>que</emphasis> dans des environnements Win32.</para>
-    </note>
-
     <para>Construisez et installez <application>Apache</application> en lançant
     les commandes suivantes :</para>
 
-<screen><userinput>./configure --enable-layout=FHS      \
-                               --enable-mods-shared=all \
-                               --enable-so &&
+<screen><userinput>cat >> config.layout << "HERE_DOC" &&
+# Présentation FHS BLFS
+<Layout FHS>
+    prefix:          /usr
+    exec_prefix:     ${prefix}
+    bindir:          ${exec_prefix}/bin
+    sbindir:         ${exec_prefix}/sbin
+    libdir:          ${exec_prefix}/lib
+    libexecdir:      ${exec_prefix}/libexec/apache
+    mandir:          ${prefix}/share/man
+    sysconfdir:      /etc/apache
+    datadir:         /srv/www
+    installbuilddir: ${libexecdir}/build
+    errordir:        ${datadir}/error
+    iconsdir:        ${datadir}/icons
+    htdocsdir:       ${datadir}/htdocs
+    manualdir:       ${datadir}/manual
+    cgidir:          ${datadir}/cgi-bin
+    includedir:      ${prefix}/include/apache
+    localstatedir:   ${datadir}
+    runtimedir:      /var/run
+    logfiledir:      /var/log/apache
+    proxycachedir:   /var/cache/apache/proxy
+</Layout>
+HERE_DOC
+./configure --enable-layout=FHS --enable-mods-shared=all &&
 make</userinput></screen>
 
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>
@@ -170,13 +137,39 @@
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
 <screen role="root"><userinput>make install &&
-chown -v root:root /usr/lib/apache/httpd.exp                     \
-    /usr/sbin/{apxs,apachectl,dbmmanage,envvars{,-std}}          \
-    /usr/share/man/man1/{dbmmanage,ht{dbm,digest,passwd}}.1      \
-    /usr/share/man/man8/{ab,apachectl,apxs,htcacheclean,httpd}.8 \
-    /usr/share/man/man8/{logresolve,rotatelogs,suexec}.8 &&
+chown -v root:root /usr/bin/{apxs,dbmmanage} \
+  /usr/sbin/{apachectl,envvars{,-std}} \
+  /usr/libexec/apache/httpd.exp \
+  /usr/share/man/man1/{ab,apxs,dbmmanage,ht{dbm,digest,passwd,txt2dbm},logresolve}.1 \
+  /usr/share/man/man8/{apachectl,htcacheclean,httpd,rotatelogs,suexec}.8 &&
 chown -v -R apache:apache /srv/www</userinput></screen>
 
+    <para>
+      Toujours en tant qu'utilisateur <systemitem class="username">root</systemitem>,
+      installez éventuellement les docs en html :
+    </para>
+
+<screen role="root"><userinput>mkdir -p /usr/share/doc/httpd-&apache-version;/style &&
+for thing in docs/manual/*.html.en
+do
+  tmp=${thing%.en}
+  cp ${thing} /usr/share/doc/httpd-&apache-version;/${tmp##*/}
+done
+cp -rf docs/manual/images /usr/share/doc/httpd-&apache-version; &&
+cp -rf docs/manual/style/css /usr/share/doc/httpd-&apache-version;/style &&
+for directory in developer faq howto misc mod platform programs rewrite ssl vhosts
+do
+  mkdir -p /usr/share/doc/httpd-&apache-version;/${directory}
+  for thing in docs/manual/${directory}/*.html.en
+  do
+    tmp=${thing%.en}
+    cp ${thing} /usr/share/doc/httpd-&apache-version;/${directory}/${tmp##*/}
+  done
+done
+sed -i \
+  '/developer\|faq\|misc\|mod\|programs\|rewrite\|ssl\|vhosts/s#/"#/index.html"#' \
+  /usr/share/doc/httpd-&apache-version;/index.html</userinput></screen>
+
   </sect2>
 
   <sect2 role="commands">
@@ -188,58 +181,26 @@
     être inclus et exclus du serveur qui utilise les lignes de 
     configuration au moment de l'exécution.</para>
 
-    <para><option>--enable-ssl</option> : Utilisez ce paramètre pour créer
-    le module <filename class="libraryfile">mod_ssl</filename> et activer le 
-    support SSL. Ce paramètre est indiqué comme faisant partie des nombreux 
-    paramètres qu'on peut passer à la commande <command>configure</command> pour
-    créer des modules DSO supplémentaires.<!-- Note that it really only affects the
-         APR-Util sub-package, which the HTTPD installation then uses.--></para>
+    <para>
+      <command>chown root:root ...</command> : Cette commande modifie le 
+      propriétaire de certains fichiers installés, le résultat de la construction
+      du paquet en tant qu'utilisateur différent de
+      <systemitem class="username">root</systemitem>.
+    </para>
 
-    <para><option>--with-pcre</option> : Ajoutez ce paramètre pour utiliser
-    la version installée sur le système de la bibliothèque
-    <application>PCRE</application>.</para>
+-
+    <para>
+      <command>chown -R apache:apache /srv/www</command> : Par défaut, le
+      processus d'installation installe des fichiers (documentation, messages
+      d'erreur, icônes par défaut, etc.) avec comme propriétaire l'utilisateur 
+      qui a extrait les fichiers de l'archive tar. Si vous voulez modifier la
+      propriété au profit d'un autre utilisateur, vous devriez le faire à ce
+      moment. La seule exigence est que les répertoires des documents soient
+      accessibles par le processus <command>httpd</command> avec les droits
+      (r-x) et il faut que les fichiers soient lisibles (r--) par l'utilisateur
+      <systemitem class="username">apache</systemitem>.
+    </para>
 
-    <para><option>--with-z</option> : Ajoutez ce paramètre pour utiliser
-        la version installée sur le système de la bibliothèque
-        <application>Zlib</application>.</para>
-
-    <para><option>--with-ldap</option> : Ce paramètre est nécessaire si
-    vous avez passé les options <option>--enable-authnz-ldap</option> ou
-    <option>--enable-ldap</option> à <command>configure</command>
-    et si vous avez activé les modules <application>OpenLDAP</application>.</para>
-
-    <para><option>--with-dbm=db4 --with-berkeley-db</option> : Utilisez
-    ces paramètres si vous avez besoin du support
-    <application>Berkeley DB</application> dans la version incluse de
-    <application>APR-util</application> (requis pour le support de la fondation
-    <application>Berkeley DB</application> dans
-    <application>Subversion</application>). Si vous utilisez
-    <application>Berkeley DB</application>-5.1, modifiez le premier paramètre en
-    <option>--with-dbm=db51</option>.</para>
-
-    <para><option>--with-mysql</option>> :nbsp;: Ajoutez ce paramètre pour utiliser la version installée
-	de <application>MySQL</application>.</para>
-
-    <para><option>--with-included-apr</option>> :nbsp;: Ajoutez ce paramètre pour utiliser la version 
-	incluse du système APR. Par défaut, une version installée sera utilisée si elle est disponible
-	Utilisez ce paramètre pour forcer la construction à utiliser et ensuite installer
-	(en remplaçant le APR existant) la copy interne (incluse) de APR.</para>
-
-    <para><command>chown root:root ...</command> : Cette commande modifie
-    l'appartenance de certains fichiers installés, le résultat de la construction
-    du paques appartenant à un utilisateur différent de
-    <systemitem class="username">root</systemitem>.</para>
-
-    <para><command>chown -R apache:apache /srv/www</command> : Par défaut,
-    le processus d'installation installe des fichierss (documentation, messages
-    d'erreur, icônes par défaut, etc.) avec l'appartenance à l'utilisateur qui a
-    extrait les fichiers du fichier tar. Si vous voulez modifier l'appartenance
-    pour un autre utilisateur, vous devriez le faire à ce moment. La seule
-    exigence est que les répertoires de document doivent être accessibles pour
-    le processus <command>httpd</command> avec les droits
-    (r-x) et les fichiers doivent être lisibles (r--) par l'utilisateur
-    <systemitem class="username">apache</systemitem>.</para>
-
   </sect2>
 
   <sect2 role="configuration">
@@ -267,9 +228,7 @@
       <filename>/etc/apache/httpd.conf</filename>. Modifiez-le pour que le
       serveur HTTP se lance en tant qu'utilisateur et groupe dédiés :</para>
 
-<screen role="root"><userinput>sed -i -e "s/User daemon/User apache/" \
-       -e "s/Group daemon/Group apache/" \
-    /etc/apache/httpd.conf</userinput></screen>
+<screen role="root"><userinput>sed -i "s/daemon$/apache/" /etc/apache/httpd.conf</userinput></screen>
 
       <para>Voir <ulink url="http://httpd.apache.org/docs-2.2/configuring.html"/>
       pour des instructions détaillées sur la personnalisation de votre fichier
@@ -300,17 +259,16 @@
 
     <segmentedlist>
       <segtitle>Programmes installés</segtitle>
-      <segtitle>Bibliothèques installées</segtitle>
       <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
-        <seg>ab, apachectl, apr-1-config, apu-1-config, apxs, checkgid,
-        dbmmanage, htcacheclean, htdbm, htdigest, htpasswd, httpd, httxt2dbm,
-        logresolve, rotatelogs, et suexec</seg>
-        <seg>libapr-1.{so,a}, libaprutil-1.{so,a}, apr_{dbd,ldap} database
-        modules, et numerous DSO modules</seg>
-        <seg>/etc/apache, /srv/www, /usr/include/apache, /usr/lib/apache,
-        /usr/lib/apr-util-1, et /var/log/apache</seg>
+        <seg>
+          ab, apachectl, apxs, checkgid, dbmmanage, htcacheclean, htdbm,
+          htdigest, htpasswd, httpd, httxt2dbm, logresolve et rotatelogs
+        </seg>
+        <seg>
+          /etc/apache, /srv/www, /usr/include/apache and /var/log/apache.
+        </seg>
       </seglistitem>
     </segmentedlist>
 
@@ -342,28 +300,6 @@
         </listitem>
       </varlistentry>
 
-      <varlistentry id="apr-1-config">
-        <term><command>apr-1-config</command></term>
-        <listitem>
-          <para>est un script simple qui donne des informations sur le programme APR
-		  installé.</para>
-          <indexterm zone="apache apr-1-config">
-            <primary sortas="b-apr-1-config">apr-1-config</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-      <varlistentry id="apu-1-config">
-        <term><command>apu-1-config</command></term>
-        <listitem>
-          <para>est un script simple qui donne des informations sur le programme APR
-		  installé.</para>
-          <indexterm zone="apache apu-1-config">
-            <primary sortas="b-apu-1-config">apu-1-config</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
       <varlistentry id="apxs">
         <term><command>apxs</command></term>
         <listitem>
@@ -488,17 +424,6 @@
         </listitem>
       </varlistentry>
 
-      <varlistentry id="suexec">
-        <term><command>suexec</command></term>
-        <listitem>
-          <para>est utilisé par le serveur <application>Apache HTTP</application>
-          pour basculer sur un autre utilisateur avant l'exécution d'un programme CGI.</para>
-          <indexterm zone="apache suexec">
-            <primary sortas="b-suexec">suexec</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
     </variablelist>
 
   </sect2>

Modified: trunk/blfs/xsoft/office/gnucash.xml
===================================================================
--- trunk/blfs/xsoft/office/gnucash.xml	2012-03-01 02:59:04 UTC (rev 1644)
+++ trunk/blfs/xsoft/office/gnucash.xml	2012-03-01 03:06:22 UTC (rev 1645)
@@ -92,7 +92,7 @@
       <xref linkend="slib"/> and
       <xref linkend="goffice"/></para>
       <para role="required">
-      <xref linkend="gtkhtml"/> ou
+      <!-- needs gtkhtml-3 <xref linkend="gtkhtml"/> or -->
       <xref linkend="webkitgtk"/> (configuré avec <option>--with-gtk=2.0</option>).
     </para>
 
@@ -132,7 +132,9 @@
     suivantes :</para>
 
 <screen><userinput>patch -p1 < ../gnucash-&gnucash-version;-guile-2_fixes-1.patch &&
-./configure --prefix=${GNOME_PREFIX} --sysconfdir=${GNOME_SYSCONFDIR} &&
+./configure --prefix=${GNOME_PREFIX} --sysconfdir=${GNOME_SYSCONFDIR} \
+  --disable-dbi \
+  --with-html-engine=webkit &&
 make</userinput></screen>
 
     <para>Si vous souhaitez créer la documentation de l'API au format HTML,
@@ -197,16 +199,19 @@
     plutôt que dans <filename class='directory'>/usr/etc/gnucash</filename>.</para>
 
     <para>
-      <option>--with-html-engine=webkit</option> : Ajoutez cette option
+      <command>--with-html-engine=webkit</command> : Ajoutez cette option
       pour utiliser 
       <xref linkend="webkitgtk"/> (configuré avec <option>--with-gtk=2.0</option>)
-      au lieu de <xref linkend="gtkhtml"/>.
+      au lieu de gtkhtml : par défaut, c'est Gtkhtml-3 qui ne se construit
+      pas sur la <application>Glib2</application> actuelle sans modifications et
+      <xref linkend="gtkhtml"/> n'est pas reconnu par cette application.
     </para>
 
     <para>
-      <option>--disable-dbi</option> : Ajoutez cette option si vous n'avez
+      <command>--disable-dbi</command> : Ajoutez cette option si vous n'avez
       pas installé
-      <application>libdbi</application>.
+      <application>libdbi</application> et un ou plusieurs de ses pilotes de 
+      base de données.
     </para>
 
   </sect2>




More information about the lfs-traducfr mailing list