[lfs-fr] r1639 - in trunk/blfs: . general/genlib gnome/add introduction/welcome template xsoft/office

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Mar 28 Fév 11:15:55 PST 2012


Author: jmengual
Date: 2012-02-28 20:15:55 +0100 (Tue, 28 Feb 2012)
New Revision: 1639

Added:
   trunk/blfs/gnome/add/rygel.xml
Modified:
   trunk/blfs/general.ent
   trunk/blfs/general/genlib/genlib.xml
   trunk/blfs/general/genlib/slib.xml
   trunk/blfs/gnome/add/add.xml
   trunk/blfs/gnome/add/gupnp.xml
   trunk/blfs/introduction/welcome/changelog.xml
   trunk/blfs/template/template.xml
   trunk/blfs/xsoft/office/gnucash.xml
   trunk/blfs/xsoft/office/office.xml
Log:
9542-45, a deboguer, je ne comprends rien du tout au bug.


Modified: trunk/blfs/general/genlib/genlib.xml
===================================================================
--- trunk/blfs/general/genlib/genlib.xml	2012-02-28 14:31:47 UTC (rev 1638)
+++ trunk/blfs/general/genlib/genlib.xml	2012-02-28 19:15:55 UTC (rev 1639)
@@ -64,7 +64,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libesmtp.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="aspell.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="enchant.xml"/>
-<!--  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="slib.xml"/>-->
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="slib.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="lzo.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libusb.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="libusb-compat.xml"/>

Modified: trunk/blfs/general/genlib/slib.xml
===================================================================
--- trunk/blfs/general/genlib/slib.xml	2012-02-28 14:31:47 UTC (rev 1638)
+++ trunk/blfs/general/genlib/slib.xml	2012-02-28 19:15:55 UTC (rev 1639)
@@ -4,7 +4,7 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY slib-download-http "http://swiss.csail.mit.edu/ftpdir/scm/OLD/slib-&slib-version;.tar.gz">
+  <!ENTITY slib-download-http "http://groups.csail.mit.edu/mac/ftpdir/scm/slib-&slib-version;.tar.gz">
   <!ENTITY slib-download-ftp  " ">
   <!ENTITY slib-md5sum        "850f48ad933e2fe8bb03b1e994ed4407">
   <!ENTITY slib-size          "948 Kio">
@@ -40,6 +40,8 @@
     Bigloo, Chez, ELK 3.0, GAMBIT 3.0, Guile, JScheme, MacScheme, MITScheme,
     PLT Scheme (DrScheme et MzScheme), Pocket Scheme, RScheme, scheme->C,
     Scheme48, SCM, SCM Mac, scsh, Stk, T3.1, umb-scheme et VSCM.</para>
+    
+    &lfs70_built;
 
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -63,23 +65,18 @@
       </listitem>
     </itemizedlist>
 
-    <!-- <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
-    <itemizedlist spacing='compact'>
-      <listitem>
-        <para>Correctif requis : <ulink
-        url="&patch-root;/slib-&slib-version;-guile_fixes-1.patch"/></para>
-      </listitem>
-    </itemizedlist>-->
-
     <bridgehead renderas="sect3">Dépendances de SLIB</bridgehead>
 
-    <para>Il n'y a aucune dépendance de construction vu que ce paquet n'est
+<!--    <para>Il n'y a aucune dépendance de construction vu que ce paquet n'est
     rien de plus que des fichiers script en texte qui sont copiés sur le système. Si vous installez
     ce paquet pour supporter une installation <application>GnuCash</application>, vous devriez vous assurer
     que <xref linkend="guile"/> est installé pour que le catalogue
     <application>SLIB</application> pour <application>Guile</application> puisse être
-    créé.</para>
+    créé.</para>-->
 
+    <bridgehead renderas="sect4">Requises</bridgehead>
+    <para role="required"><xref linkend="guile"/>.</para>
+
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/slib"/></para>
 
@@ -91,46 +88,36 @@
     <para>Installez <application>SLIB</application> en exécutant les
     commandes suivantes :</para>
 
-<screen><userinput>sed -i 's|usr/lib|usr/share|' RScheme.init        &&
-makeinfo -o slib.txt  --plaintext       slib.texi &&
+<screen><userinput>sed -i 's|usr/lib|usr/share|' RScheme.init &&
+./configure --prefix=/usr --libdir=/usr/share &&
+sed -i 's# scm$# guile#;s#ginstall-info#install-info#' Makefile &&
+makeinfo -o slib.txt --plaintext slib.texi &&
 makeinfo -o slib.html --html --no-split slib.texi</userinput></screen>
 
-    <para>Si vous avez installé <!-- <xref linkend="tetex"/> ou --> <xref linkend="texlive"/>
-    et que vous souhaitez 
+    <para>Si vous avez installé <xref linkend="texlive"/>
+    et si vous souhaitez 
     construire la documentation en PDF ou Postscript, faites tout ou partie
     des commandes suivantes :</para>
 
-<screen><userinput>texi2pdf  slib.texi &&
-texi2dvi  slib.texi &&
-dvips  -o slib.ps   slib.dvi</userinput></screen>
+<screen><userinput>texi2pdf slib.texi &&
+texi2dvi slib.texi &&
+dvips -o slib.ps slib.dvi</userinput></screen>
 
     <para>Ce paquet n'est pas fourni avec une suite de tests fonctionnelle.</para>
 
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
-<screen role="root"><userinput>make prefix=/usr/ \
-     libdir=/usr/share/ \
-     mandir=/usr/share/man/man1 \
-     infodir=/usr/share/info/ \
-  install installinfo &&
+<screen role="root"><userinput>make install &&
+ln -v -s ../slib /usr/share/guile &&
+guile -c "(use-modules (ice-9 slib)) (require 'printf)" &&
+install -v -m755 -d /usr/share/doc/slib-&slib-version; &&
+install -v -m644 ANNOUNCE FAQ README slib.{txt,html} /usr/share/doc/slib-&slib-version;</userinput></screen>
 
-install -v -m755 -d /usr/share/doc/slib-&slib-version;  &&
-install -v -m644    ANNOUNCE FAQ README slib.{txt,html} \
-                    /usr/share/doc/slib-&slib-version;</userinput></screen>
-
-    <para>Si vous avez installé <xref linkend="guile"/>, créez le lien
-    symbolique en tant qu'utilisateur <systemitem class="username">root</systemitem> pour satisfaire
-    le répertoire par défaut de l'<quote>Implementation Vicinity</quote>
-    de <application>Guile</application>.</para>
-
-<screen role="root"><userinput>ln -v -s ../slib /usr/share/guile</userinput></screen>
-
     <para>Si vous avez construit un format de documentation supplémentaire, 
     installez-la en utilisant la commande
     suivante en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
-<screen role="root"><userinput>install -v -m644 slib.{pdf,dvi,ps} \
-                 /usr/share/doc/slib-&slib-version;</userinput></screen>
+<screen role="root"><userinput>install -v -m644 slib.{pdf,dvi,ps} /usr/share/doc/slib-&slib-version;</userinput></screen>
 
   </sect2>
 
@@ -139,38 +126,28 @@
 
     <para><command>sed -i 's|usr/lib|usr/share|' RScheme.init</command> :
     Cette commande est utilisée pour modifier la variable 
-    <envar>libdir</envar> comprise dans le script pour correspondre à la
-    variable d'installation.</para>
+    <envar>libdir</envar> comprise dans le script pour correspondre à
+    l'installation.</para>
 
+    <para><option>--libdir=/usr/share</option> : Cette option met les
+    fichiers installés dans <filename class="directory">/usr/share/slib</filename> 
+    au lieu de <filename class="directory">/usr/lib/slib</filename>.</para>
+
+    <para><command>ln -v -s ../slib /usr/share/guile</command> : Cette
+    commande met dans le <quote>Implementation Vicinity</quote> par défaut de 
+    <application>Guile</application> un lien symbolique vers les fichiers 
+    <application>slib</application>.</para>
+
+    <para><command>guile -c "(use-modules (ice-9 slib)) (require
+    'printf)"</command> : Cette commande crée un catalogue guile des 
+    fichiers de <application>slib</application>.</para>
+
     <para><command>make ... install installinfo</command> : Cette commande
     installe le paquet et la documentation <command>info</command> dans les
     répertoires indiqués.</para>
 
   </sect2>
 
-  <sect2 role="configuration" id="slib-config">
-    <title>Configuration de SLIB</title>
-
-    <para>Pour la plupart des implémentations de schémas, vous devez
-    créer un catalogue d'implémentation de schémas <application>SLIB</application>,
-    Si vous avez installé <xref linkend="guile"/> pour supporter
-    une installation <application>GnuCash</application>, vous devez créer un
-    catalogue. Vous pouvez utiliser la commande <command>make catalogs</command> mais
-    il y aura beaucoup de messages d'avertissements et perturbants vu qu'elle essaie de
-    créer un catalogue pour beaucoup d'implémentations de schéma qui ne sont
-    probablement pas installées sur le système. Pour créer un catalogue uniquement
-    pour l'installation <application>Guile</application>, exécutez la
-    commande suivante en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
-
-<screen role="root"><userinput>guile -l guile.init \
-      -c "(use-modules (ice-9 slib)) (require 'new-catalog)"</userinput></screen>
-
-    <para>S'il n'y a pas eu de sortie suite à la commande précédente,
-    et si le fichier <filename>/usr/share/guile/1.8/slibcat</filename> existe à 
-    présent, le catalogue a été créé correctement.</para>
-
-  </sect2>
-
   <sect2 role="content">
     <title>Contenu</title>
 

Modified: trunk/blfs/general.ent
===================================================================
--- trunk/blfs/general.ent	2012-02-28 14:31:47 UTC (rev 1638)
+++ trunk/blfs/general.ent	2012-02-28 19:15:55 UTC (rev 1639)
@@ -3,7 +3,7 @@
 $Date: 2012-02-20 18:29:32 +0100 (lun 20 fév 2012) $
 -->
 
-<!ENTITY day          "28">                   <!-- Always 2 digits -->
+<!ENTITY day          "29">                   <!-- Always 2 digits -->
 <!ENTITY month        "02">                   <!-- Always 2 digits -->
 <!ENTITY year         "2012">
 <!ENTITY copyrightdate "2001-&year;">
@@ -186,7 +186,7 @@
 <!ENTITY libesmtp-version             "1.0.4">
 <!ENTITY aspell-version               "0.60.6">
 <!ENTITY enchant-version              "1.6.0">
-<!--<!ENTITY slib-version                 "3b2">-->
+<!ENTITY slib-version                 "3b3">
 <!ENTITY LZO-version                  "2.03">
 <!ENTITY libusb-version               "1.0.8">
 <!ENTITY libusb-compat-version        "0.1.3">
@@ -801,6 +801,7 @@
 <!ENTITY hamster-applet-version       "2.30.2">-->
 <!ENTITY nautilus-sendto-version      "3.0.1">
 <!ENTITY nemiver-version              "0.9.0">
+<!ENTITY rygel-version                "0.12.5">
 <!ENTITY seahorse-version             "2.30.1">
 <!ENTITY totem-version                "2.30.2">
 <!ENTITY vinagre-version              "2.30.2">
@@ -881,7 +882,7 @@
 <!-- Chapter 35 -->
 <!ENTITY AbiWord-version              "2.8.6">
 <!ENTITY gnumeric-version             "1.10.17">
-<!-- <!ENTITY gnucash-version              "2.2.4">-->
+<<!ENTITY gnucash-version              "2.4.10">
 <!ENTITY evolution-version            "3.2.2">
 
 <!-- Chapter 36 -->

Modified: trunk/blfs/gnome/add/add.xml
===================================================================
--- trunk/blfs/gnome/add/add.xml	2012-02-28 14:31:47 UTC (rev 1638)
+++ trunk/blfs/gnome/add/add.xml	2012-02-28 19:15:55 UTC (rev 1639)
@@ -62,6 +62,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="orca.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="nautilus-sendto.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="nemiver.xml"/>
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="rygel.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="seahorse.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="totem.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="vinagre.xml"/>

Modified: trunk/blfs/gnome/add/gupnp.xml
===================================================================
--- trunk/blfs/gnome/add/gupnp.xml	2012-02-28 14:31:47 UTC (rev 1638)
+++ trunk/blfs/gnome/add/gupnp.xml	2012-02-28 19:15:55 UTC (rev 1639)
@@ -61,9 +61,9 @@
 
     <bridgehead renderas="sect4">Requises</bridgehead>
     <para role="required"><xref linkend="glib2"/>,
-    <xref linkend="gssdp"/>,
-    <xref linkend="libsoup"/>,
-    <xref linkend="libxml2"/>, et
+    <xref linkend="gssdp"/> et
+    <!-- <xref linkend="libsoup"/>,
+    <xref linkend="libxml2"/>, et-->
     <xref linkend="shared-mime-info"/></para>
 
     <bridgehead renderas="sect4">Recommandées</bridgehead>

Added: trunk/blfs/gnome/add/rygel.xml
===================================================================
--- trunk/blfs/gnome/add/rygel.xml	                        (rev 0)
+++ trunk/blfs/gnome/add/rygel.xml	2012-02-28 19:15:55 UTC (rev 1639)
@@ -0,0 +1,205 @@
+<?xml version="1.0" encoding="ISO-8859-1"?>
+<!DOCTYPE sect1 PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
+   "http://www.oasis-open.org/docbook/xml/4.5/docbookx.dtd" [
+  <!ENTITY % general-entities SYSTEM "../../general.ent">
+  %general-entities;
+
+  <!ENTITY rygel-download-http "&gnome-download-http;/rygel/0.12/rygel-&rygel-version;.tar.xz">
+  <!ENTITY rygel-download-ftp  "&gnome-download-ftp;/rygel/0.12/rygel-&rygel-version;.tar.xz">
+  <!ENTITY rygel-md5sum        "1a52accbbe8ccb178ab428e6c1abd7a3">
+  <!ENTITY rygel-size          "1.5 Mio">
+  <!ENTITY rygel-buildsize     "53 Mio">
+  <!ENTITY rygel-time          "0.6 SBU">
+]>
+
+<sect1 id="rygel" xreflabel="rygel-&rygel-version;">
+  <?dbhtml filename="rygel.html"?>
+
+  <sect1info>
+    <othername>$LastChangedBy> : ken $</othername>
+    <date>$Date> : 2012-02-28 19:39:17 +0100 (mar 28 fév 2012) $</date>
+  </sect1info>
+
+  <title>rygel-&rygel-version;</title>
+
+  <indexterm zone="rygel">
+    <primary sortas="a-rygel">rygel</primary>
+  </indexterm>
+
+  <sect2 role="package">
+    <title>Introduction à rygel</title>
+
+    <para><application>Rygel</application> est une solution de média pour la
+    maison qui vous permet de partager facilement du son, de la vidéo et de 
+    l'image ainsi que de contrôler le lecteur multimédia de votre réseau
+    domestique. En termes techniques, c'est à la fois un serveur média A/V
+    UPnP et un MediaRenderer (diffuseur de médias) implémenté via un mécanisme
+    de greffons.</para>
+
+    &lfs70_built;
+
+    <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Téléchargement (HTTP) : <ulink url="&rygel-download-http;"/></para>
+      </listitem>
+      <listitem>
+        <para>Téléchargement (FTP) : <ulink url="&rygel-download-ftp;"/></para>
+      </listitem>
+      <listitem>
+        <para>Somme de contrôle MD5 du téléchargement : &rygel-md5sum;</para>
+      </listitem>
+      <listitem>
+        <para>Taille du téléchargement : &rygel-size;</para>
+      </listitem>
+      <listitem>
+        <para>Estimation de l'espace disque requis : &rygel-buildsize;</para>
+      </listitem>
+      <listitem>
+        <para>Estimation du temps de construction : &rygel-time;</para>
+      </listitem>
+    </itemizedlist>
+
+    <bridgehead renderas="sect3">Dépendances de rygel</bridgehead>
+
+    <bridgehead renderas="sect4">Requises</bridgehead>
+    <para role="required"><xref linkend="gst-plugins-base"/>,
+    <xref linkend="gupnp-av"/>,
+    <xref linkend="gupnp-dlna"/>,
+    <xref linkend="gupnp-vala"/>,
+    <xref linkend="gtk3"/>, et
+    <xref linkend="libgee"/></para>
+
+    <para condition="html" role="usernotes">Notes utilisateur :
+    <ulink url="&blfs-wiki;/rygel"/></para>
+
+  </sect2>
+
+  <sect2 role="installation">
+    <title>Installation de rygel</title>
+
+    <para>Installez <application>rygel</application> en lançant les commandes
+    suivantes :</para>
+
+<screen><userinput>./configure --prefix=$GNOME_PREFIX \
+            --sysconfdir=$GNOME_SYSCONFDIR &&
+make</userinput></screen>
+
+    <para>Pour tester les résultats, lancez : <command>make check</command>.</para>
+
+    <para>Maintenant, en tant qu'utilisateur the <systemitem class="username">root</systemitem> :</para>
+
+<screen role="root"><userinput>make install</userinput></screen>
+
+  </sect2>
+
+  <sect2 role="commands">
+    <title>Explications des commandes</title>
+
+    <para><parameter>--sysconfdir=$GNOME_SYSCONFDIR</parameter> : Ce
+    paramètre garantit que
+    <filename>rygel.conf</filename> sera installé au bon endroit et elle est
+    en particulier conçue pour les cas où $GNOME_PREFIX est
+    <filename class="directory">/usr</filename>.</para>
+
+    <para><option>--enable-mediathek-plugin</option> : Ce paramètre créera
+    un greffon pour la télévision publique allemande (ARD et ZDF).</para>
+
+  </sect2>
+
+  <sect2 role="content">
+    <title>Contenu</title>
+
+    <segmentedlist>
+      <segtitle>Programmes installés</segtitle>
+      <segtitle>Bibliothèques installées</segtitle>
+      <segtitle>Répertoires installés</segtitle>
+
+      <seglistitem>
+        <seg>rygel et rygel-preferences</seg>
+        <seg>librygel-external.so, librygel-media-export.so, librygel-mediathek.so (optional), librygel-mpris.so, librygel-playbin.so, et librygel-tracker.so</seg>
+        <seg><envar>$GNOME_PREFIX</envar>/{include/rygel-1.0,lib/rygel-1.0,share/{icons/hicolor/120x120/apps,rygel/xml}}</seg>
+      </seglistitem>
+    </segmentedlist>
+
+    <variablelist>
+      <bridgehead renderas="sect3">Descriptions courtes</bridgehead>
+      <?dbfo list-presentation="list"?>
+      <?dbhtml list-presentation="table"?>
+
+      <varlistentry id="rygel-prog">
+        <term><command>rygel</command></term>
+        <listitem>
+          <para>est le serveur de médias.</para>
+          <indexterm zone="rygel rygel-prog">
+            <primary sortas="b-rygel-prog">rygel</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <!-- comment unless anyone ever finds out what these do
+      <varlistentry id="rygel-preferences">
+        <term><command>rygel-preferences</command></term>
+        <listitem>
+          <para>does this .....</para>
+          <indexterm zone="rygel rygel-preferences">
+            <primary sortas="b-rygel-preferences">rygel-preferences</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="librygel-external">
+        <term><filename class='libraryfile'>librygel-external.so</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="rygel librygel-external">
+            <primary sortas="c-librygel-external">librygel-external.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="librygel-media-export">
+        <term><filename class='libraryfile'>librygel-media-export.so</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="rygel librygel-media-export">
+            <primary sortas="c-librygel-media-export">librygel-media-export.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="librygel-mpris">
+        <term><filename class='libraryfile'>librygel-mpris.so</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="rygel librygel-mpris">
+            <primary sortas="c-librygel-mpris">librygel-mpris.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="librygel-playbin">
+        <term><filename class='libraryfile'>librygel-playbin.so</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="rygel librygel-playbin">
+            <primary sortas="c-librygel-playbin">librygel-playbin.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry>
+
+      <varlistentry id="librygel-tracker">
+        <term><filename class='libraryfile'>librygel-tracker.so</filename></term>
+        <listitem>
+          <para>contains functions that .....</para>
+          <indexterm zone="rygel librygel-tracker">
+            <primary sortas="c-librygel-tracker">librygel-tracker.so</primary>
+          </indexterm>
+        </listitem>
+      </varlistentry> -->
+
+    </variablelist>
+
+  </sect2>
+
+</sect1>

Modified: trunk/blfs/introduction/welcome/changelog.xml
===================================================================
--- trunk/blfs/introduction/welcome/changelog.xml	2012-02-28 14:31:47 UTC (rev 1638)
+++ trunk/blfs/introduction/welcome/changelog.xml	2012-02-28 19:15:55 UTC (rev 1639)
@@ -76,6 +76,9 @@
         <listitem>
           <para>[ken] - ajout de nemiver-0.9.0 par Wayne.</para>
         </listitem>
+        <listitem>
+          <para>[abenton] - Gnucash-2.4.10 ajout de Slib-3b3.</para>
+        </listitem>
       </itemizedlist>
     </listitem>
     <listitem>

Modified: trunk/blfs/template/template.xml
===================================================================
--- trunk/blfs/template/template.xml	2012-02-28 14:31:47 UTC (rev 1638)
+++ trunk/blfs/template/template.xml	2012-02-28 19:15:55 UTC (rev 1639)
@@ -21,8 +21,8 @@
   <?dbhtml filename="TEMPLATE.html"?>
 
   <sect1info>
-    <othername>$LastChangedBy : andy $</othername>
-    <date>$Date : 2012-02-28 14:50:35 +0100 (mar. 28 févr. 2012) $</date>
+    <othername>$LastChangedBy: andy $</othername>
+    <date>$Date: 2012-02-28 14:50:35 +0100 (mar 28 fév 2012) $</date>
   </sect1info>
 
   <!-- No other tags inside any title-->
@@ -48,6 +48,12 @@
     <para>The <application>TEMPLATE</application> package contains...
     This is useful for...</para>
 
+    <!-- if it builds but hasn't been tested: -->
+    &lfs70_built;
+    <!-- if it works: -->
+    &lfs70_checked;
+
+
     <bridgehead renderas="sect3">Package Information</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
@@ -150,12 +156,12 @@
   <sect2 role="commands">
     <title>Command Explanations</title>
 
-    <para><command>COMMAND</command> : This command does something.</para>
+    <para><command>COMMAND</command>: This command does something.</para>
 
-    <para><parameter>--SWITCH=PARAMETER</parameter> : This parameter does
+    <para><parameter>--SWITCH=PARAMETER</parameter>: This parameter does
     something mandatory for BLFS purposes.</para>
 
-    <para><option>--OPTION</option> : This option does something optionally
+    <para><option>--OPTION</option>: This option does something optionally
     per the user's desires.</para>
   </sect2>
 

Modified: trunk/blfs/xsoft/office/gnucash.xml
===================================================================
--- trunk/blfs/xsoft/office/gnucash.xml	2012-02-28 14:31:47 UTC (rev 1638)
+++ trunk/blfs/xsoft/office/gnucash.xml	2012-02-28 19:15:55 UTC (rev 1639)
@@ -4,17 +4,18 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnucash-download-http  "http://www.gnucash.org/pub/gnucash/sources/stable/gnucash-&gnucash-version;.tar.bz2">
-  <!ENTITY gnucash-download-ftp   "ftp://ftp.at.gnucash.org/pub/gnucash/sources/stable/2.2.4/gnucash-&gnucash-version;.tar.bz2">  <!ENTITY gnucash-src-md5sum     "f521cea858ee7223325114ec98de86ca">
-  <!ENTITY gnucash-size           "6.8 Mio">
-  <!ENTITY gnucash-buildsize      "163 Mio (additional 50 Mio if running test suite; additional 124 Mio for API docs)">
-  <!ENTITY gnucash-time           "3.1 SBU (additional 1.8 SBU to run the test suite; additional 0.3 SBU for docs)">
-  <!ENTITY gnucash-docs-version   "2.2.0">
-  <!ENTITY gnucash-docs-download  "http://www.gnucash.org/pub/gnucash/sources/stable/gnucash-docs-&gnucash-docs-version;.tar.gz">
-  <!ENTITY gnucash-docs-md5sum    "97a29e499baca1807a3944ae3c0ad61e">
-  <!ENTITY gnucash-docs-size      "10.0 Mio">
-  <!ENTITY gnucash-docs-buildsize "27 Mio (additional 41 Mio for html et pdf)">
-  <!ENTITY gnucash-docs-time      "moins de 0.1 SBU (additional 0.4 SBU for html et pdf)">
+  <!ENTITY gnucash-download-http  "&sourceforge-repo;/gnucash/gnucash-&gnucash-version;.tar.bz2">
+  <!ENTITY gnucash-download-ftp   " ">
+  <!ENTITY gnucash-src-md5sum     "eebcf231beffe39a9c1b5f09625bb38e">
+  <!ENTITY gnucash-size           "8.9 Mio">
+  <!ENTITY gnucash-buildsize      "234 Mio (additional 50 Mio if running test suite; additional 124 Mio for API docs)">
+  <!ENTITY gnucash-time           "2.2 SBU (additional 1.8 SBU to run the test suite; additional 0.3 SBU for docs)">
+  <!ENTITY gnucash-docs-version   "2.4.1">
+  <!ENTITY gnucash-docs-download  "&sourceforge-repo;/gnucash/gnucash-docs-&gnucash-docs-version;.tar.gz">
+  <!ENTITY gnucash-docs-md5sum    "38daeb3b15f296726ee8124122040f08">
+  <!ENTITY gnucash-docs-size      "32.5 Mio">
+  <!ENTITY gnucash-docs-buildsize "27 Mio">
+  <!ENTITY gnucash-docs-time      "0.5 SBU">
 ]>
 
 <sect1 id="gnucash" xreflabel="GnuCash-&gnucash-version;">
@@ -60,11 +61,14 @@
     </itemizedlist>
 
     <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
-    <itemizedlist spacing='compact'>
+    <itemizedlist spacing="compact">
       <listitem>
-        <para>Documentation d'aide : <ulink url="&gnucash-docs-download;"/></para>
+        <para>Correctif requis : <ulink url="&patch-root;/gnucash-&gnucash-version;-guile-2_fixes-1.patch"/></para>
       </listitem>
       <listitem>
+        <para>Documentation d'aide facultative : <ulink url="&gnucash-docs-download;"/></para>
+      </listitem>
+      <listitem>
         <para>Somme de contrôle MD5 du téléchargement : &gnucash-docs-md5sum;</para>
       </listitem>
       <listitem>
@@ -81,29 +85,40 @@
     <bridgehead renderas="sect3">Dépendances de GnuCash</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
-    <para role="required"><xref linkend="guile"/>,
-    <xref linkend="slib"/>,
-    <xref linkend="goffice"/> et
-    <xref linkend="gtkhtml"/></para>
+    <para role="required">
+      <xref linkend="guile"/>,
+      <xref linkend="libgnomeui"/>,
+      <xref linkend="gnome-vfs"/>,
+      <xref linkend="slib"/> and
+      <xref linkend="goffice"/></para>
+      <para role="required">
+      <xref linkend="gtkhtml"/> ou
+      <xref linkend="webkitgtk"/> (configuré avec <option>--with-gtk=2.0</option>).
+    </para>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional"><xref linkend="postgresql"/>,
-    <ulink url="ftp://ftp.gnu.org/pub/gnu/guile/">Guile-www</ulink> et
-    <ulink url="http://perens.com/FreeSoftware/">Electric Fence</ulink></para>
+    <para role="optional">
+      <ulink url="http://libdbi.sourceforge.net/">libdbi</ulink> (et
+      <ulink url="http://libdbi-drivers.sourceforge.net/">les pilotes
+      libdbi</ulink>) et
+      <ulink url="ftp://ftp.gnu.org/pub/gnu/guile/">Guile-www</ulink>
+    </para>
 
-    <bridgehead renderas="sect4">Facultatives (Required for the Help System)</bridgehead>
-    <para role="optional"><xref linkend="scrollkeeper"/> et
-    <xref linkend="yelp"/> (run-time requirement to view the Help documents)</para>
+    <bridgehead renderas="sect4">Facultatives (Requises pour le système d'aide)</bridgehead>
+    <para role="optional">
+      <xref linkend="rarian"/> et
+      <xref linkend="yelp"/> (run-time requirement to view the Help documents).
+    </para>
 
-    <bridgehead renderas="sect4">Facultatives (for On-Line Banking)</bridgehead>
-    <para role="optional"><ulink
-    url="http://libofx.sourceforge.net/">LibOFX</ulink>
-    (exige <xref linkend="opensp"/> et <xref linkend="curl"/>),
-    <ulink url="http://sourceforge.net/projects/ktoblzcheck">KtoBlzCheck</ulink>,
-    et <ulink url="http://www.aquamaniac.de/aqbanking/">AqBanking</ulink>
-    (exige <ulink
-    url="http://gwenhywfar.sourceforge.net/">Gwenhywfar</ulink>
-    et <ulink url="http://www.libchipcard.de/">libchipcard3</ulink>)</para>
+    <bridgehead renderas="sect4">Facultatives (pour la banque en ligne)</bridgehead>
+    <para role="optional">
+      <ulink url="http://libofx.sourceforge.net/">LibOFX</ulink> (requires
+      <xref linkend="opensp"/> and <xref linkend="curl"/>),
+      <ulink url="http://sourceforge.net/projects/ktoblzcheck">KtoBlzCheck</ulink> and
+      <ulink url="http://www.aquamaniac.de/aqbanking/">AqBanking</ulink> (requires
+      <ulink url="http://gwenhywfar.sourceforge.net/">Gwenhywfar</ulink> et
+      <ulink url="http://www.libchipcard.de/">libchipcard3</ulink>)
+    </para>
 
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/gnucash"/></para>
@@ -116,13 +131,8 @@
     <para>Installez <application>GnuCash</application> en lançant les commandes
     suivantes :</para>
 
-<screen><userinput>sed -i 's|xml::${sysconfdir}|xml::${GNOME_SYSCONFDIR}|' configure &&
-  
-./configure \
-    --prefix=/usr \
-    --sysconfdir=/etc \
-    --libexecdir=/usr/lib \
-    --with-gconf-schema-file-dir=$GNOME_SYSCONFDIR/gconf/schemas &&
+<screen><userinput>patch -p1 < ../gnucash-&gnucash-version;-guile-2_fixes-1.patch &&
+./configure --prefix=${GNOME_PREFIX} --sysconfdir=${GNOME_SYSCONFDIR} &&
 make</userinput></screen>
 
     <para>Si vous souhaitez créer la documentation de l'API au format HTML,
@@ -132,52 +142,24 @@
     avoir installé <!-- <xref linkend="tetex"/> ou --> <xref linkend="texlive"/>et lancer :
     <command>make -C src/doc/design html pdf ps</command>.</para>
 
-    <para>Pour tester les résultats, taper : <command>make check</command>. Tous
-    les tests devraient réussir. Une façon facile de voir les résultats des 
-    tests est d'exécuter <command>grep -A1 ============== check.log</command> 
-    (cela suppose que vous avez redirigé la sortie des tests vers le nom de
-    fichier indiqué).</para>
+    <para>La suite de tests est actuellement cassée à cause de problèmes avec
+    <application>Guile 2</application>.</para>
 
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
-<screen role='root'><userinput>make install &&
+<screen role="root"><userinput>make install</userinput></screen>
 
-mv -v /usr/share/gnucash/doc /usr/share/doc/gnucash-&gnucash-version; &&
-ln -v -s ../doc/gnucash-&gnucash-version; /usr/share/gnucash/doc &&
+    <para>Si vous voulez installer le système de documentation et d'aide, vous
+    devez avoir installé 
+      <xref linkend="yelp"/> et <xref linkend="rarian"/> afin de voir les
+      documents d'aide. Déballez l'archive tar supplémentaire, rendez-vous dans 
+      le répertoire des sources
+      <filename class="directory">gnucash-docs-&gnucash-docs-version;</filename>
+      nouvellement créé et lancez les commandes suivantes en tant qu'utilisateur 
+      non privilégié :
+    </para>
 
-for FILENAME in doc/{misc*,gnome*,generic*,build*}.txt \
-                doc/{gtkrc*,TRANSLATION_HOWTO,README.translator.txt} \
-                doc/README.{build-system,OFX,HBCI}
-do
-    install -v -m644 ${FILENAME} /usr/share/doc/gnucash-&gnucash-version;
-done &&
-
-install -v -m755 -d /usr/share/doc/gnucash-&gnucash-version;/api/engine &&
-install -v -m644    src/doc/{TODO*,*.txt,*.html} \
-                    /usr/share/doc/gnucash-&gnucash-version;/api &&
-install -v -m644    src/engine/*.txt \
-                    /usr/share/doc/gnucash-&gnucash-version;/api/engine</userinput></screen>
-
-    <para>Si vous avez construit la documentation HTML de l'API ou le Guide du 
-    concept, exécutez les commandes suivantes (modifiées comme nécessaire, selon
-    les docs qui vont être installées) en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
-
-<screen role='root'><userinput>install -v -m755 -d /usr/share/doc/gnucash-&gnucash-version;/{design,api}/html &&
-install -v -m644    src/doc/design/gnucash-design.html/* \
-                    /usr/share/doc/gnucash-&gnucash-version;/design/html &&
-install -v -m644    src/doc/design/gnucash-design.{pdf,ps,dvi} \
-                    /usr/share/doc/gnucash-&gnucash-version;/design &&
-install -v -m644    src/doc/html/* \
-                    /usr/share/doc/gnucash-&gnucash-version;/api/html</userinput></screen>
-
-    <para>Si vous voulez installer le szstème de documentation d'aide, vous 
-    devez avoir installé <xref linkend="scrollkeeper"/>. Puis déballez l'archive
-    tar supplémentaire, allez dans le répertoire des sources
-    <filename class='directory'>gnucash-docs-&gnucash-docs-version;</filename>,
-    et exécutez les commandes suivantes en tant qu'utilisateur non privilégié :</para>
-
-<screen><userinput>./configure --prefix=/usr \
-            --localstatedir=/var/lib &&
+<screen><userinput>./configure --prefix=${GNOME_PREFIX} &&
 make</userinput></screen>
 
     <para>Vous pouvez créer les HTML du manuel d'aide et du guide de 
@@ -189,76 +171,44 @@
     et <xref linkend="jadetex"/>. Exécutez les commandes suivantes pour créer
     la documentation (modifiez comme il faut selon vos désirs) :</para>
 
-<screen><userinput>make -C help  html &&
-make -C guide html &&
+<screen><userinput>make -C guide html &&
 make -C guide pdf</userinput></screen>
 
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
-<screen role='root'><userinput>make install</userinput></screen>
+<screen role="root"><userinput>make install</userinput></screen>
 
     <para>Si vous avez construit le manuel d'aide ou le guide des utilisateurs,
     installez-les en utilisant les commandes suivantes en tant qu'utilisateur 
     <systemitem class="username">root</systemitem>
     (modifiez comme nécessaire) :</para>
 
-<screen role='root'><userinput>install -v -m755 -d /usr/share/doc/gnucash-&gnucash-docs-version;/{users_guide,help} &&
-cp -v -R            help/C/gnucash-help/* \
-                    /usr/share/doc/gnucash-&gnucash-docs-version;/help &&
-cp -v -R            guide/C/gnucash-guide/* \
-                    /usr/share/doc/gnucash-&gnucash-docs-version;/users_guide &&
-install -v -m644    guide/C/gnucash-guide.pdf \
-                    /usr/share/doc/gnucash-&gnucash-docs-version;</userinput></screen>
+<screen role="root"><userinput>mkdir -p ${GNOME_PREFIX}/share/doc/gnucash-&gnucash-docs-version; &&
+cp -v -R guide/C/gnucash-guide/* ${GNOME_PREFIX}/share/doc/gnucash-&gnucash-docs-version; &&
+cp -v guide/C/gnucash-guide.pdf ${GNOME_PREFIX}/share/doc/gnucash-&gnucash-docs-version;</userinput></screen>
 
-    <para>Remarquez que vous devez avoir installé <xref linkend="yelp"/> pour
-    lire les documents d'aide en utilisant la méthode par défaut de
-    <application>GnuCash</application>.</para>
-
   </sect2>
 
   <sect2 role="commands">
     <title>Explication des commandes</title>
 
-    <para><command>sed -i 's|xml::${sysconfdir}|xml::${GNOME_SYSCONFDIR}|'
-     configure</command> : Cette commande est utilisée car l'emplacement de
-    la base de données des sources <application>GConf</application> est
-    codé en dur dans le script <command>configure</command> en tant que
-    <filename class='directory'><envar>$sysconfdir</envar>/gconf</filename>
-    (ce qui rend le paramètre <option>--with-gconf-source</option> inutile).
-    La modification garantit que la base de données <application>GConf</application> 
-    est mise à jour correctement, tout en permettant aux fichiers de configuration 
-    du paquet de s'installer dans
-    <filename class='directory'>/etc/gnucash</filename>.</para>
-
     <para><parameter>--sysconfdir=/etc</parameter> : Ceci installse les
     fichiers de configuration dans <filename class='directory'>/etc/gnucash</filename> 
     plutôt que dans <filename class='directory'>/usr/etc/gnucash</filename>.</para>
 
-    <para><parameter>--with-gconf-schema-file-dir=$GNOME_SYSCONFDIR/gconf/schemas</parameter> :
-    Ce paramètre assure que les fichiers de schéma <application>GConf</application> 
-    s'installent au bon endroit et pas dans 
-    <filename class='directory'>/etc/gconf</filename>.</para>
+    <para>
+      <option>--with-html-engine=webkit</option> : Ajoutez cette option
+      pour utiliser 
+      <xref linkend="webkitgtk"/> (configuré avec <option>--with-gtk=2.0</option>)
+      au lieu de <xref linkend="gtkhtml"/>.
+    </para>
 
-    <para><command>mv -v /usr/share/gnucash/doc
-    /usr/share/doc/gnucash-&gnucash-version;</command> et
-    <command>ln -v -s ../doc/gnucash-&gnucash-version;
-    /usr/share/gnucash/doc</command> : Ces commandes sont utilisées pour
-    replacer les fichiers de documentation à l'endroit habituel et créer un 
-    lien symbolique vers l'emplacement d'origine.</para>
+    <para>
+      <option>--disable-dbi</option> : Ajoutez cette option si vous n'avez
+      pas installé
+      <application>libdbi</application>.
+    </para>
 
-    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-    href="../../xincludes/scrollkeeper-dir.xml"/>
-
-    <para><option>--enable-sql</option> : Ce paramètre est nécessaire si
-    vous voulez construire en dur le support SQL en utilisant <application>PostgreSQL</application>.</para>
-
-    <para><option>--enable-hbci</option> : Ce paramètre est nécessaire si
-    vous voulez construire en dur le support de banque en ligne en utilisant 
-    <application>AqBanking</application>. Voir
-    <filename>doc/README.HBCI</filename> dans l'arborescence des sources de
-    <application>GnuCash</application> pour des
-    informations complètes.</para>
-
   </sect2>
 
   <sect2 role="configuration">
@@ -292,23 +242,22 @@
       <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
-        <seg>gnc-fq-check, gnc-fq-dump, gnc-fq-helper, gnc-fq-update,
-        gnc-test-env, gnucash, gnucash-bin, gnucash-env, gnucash-make-guids,
-        gnucash-valgrind, et update-gnucash-gconf</seg>
-        <seg>libgnc-backend-file-utils.so, libgnc-backend-postgres.so,
-        libgnc-business-ledger.so,libgnc-core-utils.so, libgnc-gnome.so,
-        libgnc-module.so, libgnc-qof.so et numerous support libraries
-        installed in
-        <filename class='directory'>/usr/lib/gnucash</filename></seg>
-        <seg>/etc/gnucash,
-        /usr/include/gnucash,
-        /usr/lib/gnucash,
-        et the following subdirectories of /usr/share/:
-        doc/gnucash-&gnucash-version;,
-        gnome/help/gnucash,
-        gnucash,
-        omf/gnucash-docs, et
-        /xml/gnucash</seg>
+        <seg>
+          gnc-fq-check, gnc-fq-dump, gnc-fq-helper, gnc-fq-update,
+          gnucash, gnucash-env, gnucash-make-guids, gnucash-valgrind et
+          update-gnucash-gconf
+        </seg>
+        <seg>
+          libgnc-backend-sql.so, libgnc-backend-xml-utils.so,
+          libgnc-business-ledger.so,libgnc-core-utils.so, libgnc-gnome.so,
+          libgnc-module.so, libgnc-qof.so et de nombreuses bibliothèques support
+          installées dans <filename class="directory">/usr/lib/gnucash</filename>
+        </seg>
+        <seg>
+          ${GNOME_SYSCONFDIR}/gnucash, ${GNOME_PREFIX}/include/gnucash,
+          ${GNOME_PREFIX}/lib/gnucash, ${GNOME_PREFIX}/libexec/gnucash and
+          ${GNOME_PREFIX}/share/doc/gnucash-&gnucash-version;.
+        </seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/blfs/xsoft/office/office.xml
===================================================================
--- trunk/blfs/xsoft/office/office.xml	2012-02-28 14:31:47 UTC (rev 1638)
+++ trunk/blfs/xsoft/office/office.xml	2012-02-28 19:15:55 UTC (rev 1639)
@@ -23,7 +23,7 @@
 
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="abiword.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnumeric.xml"/>
-<!--  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnucash.xml"/>-->
+  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="gnucash.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="evolution.xml"/>
 
 </chapter>




More information about the lfs-traducfr mailing list