[lfs-fr] r1576 - in trunk/blfs: . introduction/welcome multimedia/libdriv postlfs/security server/databases x/lib xsoft/graphweb xsoft/other

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Mer 1 Fév 15:00:16 PST 2012


Author: jmengual
Date: 2012-02-02 00:00:16 +0100 (Thu, 02 Feb 2012)
New Revision: 1576

Modified:
   trunk/blfs/general.ent
   trunk/blfs/introduction/welcome/changelog.xml
   trunk/blfs/multimedia/libdriv/libvpx.xml
   trunk/blfs/postlfs/security/sudo.xml
   trunk/blfs/server/databases/sqlite.xml
   trunk/blfs/x/lib/xulrunner.xml
   trunk/blfs/xsoft/graphweb/firefox.xml
   trunk/blfs/xsoft/graphweb/seamonkey.xml
   trunk/blfs/xsoft/other/thunderbird.xml
Log:
Traduction r9256-9261


Modified: trunk/blfs/general.ent
===================================================================
--- trunk/blfs/general.ent	2012-02-01 21:46:07 UTC (rev 1575)
+++ trunk/blfs/general.ent	2012-02-01 23:00:16 UTC (rev 1576)
@@ -3,8 +3,8 @@
 $Date: 2012-01-25 04:51:47 +0100 (mer. 25 janv. 2012) $
 -->
 
-<!ENTITY day          "29">                   <!-- Always 2 digits -->
-<!ENTITY month        "01">                   <!-- Always 2 digits -->
+<!ENTITY day          "01">                   <!-- Always 2 digits -->
+<!ENTITY month        "02">                   <!-- Always 2 digits -->
 <!ENTITY year         "2012">
 <!ENTITY copyrightdate "2001-&year;">
 <!ENTITY copyholder   "L'équipe de developpement BLFS">
@@ -549,7 +549,7 @@
 <!ENTITY db-version                   "5.2.36">
 <!ENTITY mysql-version                "5.5.17">
 <!ENTITY postgresql-version           "9.0.6">
-<!ENTITY sqlite-version               "3.7.8">
+<!ENTITY sqlite-version               "3.7.10">
 
 <!-- Chapter 22 -->
 <!-- dhcp (chapter 13) -->
@@ -605,7 +605,7 @@
 <!ENTITY freeglut-version             "2.6.0">
 <!ENTITY goffice-version              "0.8.17">
 <!ENTITY mesalib-version              "7.9">
-<!ENTITY xulrunner-version            "9.0.1">
+<!ENTITY xulrunner-version            "10.0.">
 <!ENTITY webkitgtk-version            "1.6.1">
 <!ENTITY libsexy-version              "0.1.11">
 <!ENTITY libnotify-version            "0.4.5">
@@ -823,8 +823,8 @@
 <!ENTITY openoffice-version           "3.2.1">
 
 <!-- Chapter 37 -->
-<!ENTITY seamonkey-version            "2.6.1">
-<!ENTITY firefox-version              "9.0.1">
+<!ENTITY seamonkey-version            "2.7">
+<!ENTITY firefox-version              "10.0">
 
 <!-- Obsolete
 <!ENTITY dillo-version                "0.8.5">
@@ -832,7 +832,7 @@
 -->
 
 <!-- Chapter 38 -->
-<!ENTITY thunderbird-version          "9.0.1">
+<!ENTITY thunderbird-version          "10.0">
 <!ENTITY pan-version                  "0.133">
 <!ENTITY balsa-version                "2.3.22">
 <!ENTITY pidgin-version               "2.10.0">
@@ -885,7 +885,7 @@
 <!ENTITY libmpeg2-version             "0.5.1">
 <!ENTITY libtheora-version            "1.1.1">
 <!ENTITY opal-version                 "3.6.8">
-<!ENTITY libvpx-version               "0.9.7">
+<!ENTITY libvpx-version               "1.0.0">
 <!ENTITY libsndfile-version           "1.0.23">
 <!ENTITY pulseaudio-version           "0.9.23">
 

Modified: trunk/blfs/introduction/welcome/changelog.xml
===================================================================
--- trunk/blfs/introduction/welcome/changelog.xml	2012-02-01 21:46:07 UTC (rev 1575)
+++ trunk/blfs/introduction/welcome/changelog.xml	2012-02-01 23:00:16 UTC (rev 1576)
@@ -41,6 +41,26 @@
     </listitem>
 
 -->
+    <listitem>
+      <para>1 février 2012</para>
+      <itemizedlist>
+        <listitem>
+          <para>[abenton] - libvpx 1.0.0</para>
+        </listitem>
+        <listitem>
+          <para>[abenton] - Firefox 10.0</para>
+        </listitem>
+        <listitem>
+          <para>[abenton] - SeaMonkey 2.7</para>
+        </listitem>
+        <listitem>
+          <para>[abenton] - SQLite 3.7.10</para>
+        </listitem>
+        <listitem>
+          <para>[abenton] - Thunderbird 10.0</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
 
     <listitem>
       <para>29 janvier 2012</para>

Modified: trunk/blfs/multimedia/libdriv/libvpx.xml
===================================================================
--- trunk/blfs/multimedia/libdriv/libvpx.xml	2012-02-01 21:46:07 UTC (rev 1575)
+++ trunk/blfs/multimedia/libdriv/libvpx.xml	2012-02-01 23:00:16 UTC (rev 1576)
@@ -6,9 +6,9 @@
 
   <!ENTITY libvpx-download-http "http://webm.googlecode.com/files/libvpx-v&libvpx-version;.tar.bz2">
   <!ENTITY libvpx-download-ftp  " ">
-  <!ENTITY libvpx-md5sum        "893d07d1bdedaac1ad2ab63d32de7d83">
-  <!ENTITY libvpx-size          "1.2 Mio">
-  <!ENTITY libvpx-buildsize     "25 MB (without the documentation)">
+  <!ENTITY libvpx-md5sum        "d987b5140412edd37d2c6b10c29ad484">
+  <!ENTITY libvpx-size          "1.6 Mio">
+  <!ENTITY libvpx-buildsize     "18 MB (without the documentation)">
   <!ENTITY libvpx-time          "0.3 SBU">
 ]>
 

Modified: trunk/blfs/postlfs/security/sudo.xml
===================================================================
--- trunk/blfs/postlfs/security/sudo.xml	2012-02-01 21:46:07 UTC (rev 1575)
+++ trunk/blfs/postlfs/security/sudo.xml	2012-02-01 23:00:16 UTC (rev 1576)
@@ -59,6 +59,14 @@
       </listitem>
     </itemizedlist>
 
+    <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
+    <itemizedlist spacing="compact">
+      <listitem>
+        <para>Correctif requis : <ulink
+        url="&patch-root;/sudo-&sudo-version;-fprintf_debug-1.patch"/></para>
+      </listitem>
+    </itemizedlist>
+
     <bridgehead renderas="sect3">Dépendances de Sudo</bridgehead>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
@@ -84,7 +92,8 @@
     <para>Installez <application>sudo</application> en lançant
     les commandes suivantes :</para>
 
-<screen><userinput>./configure --prefix=/usr \
+<screen><userinput>patch -p1 < ../sudo-&sudo-version;-fprintf_debug-1.patch &&
+./configure --prefix=/usr \
             --libexecdir=/usr/lib \
             --with-ignore-dot \
             --with-all-insults \
@@ -106,6 +115,11 @@
   <sect2 role="commands">
     <title>Explication des commandes</title>
 
+     <para><command>patch -p1 < ...</command> : Ce correctif corrige une
+    vulnérabilité dans le code de débohage des versions 1.8.0 à 1.8.3p1 de
+    sudo, qu'on peut utiliser pour faire planter sudo ou éventuellement pour
+    autoriser un utilisateur non autorisé à acquérir les privslèges root.</para>
+
     <para><option>--with-ignore-dot</option> : Il résulte de ce paramètre
     que <application>sudo</application> ignore '.' dans le PATH.</para>
 

Modified: trunk/blfs/server/databases/sqlite.xml
===================================================================
--- trunk/blfs/server/databases/sqlite.xml	2012-02-01 21:46:07 UTC (rev 1575)
+++ trunk/blfs/server/databases/sqlite.xml	2012-02-01 23:00:16 UTC (rev 1576)
@@ -4,17 +4,17 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY sqlite-dl-version    "3070800">
+  <!ENTITY sqlite-dl-version    "3071000">
   <!ENTITY sqlite-download-http "http://sqlite.org/sqlite-autoconf-&sqlite-dl-version;.tar.gz">
   <!ENTITY sqlite-download-ftp  " ">
-  <!ENTITY sqlite-md5sum        "6bfb46d73caaa1bbbcd2b52184b6c542">
+  <!ENTITY sqlite-md5sum        "9ed2ca93577b58cfa0d01f64b9312ab9">
   <!ENTITY sqlite-size          "1.7 MB">
   <!ENTITY sqlite-buildsize     "46 Mio (y compris la documentation facultative)">
   <!ENTITY sqlite-time          "0.4 SBU">
 
   <!ENTITY sqlite-docs-version  "3070800">
-  <!ENTITY sqlite-docs-md5sum   "56c2e37c65075c612710ae1aba9703f2">
-  <!ENTITY sqlite-docs-size     "3.3 MB">
+  <!ENTITY sqlite-docs-md5sum   "d4c8070ea2cec54b77002c265e680b0f">
+  <!ENTITY sqlite-docs-size     "3.5 MB">
   <!ENTITY sqlite-docs-download "http://sqlite.org/sqlite-doc-&sqlite-dl-version;.zip">
 ]>
 
@@ -93,15 +93,16 @@
     <para>Si vous avez téléchargée la documentation supplémentaire, taper la commande
     suivante pour installer la documentation dans l'arborescence des sources:</para>
 
-<screen><userinput>unzip -q ../sqlite-doc-&sqlite-docs-version;.zip</userinput></screen>
+<screen><userinput>unzip -q ../sqlite-doc-&sqlite-dl-version;.zip</userinput></screen>
 
     <para>Installer <application>SQLite</application> en exécutant les commandes suivantes:</para>
 
-<screen><userinput>CFLAGS="-g -O2 -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_UNLOCK_NOTIFY=1" \
-            ./configure --prefix=/usr \
+<screen><userinput>./configure --prefix=/usr \
             --enable-threadsafe \
             --enable-readline \
-            --enable-dynamic-extensions &&
+            --disable-static \
+            --enable-dynamic-extensions \
+  CFLAGS="-g -O2 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1" &&
 make</userinput></screen>
 
     <para>Ce paquet n'est pas livré avec une suite de tests.</para>
@@ -115,18 +116,17 @@
 	l'installer:</para>
 
 <screen role="root"><userinput>install -v -m755 -d /usr/share/doc/sqlite-&sqlite-version; &&
-cp      -v -R       sqlite-doc-&sqlite-docs-version;/* \
-                    /usr/share/doc/sqlite-&sqlite-version;</userinput></screen>
+cp -v -R sqlite-doc-&sqlite-dl-version;/* /usr/share/doc/sqlite-&sqlite-version;</userinput></screen>
 
   </sect2>
 
   <sect2 role="commands">
     <title>Explications des commandes</title>
 
-    <para><parameter>CFLAGS="-g -O2 -DSQLITE_SECURE_DELETE -DSQLITE_ENABLE_UNLOCK_NOTIFY=1"
-    </parameter>: Des applications comme <application>firefox</application> nécéssite
+    <para><parameter>CFLAGS="-g -O2 -DSQLITE_SECURE_DELETE
+    -DSQLITE_ENABLE_UNLOCK_NOTIFY=1"</parameter> : Des applications comme <application>firefox</application> nécéssitent
     une suppression sécurisée et l'activation de la notification de verrouillage.
-	La seule façon de faire cela est de les inclures dans le CFLAGS.  Par défaut,
+	La seule façon de faire cela est de les inclure dans le CFLAGS.  Par défaut,
 	il est initialisé à <literal>"-g -O2"</literal> alors nous spécifions cela
 	pour préserver ces réglages.
     Vous pouvez, bien sûr, souhaiter omettre le <literal> '-g' </literal> si vous n'avez
@@ -141,6 +141,9 @@
     <para><parameter>--enable-readline</parameter>: Ce paramètre active
     la capacité d'édition en ligne de commande du programme <command>sqlite3</command>.</para>
 
+    <para><parameter>--disable-static</parameter> : Ce paramètre arrête
+    l'installation d'une version statique de libsqlite3.</para>
+
     <para><parameter>--enable-dynamic-extensions</parameter>: Cela crée
     des modules bibliothèques qui sont liés dynamiquement au besoin au lieu qu'elles soient
 	liées staiquement à la bbliothèque principale <application>SQLite</application>.</para>
@@ -157,7 +160,7 @@
 
       <seglistitem>
         <seg>sqlite3</seg>
-        <seg>libsqlite3.{so,a}</seg>
+        <seg>libsqlite3.so</seg>
         <seg>aucun</seg>
       </seglistitem>
     </segmentedlist>
@@ -180,11 +183,11 @@
       </varlistentry>
 
       <varlistentry id="libsqlite3">
-        <term><filename class='libraryfile'>libsqlite3.{so,a}</filename></term>
+        <term><filename class='libraryfile'>libsqlite3.so</filename></term>
         <listitem>
           <para>Contient les fonctions API de <application>SQLite</application>.</para>
           <indexterm zone="sqlite libsqlite3">
-            <primary sortas="c-libsqlite3">libsqlite3.{so,a}</primary>
+            <primary sortas="c-libsqlite3">libsqlite3.so</primary>
           </indexterm>
         </listitem>
       </varlistentry>

Modified: trunk/blfs/x/lib/xulrunner.xml
===================================================================
--- trunk/blfs/x/lib/xulrunner.xml	2012-02-01 21:46:07 UTC (rev 1575)
+++ trunk/blfs/x/lib/xulrunner.xml	2012-02-01 23:00:16 UTC (rev 1576)
@@ -7,8 +7,8 @@
    <!ENTITY xulrunner-download-http "http://releases.mozilla.org/pub/mozilla.org/firefox/releases/&firefox-version;/source/firefox-&firefox-version;.source.tar.bz2">
   <!ENTITY xulrunner-download-ftp  "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/&firefox-version;/source/firefox-&firefox-version;.source.tar.bz2">
   <!-- md5sum et size should match firefox, but the buildsize and time will differ -->
-  <!ENTITY xulrunner-md5sum        "7cf2bd379792a9b232267c6a79680566">
-  <!ENTITY xulrunner-size          "70.8 MB">
+  <!ENTITY xulrunner-md5sum        "13c61203ccfa583e5a54b4dc22f41233">
+  <!ENTITY xulrunner-size          "72 MB">
   <!ENTITY xulrunner-buildsize     "2.6 GB (440 MB installé)">
   <!ENTITY xulrunner-time          "22 SBU">
 ]>
@@ -62,16 +62,6 @@
       </listitem>
     </itemizedlist>
     
-    
-    <bridgehead renderas="sect3">Téléchargement supplémentaire</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>Correctif requis :
-        <ulink
-        url="&patch-root;/xulrunner-&xulrunner-version;-libpng-1.5-1.patch"/></para>
-      </listitem>
-    </itemizedlist>
-    
     <bridgehead renderas="sect3">Dépendances de Xulrunner</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
@@ -121,8 +111,7 @@
     <command>./configure --help</command>. Vosu devez éditer entièrement le fichier
     et commenter ou décommenter les options il faut.</para>
 
-<screen><?dbfo keep-together="auto"?><userinput>patch -p1 < ../xulrunner-&xulrunner-version;-libpng-1.5-1.patch &&
-cat > mozconfig << "EOF"
+<screen><userinput>cat > mozconfig << "EOF"
 # Si vous avez une machine multicoeurs, vous pouvez accélérer la
 # construction en lançant plusieurs tâches en même temps, mais vous n'avez qu'un
 # coeur, effacez cette ligne :
@@ -172,7 +161,8 @@
     <para>Installez <application>Xulrunner</application> en tapant les
     commandes suivantes :</para>
 
-<screen><userinput>echo "Requires: nspr" >>xulrunner/installer/libxul-embedding.pc.in &&
+<screen><userinput>sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' configure &&
+sed -i '/Version/aRequires: nspr >= &nspr-version;' xulrunner/installer/libxul-embedding.pc.in &&
 make -f client.mk build</userinput></screen>
 
     <para>Ce paquet n'est pas fourni avec une suite de tests.</para>
@@ -200,6 +190,12 @@
 
   <sect2 role="commands">
     <title>Explication des commandes</title>
+ 
+    <para><command>sed -i 's#VPX_CODEC_USE ...</command> : Ceci corrige le
+    script <command>configure</command> de <application>Xulrunner's</application> 
+    pour détecter correctement libvpx-v1.0.0. Ce n'est pas utile si vous avez
+    installé libvpx-v0.9.7 ou supérieur ou si vous n'avez pas installé
+    <xref linkend="libvpx"/>.</para>
 
     <para><command>sed ... Requires: nspr</command> : Si vous essayez de
     construire <application>Yelp</application> sans

Modified: trunk/blfs/xsoft/graphweb/firefox.xml
===================================================================
--- trunk/blfs/xsoft/graphweb/firefox.xml	2012-02-01 21:46:07 UTC (rev 1575)
+++ trunk/blfs/xsoft/graphweb/firefox.xml	2012-02-01 23:00:16 UTC (rev 1576)
@@ -6,8 +6,8 @@
 
   <!ENTITY firefox-download-http "http://releases.mozilla.org/pub/mozilla.org/firefox/releases/&firefox-version;/source/firefox-&firefox-version;.source.tar.bz2">
   <!ENTITY firefox-download-ftp  "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/&firefox-version;/source/firefox-&firefox-version;.source.tar.bz2">
-  <!ENTITY firefox-md5sum        "7cf2bd379792a9b232267c6a79680566">
-  <!ENTITY firefox-size          "70.8 MB">
+  <!ENTITY firefox-md5sum        "13c61203ccfa583e5a54b4dc22f41233">
+  <!ENTITY firefox-size          "72 MB">
   <!ENTITY firefox-buildsize     "3 GB (33 MB installé)">
   <!ENTITY firefox-time          "24 SBU (ou 0.3 si vous construisez contre un Xulrunner installé)">
 ]>
@@ -55,14 +55,6 @@
         <para>Estimation du temps de construction : &firefox-time;</para>
       </listitem>
     </itemizedlist>
-    
-    <bridgehead renderas="sect3">Chargement supplémentaire</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>Correctif requis : <ulink
-        url="&patch-root;/firefox-&firefox-version;-libpng-1.5-1.patch"/></para>
-      </listitem>
-    </itemizedlist>
 
     <bridgehead renderas="sect3">Dépendances de Firefox</bridgehead>
 
@@ -116,8 +108,7 @@
     décommenter d'autres options souhaitées. Créez le fichier en lançant la
     commande suivante :</para>
 
-<screen><?dbfo keep-together="auto"?><userinput>patch -p1 < ../firefox-&firefox-version;-libpng-1.5-1.patch &&
-cat > mozconfig << "EOF"
+<screen><userinput>cat > mozconfig << "EOF"
 # Si vous avez une machine multicoeurs, vous pouvez accélérer la
 # construction en lançant plusieurs tâches en même temps, mais si vous n'avez qu'un
 # coeur, effacez cette ligne :
@@ -173,7 +164,8 @@
     <para>Compilez <application>Firefox</application> en lançant les commandes
     suivantes :</para>
 
-<screen><userinput>sed -i 's# ""##' browser/base/Makefile.in &&
+<screen><userinput>sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' configure &&
+sed -i 's# ""##' browser/base/Makefile.in &&
 make -f client.mk</userinput></screen>
 
     <para>Si vous <emphasis>n'avez pas</emphasis> lié
@@ -215,9 +207,15 @@
 
   <sect2 role="commands">
     <title>Explication des commandes</title>
+ 
+    <para><command>sed -i 's#VPX_CODEC_USE ...</command> : Ceci corrige le
+    script <command>configure</command> de <application>Firefox's</application> 
+    pour détecter correctement libvpx-v1.0.0. Vous n'en avez pas besoin si vous
+    avez iostallé libvpx-v0.9.7 ou supérieur ou si vous n'avez pas iostallé
+    <xref linkend="libvpx"/>.</para>
 
-    <para><command>sed -i 's# ""##' browser/base/Makefile.in</command> : Ceci
-    supprime un caractère de contrôle non imprimable de la barre de titre.</para>
+    <para><command>sed -i 's# ""##' browser/base/Makefile.in</command> : Ce
+    sed supprime un caractère de contrôle non imprimable de la barre de titre.</para>
 
     <para><command>make -f client.mk ...</command> : Les produits Mozilla
     sont enpaquetés pour permettre l'utilisation d'un fichier de configuration qui peut

Modified: trunk/blfs/xsoft/graphweb/seamonkey.xml
===================================================================
--- trunk/blfs/xsoft/graphweb/seamonkey.xml	2012-02-01 21:46:07 UTC (rev 1575)
+++ trunk/blfs/xsoft/graphweb/seamonkey.xml	2012-02-01 23:00:16 UTC (rev 1576)
@@ -6,9 +6,9 @@
 
   <!ENTITY seamonkey-download-http      "http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/&seamonkey-version;/source/seamonkey-&seamonkey-version;.source.tar.bz2">
   <!ENTITY seamonkey-download-ftp       "ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/&seamonkey-version;/source//seamonkey-&seamonkey-version;.source.tar.bz2">
-  <!ENTITY seamonkey-md5sum             "69a43877107f97cfc7504829405ba319">
-  <!ENTITY seamonkey-size               "92.3 Mio">
-  <!ENTITY seamonkey-buildsize          "3 Gio (47 Mio installés)">
+  <!ENTITY seamonkey-md5sum             "a566e49ab96ba93ceea1a3c636757435">
+  <!ENTITY seamonkey-size               "93.5 Mio">
+  <!ENTITY seamonkey-buildsize          "3 Gio (46 Mio installés)">
   <!ENTITY seamonkey-time               "26.6 SBU">
 ]>
 
@@ -50,9 +50,9 @@
 
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
-      <listitem>
+      <!-- <listitem>
         <para>Téléchargement (HTTP) : <ulink url="&seamonkey-download-http;"/></para>
-      </listitem>
+      </listitem>-->
       <listitem>
         <para>Téléchargement (FTP) : <ulink url="&seamonkey-download-ftp;"/></para>
       </listitem>
@@ -170,7 +170,9 @@
     <para>Compilez <application>SeaMonkey</application> en lançant la commande
     suivante :</para>
 
-<screen><userinput>make -f client.mk</userinput></screen>
+<screen><userinput>sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' \
+  mozilla/configure &&
+make -f client.mk</userinput></screen>
 
     <para>Ce paquet n'est pas fourni avec une suite de tests. Néanmoins, on peut
     le lancer à partir du répertoire de construction avant de l'installer avec
@@ -191,6 +193,11 @@
   <sect2 role="commands">
     <title>Explication des commandes</title>
 
+    <para><command>sed -i 's#VPX_CODEC_USE ...</command> : Ceci corrige le
+    script <command>configure</command> de mozilla pour détecter correctement
+    libvpx-v1.0.0. Ce sed n'est pas utile si vous avez installé libvpx-v0.9.7 ou
+    supérieur ou si vous n'avez pas installé <xref linkend="libvpx"/>.</para>
+
     <para><command>make -f client.mk</command> : Les produits Mozilla
     sont empaquetés pour permettre l'utilisation d'un fichier de configuration
     utilisable pour passer les paramètres de configuration à la commande

Modified: trunk/blfs/xsoft/other/thunderbird.xml
===================================================================
--- trunk/blfs/xsoft/other/thunderbird.xml	2012-02-01 21:46:07 UTC (rev 1575)
+++ trunk/blfs/xsoft/other/thunderbird.xml	2012-02-01 23:00:16 UTC (rev 1576)
@@ -4,10 +4,10 @@
  <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY thunderbird-download-http     "http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/&thunderbird-version;/source/thunderbird-&thunderbird-version;.source.tar.bz2">
-  <!ENTITY thunderbird-download-ftp      "ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/&thunderbird-version;/source/thunderbird-&thunderbird-version;.source.tar.bz2">
-  <!ENTITY thunderbird-md5sum            "a5904751dbd33074682b438b732fdbab">
-  <!ENTITY thunderbird-size              "91 MB">
+  <!ENTITY thunderbird-download-http     "http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/&thunderbird-version;-real/source/thunderbird-&thunderbird-version;.source.tar.bz2">
+  <!ENTITY thunderbird-download-ftp      "ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/&thunderbird-version;-real/source/thunderbird-&thunderbird-version;.source.tar.bz2">
+  <!ENTITY thunderbird-md5sum            "6f76f25894ba746a2e33614d3dd8dbab">
+  <!ENTITY thunderbird-size              "93 Mio">
   <!ENTITY thunderbird-buildsize         "3 Gio (46 Mio installés)">
   <!ENTITY thunderbird-time              "26 SBU">
 
@@ -57,15 +57,6 @@
       </listitem>
     </itemizedlist>
 
-    <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
-    <itemizedlist spacing="compact">
-      <listitem>
-        <para>Correctif requis : <ulink
-        url="&patch-root;/thunderbird-&thunderbird-version;-libpng-1.5-2.patch"/></para>
-      </listitem>
-    </itemizedlist>
-
-
     <bridgehead renderas="sect3">Dépendances de Thunderbird</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
@@ -108,8 +99,7 @@
     <command>./configure --help</command>. Créez le fichier en lançant la
     commande suivante :</para>
 
-<screen><?dbfo keep-together="auto"?><userinput>patch -p1 < ../thunderbird-&thunderbird-version;-libpng-1.5-2.patch &&
-cat > mozconfig << "EOF"
+<screen><userinput>cat > mozconfig << "EOF"
 # Si vous avez une machine multicoeurs, vous pouvez accélérer la
 # construction en lançant plusieurs tâches en même temps, mais vous n'avez qu'un
 # coeur, effacez cette ligne :
@@ -155,7 +145,9 @@
 
     <para>Compiler <application>Thunderbird</application> en tapant les commandes suivantes:</para>
 
-<screen><userinput>make -f client.mk &&
+<screen><userinput>sed -i 's#VPX_CODEC_USE_INPUT_PARTITION#VPX_CODEC_USE_INPUT_FRAGMENTS#' \
+  mozilla/configure &&
+make -f client.mk &&
 make -C thunderbuild/mail/installer</userinput></screen>
 
     <para>Ce paquet n'est pas livré avec une suite de tests.</para>
@@ -163,7 +155,7 @@
     <para>Installez <application>Thunderbird</application> en exécutant les commantes
     suivantes en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
-<screen role="root"><userinput>mkdir -p /usr/lib/thunderbird-9.0.1 &&
+<screen role="root"><userinput>mkdir -p /usr/lib/thunderbird-&thunderbird-version; &&
 tar xf thunderbuild/mozilla/dist/thunderbird-*.tar.bz2 -C /usr/lib/thunderbird-&thunderbird-version; --strip-components=1 &&
 ln -s ../lib/thunderbird-&thunderbird-version;/thunderbird /usr/bin/thunderbird</userinput></screen>
 
@@ -172,6 +164,11 @@
   <sect2 role="commands">
     <title>Explication des commandes</title>
 
+    <para><command>sed -i 's#VPX_CODEC_USE ...</command> : Ceci corrige le
+    script <command>configure</command> de mozilla pour détecter correctement
+    libvpx-v1.0.0. Ce sed n'est pas utile si vous avez installé libvpx-v0.9.7 ou
+    supérieur ou si vous n'avez pas installé <xref linkend="libvpx"/>.</para>
+
     <para><command>make -f client.mk</command> : Les produits Mozilla sont
     empaquetés pour permettre d'utiliser un fichier de configuration qui peut
     être utilisé pour passer les paramètres de configuration à la commande
@@ -258,7 +255,8 @@
 StartupNotify=true
 Terminal=false
 EOF
-ln -sv -f /usr/lib/firefox-&firefox-version;/icons/mozicon128.png /usr/share/pixmaps/firefox.png</userinput></screen>
+ln -sv -f /usr/lib/thunderbird-&thunderbird-version;/chrome/icons/default/default256.png \
+  /usr/share/pixmaps/thunderbird.png</userinput></screen>
 
     </sect3>
 




More information about the lfs-traducfr mailing list