[lfs-fr] r1358 - in trunk/lfs: . chapter01 chapter05

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Dim 26 Juin 17:36:36 PDT 2011


Author: jmengual
Date: 2011-06-27 02:36:36 +0200 (Mon, 27 Jun 2011)
New Revision: 1358

Modified:
   trunk/lfs/chapter01/changelog.xml
   trunk/lfs/chapter01/whatsnew.xml
   trunk/lfs/chapter05/perl.xml
   trunk/lfs/general.ent
   trunk/lfs/packages.ent
Log:
Mise a jour de Glib et less.


Modified: trunk/lfs/chapter01/changelog.xml
===================================================================
--- trunk/lfs/chapter01/changelog.xml	2011-06-25 14:25:27 UTC (rev 1357)
+++ trunk/lfs/chapter01/changelog.xml	2011-06-27 00:36:36 UTC (rev 1358)
@@ -38,6 +38,24 @@
 
 -->
     <listitem>
+      <para>26-06-2011</para>
+      <itemizedlist>
+        <listitem>
+          <para>[bdubbs] - Passage à perl-5-14.1. Corrige
+          <ulink url="&lfs-ticket-root;2874">#2874</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[bdubbs] - Passage à less-444. Corrige
+          <ulink url="&lfs-ticket-root;2887">#2887</ulink>.</para>
+        </listitem>
+        <listitem>
+          <para>[bdubbs] - Passage à glib-2.28.8. Corrige
+          <ulink url="&lfs-ticket-root;2886">#2886</ulink>.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>24-06-2011</para>
       <itemizedlist>
         <listitem>

Modified: trunk/lfs/chapter01/whatsnew.xml
===================================================================
--- trunk/lfs/chapter01/whatsnew.xml	2011-06-25 14:25:27 UTC (rev 1357)
+++ trunk/lfs/chapter01/whatsnew.xml	2011-06-27 00:36:36 UTC (rev 1358)
@@ -165,9 +165,9 @@
     <!--<listitem>
       <para>Patch &patch-version;</para>
     </listitem>-->
-    <!--<listitem>
+    <listitem>
       <para>Perl &perl-version;</para>
-    </listitem>-->
+    </listitem>
     <!--<listitem>
       <para>Procps &procps-version;</para>
     </listitem>-->

Modified: trunk/lfs/chapter05/perl.xml
===================================================================
--- trunk/lfs/chapter05/perl.xml	2011-06-25 14:25:27 UTC (rev 1357)
+++ trunk/lfs/chapter05/perl.xml	2011-06-27 00:36:36 UTC (rev 1358)
@@ -48,47 +48,21 @@
 
 <screen><userinput remap="pre">patch -Np1 -i ../&perl-libc-patch;</userinput></screen>
 
-    <!-- <para>Corrigez une incompatibilité avec gcc-&gcc-version;:</para>
+    <para>Préparez la compilation de Perl :</para>
     
-<screen><userinput remap="pre">mv -v makedepend.SH{,.orig}
-sed 's/command /command[ -]/' makedepend.SH.orig > makedepend.SH</userinput></screen> -->
+<screen><userinput remap="configure">sh Configure -des -Dprefix=/tools</userinput></screen>
 
-    <para>Préparez la compilation de Perl (assurez-vous que la partie de la
-    commande 'Data/Dumper Fcntl IO' est saisie correctement—ce
-    ne sont que des lettres) :</para>
+    <para>Construisez le paquet :</para>
+    
+<screen><userinput remap="make">make</userinput></screen>
 
-<screen><userinput remap="configure">sh Configure -des -Dprefix=/tools \
-                  -Dstatic_ext='Data/Dumper Fcntl IO'</userinput></screen>
+    <para>Bien que Perl soit fourni avec une suite de tests, il vaudrait mieux
+    attendre qu'il soit installé au prochain chapitre.</para>
 
-    <variablelist>
-      <title>Voici la signification de l'option de configure :</title>
-
-      <varlistentry>
-        <term><parameter>-Dstatic_ext='Data/Dumper Fcntl IO'</parameter></term>
-        <listitem>
-          <para>Ceci indique à Perl de construire l'ensemble minimal d'extensions statiques
-          nécessaires à l'installation et au test du paquet Coreutils dans le 
-          prochain chapitre.</para>
-        </listitem>
-      </varlistentry>
-
-    </variablelist>
-
-    <para>Seulement une partie des outils de ce paquetage et une de ses
-    bibliothèques doivent être construit :</para>
-
-<screen><userinput remap="make">make perl utilities ext/Errno/pm_to_blib</userinput></screen>
-
-    <para>Bien que Perl soit fourni avec une suite de tests, il n'est pas recommandé
-    de l'exécuter maintenant. Seules des parties de Perl ont été construites et
-    l'exécution de
-    <command>make test</command> obligerait la construction du
-    reste de Perl, ce qui n'est pas nécessaire actuellement. La suite de tests peut
-    être exécutée dans le chapitre suivant si désiré.</para>
-
-    <para>Puis, installez ces outils et leurs bibliothèques :</para>
-
-<screen><userinput remap="install">cp -v perl pod/pod2man /tools/bin
+    <para>Seuls quelques outils et quelques bibliothèques doivent être installés
+    pour l'instant :</para>
+    
+<screen><userinput remap="install">cp -v perl cpan/podlators/pod2man /tools/bin
 mkdir -pv /tools/lib/perl5/&perl-version;
 cp -Rv lib/* /tools/lib/perl5/&perl-version;</userinput></screen>
 

Modified: trunk/lfs/general.ent
===================================================================
--- trunk/lfs/general.ent	2011-06-25 14:25:27 UTC (rev 1357)
+++ trunk/lfs/general.ent	2011-06-27 00:36:36 UTC (rev 1358)
@@ -1,7 +1,7 @@
 <?xml version="1.0" encoding="ISO-8859-1"?>
 
-<!ENTITY version "SVN-20110624">
-<!ENTITY releasedate "24 juin 2011">
+<!ENTITY version "SVN-20110626">
+<!ENTITY releasedate "26 juin 2011">
 <!ENTITY copyrightdate "1999–2011">
 <!ENTITY milestone "6.9">
 <!ENTITY generic-version "development"> <!-- Use "development", "testing", or "x.y[-pre{x}]" -->

Modified: trunk/lfs/packages.ent
===================================================================
--- trunk/lfs/packages.ent	2011-06-25 14:25:27 UTC (rev 1357)
+++ trunk/lfs/packages.ent	2011-06-27 00:36:36 UTC (rev 1358)
@@ -192,13 +192,13 @@
 <!ENTITY gettext-ch6-du "125 Mio">
 <!ENTITY gettext-ch6-sbu "5.8 SBU">
 
-<!ENTITY glib-version "2.28.7">
-<!ENTITY glib-size "6,809 Kio">
+<!ENTITY glib-version "2.28.8">
+<!ENTITY glib-size "6,854 Kio">
 <!ENTITY glib-url "http://ftp.gnome.org/pub/gnome/sources/glib/2.28/glib-&glib-version;.tar.bz2">
-<!ENTITY glib-md5 "feda1650c8646ad39c7b01d95b03766b">
+<!ENTITY glib-md5 "789e7520f71c6a4bf08bc683ec764d24">
 <!ENTITY glib-home "http://developer.gnome.org/glib/">
-<!ENTITY glib-ch6-du "106 Mio">
-<!ENTITY glib-ch6-sbu "1.5 SBU">
+<!ENTITY glib-ch6-du "157 Mio">
+<!ENTITY glib-ch6-sbu "1.3 SBU">
 
 <!ENTITY glibc-version "2.13">
 <!ENTITY glibc-size "15,357 Kio">
@@ -288,12 +288,12 @@
 <!ENTITY kbd-ch6-du "16.0 Mio">
 <!ENTITY kbd-ch6-sbu "moins de 0.1 SBU">
 
-<!ENTITY less-version "443">
-<!ENTITY less-size "300 Kio">
+<!ENTITY less-version "444">
+<!ENTITY less-size "301 Kio">
 <!ENTITY less-url "http://www.greenwoodsoftware.com/less/less-&less-version;.tar.gz">
-<!ENTITY less-md5 "47db098fb3cdaf847b3c4be05ee954fc">
+<!ENTITY less-md5 "56f9f76ffe13f70155f47f6b3c87d421">
 <!ENTITY less-home "http://www.greenwoodsoftware.com/less/">
-<!ENTITY less-ch6-du "2.9 Mio">
+<!ENTITY less-ch6-du "3.5 Mio">
 <!ENTITY less-ch6-sbu "moins de 0.1 SBU">
 
 <!ENTITY lfs-bootscripts-version "20110531">                 <!-- Scripts depend on this format -->
@@ -431,15 +431,15 @@
 <!ENTITY pcre-ch6-du "12 Mio">
 <!ENTITY pcre-ch6-sbu "0.4 SBU">
 
-<!ENTITY perl-version "5.12.3">
-<!ENTITY perl-size "11,759 Kio">
+<!ENTITY perl-version "5.14.1">
+<!ENTITY perl-size "12,956 Kio">
 <!ENTITY perl-url "http://www.cpan.org/src/5.0/perl-&perl-version;.tar.bz2">
-<!ENTITY perl-md5 "72f3f7e1c700e79bbf9d9279ca5b42d9">
+<!ENTITY perl-md5 "97cd306a2c22929cc141a09568f43bb0">
 <!ENTITY perl-home "http://www.perl.org/">
-<!ENTITY perl-ch5-du "106 Mio">
-<!ENTITY perl-ch5-sbu "0.8 SBU">
-<!ENTITY perl-ch6-du "171 Mio">
-<!ENTITY perl-ch6-sbu "5.5 SBU">
+<!ENTITY perl-ch5-du "223 Mio">
+<!ENTITY perl-ch5-sbu "1.8 SBU">
+<!ENTITY perl-ch6-du "235 Mio">
+<!ENTITY perl-ch6-sbu "7.6 SBU">
 
 <!ENTITY pkg-config-version "0.26">
 <!ENTITY pkg-config-size "387 Kio">




More information about the lfs-traducfr mailing list