[lfs-fr] r1335 - in trunk/blfs: . postlfs/security

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Mar 7 Juin 05:29:52 PDT 2011


Author: jmengual
Date: 2011-06-07 14:29:52 +0200 (Tue, 07 Jun 2011)
New Revision: 1335

Modified:
   trunk/blfs/blfsmaj.txt
   trunk/blfs/postlfs/security/cracklib.xml
   trunk/blfs/postlfs/security/cyrus-sasl.xml
   trunk/blfs/postlfs/security/gnupg2.xml
   trunk/blfs/postlfs/security/gnutls.xml
   trunk/blfs/postlfs/security/heimdal.xml
Log:
Suite mise a jour par myou. Merci.



Modified: trunk/blfs/blfsmaj.txt
===================================================================
--- trunk/blfs/blfsmaj.txt	2011-06-05 19:15:20 UTC (rev 1334)
+++ trunk/blfs/blfsmaj.txt	2011-06-07 12:29:52 UTC (rev 1335)
@@ -3187,319 +3187,7 @@
 Seulement dans /home/jp/blfs/postlfs/security> : acl.xml
 Seulement dans /home/jp/blfs/postlfs/security> : attr.xml
 Seulement dans /home/jp/blfs/postlfs/security> : consolekit.xml
-diff -ru BOOK/postlfs/security/cracklib.xml /home/jp/blfs/postlfs/security/cracklib.xml
---- BOOK/postlfs/security/cracklib.xml	2010-02-17 02:50:55.000000000 +0100
-+++ /home/jp/blfs/postlfs/security/cracklib.xml	2011-02-27 04:05:22.000000000 +0100
-@@ -6,10 +6,10 @@
- 
-   <!ENTITY cracklib-download-http "&sourceforge-repo;/cracklib/cracklib-&cracklib-version;.tar.gz">
-   <!ENTITY cracklib-download-ftp  "&gentoo-ftp-repo;/cracklib-&cracklib-version;.tar.gz">
--  <!ENTITY cracklib-md5sum        "5beb4c6b3c31c83fc98c4c225b25cd94">
--  <!ENTITY cracklib-size          "593 Kio">
-+  <!ENTITY cracklib-md5sum        "79053ad8bc714a44cd660cb12116211b">
-+  <!ENTITY cracklib-size          "587 Kio">
-   <!ENTITY cracklib-buildsize     "29 Mio">
--  <!ENTITY cracklib-time          "0.2 SBU">
-+  <!ENTITY cracklib-time          "less than 0.1 SBU">
- 
-   <!ENTITY crackdict-version      "20080507">
-   <!ENTITY crackdict-download     "&sourceforge-repo;/cracklib/cracklib-words-&crackdict-version;.gz">
-@@ -22,7 +22,7 @@
- 
-   <sect1info>
-     <othername>$LastChangedBy: randy $</othername>
--    <date>$Date: 2008-10-13 17:32:21 +0200 (lun 13 oct 2008) $</date>
-+    <date>$Date: 2010-11-02 14:57:57 +0100 (mar 02 nov 2010) $</date>
-   </sect1info>
- 
-   <title>CrackLib-&cracklib-version;</title>
-@@ -38,6 +38,8 @@
-     library used to enforce strong passwords by comparing user selected
-     passwords to words in chosen word lists.</para>
- 
-+    <para>&lfssvn_checked;20101029&lfssvn_checked2;</para>
-+
-     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
-     <itemizedlist spacing="compact">
-       <listitem>
-@@ -131,7 +133,7 @@
- 
- <screen role="root"><userinput>make install &&
- mv -v /usr/lib/libcrack.so.2* /lib &&
--ln -v -sf ../../lib/libcrack.so.2.8.0 /usr/lib/libcrack.so</userinput></screen>
-+ln -v -sf ../../lib/libcrack.so.2.8.1 /usr/lib/libcrack.so</userinput></screen>
- 
-     <para>Issue the following commands as the
-     <systemitem class="username">root</systemitem>  to install the
-@@ -177,8 +179,8 @@
-     <filename class='directory'>/lib</filename> hierarchy.</para>
- 
-     <para><command>mv -v /usr/lib/libcrack.so.2* /lib</command> et
--    <command>ln -v -sf ../../lib/libcrack.so.2.8.0 ...</command>: These two
--    commands move the <filename class='libraryfile'>libcrack.so.2.8.0</filename>
-+    <command>ln -v -sf ../../lib/libcrack.so.2.8.1 ...</command>: These two
-+    commands move the <filename class='libraryfile'>libcrack.so.2.8.1</filename>
-     library et associated symlink from
-     <filename class='directory'>/usr/lib</filename> to
-     <filename class='directory'>/lib</filename>, then recreates the
-@@ -232,7 +234,7 @@
-       <?dbhtml list-presentation="table"?>
- 
-       <varlistentry id="create-cracklib-dict">
--        <term><filename>create-cracklib-dict</filename></term>
-+        <term><command>create-cracklib-dict</command></term>
-         <listitem>
-           <para>is used to create the <application>CrackLib</application>
-           dictionary from the given word list(s).</para>
-diff -ru BOOK/postlfs/security/cyrus-sasl.xml /home/jp/blfs/postlfs/security/cyrus-sasl.xml
---- BOOK/postlfs/security/cyrus-sasl.xml	2010-02-17 02:50:55.000000000 +0100
-+++ /home/jp/blfs/postlfs/security/cyrus-sasl.xml	2011-02-27 04:05:21.000000000 +0100
-@@ -4,20 +4,20 @@
-   <!ENTITY % general-entities SYSTEM "../../general.ent">
-   %general-entities;
- 
--  <!ENTITY cyrus-sasl-download-http "http://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-&cyrus-sasl-version;.tar.gz ">
-+  <!ENTITY cyrus-sasl-download-http "http://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-&cyrus-sasl-version;.tar.gz">
-   <!ENTITY cyrus-sasl-download-ftp  "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-&cyrus-sasl-version;.tar.gz">
--  <!ENTITY cyrus-sasl-md5sum        "45dde9d19193ae9dd388eb68b2027bc9">
--  <!ENTITY cyrus-sasl-size          "1.5 Mio">
--  <!ENTITY cyrus-sasl-buildsize     "14 Mio">
--  <!ENTITY cyrus-sasl-time          "0.2 SBU">
-+  <!ENTITY cyrus-sasl-md5sum        "2eb0e48106f0e9cd8001e654f267ecbc">
-+  <!ENTITY cyrus-sasl-size          "1.6 Mio">
-+  <!ENTITY cyrus-sasl-buildsize     "17 Mio">
-+  <!ENTITY cyrus-sasl-time          "0.3 SBU">
- ]>
- 
- <sect1 id="cyrus-sasl" xreflabel="Cyrus SASL-&cyrus-sasl-version;">
-   <?dbhtml filename="cyrus-sasl.html"?>
- 
-   <sect1info>
--    <othername>$LastChangedBy: randy $</othername>
--    <date>$Date: 2009-07-19 16:13:01 +0200 (dim 19 jui 2009) $</date>
-+    <othername>$LastChangedBy: dj $</othername>
-+    <date>$Date: 2010-10-17 19:55:40 +0200 (dim 17 oct 2010) $</date>
-   </sect1info>
- 
-   <title>Cyrus SASL-&cyrus-sasl-version;</title>
-@@ -68,14 +68,14 @@
-     <para role="optional"><xref linkend="linux-pam"/>,
-     <xref linkend="openldap"/>,
-     <xref linkend="heimdal"/> or <xref linkend="mitkrb"/>,
--    <xref linkend="jdk"/>,
-+    <xref linkend="icedtea6"/> or <xref linkend="jdk"/>,
-     <xref linkend="mysql"/>,
-     <xref linkend="postgresql"/>,
-     <xref linkend="db"/>,
-+    <xref linkend="sqlite"/>,
-     <!-- <xref linkend="gdbm"/>,
-     <xref linkend="courier"/>,  -->
--    <ulink url="http://www.pdc.kth.se/kth-krb/">krb4</ulink>,
--    <ulink url="http://sqlite.org/">SQLite</ulink>, et
-+    <ulink url="http://www.pdc.kth.se/kth-krb/">krb4</ulink>, et
-     <ulink url="http://dmalloc.com/">Dmalloc</ulink></para>
- 
-     <para condition="html" role="usernotes">Notes utilisateur :
-@@ -89,7 +89,10 @@
-     <para>Installez <application>Cyrus SASL</application> by
-     running the following suivantes :</para>>
- 
--<screen><userinput>./configure --prefix=/usr --sysconfdir=/etc \
-+<screen><userinput>sed -i.bak 's/#elif WITH_DES/#elif defined(WITH_DES)/' \
-+    plugins/digestmd5.c &&
-+./configure --prefix=/usr \
-+            --sysconfdir=/etc \
-             --with-dbpath=/var/lib/sasl/sasldb2 \
-             --with-saslauthd=/var/run/saslauthd &&
- make</userinput></screen>
-@@ -107,13 +110,17 @@
- install -v -m755 -d /usr/share/doc/cyrus-sasl-&cyrus-sasl-version; &&
- install -v -m644 doc/{*.{html,txt,fig},ONEWS,TODO} \
-     saslauthd/LDAP_SASLAUTHD /usr/share/doc/cyrus-sasl-&cyrus-sasl-version; &&
--install -v -m700 -d /var/lib/sasl /var/run/saslauthd</userinput></screen>
-+install -v -m700 -d /var/lib/sasl &&
-+install -v -m711 -d /var/run/saslauthd</userinput></screen>
- 
-   </sect2>
- 
-   <sect2 role="commands">
-     <title>Explications des commandes</title>
- 
-+    <para><command>sed -i.bak ... plugins/digestmd5.c</command>: This fixes
-+    a build problem caused by using newer compilers.</para>
-+
-     <para><parameter>--with-dbpath=/var/lib/sasl/sasldb2</parameter>: This
-     parameter forces the <command>sasldb</command> database to be created
-     in <filename class='directory'>/var/lib/sasl</filename> instead of
-@@ -140,7 +147,7 @@
-     install documentation which is not installed by the
-     <command>make install</command> command.</para>
- 
--    <para><command>install -v -m700 -d /var/lib/sasl /var/run/saslauthd</command>:
-+    <para><command>install -v -m700 -d /var/lib/sasl ... -m711 /var/run/saslauthd</command>:
-     These directories must exist when starting <command>saslauthd</command> or
-     using the sasldb plugin. If you're not going to be running the daemon or
-     using the plugins, you may omit the creation of this directory.</para>
-diff -ru BOOK/postlfs/security/gnupg2.xml /home/jp/blfs/postlfs/security/gnupg2.xml
---- BOOK/postlfs/security/gnupg2.xml	2010-02-17 02:50:55.000000000 +0100
-+++ /home/jp/blfs/postlfs/security/gnupg2.xml	2011-02-27 04:05:21.000000000 +0100
-@@ -4,21 +4,20 @@
-   <!ENTITY % general-entities SYSTEM "../../general.ent">
-   %general-entities;
- 
--  <!ENTITY gnupg2-download-http "&sources-anduin-http;/g/gnupg-&gnupg2-version;.tar.bz2">
--  <!-- <!ENTITY gnupg2-download-http "http://public.ftp.planetmirror.com/pub/gnupg/gnupg-&gnupg2-version;.tar.bz2"> -->
-+  <!ENTITY gnupg2-download-http " ">
-   <!ENTITY gnupg2-download-ftp  "ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-&gnupg2-version;.tar.bz2">
--  <!ENTITY gnupg2-md5sum        "fc4377ca67e1bf687eeaf22e79c0b9d1">
--  <!ENTITY gnupg2-size          "3.6 Mio">
--  <!ENTITY gnupg2-buildsize     "65 Mio">
--  <!ENTITY gnupg2-time          "0.7 SBU">
-+  <!ENTITY gnupg2-md5sum        "c1286e85b66349879dc4b760dd83e2f1">
-+  <!ENTITY gnupg2-size          "3.8 Mio">
-+  <!ENTITY gnupg2-buildsize     "60 Mio">
-+  <!ENTITY gnupg2-time          "0.8 SBU">
- ]>
- 
- <sect1 id="gnupg2" xreflabel="GnuPG-&gnupg2-version;">
-   <?dbhtml filename="gnupg2.html"?>
- 
-   <sect1info>
--    <othername>$LastChangedBy: gdalziel $</othername>
--    <date>$Date: 2009-07-06 21:12:40 +0200 (lun 06 jui 2009) $</date>
-+    <othername>$LastChangedBy: randy $</othername>
-+    <date>$Date: 2011-01-18 01:13:43 +0100 (mar 18 jan 2011) $</date>
-   </sect1info>
- 
-   <title>GnuPG-&gnupg2-version;</title>
-@@ -39,6 +38,8 @@
-     S/MIME. It does not conflict with an installed <xref linkend="gnupg"/>
-     OpenPGP-only version.</para>
- 
-+    &lfs65_built;
-+
-     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
-     <itemizedlist spacing="compact">
-       <listitem>
-@@ -78,15 +79,17 @@
-     <xref linkend="libgcrypt"/>, et
-     <xref linkend="libksba"/></para>
- 
-+    <bridgehead renderas="sect4">Recommandées</bridgehead>
-+    <para role="recommended"><xref linkend="pinentry"/> (Run-time requirement for most of
-+    the package's functionality)</para>
-+
-     <bridgehead renderas="sect4">Facultatives</bridgehead>
-     <para role="optional"><xref linkend="openldap"/>,
-     <xref linkend="libusb-compat"/>,
--    <xref linkend="curl"/>, et
--    an <xref linkend="server-mail"/></para>
--
--    <bridgehead renderas="sect4">Facultatives (Run-time Requirement For Most of
--    the Package's Functionality)</bridgehead>
--    <para role="optional"><xref linkend="pinentry"/></para>
-+    <xref linkend="curl"/>,
-+    <ulink url="http://www.chiark.greenend.org.uk/~ian/adns/">GNU
-+    adns</ulink>, et an
-+    <xref linkend="server-mail"/></para>
- 
-     <para condition="html" role="usernotes">Notes utilisateur :
-     <ulink url="&blfs-wiki;/gnupg2"/></para>
-@@ -99,16 +102,20 @@
-     <para>Installez <application>GnuPG 2</application> en lançant les commandes
-     suivantes :</para>>
- 
--<screen><userinput>./configure --prefix=/usr --libexecdir=/usr/lib/gnupg2 &&
--make</userinput></screen>
--
--    <para>If you have <xref linkend="tetex"/> installed et you wish to create
--    documentation in alternate formats, issue the following suivantes :</para>>
-+<screen><userinput>./configure --prefix=/usr \
-+            --libexecdir=/usr/lib/gnupg2 \
-+            --docdir=/usr/share/doc/gnupg-&gnupg2-version; &&
-+make
- 
--<screen><userinput>make -C doc pdf ps html &&
- makeinfo --html --no-split -o doc/gnupg_nochunks.html doc/gnupg.texi &&
- makeinfo --plaintext       -o doc/gnupg.txt           doc/gnupg.texi</userinput></screen>
- 
-+    <para>If you have <xref linkend="tetex"/> or <xref linkend="texlive"/>
-+    installed et you wish to create documentation in alternate formats,
-+    issue the following suivantes :</para>>
-+
-+<screen><userinput>make -C doc pdf ps html</userinput></screen>
-+
-     <para>Pour tester les résultats, lancez : <command>make check</command>.</para>
- 
-     <para>Maintenant, en tant qu'utilisateur the <systemitem class="username">root</systemitem> :</para>
-@@ -120,28 +127,33 @@
-          chmod -v 4755 /usr/bin/gpg &&
-     -->
- 
--<screen role="root"><userinput>make install &&
-+<screen role="root"><userinput>make install
-+
-+install -v -m755 -d /usr/share/doc/gnupg-&gnupg2-version;/html &&
-+install -v -m644    doc/gnupg_nochunks.html \
-+                    /usr/share/doc/gnupg-&gnupg2-version;/gnupg.html &&
-+install -v -m644    doc/*.texi doc/gnupg.txt \
-+                    /usr/share/doc/gnupg-&gnupg2-version;</userinput></screen>
-+
-+<!-- Documentation is installed by default -->
-+
-+<!-- <screen role="root"><userinput>make install &&
- 
- install -v -m755 -d         /usr/share/doc/gnupg-&gnupg2-version; &&
- ln -sv ../../gnupg/FAQ      /usr/share/doc/gnupg-&gnupg2-version; &&
- ln -sv ../../gnupg/faq.html /usr/share/doc/gnupg-&gnupg2-version; &&
- 
- install -v -m644 doc/{DETAILS,KEYSERVER,OpenPGP,TRANSLATE} \
--                            /usr/share/doc/gnupg-&gnupg2-version;</userinput></screen>
-+                 /usr/share/doc/gnupg-&gnupg2-version;</userinput></screen> -->
- 
-     <para>If you created alternate formats of the documentation, install it
-     using the following command as the
-     <systemitem class="username">root</systemitem> :</para>
- 
--<screen role="root"><userinput>install -v -m755 -d /usr/share/doc/gnupg-&gnupg2-version;/html       &&
--install -v -m644 doc/gnupg.html/* \
--                    /usr/share/doc/gnupg-&gnupg2-version;/html       &&
--install -v -m644 doc/gnupg_nochunks.html \
--                    /usr/share/doc/gnupg-&gnupg2-version;/gnupg.html &&
--install -v -m644 doc/*.texi \
--                    /usr/share/doc/gnupg-&gnupg2-version;            &&
--install -v -m644 doc/gnupg.{pdf,dvi,ps,txt} \
--                    /usr/share/doc/gnupg-&gnupg2-version;</userinput></screen>
-+<screen role="root"><userinput>install -v -m644 doc/gnupg.html/* \
-+                 /usr/share/doc/gnupg-&gnupg2-version;/html &&
-+install -v -m644 doc/gnupg.{pdf,dvi,ps} \
-+                 /usr/share/doc/gnupg-&gnupg2-version;</userinput></screen>
- 
-   </sect2>
- 
-@@ -153,6 +165,13 @@
-     <filename class="directory">/usr/lib</filename> instead of
-     <filename class="directory">/usr/libexec</filename>.</para>
- 
-+    <para><parameter>--docdir=/usr/share/doc/gnupg-&gnupg2-version;</parameter>:
-+    This switch changes the default docdir to <filename
-+    class="directory">/usr/share/doc/gnupg-&gnupg2-version;</filename>.</para>
-+
-+    <para><parameter>--enable-symcryptrun</parameter>: This switch enables
-+    building the symcryptrun program.</para>
-+
-     <!-- See above why this is no longer included
-     <para><command>chmod -v 4755 /usr/bin/gpg</command>:
-     <command>gpg</command> is installed setuid
-@@ -176,7 +195,7 @@
-         gpgv2, kbxutil, scdaemon, symcryptrun, et watchgnupg</seg>
-         <seg>None</seg>
-         <seg>/usr/lib/gnupg2, /usr/share/gnupg et
--        /usr/share/doc/gnupg2-&gnupg2-version;</seg>
-+        /usr/share/doc/gnupg-&gnupg2-version;</seg>
-       </seglistitem>
-     </segmentedlist>
- 
+
 diff -ru BOOK/postlfs/security/gnupg.xml /home/jp/blfs/postlfs/security/gnupg.xml
 --- BOOK/postlfs/security/gnupg.xml	2010-02-17 02:50:55.000000000 +0100
 +++ /home/jp/blfs/postlfs/security/gnupg.xml	2011-02-27 04:05:21.000000000 +0100
@@ -3628,488 +3316,9 @@
        <varlistentry id="gpgsplit">
          <term><command>gpgsplit</command></term>
          <listitem>
-diff -ru BOOK/postlfs/security/gnutls.xml /home/jp/blfs/postlfs/security/gnutls.xml
---- BOOK/postlfs/security/gnutls.xml	2010-02-17 02:50:55.000000000 +0100
-+++ /home/jp/blfs/postlfs/security/gnutls.xml	2011-02-27 04:05:22.000000000 +0100
-@@ -4,12 +4,12 @@
-   <!ENTITY % general-entities SYSTEM "../../general.ent">
-   %general-entities;
- 
--  <!ENTITY gnutls-download-http "http://www.gnu.org/software/gnutls/releases/gnutls-&gnutls-version;.tar.bz2">
-+  <!ENTITY gnutls-download-http "http://mirrors.kernel.org/gnu/gnutls/gnutls-&gnutls-version;.tar.bz2">
-   <!ENTITY gnutls-download-ftp  "ftp://ftp.gnutls.org/pub/gnutls/gnutls-&gnutls-version;.tar.bz2">
--  <!ENTITY gnutls-md5sum        "73da68a4248d34c4d38491ce2119af0f">
--  <!ENTITY gnutls-size          "4.2 Mio">
--  <!ENTITY gnutls-buildsize     "49 Mio">
--  <!ENTITY gnutls-time          "0.5 SBU">
-+  <!ENTITY gnutls-md5sum        "777823f5746ab80cd6f7f7b5fcb2f91b">
-+  <!ENTITY gnutls-size          "7.4 Mio">
-+  <!ENTITY gnutls-buildsize     "100 Mio">
-+  <!ENTITY gnutls-time          "1.3 SBU (additional 1.5 SBU to run the test suite)">
- ]>
- 
- <sect1 id="gnutls" xreflabel="GnuTLS-&gnutls-version;">
-@@ -17,7 +17,7 @@
- 
-   <sect1info>
-     <othername>$LastChangedBy: randy $</othername>
--    <date>$Date: 2008-05-09 15:00:42 +0200 (ven 09 mai 2008) $</date>
-+    <date>$Date: 2011-01-03 22:38:16 +0100 (lun 03 jan 2011) $</date>
-   </sect1info>
- 
-   <title>GnuTLS-&gnutls-version;</title>
-@@ -47,6 +47,8 @@
-     the TLS Pre-Shared-Keys (PSK) extension, the Inner Application (TLS/IA)
-     extension et X.509 and OpenPGP certificate handling.</para>
- 
-+    &lfs65_checked;
-+
-     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
-     <itemizedlist spacing="compact">
-       <listitem>
-@@ -76,16 +78,18 @@
- 
-     <bridgehead renderas="sect4">Facultatives</bridgehead>
-     <para role="optional"><xref linkend="gtk-doc"/>,
--    <ulink url="http://www.gnu.org/software/gnutls/download.html">OpenCDK</ulink>,
--    <ulink url="http://www.gnu.org/software/gnutls/download.html">Tiny ASN.1</ulink>,
--    <!-- <ulink url="http://platon.sk/projects/libcfg+">libcfg+</ulink>, -->
--    <ulink url="http://webscripts.softpedia.com/script/Development-Scripts-js/C-C-Library/libcfg--26570.html">libcfg+</ulink>,
--    <xref linkend="LZO"/>, et
-+    <xref linkend="guile"/>,
-+    <xref linkend="libtasn1"/>,
-+    <ulink url="http://webscripts.softpedia.com/script/Development-Scripts-js/C-C-Library/libcfg--26570.html">libcfg+</ulink>, et
-     <ulink url="http://valgrind.org/">Valgrind</ulink> (used during the test suite)</para>
- 
--    <bridgehead renderas="sect4">Facultatives Debugging Libraries</bridgehead>
-+    <para>Note that if you do not install <xref linkend="libtasn1"/>, an older
-+    version shipped in the <application>GnuTLS</application> tarball will be
-+    used instead.</para>
-+
-+    <!-- <bridgehead renderas="sect4">Facultatives Debugging Libraries</bridgehead>
-     <para role="optional"><ulink url="http://dmalloc.com/">Dmalloc</ulink> et
--    <ulink url="http://perens.com/FreeSoftware/ElectricFence/">Electric Fence</ulink></para>
-+    <ulink url="http://perens.com/FreeSoftware/ElectricFence/">Electric Fence</ulink></para> -->
- 
-     <para condition="html" role="usernotes">Notes utilisateur :
-     <ulink url="&blfs-wiki;/gnutls"/></para>
-@@ -107,13 +111,27 @@
-     user:</para>
- 
- <screen role="root"><userinput>make install &&
--
--install -v -m755 -d /usr/share/doc/gnutls-&gnutls-version;/reference &&
--install -v -m644    doc/reference/html/* \
--                    /usr/share/doc/gnutls-&gnutls-version;/reference &&
--install -v -m644    doc/*.{html,png,eps,pdf,ps} \
-+install -v -m755 -d /usr/share/doc/gnutls-&gnutls-version; &&
-+install -v -m644    doc/*.{html,png,eps,pdf,ps} doc/cyclo/*.html \
-+                    /usr/share/doc/gnutls-&gnutls-version; &&
-+cp -v -R            doc/credentials \
-                     /usr/share/doc/gnutls-&gnutls-version;</userinput></screen>
- 
-+    <para>If you did not pass the <option>--enable-gtk-doc</option> parameter
-+    to the <command>configure</command> script, install the API documentation
-+    using the following command as the
-+    <systemitem class="username">root</systemitem> :</para>
-+
-+<screen role="root"><userinput>make -C doc/reference install-data-local</userinput></screen>
-+
-+  </sect2>
-+
-+  <sect2 role="commands">
-+    <title>Explications des commandes</title>
-+
-+    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
-+    href="../../xincludes/gtk-doc-rebuild.xml"/>
-+
-   </sect2>
- 
-   <sect2 role="content">
-@@ -122,15 +140,16 @@
-     <segmentedlist>
-       <segtitle>Programmes installés</segtitle>
-       <segtitle>Bibliothèques installées</segtitle>
--      <segtitle>Répertoire installé</segtitle>
-+      <segtitle>Répertoires installés</segtitle>
- 
-       <seglistitem>
-         <seg>certtool, gnutls-cli, gnutls-cli-debug, gnutls-serv,
--        libgnutls-config, libgnutls-extra-config, psktool, et srptool</seg>
-+        psktool, et srptool</seg>
-         <seg>libgnutls.{so,a}, libgnutls-extra.{so,a},
-         libgnutls-openssl.{so,a}, et libgnutlsxx.{so,a}</seg>
--        <seg>/usr/include/gnutls et
--        /usr/share/doc/gnutls-&gnutls-version;</seg>
-+        <seg>/usr/include/gnutls,
-+        /usr/share/doc/gnutls-&gnutls-version;, et
-+        /usr/share/gtk-doc/html/gnutls</seg>
-       </seglistitem>
-     </segmentedlist>
- 
-@@ -183,32 +202,6 @@
-         </listitem>
-       </varlistentry>
- 
--      <varlistentry id="gnutls-config">
--        <term><command>gnutls-config</command></term>
--        <listitem>
--          <para>is a utility used to configure et build applications based on
--          the gnutls(3) library. It can be used to query the C compiler et
--          linker flags which are required to correctly compile et link the
--          application against the gnutls(3) library.</para>
--          <indexterm zone="gnutls gnutls-config">
--            <primary sortas="b-gnutls-config">gnutls-config</primary>
--          </indexterm>
--        </listitem>
--      </varlistentry>
--
--      <varlistentry id="gnutls-extra-config">
--        <term><command>gnutls-extra-config</command></term>
--        <listitem>
--          <para>is a utility used to configure et build applications based on
--          the gnutls-extra(3) library. It can be used to query the C compiler et
--          linker flags which are required to correctly compile et link the
--          application against the gnutls-extra(3) library.</para>
--          <indexterm zone="gnutls gnutls-extra-config">
--            <primary sortas="b-gnutls-extra-config">gnutls-extra-config</primary>
--          </indexterm>
--        </listitem>
--      </varlistentry>
--
-       <varlistentry id="psktool">
-         <term><command>psktool</command></term>
-         <listitem>
+
 Seulement dans /home/jp/blfs/postlfs/security> : gpgme.xml
-diff -ru BOOK/postlfs/security/heimdal.xml /home/jp/blfs/postlfs/security/heimdal.xml
---- BOOK/postlfs/security/heimdal.xml	2010-02-17 02:50:55.000000000 +0100
-+++ /home/jp/blfs/postlfs/security/heimdal.xml	2011-02-27 04:05:21.000000000 +0100
-@@ -6,10 +6,10 @@
- 
-   <!ENTITY heimdal-download-http "http://www.h5l.org/dist/src/heimdal-&heimdal-version;.tar.gz">
-   <!ENTITY heimdal-download-ftp  "ftp://ftp.pdc.kth.se/pub/heimdal/src/heimdal-&heimdal-version;.tar.gz">
--  <!ENTITY heimdal-md5sum        "7892e97b346534cc9afeeee461fe3bab">
--  <!ENTITY heimdal-size          "3.6 Mio">
--  <!ENTITY heimdal-buildsize     "136 Mio">
--  <!ENTITY heimdal-time          "4.0 SBU (additional 1.5 SBU to run the test suite)">
-+  <!ENTITY heimdal-md5sum        "31d08bbf47a77827fe97ef3f52b4c9c4">
-+  <!ENTITY heimdal-size          "6.0 Mio">
-+  <!ENTITY heimdal-buildsize     "205 Mio">
-+  <!ENTITY heimdal-time          "3.9 SBU (additional 2.3 SBU to run the test suite)">
- ]>
- 
- <sect1 id="heimdal" xreflabel="Heimdal-&heimdal-version;">
-@@ -17,7 +17,7 @@
- 
-   <sect1info>
-     <othername>$LastChangedBy: randy $</othername>
--    <date>$Date: 2009-07-19 16:13:01 +0200 (dim 19 jui 2009) $</date>
-+    <date>$Date: 2011-01-18 01:13:43 +0100 (mar 18 jan 2011) $</date>
-   </sect1info>
- 
-   <title>Heimdal-&heimdal-version;</title>
-@@ -43,6 +43,8 @@
-     <ulink url="&files-anduin;/heimdal-overwrites"/> for a complete list of
-     all the files et commands to rename each of them.</para>
- 
-+    <para>&lfssvn_checked;20101029&lfssvn_checked2;</para>
-+
-     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
-     <itemizedlist spacing="compact">
-       <listitem>
-@@ -69,30 +71,30 @@
-     <itemizedlist spacing='compact'>
-       <listitem>
-         <para>Required Patch> : <ulink
--        url="&patch-root;/heimdal-&heimdal-version;-blfs_docs-1.patch"/></para>
-+        url="&patch-root;/heimdal-&heimdal-version;-otp_fixes-1.patch"/></para>
-       </listitem>
--      <listitem>
-+      <!-- <listitem>
-         <para>Required Patch> : <ulink
-         url="&patch-root;/heimdal-&heimdal-version;-libss-1.patch"/></para>
--      </listitem>
-+      </listitem> -->
-     </itemizedlist>
- 
-     <bridgehead renderas="sect3">Heimdal Dependencies</bridgehead>
- 
-     <bridgehead renderas="sect4">Requises to Build the Server-Side Tools</bridgehead>
--    <para role="required">
--    <xref linkend="db"/> (recommended) or GDBM (GDBM is installed in LFS)</para>
--    <!-- <xref linkend="db"/> is recommended (installed in LFS)
--    or <xref linkend="gdbm"/></para> -->
-+    <para role="required"><xref linkend="db"/></para>
- 
-     <bridgehead renderas="sect4">Recommandées</bridgehead>
-     <para role="recommended"><xref linkend="openssl"/></para>
- 
-     <bridgehead renderas="sect4">Facultatives</bridgehead>
--    <para role="optional"><xref linkend="linux-pam"/>,
--    <xref linkend="openldap"/>,
--    <xref linkend="x-window-system"/>, et
--    <ulink url="http://packages.debian.org/stable/source/libcap">libcap</ulink></para>
-+    <para role="optional"><xref linkend="openldap"/>,
-+    <xref linkend="sqlite"/>,
-+    <xref linkend="x-window-system"/>,
-+    <ulink url="http://www.kernel.org/pub/linux/libs/security/linux-privs/libcap2/">libcap2</ulink>, et
-+    <ulink url="http://people.redhat.com/sgrubb/libcap-ng/">libcap-ng</ulink> (with this
-+    <ulink url="&patch-root;/libcap-ng-0.6.4-2.6.36_kernel_fix-1.patch">patch</ulink>
-+    if the Linux kernel version is >=2.6.36)</para>
- 
-     <note>
-       <para>Some sort of time synchronization facility on your system
-@@ -118,8 +120,9 @@
-     <para>Installez <application>Heimdal</application> en lançant les commandes
-     suivantes :</para>>
- 
--<screen><userinput>patch -Np1 -i ../heimdal-&heimdal-version;-blfs_docs-1.patch &&
--patch -Np1 -i ../heimdal-&heimdal-version;-libss-1.patch &&
-+<screen><userinput>patch -Np1 -i ../heimdal-&heimdal-version;-otp_fixes-1.patch &&
-+sed -i 's|/var/heimdal|/var/lib/heimdal|' \
-+       `grep -lr "/var/heimdal" doc kadmin kdc lib` &&
- 
- ./configure --prefix=/usr \
-             --sysconfdir=/etc/heimdal \
-@@ -129,60 +132,56 @@
-             --with-hdbdir=/var/lib/heimdal \
-             --with-readline=/usr \
-             --enable-kcm &&
--make</userinput></screen>
--
--    <para>If you have <xref linkend="tetex"/> installed et wish to create
--    alternate forms of the documentation, change into the
--    <filename class='directory'>doc</filename> directory et issue any or all
--    of the following suivantes :</para>>
--
--<screen><userinput>pushd doc                                        &&
--
--make html                                        &&
--
--texi2pdf                            heimdal.texi &&
--texi2dvi                            heimdal.texi &&
--dvips                -o heimdal.ps  heimdal.dvi  &&
--makeinfo --plaintext -o heimdal.txt heimdal.texi &&
--
--texi2pdf                            hx509.texi   &&
--texi2dvi                            hx509.texi   &&
--dvips                -o hx509.ps    hx509.dvi    &&
--makeinfo --plaintext -o hx509.txt   hx509.texi   &&
-+make &&
- 
-+install -v -m755 -d doc/html                                    &&
-+make -C doc html                                                &&
-+mv -v doc/heimdal.html doc/html/heimdal                         &&
-+mv -v doc/hx509.html   doc/html/hx509                           && 
-+makeinfo --html --no-split -o doc/heimdal.html doc/heimdal.texi &&
-+makeinfo --html --no-split -o doc/hx509.html   doc/hx509.texi   &&
-+makeinfo --plaintext       -o doc/heimdal.txt  doc/heimdal.texi &&
-+makeinfo --plaintext       -o doc/hx509.txt    doc/hx509.texi</userinput></screen>
-+
-+    <para>If you have <xref linkend="tetex"/> or <xref linkend="texlive"/>
-+    installed et wish to create PDF and Postscript forms of the documentation,
-+    change into the <filename class='directory'>doc</filename> directory et
-+    issue any or all of the following suivantes :</para>>
-+
-+<screen><userinput>pushd doc                        &&
-+texi2pdf            heimdal.texi &&
-+texi2dvi            heimdal.texi &&
-+dvips -o heimdal.ps heimdal.dvi  &&
-+texi2pdf            hx509.texi   &&
-+texi2dvi            hx509.texi   &&
-+dvips -o hx509.ps   hx509.dvi    &&
- popd</userinput></screen>
- 
-     <para>Pour tester les résultats, lancez : <command>make -k check</command>. The
--    <command>ipropd</command> test is known to fail but all others should
-+    <command>check-iprop</command> test is known to fail but all others should
-     pass.</para>
- 
-     <para>Maintenant, en tant qu'utilisateur the <systemitem class="username">root</systemitem> :</para>
- 
--<!-- <screen role="root"><?dbfo keep-together="auto"?><userinput>mv -v /usr/include/ss/ss.h   /usr/include/ss/ss.h.e2fsprogs &&
--mv -v /usr/lib/libss.a       /usr/lib/libss.a.e2fsprogs &&
--mv -v /usr/lib/libss.so      /usr/lib/libss.so.e2fsprogs &&
--mv -v /usr/bin/mk_cmds       /usr/bin/mk_cmds.e2fsprogs &&
---->
--
- <screen role="root"><userinput>make install &&
- 
--install -v -m755 -d /usr/share/doc/heimdal-&heimdal-version; &&
--install -v -m644    doc/{init-creds,layman.asc} \
--                    /usr/share/doc/heimdal-&heimdal-version; &&
--
--ln -sfv         mech.5 /usr/share/man/man5/qop.5  &&
--ln -sfv ../man5/mech.5 /usr/share/man/cat5/qop.5  &&
--ln -sfv ../man5/mech.5 /usr/share/man/cat5        &&
-+install -v -m755 -d /usr/share/doc/heimdal-&heimdal-version;        &&
-+install -v -m644    doc/{heimdal,hx509}.{html,txt} \
-+                    doc/{init-creds,layman.asc}    \
-+                    /usr/share/doc/heimdal-&heimdal-version;        &&
-+cp      -v -R       doc/html \
-+                    destdir/usr/share/doc/heimdal-&heimdal-version; &&
- 
- mv -v /bin/login          /bin/login.SHADOW &&
- mv -v /bin/su             /bin/su.SHADOW    &&
- mv -v /usr/bin/{login,su} /bin              &&
- ln -v -sf ../../bin/login /usr/bin          &&
- 
--for LINK in   lib{otp,kafs,krb5,hx509,asn1,roken,crypto}; do
--    mv -v     /usr/lib/${LINK}.so.* /lib &&
--    ln -v -sf ../../lib/$(readlink  /usr/lib/${LINK}.so) \
--              /usr/lib/${LINK}.so
-+for LINK in   \
-+    lib{otp,kafs,krb5,hx509,sqlite3,asn1,roken,crypto,wind}; do
-+        mv -v     /usr/lib/${LINK}.so.* /lib &&
-+        ln -v -sf ../../lib/$(readlink  /usr/lib/${LINK}.so) \
-+                  /usr/lib/${LINK}.so
- done &&
- 
- mv -v     /usr/lib/$(readlink /usr/lib/libdb.so) \
-@@ -193,21 +192,11 @@
- 
- ldconfig</userinput></screen>
- 
--<!-- mv -v /usr/include/ss/ss.h            /usr/include/ss/ss.h.heimdal &&
--mv -v /usr/include/ss/ss.h.e2fsprogs  /usr/include/ss/ss.h &&
--mv -v /usr/lib/libss.a                /usr/lib/libss.a.heimdal &&
--mv -v /usr/lib/libss.a.e2fsprogs      /usr/lib/libss.a &&
--mv -v /usr/lib/libss.so               /usr/lib/libss.so.heimdal &&
--mv -v /usr/lib/libss.so.e2fsprogs     /usr/lib/libss.so &&
--mv -v /usr/lib/libss.la               /usr/lib/libss.la.heimdal &&
--mv -v /usr/bin/mk_cmds                /usr/bin/mk_cmds.heimdal &&
--mv -v /usr/bin/mk_cmds.e2fsprogs      /usr/bin/mk_cmds && -->
--
--    <para>If you built any of the alternate forms of documentation, install it
-+    <para>If you built any of the additional forms of documentation, install it
-     using the following commands as the
-     <systemitem class="username">root</systemitem> :</para>
- 
--<screen role="root"><userinput>install -v -m644 doc/{heimdal,hx509}.{dvi,ps,pdf,html,txt} \
-+<screen role="root"><userinput>install -v -m644 doc/{heimdal,hx509}.{dvi,ps,pdf} \
-                  /usr/share/doc/heimdal-&heimdal-version;</userinput></screen>
- 
-     <para>If you wish to use the <xref linkend="cracklib"/> library to enforce
-@@ -218,7 +207,7 @@
-     -e 's|/usr/lib/cracklib_dict|/lib/cracklib/pw_dict|' \
-     -e 's|/var/heimdal|/var/lib/heimdal|' \
-         lib/kadm5/check-cracklib.pl \
--    > /bin/krb5-check-cracklib.pl &&
-+     > /bin/krb5-check-cracklib.pl &&
- 
- chmod -v 755 /bin/krb5-check-cracklib.pl</userinput></screen>
- 
-@@ -227,16 +216,12 @@
-   <sect2 role="commands">
-     <title>Explications des commandes</title>
- 
--    <!-- <para><command>mv -v /usr/include/...</command>,
--    <command>mv -v /usr/lib/libss.* ...</command> et
--    <command>mv -v /usr/bin/mk_cmds ...</command>: The
--    <application>Heimdal</application> installation will overwrite an
--    interface header, static library, library symbolic link et a
--    shell script from the
--    <application>E2fsprogs</application> package. These commands rename the
--    original files before the installation, et then restore them (after
--    renaming the new <application>Heimdal</application> files) after the
--    installation.</para> -->
-+    <para><command>sed -i ... `grep -lr "/var/heimdal"
-+    doc kadmin kdc lib`</command>: This command is used to change the
-+    hard-coded references in the documentation files from
-+    <filename class='directory'>/var/heimdal</filename> to the FHS compliant
-+    <filename class='directory'>/var/lib/heimdal</filename> directory
-+    name.</para>
- 
-     <para><parameter>--libexecdir=/usr/sbin</parameter>: This switch causes
-     the daemon programs to be installed into
-@@ -271,8 +256,15 @@
-     <para><parameter>--enable-kcm</parameter>: This parameter enables building
-     the Kerberos Credentials Manager.</para>
- 
--    <para><command>ln -sfv .../mech.5 /usr/share/man/...</command>: These
--    commands are used to fix some broken symbolic links.</para>
-+    <para><option>--with-sqlite3=/usr</option>: This parameter must be
-+    used so that the <command>configure</command> script properly locates the
-+    installed <application>Sqlite3</application> package.</para>
-+
-+    <para><option>--with-openldap=/usr</option> et
-+    <option>--enable-hdb-openldap-module</option>: These parameters must be
-+    used so that the <command>configure</command> script properly locates the
-+    installed <application>OpenLDAP</application> package in order to build the
-+    module allowing an LDAP backend database.</para>
- 
-     <para><command>mv ... ...SHADOW</command>, <command>mv ... /bin</command>
-     et <command> ln ... /usr/bin</command>: The <command>login</command>
-@@ -422,11 +414,10 @@
- 
- <screen role="root"><userinput>ext host/<replaceable><hostname.example.com></replaceable></userinput></screen>
- 
--        <para>This should have created two files in
--        <filename class="directory">/etc/heimdal</filename>:
--        <filename>krb5.keytab</filename> (Kerberos 5) et
--        <filename>srvtab</filename> (Kerberos 4). Both files should have 600
--        (root rw only) permissions. Keeping the keytab files from public access
-+        <para>This should have created a file in
-+        <filename class="directory">/etc/heimdal</filename> named
-+        <filename>krb5.keytab</filename>. This file should have 600
-+        (root rw only) permissions. Keeping the keytab file from public access
-         is crucial to the overall security of the Kerberos installation.</para>
- 
-         <para>Eventually, you'll want to add server daemon principles to the
-@@ -485,7 +476,7 @@
-         <application>Crypt::Cracklib</application>
-         <application>Perl</application> module. Download it from the CPAN
-         site. The URL at the time of this writing is <ulink
--        url="http://cpan.org/authors/id/D/DA/DANIEL/Crypt-Cracklib-1.2.tar.gz"/>.
-+        url="http://www.cpan.org/authors/id/D/DA/DANIEL/Crypt-Cracklib-1.5.tar.gz"/>.
-         After unpacking the tarball et changing into the newly created
-         directory, issue the following command to add the BLFS
-         <application>Cracklib</application> dictionary location to one of the
-@@ -495,8 +486,7 @@
- 
-         <para>Then use the standard <command>perl Makefile.PL</command>;
-         <command>make</command>; <command>make test</command>;
--        <command>make install</command> commands. Note that one test fails
--        due to an unknown reason.</para>
-+        <command>make install</command> commands.</para> 
- 
-         <para id="heimdal-init">Installez the
-         <filename>/etc/rc.d/init.d/heimdal</filename> init script included
-@@ -566,14 +556,14 @@
-         popper, push, rcp, rsh, rshd, rxtelnet, rxterm, string2key, su,
-         telnet, telnetd, tenletxr, verify_krb5_conf et xnlock</seg>
- 
--        <seg>hdb_ldap.{so,a}, libasn1.{so,a}, libeditline.{so,a},
-+        <seg>hdb_ldap.{so,a}, libasn1.{so,a},
-         libgssapi.{so,a}, libhdb.{so,a}, libheimntlm.{so,a}, libhx509.{so,a},
-         libkadm5clnt.{so,a}, libkadm5srv.{so,a}, libkafs.{so,a},
-         libkdc.{so,a}, libkrb5.{so,a}, libotp.{so,a}, libroken.{so,a},
--        libsl.{so,a}, libss-krb5.{so,a} et windc.{so,a}</seg>
-+        libsl.{so,a}, libss-krb5.{so,a} et wind.{so,a}</seg>
- 
-         <seg>/etc/heimdal, /usr/include/gssapi, /usr/include/kadm5,
--        /usr/include/krb5, /usr/include/roken, /usr/include/ss,
-+        /usr/include/krb5, /usr/include/roken,
-         /usr/share/doc/heimdal-&heimdal-version; et /var/lib/heimdal</seg>
-       </seglistitem>
-     </segmentedlist>
-@@ -1056,16 +1046,6 @@
-         </listitem>
-       </varlistentry>
- 
--      <varlistentry id="libeditline">
--        <term><filename class='libraryfile'>libeditline.a</filename></term>
--        <listitem>
--          <para>is a command-line editing library with history.</para>
--          <indexterm zone="heimdal libeditline">
--            <primary sortas="c-libeditline">libeditline.a</primary>
--          </indexterm>
--        </listitem>
--      </varlistentry>
--
-       <varlistentry id="libgssapi">
-         <term><filename class='libraryfile'>libgssapi.{so,a}</filename></term>
-         <listitem>
+
 diff -ru BOOK/postlfs/security/iptables.xml /home/jp/blfs/postlfs/security/iptables.xml
 --- BOOK/postlfs/security/iptables.xml	2010-02-17 02:50:55.000000000 +0100
 +++ /home/jp/blfs/postlfs/security/iptables.xml	2010-04-28 20:27:53.000000000 +0200

Modified: trunk/blfs/postlfs/security/cracklib.xml
===================================================================
--- trunk/blfs/postlfs/security/cracklib.xml	2011-06-05 19:15:20 UTC (rev 1334)
+++ trunk/blfs/postlfs/security/cracklib.xml	2011-06-07 12:29:52 UTC (rev 1335)
@@ -6,10 +6,10 @@
 
   <!ENTITY cracklib-download-http "&sourceforge-repo;/cracklib/cracklib-&cracklib-version;.tar.gz">
   <!ENTITY cracklib-download-ftp  "&gentoo-ftp-repo;/cracklib-&cracklib-version;.tar.gz">
-  <!ENTITY cracklib-md5sum        "5beb4c6b3c31c83fc98c4c225b25cd94">
-  <!ENTITY cracklib-size          "593 Kio">
+  <!ENTITY cracklib-md5sum        "79053ad8bc714a44cd660cb12116211b">
+  <!ENTITY cracklib-size          "587 Kio">
   <!ENTITY cracklib-buildsize     "29 Mio">
-  <!ENTITY cracklib-time          "0.2 SBU">
+  <!ENTITY cracklib-time          "less than 0.1 SBU">
 
   <!ENTITY crackdict-version      "20080507">
   <!ENTITY crackdict-download     "&sourceforge-repo;/cracklib/cracklib-words-&crackdict-version;.gz">
@@ -22,7 +22,7 @@
 
   <sect1info>
     <othername>$LastChangedBy: randy $</othername>
-    <date>$Date: 2008-10-13 17:32:21 +0200 (lun 13 oct 2008) $</date>
+    <date>$Date: 2010-11-02 14:57:57 +0100 (mar 02 nov 2010) $</date>
   </sect1info>
 
   <title>CrackLib-&cracklib-version;</title>
@@ -39,6 +39,8 @@
     passe sélectionnés par l'utilisateur avec des mots dans des listes de mots
     choisies.</para>
 
+    <para>&lfssvn_checked;20101029&lfssvn_checked2;</para>
+
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
@@ -134,7 +136,7 @@
 
 <screen role="root"><userinput>make install &&
 mv -v /usr/lib/libcrack.so.2* /lib &&
-ln -v -sf ../../lib/libcrack.so.2.8.0 /usr/lib/libcrack.so</userinput></screen>
+ln -v -sf ../../lib/libcrack.so.2.8.1 /usr/lib/libcrack.so</userinput></screen>
 
     <para>Lancez les commandes suivantes en tant qu'utilisateur
     <systemitem class="username">root</systemitem> pour installer la liste de
@@ -180,8 +182,8 @@
     <filename class='directory'>/lib</filename>.</para>
 
     <para><command>mv -v /usr/lib/libcrack.so.2* /lib</command> et
-    <command>ln -v -sf ../../lib/libcrack.so.2.8.0 ...</command> : Ces
-    deux commandes déplacent la bibliothèque <filename class='libraryfile'>libcrack.so.2.8.0</filename>
+    <command>ln -v -sf ../../lib/libcrack.so.2.8.1 ...</command> : Ces
+    deux commandes déplacent la bibliothèque <filename class='libraryfile'>libcrack.so.2.8.1</filename>
     et les liens associés de <filename class='directory'>/usr/lib</filename> vers
     <filename class='directory'>/lib</filename>, puis recréent le lien symbolique
     <filename class='symlink'>/usr/lib/libcrack.so</filename> qui pointe vers
@@ -236,7 +238,7 @@
       <?dbhtml list-presentation="table"?>
 
       <varlistentry id="create-cracklib-dict">
-        <term><filename>create-cracklib-dict</filename></term>
+        <term><command>create-cracklib-dict</command></term>
         <listitem>
           <para>est utilisé pour créer le dictionnaire <application>CrackLib</application>
           à partir de la/des liste(s) de mots donnée(s).</para>

Modified: trunk/blfs/postlfs/security/cyrus-sasl.xml
===================================================================
--- trunk/blfs/postlfs/security/cyrus-sasl.xml	2011-06-05 19:15:20 UTC (rev 1334)
+++ trunk/blfs/postlfs/security/cyrus-sasl.xml	2011-06-07 12:29:52 UTC (rev 1335)
@@ -4,20 +4,20 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY cyrus-sasl-download-http "http://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-&cyrus-sasl-version;.tar.gz ">
+  <!ENTITY cyrus-sasl-download-http "http://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-&cyrus-sasl-version;.tar.gz">
   <!ENTITY cyrus-sasl-download-ftp  "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-&cyrus-sasl-version;.tar.gz">
-  <!ENTITY cyrus-sasl-md5sum        "45dde9d19193ae9dd388eb68b2027bc9">
-  <!ENTITY cyrus-sasl-size          "1.5 Mio">
-  <!ENTITY cyrus-sasl-buildsize     "14 Mio">
-  <!ENTITY cyrus-sasl-time          "0.2 SBU">
+  <!ENTITY cyrus-sasl-md5sum        "2eb0e48106f0e9cd8001e654f267ecbc">
+  <!ENTITY cyrus-sasl-size          "1.6 Mio">
+  <!ENTITY cyrus-sasl-buildsize     "17 Mio">
+  <!ENTITY cyrus-sasl-time          "0.3 SBU">
 ]>
 
 <sect1 id="cyrus-sasl" xreflabel="Cyrus SASL-&cyrus-sasl-version;">
   <?dbhtml filename="cyrus-sasl.html"?>
 
   <sect1info>
-    <othername>$LastChangedBy: randy $</othername>
-    <date>$Date: 2009-07-19 16:13:01 +0200 (dim 19 jui 2009) $</date>
+    <othername>$LastChangedBy: dj $</othername>
+    <date>$Date: 2010-10-17 19:55:40 +0200 (dim 17 oct 2010) $</date>
   </sect1info>
 
   <title>Cyrus SASL-&cyrus-sasl-version;</title>
@@ -69,14 +69,14 @@
     <para role="optional"><xref linkend="linux-pam"/>,
     <xref linkend="openldap"/>,
     <xref linkend="heimdal"/> or <xref linkend="mitkrb"/>,
-    <xref linkend="jdk"/>,
+    <xref linkend="icedtea6"/> or <xref linkend="jdk"/>,
     <xref linkend="mysql"/>,
     <xref linkend="postgresql"/>,
     <xref linkend="db"/>,
+    <xref linkend="sqlite"/>,
     <!-- <xref linkend="gdbm"/>,
     <xref linkend="courier"/>,  -->
-    <ulink url="http://www.pdc.kth.se/kth-krb/">krb4</ulink>,
-    <ulink url="http://sqlite.org/">SQLite</ulink> et
+    <ulink url="http://www.pdc.kth.se/kth-krb/">krb4</ulink>, et
     <ulink url="http://dmalloc.com/">Dmalloc</ulink></para>
 
     <para condition="html" role="usernotes">Notes utilisateur :
@@ -90,7 +90,10 @@
     <para>Installez <application>Cyrus SASL</application> en lançant les 
     commandes suivantes :</para>
 
-<screen><userinput>./configure --prefix=/usr --sysconfdir=/etc \
+<screen><userinput>sed -i.bak 's/#elif WITH_DES/#elif defined(WITH_DES)/' \
+    plugins/digestmd5.c &&
+./configure --prefix=/usr \
+            --sysconfdir=/etc \
             --with-dbpath=/var/lib/sasl/sasldb2 \
             --with-saslauthd=/var/run/saslauthd &&
 make</userinput></screen>
@@ -108,13 +111,18 @@
 install -v -m755 -d /usr/share/doc/cyrus-sasl-&cyrus-sasl-version; &&
 install -v -m644 doc/{*.{html,txt,fig},ONEWS,TODO} \
     saslauthd/LDAP_SASLAUTHD /usr/share/doc/cyrus-sasl-&cyrus-sasl-version; &&
-install -v -m700 -d /var/lib/sasl /var/run/saslauthd</userinput></screen>
+install -v -m700 -d /var/lib/sasl &&
+install -v -m711 -d /var/run/saslauthd</userinput></screen>
 
   </sect2>
 
   <sect2 role="commands">
     <title>Explication des commandes</title>
 
+    <para><command>sed -i.bak ... plugins/digestmd5.c</command>: Cela resoud un problème
+    de construction causé par l'utilisation des compilateurs récents.</para>
+
+ 
     <para><parameter>--with-dbpath=/var/lib/sasl/sasldb2</parameter> : Ce
     paramètre oblige la base de données <command>sasldb</command> à se créer 
     dans <filename class='directory'>/var/lib/sasl</filename> au lieu de
@@ -142,7 +150,7 @@
     installent la documentation qui n'est pas installée par la commande
     <command>make install</command>.</para>
 
-    <para><command>install -v -m700 -d /var/lib/sasl /var/run/saslauthd</command> :
+    <para><command>install -v -m700 -d /var/lib/sasl ... -m711 /var/run/saslauthd</command> :
     Ces répertoires doivent exister au démarrage de <command>saslauthd</command> ou
     pendant l'utilisation de l'extension sasldb. Si vous n'allez pas utiliser
     le démon ou les extensions, vous pouvez vous passer de la création de ce 

Modified: trunk/blfs/postlfs/security/gnupg2.xml
===================================================================
--- trunk/blfs/postlfs/security/gnupg2.xml	2011-06-05 19:15:20 UTC (rev 1334)
+++ trunk/blfs/postlfs/security/gnupg2.xml	2011-06-07 12:29:52 UTC (rev 1335)
@@ -4,21 +4,20 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnupg2-download-http "&sources-anduin-http;/g/gnupg-&gnupg2-version;.tar.bz2">
-  <!-- <!ENTITY gnupg2-download-http "http://public.ftp.planetmirror.com/pub/gnupg/gnupg-&gnupg2-version;.tar.bz2"> -->
+  <!ENTITY gnupg2-download-http " ">
   <!ENTITY gnupg2-download-ftp  "ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-&gnupg2-version;.tar.bz2">
-  <!ENTITY gnupg2-md5sum        "fc4377ca67e1bf687eeaf22e79c0b9d1">
-  <!ENTITY gnupg2-size          "3.6 Mio">
-  <!ENTITY gnupg2-buildsize     "65 Mio">
-  <!ENTITY gnupg2-time          "0.7 SBU">
+  <!ENTITY gnupg2-md5sum        "c1286e85b66349879dc4b760dd83e2f1">
+  <!ENTITY gnupg2-size          "3.8 Mio">
+  <!ENTITY gnupg2-buildsize     "60 Mio">
+  <!ENTITY gnupg2-time          "0.8 SBU">
 ]>
 
 <sect1 id="gnupg2" xreflabel="GnuPG-&gnupg2-version;">
   <?dbhtml filename="gnupg2.html"?>
 
   <sect1info>
-    <othername>$LastChangedBy: gdalziel $</othername>
-    <date>$Date: 2009-07-06 21:12:40 +0200 (lun 06 jui 2009) $</date>
+    <othername>$LastChangedBy: randy $</othername>
+    <date>$Date: 2011-01-18 01:13:43 +0100 (mar 18 jan 2011) $</date>
   </sect1info>
 
   <title>GnuPG-&gnupg2-version;</title>
@@ -39,6 +38,8 @@
     d'intégration de GnuPG d'OpenPGP et de S/MIME. Il n'entre pas en conflit
     avec une version de <xref linkend="gnupg"/> seulement OpenPGP installçe.</para>
 
+    &lfs65_built;
+
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
@@ -78,15 +79,18 @@
     <xref linkend="libgcrypt"/> et
     <xref linkend="libksba"/></para>
 
+    <bridgehead renderas="sect4">Recommandées</bridgehead>
+    <para role="recommended"><xref linkend="pinentry"/> (Exigence au moment de l'exécution
+    pour la plupart des fonctionnalités du paquet)</para>
+
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional"><xref linkend="openldap"/>,
     <xref linkend="libusb-compat"/>,
-    <xref linkend="curl"/> et
-    un <xref linkend="server-mail"/></para>
 
-    <bridgehead renderas="sect4">Facultatives (Exigence au moment de l'exécution
-    pour la plupart des fonctionnalités du paquet)</bridgehead>
-    <para role="optional"><xref linkend="pinentry"/></para>
+    <xref linkend="curl"/>,
+    <ulink url="http://www.chiark.greenend.org.uk/~ian/adns/">GNU
+    adns</ulink>, et un
+    <xref linkend="server-mail"/></para>
 
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/gnupg2"/></para>
@@ -99,17 +103,20 @@
     <para>Installez <application>GnuPG 2</application> en lançant les commandes
     suivantes :</para>
 
-<screen><userinput>./configure --prefix=/usr --libexecdir=/usr/lib/gnupg2 &&
-make</userinput></screen>
+<screen><userinput>./configure --prefix=/usr \
+            --libexecdir=/usr/lib/gnupg2 \
+            --docdir=/usr/share/doc/gnupg-&gnupg2-version; &&
+make
 
-    <para>Si vous avez installé <xref linkend="tetex"/> installed et si vous
-    souhaitez créer la documentation dans des  formats alternatifs, lancez les 
-    commandes suivantes :</para>
-
-<screen><userinput>make -C doc pdf ps html &&
 makeinfo --html --no-split -o doc/gnupg_nochunks.html doc/gnupg.texi &&
 makeinfo --plaintext       -o doc/gnupg.txt           doc/gnupg.texi</userinput></screen>
 
+    <para>Si vous avez installé <xref linkend="tetex"/> ou <xref linkend="texlive"/> 
+    installed et si vous souhaitez créer la documentation dans des  formats alternatifs, 
+    lancez les commandes suivantes :</para>
+
+<screen><userinput>make -C doc pdf ps html</userinput></screen>
+
     <para>Pour tester les résultats, lancez : <command>make check</command>.</para>
 
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
@@ -121,29 +128,35 @@
          chmod -v 4755 /usr/bin/gpg &&
     -->
 
-<screen role="root"><userinput>make install &&
+<screen role="root"><userinput>make install
+<screen role="root"><userinput>make install
 
+install -v -m755 -d /usr/share/doc/gnupg-&gnupg2-version;/html &&
+install -v -m644    doc/gnupg_nochunks.html \
+                    /usr/share/doc/gnupg-&gnupg2-version;/gnupg.html &&
+install -v -m644    doc/*.texi doc/gnupg.txt \
+                    /usr/share/doc/gnupg-&gnupg2-version;</userinput></screen>
+
+<!-- Documentation is installed by default -->
+
+<!-- <screen role="root"><userinput>make install &&
+ 
 install -v -m755 -d         /usr/share/doc/gnupg-&gnupg2-version; &&
 ln -sv ../../gnupg/FAQ      /usr/share/doc/gnupg-&gnupg2-version; &&
 ln -sv ../../gnupg/faq.html /usr/share/doc/gnupg-&gnupg2-version; &&
 
 install -v -m644 doc/{DETAILS,KEYSERVER,OpenPGP,TRANSLATE} \
-                            /usr/share/doc/gnupg-&gnupg2-version;</userinput></screen>
+                        /usr/share/doc/gnupg-&gnupg2-version;</userinput></screen> -->
 
     <para>Si vous avez créé des formats alternatifs de documentation,
     installez-les en utilisant la commande suivante en tant qu'utilisateur 
     <systemitem class="username">root</systemitem> :</para>
 
-<screen role="root"><userinput>install -v -m755 -d /usr/share/doc/gnupg-&gnupg2-version;/html       &&
-install -v -m644 doc/gnupg.html/* \
-                    /usr/share/doc/gnupg-&gnupg2-version;/html       &&
-install -v -m644 doc/gnupg_nochunks.html \
-                    /usr/share/doc/gnupg-&gnupg2-version;/gnupg.html &&
-install -v -m644 doc/*.texi \
-                    /usr/share/doc/gnupg-&gnupg2-version;            &&
-install -v -m644 doc/gnupg.{pdf,dvi,ps,txt} \
-                    /usr/share/doc/gnupg-&gnupg2-version;</userinput></screen>
-
+<screen role="root"><userinput>install -v -m644 doc/gnupg.html/* \
+                 /usr/share/doc/gnupg-&gnupg2-version;/html &&
+install -v -m644 doc/gnupg.{pdf,dvi,ps} \
+                 /usr/share/doc/gnupg-&gnupg2-version;</userinput></screen>
+ 
   </sect2>
 
   <sect2 role="commands">
@@ -154,6 +167,13 @@
     dans <filename class="directory">/usr/lib</filename> plutôt que dans
     <filename class="directory">/usr/libexec</filename>.</para>
 
+    <para><parameter>--docdir=/usr/share/doc/gnupg-&gnupg2-version;</parameter>:
+    Ce paramètre change le répertoire par défaut de la documentation<filename
+    class="directory">/usr/share/doc/gnupg-&gnupg2-version;</filename>.</para>
+
+    <para><parameter>--enable-symcryptrun</parameter>: Ce paramètre autorise la
+    construction du programme symcryptrun.</para>
+
     <!-- See above why this is no longer included
     <para><command>chmod -v 4755 /usr/bin/gpg</command>:
     <command>gpg</command> is installed setuid
@@ -177,7 +197,7 @@
         gpgv2, kbxutil, scdaemon, symcryptrun, et watchgnupg</seg>
         <seg>Aucune</seg>
         <seg>/usr/lib/gnupg2, /usr/share/gnupg et
-        /usr/share/doc/gnupg2-&gnupg2-version;</seg>
+        /usr/share/doc/gnupg-&gnupg2-version;</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/blfs/postlfs/security/gnutls.xml
===================================================================
--- trunk/blfs/postlfs/security/gnutls.xml	2011-06-05 19:15:20 UTC (rev 1334)
+++ trunk/blfs/postlfs/security/gnutls.xml	2011-06-07 12:29:52 UTC (rev 1335)
@@ -4,12 +4,12 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!ENTITY gnutls-download-http "http://www.gnu.org/software/gnutls/releases/gnutls-&gnutls-version;.tar.bz2">
+  <!ENTITY gnutls-download-http "http://mirrors.kernel.org/gnu/gnutls/gnutls-&gnutls-version;.tar.bz2">
   <!ENTITY gnutls-download-ftp  "ftp://ftp.gnutls.org/pub/gnutls/gnutls-&gnutls-version;.tar.bz2">
-  <!ENTITY gnutls-md5sum        "73da68a4248d34c4d38491ce2119af0f">
-  <!ENTITY gnutls-size          "4.2 Mio">
-  <!ENTITY gnutls-buildsize     "49 Mio">
-  <!ENTITY gnutls-time          "0.5 SBU">
+  <!ENTITY gnutls-md5sum        "777823f5746ab80cd6f7f7b5fcb2f91b">
+  <!ENTITY gnutls-size          "7.4 Mio">
+  <!ENTITY gnutls-buildsize     "100 Mio">
+  <!ENTITY gnutls-time          "1.3 SBU (ajouter 1.5 SBU pour exécuter la suite de tests)">
 ]>
 
 <sect1 id="gnutls" xreflabel="GnuTLS-&gnutls-version;">
@@ -17,7 +17,7 @@
 
   <sect1info>
     <othername>$LastChangedBy: randy $</othername>
-    <date>$Date: 2008-05-09 15:00:42 +0200 (ven, 09 mai 2008) $</date>
+    <date>$Date: 2011-01-03 22:38:16 +0100 (lun 03 jan 2011) $</date>
   </sect1info>
 
   <title>GnuTLS-&gnutls-version;</title>
@@ -48,6 +48,8 @@
     TLS Pre-Shared-Keys (PSK, clés prépartagées TLS), l'extension d'application
     Inner (TLS/IA) et la gestion des certificats X.509 et OpenPGP.</para>
 
+    &lfs65_checked;
+
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
@@ -77,17 +79,18 @@
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional"><xref linkend="gtk-doc"/>,
-    <ulink url="http://www.gnu.org/software/gnutls/download.html">OpenCDK</ulink>,
-    <ulink url="http://www.gnu.org/software/gnutls/download.html">Tiny ASN.1</ulink>,
-    <!-- <ulink url="http://platon.sk/projects/libcfg+">libcfg+</ulink>, -->
-    <ulink url="http://webscripts.softpedia.com/script/Development-Scripts-js/C-C-Library/libcfg--26570.html">libcfg+</ulink>,
-    <xref linkend="LZO"/> et
-    <ulink url="http://valgrind.org/">Valgrind</ulink> (used during the test suite)</para>
+    <xref linkend="guile"/>,
+    <xref linkend="libtasn1"/>,
+    <ulink url="http://webscripts.softpedia.com/script/Development-Scripts-js/C-C-Library/libcfg--26570.html">libcfg+</ulink>, et
+    <ulink url="http://valgrind.org/">Valgrind</ulink> (utilisé pendant la suite de tests)</para>
 
-    <bridgehead renderas="sect4">Facultatives Debugging Libraries</bridgehead>
-    <para role="optional"><ulink url="http://dmalloc.com/">Dmalloc</ulink> et
-    <ulink url="http://perens.com/FreeSoftware/ElectricFence/">Electric Fence</ulink></para>
+    <para>Notez que si vous installez <xref linkend="libtasn1"/>, une ancienne version chargée
+    dans l'archive de <application>GnuTLS</application> sera utilisée à la place.</para>
 
+    <!-- <bridgehead renderas="sect4">Facultatives Debugging Libraries</bridgehead>
+     <para role="optional"><ulink url="http://dmalloc.com/">Dmalloc</ulink> et
+       <ulink url="http://perens.com/FreeSoftware/ElectricFence/">Electric Fence</ulink></para> -->
+
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/gnutls"/></para>
 
@@ -107,30 +110,44 @@
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
 <screen role="root"><userinput>make install &&
-
-install -v -m755 -d /usr/share/doc/gnutls-&gnutls-version;/reference &&
-install -v -m644    doc/reference/html/* \
-                    /usr/share/doc/gnutls-&gnutls-version;/reference &&
-install -v -m644    doc/*.{html,png,eps,pdf,ps} \
+install -v -m755 -d /usr/share/doc/gnutls-&gnutls-version; &&
+install -v -m644    doc/*.{html,png,eps,pdf,ps} doc/cyclo/*.html \
+                    /usr/share/doc/gnutls-&gnutls-version; &&
+cp -v -R            doc/credentials \
                     /usr/share/doc/gnutls-&gnutls-version;</userinput></screen>
 
+    <para>Si vous ne passez pas le parametre <option>--enable-gtk-doc</option> dans le script
+    <command>configure</command>, installez la documentation de l'API en utilisant la commande
+    suivante en <systemitem class="username">root</systemitem> :</para>
+
+<screen role="root"><userinput>make -C doc/reference install-data-local</userinput></screen>
+
   </sect2>
 
+  <sect2 role="commands">
+    <title>Explications des commandes</title>
+
+    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude"
+    href="../../xincludes/gtk-doc-rebuild.xml"/>
+
+  </sect2>
+
   <sect2 role="content">
     <title>Contenu</title>
 
     <segmentedlist>
       <segtitle>Programmes installés</segtitle>
       <segtitle>Bibliothèques installées</segtitle>
-      <segtitle>Répertoire installé</segtitle>
+      <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
         <seg>certtool, gnutls-cli, gnutls-cli-debug, gnutls-serv,
-        libgnutls-config, libgnutls-extra-config, psktool, et srptool</seg>
+        psktool, et srptool</seg>
         <seg>libgnutls.{so,a}, libgnutls-extra.{so,a},
         libgnutls-openssl.{so,a}, et libgnutlsxx.{so,a}</seg>
-        <seg>/usr/include/gnutls et
-        /usr/share/doc/gnutls-&gnutls-version;</seg>
+        <seg>/usr/include/gnutls,
+        /usr/share/doc/gnutls-&gnutls-version;, et
+        /usr/share/gtk-doc/html/gnutls</seg>
       </seglistitem>
     </segmentedlist>
 
@@ -182,34 +199,6 @@
         </listitem>
       </varlistentry>
 
-      <varlistentry id="gnutls-config">
-        <term><command>gnutls-config</command></term>
-        <listitem>
-          <para>est un outil utilisé pour configurer et construire des
-          applications basées sur la bibliothèque gnutls(3). On peut l'utiliser pour
-          connaître le compilateur C et les drapeaux de l'éditeur de liens 
-          nécessaires pour compiler et éditer correctement les liens d'une
-          application liée à la bibliothèque gnutls(3).</para>
-          <indexterm zone="gnutls gnutls-config">
-            <primary sortas="b-gnutls-config">gnutls-config</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
-      <varlistentry id="gnutls-extra-config">
-        <term><command>gnutls-extra-config</command></term>
-        <listitem>
-          <para>est un outil utilisé pour configurer et construire des applications
-          basées sur la bibliothèque gnutls-extra(3). On peut l'utiliser pour
-          connaître le compilateur C et les drapeaux de l'éditeur de liens 
-          nécessaires pour compiler et éditer correctement les liens d'une
-          application liée à la bibliothèque gnutls-extra(3).</para>
-          <indexterm zone="gnutls gnutls-extra-config">
-            <primary sortas="b-gnutls-extra-config">gnutls-extra-config</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
       <varlistentry id="psktool">
         <term><command>psktool</command></term>
         <listitem>

Modified: trunk/blfs/postlfs/security/heimdal.xml
===================================================================
--- trunk/blfs/postlfs/security/heimdal.xml	2011-06-05 19:15:20 UTC (rev 1334)
+++ trunk/blfs/postlfs/security/heimdal.xml	2011-06-07 12:29:52 UTC (rev 1335)
@@ -6,10 +6,10 @@
 
   <!ENTITY heimdal-download-http "http://www.h5l.org/dist/src/heimdal-&heimdal-version;.tar.gz">
   <!ENTITY heimdal-download-ftp  "ftp://ftp.pdc.kth.se/pub/heimdal/src/heimdal-&heimdal-version;.tar.gz">
-  <!ENTITY heimdal-md5sum        "7892e97b346534cc9afeeee461fe3bab">
-  <!ENTITY heimdal-size          "3.6 Mio">
-  <!ENTITY heimdal-buildsize     "136 Mio">
-  <!ENTITY heimdal-time          "4.0 SBU (additional 1.5 SBU to run the test suite)">
++  <!ENTITY heimdal-md5sum        "31d08bbf47a77827fe97ef3f52b4c9c4">
++  <!ENTITY heimdal-size          "6.0 Mio">
++  <!ENTITY heimdal-buildsize     "205 Mio">
++  <!ENTITY heimdal-time          "3.9 SBU (ajouté 2.3 SBU pour exécuter la suite de tests)">
 ]>
 
 <sect1 id="heimdal" xreflabel="Heimdal-&heimdal-version;">
@@ -17,7 +17,7 @@
 
   <sect1info>
     <othername>$LastChangedBy: randy $</othername>
-    <date>$Date: 2009-07-19 16:13:01 +0200 (dim 19 jui 2009) $</date>
+    <date>$Date: 2011-01-18 01:13:43 +0100 (mar 18 jan 2011) $</date>
   </sect1info>
 
   <title>Heimdal-&heimdal-version;</title>
@@ -44,6 +44,8 @@
     <ulink url="&files-anduin;/heimdal-overwrites"/> pour une liste complète de
     tous les fichiers et de toutes les commandes pour renommer chacun d'eux.</para>
 
+    <para>&lfssvn_checked;20101029&lfssvn_checked2;</para>
+
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
       <listitem>
@@ -70,31 +72,29 @@
     <itemizedlist spacing='compact'>
       <listitem>
         <para>Correctif requis : <ulink
-        url="&patch-root;/heimdal-&heimdal-version;-blfs_docs-1.patch"/></para>
+        url="&patch-root;/heimdal-&heimdal-version;-otp_fixes-1.patch"/></para>
       </listitem>
-      <listitem>
+      <!-- <listitem>
         <para>Correctif requis : <ulink
         url="&patch-root;/heimdal-&heimdal-version;-libss-1.patch"/></para>
-      </listitem>
+      </listitem> -->
     </itemizedlist>
 
     <bridgehead renderas="sect3">Dépendances de Heimdal</bridgehead>
 
-    <bridgehead renderas="sect4">Requises pour construire les outils côté 
-    serveur</bridgehead>
-    <para role="required">
-    <xref linkend="db"/> (recommended) or GDBM (GDBM is installed in LFS)</para>
-    <!-- <xref linkend="db"/> is recommended (installed in LFS)
-    or <xref linkend="gdbm"/></para> -->
+    <para role="required"><xref linkend="db"/></para>
 
     <bridgehead renderas="sect4">Recommandées</bridgehead>
     <para role="recommended"><xref linkend="openssl"/></para>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional"><xref linkend="linux-pam"/>,
-    <xref linkend="openldap"/>,
-    <xref linkend="x-window-system"/> et
-    <ulink url="http://packages.debian.org/stable/source/libcap">libcap</ulink></para>
+    <para role="optional"><xref linkend="openldap"/>,
+    <xref linkend="sqlite"/>,
+    <xref linkend="x-window-system"/>,
+    <ulink url="http://www.kernel.org/pub/linux/libs/security/linux-privs/libcap2/">libcap2</ulink>, et
+    <ulink url="http://people.redhat.com/sgrubb/libcap-ng/">libcap-ng</ulink> (avec ce correctif
+    <ulink url="&patch-root;/libcap-ng-0.6.4-2.6.36_kernel_fix-1.patch"></ulink>
+    si la version du noyau linux est >=2.6.36)</para>
 
     <note>
       <para>Un outil de synchronisation de temps est nécessaire sur votre système 
@@ -121,8 +121,9 @@
     <para>Installez <application>Heimdal</application> en lançant les commandes
     suivantes :</para>
 
-<screen><userinput>patch -Np1 -i ../heimdal-&heimdal-version;-blfs_docs-1.patch &&
-patch -Np1 -i ../heimdal-&heimdal-version;-libss-1.patch &&
+<screen><userinput>patch -Np1 -i ../heimdal-&heimdal-version;-otp_fixes-1.patch &&
+sed -i 's|/var/heimdal|/var/lib/heimdal|' \
+       `grep -lr "/var/heimdal" doc kadmin kdc lib` &&
 
 ./configure --prefix=/usr \
             --sysconfdir=/etc/heimdal \
@@ -132,60 +133,58 @@
             --with-hdbdir=/var/lib/heimdal \
             --with-readline=/usr \
             --enable-kcm &&
-make</userinput></screen>
+make &&
+ 
+install -v -m755 -d doc/html                                    &&
+make -C doc html                                                &&
+mv -v doc/heimdal.html doc/html/heimdal                         &&
+mv -v doc/hx509.html   doc/html/hx509                           && 
+makeinfo --html --no-split -o doc/heimdal.html doc/heimdal.texi &&
+makeinfo --html --no-split -o doc/hx509.html   doc/hx509.texi   &&
+makeinfo --plaintext       -o doc/heimdal.txt  doc/heimdal.texi &&
+makeinfo --plaintext       -o doc/hx509.txt    doc/hx509.texi</userinput></screen>
 
-    <para>Si vous avez installé <xref linkend="tetex"/> et si vous souhaitez
-    créer des formats alternatifs de documentation, allez dans le répertoire
-    <filename class='directory'>doc</filename> et lancez tout ou partie
-    des commandes suivantes :</para>
+    <para>Si vous avez installé <xref linkend="tetex"/> ou <xref linkend="texlive"/>
+    et voulez créer la documentation au format PDF et Postscript,
+    modifiez dans le repertoire <filename class='directory'>doc</filename> et tapez 
+    quelques-une ou toutes les commandes suivantes :</para>>
++
++<screen><userinput>pushd doc                        &&
++texi2pdf            heimdal.texi &&
++texi2dvi            heimdal.texi &&
++dvips -o heimdal.ps heimdal.dvi  &&
++texi2pdf            hx509.texi   &&
++texi2dvi            hx509.texi   &&
++dvips -o hx509.ps   hx509.dvi    &&
 
-<screen><userinput>pushd doc                                        &&
-
-make html                                        &&
-
-texi2pdf                            heimdal.texi &&
-texi2dvi                            heimdal.texi &&
-dvips                -o heimdal.ps  heimdal.dvi  &&
-makeinfo --plaintext -o heimdal.txt heimdal.texi &&
-
-texi2pdf                            hx509.texi   &&
-texi2dvi                            hx509.texi   &&
-dvips                -o hx509.ps    hx509.dvi    &&
-makeinfo --plaintext -o hx509.txt   hx509.texi   &&
-
 popd</userinput></screen>
 
     <para>Pour tester les résultats, lancez : <command>make -k check</command>.
-    Le test <command>ipropd</command> est connu pour échouer mais tous les autres
+    Le test <command>check-iprop</command> est connu pour échouer mais tous les autres
     devraient réussir.</para>
 
     <para>Maintenant, en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
-<!-- <screen role="root"><?dbfo keep-together="auto"?><userinput>mv -v /usr/include/ss/ss.h   /usr/include/ss/ss.h.e2fsprogs &&
-mv -v /usr/lib/libss.a       /usr/lib/libss.a.e2fsprogs &&
-mv -v /usr/lib/libss.so      /usr/lib/libss.so.e2fsprogs &&
-mv -v /usr/bin/mk_cmds       /usr/bin/mk_cmds.e2fsprogs &&
 -->
-
 <screen role="root"><userinput>make install &&
 
-install -v -m755 -d /usr/share/doc/heimdal-&heimdal-version; &&
-install -v -m644    doc/{init-creds,layman.asc} \
-                    /usr/share/doc/heimdal-&heimdal-version; &&
+install -v -m755 -d /usr/share/doc/heimdal-&heimdal-version;        &&
+install -v -m644    doc/{heimdal,hx509}.{html,txt} \
+                    doc/{init-creds,layman.asc}    \
+                    /usr/share/doc/heimdal-&heimdal-version;        &&
+cp      -v -R       doc/html \
+                    destdir/usr/share/doc/heimdal-&heimdal-version; &&
 
-ln -sfv         mech.5 /usr/share/man/man5/qop.5  &&
-ln -sfv ../man5/mech.5 /usr/share/man/cat5/qop.5  &&
-ln -sfv ../man5/mech.5 /usr/share/man/cat5        &&
-
 mv -v /bin/login          /bin/login.SHADOW &&
 mv -v /bin/su             /bin/su.SHADOW    &&
 mv -v /usr/bin/{login,su} /bin              &&
 ln -v -sf ../../bin/login /usr/bin          &&
 
-for LINK in   lib{otp,kafs,krb5,hx509,asn1,roken,crypto}; do
-    mv -v     /usr/lib/${LINK}.so.* /lib &&
-    ln -v -sf ../../lib/$(readlink  /usr/lib/${LINK}.so) \
-              /usr/lib/${LINK}.so
+for LINK in   \
+    lib{otp,kafs,krb5,hx509,sqlite3,asn1,roken,crypto,wind}; do
+        mv -v     /usr/lib/${LINK}.so.* /lib &&
+        ln -v -sf ../../lib/$(readlink  /usr/lib/${LINK}.so) \
+                  /usr/lib/${LINK}.so
 done &&
 
 mv -v     /usr/lib/$(readlink /usr/lib/libdb.so) \
@@ -196,21 +195,11 @@
 
 ldconfig</userinput></screen>
 
-<!-- mv -v /usr/include/ss/ss.h            /usr/include/ss/ss.h.heimdal &&
-mv -v /usr/include/ss/ss.h.e2fsprogs  /usr/include/ss/ss.h &&
-mv -v /usr/lib/libss.a                /usr/lib/libss.a.heimdal &&
-mv -v /usr/lib/libss.a.e2fsprogs      /usr/lib/libss.a &&
-mv -v /usr/lib/libss.so               /usr/lib/libss.so.heimdal &&
-mv -v /usr/lib/libss.so.e2fsprogs     /usr/lib/libss.so &&
-mv -v /usr/lib/libss.la               /usr/lib/libss.la.heimdal &&
-mv -v /usr/bin/mk_cmds                /usr/bin/mk_cmds.heimdal &&
-mv -v /usr/bin/mk_cmds.e2fsprogs      /usr/bin/mk_cmds && -->
-
-    <para>Si vous avez construit un des formats alternatifs de la documentation,
+    <para>Si vous avez construit un des formats supplémentaire de la documentation,
     installez-le en utilisant les commandes suivantes en tant qu'utilisateur
     <systemitem class="username">root</systemitem> :</para>
 
-<screen role="root"><userinput>install -v -m644 doc/{heimdal,hx509}.{dvi,ps,pdf,html,txt} \
+<screen role="root"><userinput>install -v -m644 doc/{heimdal,hx509}.{dvi,ps,pdf} \
                  /usr/share/doc/heimdal-&heimdal-version;</userinput></screen>
 
     <para>Si vous souhaitez utiliser la bibliothèque <xref linkend="cracklib"/>
@@ -222,7 +211,7 @@
     -e 's|/usr/lib/cracklib_dict|/lib/cracklib/pw_dict|' \
     -e 's|/var/heimdal|/var/lib/heimdal|' \
         lib/kadm5/check-cracklib.pl \
-    > /bin/krb5-check-cracklib.pl &&
+     > /bin/krb5-check-cracklib.pl &&
 
 chmod -v 755 /bin/krb5-check-cracklib.pl</userinput></screen>
 
@@ -231,16 +220,12 @@
   <sect2 role="commands">
     <title>Explication des commandes</title>
 
-    <!-- <para><command>mv -v /usr/include/...</command>,
-    <command>mv -v /usr/lib/libss.* ...</command> et
-    <command>mv -v /usr/bin/mk_cmds ...</command>: The
-    <application>Heimdal</application> installation will overwrite an
-    interface header, static library, library symbolic link et a
-    shell script from the
-    <application>E2fsprogs</application> package. These commands rename the
-    original files before the installation, et then restore them (after
-    renaming the new <application>Heimdal</application> files) after the
-    installation.</para> -->
+    <para><command>sed -i ... `grep -lr "/var/heimdal"
+    doc kadmin kdc lib`</command>: Cette commande est utilisée pour changer dans les
+    fichiers de documentation les références codés en dur <filename class='directory'>
+    /var/heimdal</filename> par les noms de repertoire <filename class='directory'>
+    /var/lib/heimdal</filename> qui respecte la FHS.</para>
+ 
 
     <para><parameter>--libexecdir=/usr/sbin</parameter> : Ce paramètre a
     pour conséquence que les programmes s'installent dans
@@ -276,9 +261,16 @@
     <para><parameter>--enable-kcm</parameter> : Ce paramètre active la
     construction du Kerberos Credentials Manager (gestionnaire d'autorisations).</para>
 
-    <para><command>ln -sfv .../mech.5 /usr/share/man/...</command> : Ces
-    commandes sont utilisées pour corriger certains liens symboliques.</para>
+    <para><option>--with-sqlite3=/usr</option>: Ce paramètre doit être utilisé pour que le 
+    script <command>configure</command> localise proprement le paquet <application>Sqlite3
+    </application> installé.</para>
 
+    <para><option>--with-openldap=/usr</option> et
+    <option>--enable-hdb-openldap-module</option>: These parameters must be
+    used so that the <command>configure</command> script properly locates the
+    installed <application>OpenLDAP</application> package in order to build the
+    module allowing an LDAP backend database.</para>
+
     <para><command>mv ... ...SHADOW</command>, <command>mv ... /bin</command>
     et <command> ln ... /usr/bin</command> : Les programmes <command>login</command>
     et <command>su</command> installés par
@@ -432,10 +424,9 @@
 
 <screen role="root"><userinput>ext host/<replaceable><hostname.example.com></replaceable></userinput></screen>
 
-        <para>Cela devrait créer deux fichiers dans
+        <para>Cela devrait créer un fichier dans
         <filename class="directory">/etc/heimdal</filename> :
-        <filename>krb5.keytab</filename> (Kerberos 5) et
-        <filename>srvtab</filename> (Kerberos 4). Les deux fichiers devraient
+        nommé <filename>krb5.keytab</filename>. Ce fichiers devraient
         avoir les droits 600 (lecture et écriture pour root seulement). Préserver
         les fichiers de tables de clés hors d'accès du public est crucial pour 
         toute la sécurité de l'installation Kerberos.</para>
@@ -497,7 +488,7 @@
         <application>Perl</application> <application>Crypt::Cracklib</application>.
         Téléchargez-le sur le site de CPAN. Au moment d'écrire ce texte, 
         l'adresse est <ulink
-        url="http://cpan.org/authors/id/D/DA/DANIEL/Crypt-Cracklib-1.2.tar.gz"/>.
+        url="http://www.cpan.org/authors/id/D/DA/DANIEL/Crypt-Cracklib-1.2.tar.gz"/>.
         Après avoir déballé l'archive tar et être allé dans le répertoire 
         nouvellement créé, lancez la commande suivante pour ajouter l'emplacement
         du dictionnaire <application>Cracklib</application> de BLFS à un des
@@ -507,8 +498,7 @@
 
         <para>Puis utilisez les commandes standards <command>perl Makefile.PL</command>;
         <command>make</command>; <command>make test</command>;
-        <command>make install</command>. Remarquez qu'un test échoue pour une
-        raison inconnue.</para>
+        <command>make install</command>.</para>
 
         <para id="heimdal-init">Installez le script de démarrage
         <filename>/etc/rc.d/init.d/heimdal</filename> inclu dans le paquet
@@ -580,14 +570,14 @@
         popper, push, rcp, rsh, rshd, rxtelnet, rxterm, string2key, su,
         telnet, telnetd, tenletxr, verify_krb5_conf et xnlock</seg>
 
-        <seg>hdb_ldap.{so,a}, libasn1.{so,a}, libeditline.{so,a},
+        <seg>hdb_ldap.{so,a}, libasn1.{so,a},
         libgssapi.{so,a}, libhdb.{so,a}, libheimntlm.{so,a}, libhx509.{so,a},
         libkadm5clnt.{so,a}, libkadm5srv.{so,a}, libkafs.{so,a},
         libkdc.{so,a}, libkrb5.{so,a}, libotp.{so,a}, libroken.{so,a},
-        libsl.{so,a}, libss-krb5.{so,a} et windc.{so,a}</seg>
+        libsl.{so,a}, libss-krb5.{so,a} et wind.{so,a}</seg>
 
         <seg>/etc/heimdal, /usr/include/gssapi, /usr/include/kadm5,
-        /usr/include/krb5, /usr/include/roken, /usr/include/ss,
+        /usr/include/krb5, /usr/include/roken,
         /usr/share/doc/heimdal-&heimdal-version; et /var/lib/heimdal</seg>
       </seglistitem>
     </segmentedlist>
@@ -1072,17 +1062,6 @@
         </listitem>
       </varlistentry>
 
-      <varlistentry id="libeditline">
-        <term><filename class='libraryfile'>libeditline.a</filename></term>
-        <listitem>
-          <para>est une bibliothèque d'édition en ligne de commande avec 
-          historique.</para>
-          <indexterm zone="heimdal libeditline">
-            <primary sortas="c-libeditline">libeditline.a</primary>
-          </indexterm>
-        </listitem>
-      </varlistentry>
-
       <varlistentry id="libgssapi">
         <term><filename class='libraryfile'>libgssapi.{so,a}</filename></term>
         <listitem>




More information about the lfs-traducfr mailing list