[lfs-fr] r1472 - in trunk/blfs: . introduction/welcome multimedia/libdriv networking/netprogs postlfs/security x/lib xsoft/graphweb xsoft/other

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Ven 2 Déc 17:28:14 PST 2011


Author: jmengual
Date: 2011-12-03 02:28:14 +0100 (Sat, 03 Dec 2011)
New Revision: 1472

Modified:
   trunk/blfs/general.ent
   trunk/blfs/introduction/welcome/changelog.xml
   trunk/blfs/multimedia/libdriv/libvpx.xml
   trunk/blfs/networking/netprogs/netprogs.xml
   trunk/blfs/networking/netprogs/nfs-utils.xml
   trunk/blfs/networking/netprogs/rpcbind.xml
   trunk/blfs/postlfs/security/cyrus-sasl.xml
   trunk/blfs/x/lib/xulrunner.xml
   trunk/blfs/xsoft/graphweb/firefox.xml
   trunk/blfs/xsoft/graphweb/seamonkey.xml
   trunk/blfs/xsoft/other/thunderbird.xml
Log:
La mise a jour du jour (qui valide du 1er coup, miracle).



Modified: trunk/blfs/general.ent
===================================================================
--- trunk/blfs/general.ent	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/general.ent	2011-12-03 01:28:14 UTC (rev 1472)
@@ -3,7 +3,7 @@
 $Date: 2011-07-24 16:07:01 +0200 (dim 24 jui 2011) $
 -->
 
-<!ENTITY day          "01">                   <!-- Always 2 digits -->
+<!ENTITY day          "02">                   <!-- Always 2 digits -->
 <!ENTITY month        "12">                   <!-- Always 2 digits -->
 <!ENTITY year         "2011">
 <!ENTITY copyrightdate "2001-&year;">
@@ -55,7 +55,7 @@
 <!ENTITY lfs-vim-version              "7.3">
 <!-- End LFS versions -->
 
-<!ENTITY blfs-bootscripts-version     "20111126">
+<!ENTITY blfs-bootscripts-version     "20111201">
 <!ENTITY blfs-bootscripts-download    "&downloads-root;/blfs-bootscripts-&blfs-bootscripts-version;.tar.bz2">
 
 <!ENTITY blfs-wiki                    "http://wiki.&lfs-domainname;/blfs/wiki">
@@ -783,7 +783,7 @@
 <!ENTITY openoffice-version           "3.2.1">
 
 <!-- Chapter 36 -->
-<!ENTITY seamonkey-version            "2.0">
+<!ENTITY seamonkey-version            "2.5">
 <!ENTITY firefox-version              "8.0.1">
 <!ENTITY galeon-version               "2.0.1">
 
@@ -845,7 +845,7 @@
 <!ENTITY libmpeg2-version             "0.5.1">
 <!ENTITY libtheora-version            "1.1.1">
 <!ENTITY opal-version                 "3.6.8">
-<!ENTITY libvpx-version               "0.9.5">
+<!ENTITY libvpx-version               "0.9.7">
 
 <!-- Obsolete
 <!ENTITY openquicktime-version        "1.0">

Modified: trunk/blfs/introduction/welcome/changelog.xml
===================================================================
--- trunk/blfs/introduction/welcome/changelog.xml	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/introduction/welcome/changelog.xml	2011-12-03 01:28:14 UTC (rev 1472)
@@ -42,6 +42,18 @@
 
 -->
     <listitem>
+      <para>2 décembre 2011</para>
+      <itemizedlist>
+        <listitem>
+          <para>[abenton] - Mise à jour de seamonkey vers 2.5.</para>
+        </listitem>
+        <listitem>
+          <para>[abenton] - Mise à jour de libvpx vers v0.9.7.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
+    <listitem>
       <para>1er décembre 2011</para>
       <itemizedlist>
         <listitem>
@@ -50,7 +62,10 @@
         <listitem>
           <para>[abenton] - Ajout de yasm-1.2.0.</para>
         </listitem>
-
+        <listitem>
+          <para>[bdubbs] - Mises à jour des scripts de démarrage liés à nfs
+          Suppression de portmap au profit de rpcbind.</para>
+        </listitem>
       </itemizedlist>
     </listitem>
 

Modified: trunk/blfs/multimedia/libdriv/libvpx.xml
===================================================================
--- trunk/blfs/multimedia/libdriv/libvpx.xml	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/multimedia/libdriv/libvpx.xml	2011-12-03 01:28:14 UTC (rev 1472)
@@ -4,11 +4,9 @@
   <!ENTITY % general-entities SYSTEM "../../general.ent">
   %general-entities;
 
-  <!-- this can come out of the book when ffmpeg _releases_ a version that does not need it
-  for html5 on youtube -->
   <!ENTITY libvpx-download-http "http://webm.googlecode.com/files/libvpx-v&libvpx-version;.tar.bz2">
   <!ENTITY libvpx-download-ftp  " ">
-  <!ENTITY libvpx-md5sum        "4bf2f2c76700202c1fe9201fcb0680e3">
+  <!ENTITY libvpx-md5sum        "893d07d1bdedaac1ad2ab63d32de7d83">
   <!ENTITY libvpx-size          "1.2 Mio">
   <!ENTITY libvpx-buildsize     "25 MB (without the documentation)">
   <!ENTITY libvpx-time          "0.3 SBU">
@@ -34,7 +32,7 @@
     <para>Ce paquet fournit l'implementation de référencedu codec vp8
     pour le projet WebM , utilisé dans la plupart des vidéos html5 actuelles.</para>
 
-    &lfs67_checked;
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -60,9 +58,12 @@
 
     <bridgehead renderas="sect3">Dépendances de libvpx</bridgehead>
 
+    <para role="required"><xref linkend="yasm"/> (la compilation avec
+    <xref linkend="NASM"/> est actuellement cassée)</para>
+
     <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional"><xref linkend="doxygen"/> et
-    <xref linkend="php"/> (pour construire la documentation). </para>
+    <para role="optional"><xref linkend="doxygen"/> et <xref linkend="php"/>
+    (pour construire la documentation).</para>
 
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/libvpx"/></para>
@@ -91,7 +92,8 @@
   <sect2 role="commands">
     <title>Explications des commandes</title>
 
-    <para><command>mkdir ../libvpx-build && cd ../libvpx-build</command>:
+    <para><command>mkdir ../libvpx-build && cd
+    ../libvpx-build</command> :
     Les developpeurs de <application>libvpx</application> recommandent une construction dans un
     répertoire de construction dédié.</para>
 

Modified: trunk/blfs/networking/netprogs/netprogs.xml
===================================================================
--- trunk/blfs/networking/netprogs/netprogs.xml	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/networking/netprogs/netprogs.xml	2011-12-03 01:28:14 UTC (rev 1472)
@@ -31,7 +31,7 @@
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="nfs-utils-client.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="netfs.xml"/>
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="ntp.xml"/>
-  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="portmap.xml"/>
+<!--  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="portmap.xml"/>-->
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="rpcbind.xml"/>
 <!--  <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="rsync-client.xml"/> -->
   <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" href="rsync.xml"/>

Modified: trunk/blfs/networking/netprogs/nfs-utils.xml
===================================================================
--- trunk/blfs/networking/netprogs/nfs-utils.xml	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/networking/netprogs/nfs-utils.xml	2011-12-03 01:28:14 UTC (rev 1472)
@@ -58,42 +58,46 @@
       </listitem>
     </itemizedlist>
 
-    <!--
-    <bridgehead renderas="sect3">Téléchargements supplémentaires</bridgehead>
-    <itemizedlist spacing='compact'>
-      <listitem>
-        <para>Correctif requis : <ulink
-        url="&patch-root;/nfs-utils-&nfs-utils-version;-gcc4-1.patch"/></para>
-      </listitem>
-    </itemizedlist>
-    -->
-
     <bridgehead renderas="sect3">Dépendances de NFS Utilities</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
-    <para role="required"><xref linkend="rpcbind"/> (dépendance au moment de
-    l'exécution)</para>
+    <para role="required"> <xref linkend="libtirpc"/> et
+    <xref linkend="pkgconfig"/></para>
 
+   <para role="required">
+       <xref linkend="rpcbind"/> (dépendance au moment de l'exécution)
+     </para>
+
     <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional"><xref linkend="tcpwrappers"/></para>
+    <para role="optional"> 
+      <xref linkend="tcpwrappers"/>
+    </para>
 
     <bridgehead renderas="sect4">Facultatives for NFSv4 Support</bridgehead>
-    <para role="optional"><!-- <xref linkend="pkgconfig"/>, -->
-    <ulink url="http://www.monkey.org/~provos/libevent/">libevent</ulink> et
-    <ulink url="http://www.citi.umich.edu/projects/nfsv4/linux/">libnfsidmap</ulink>
+    <para role="optional">
+      <ulink url="http://www.monkey.org/~provos/libevent/">libevent</ulink> et
+      <ulink url="http://www.citi.umich.edu/projects/nfsv4/linux/">libnfsidmap</ulink>
  
     </para>
 
-    <bridgehead renderas="sect4">Facultatives for GSS (RPC Security) Support</bridgehead>
-    <para role="optional"><!-- <xref linkend="pkgconfig"/>-->,
-    <xref linkend="mitkrb"/> or
-    <xref linkend="heimdal"/> or
-    <ulink url="http://www.citi.umich.edu/projects/nfsv4/linux/">libgssapi</ulink> et
-    <ulink url="http://www.citi.umich.edu/projects/nfsv4/linux/">librpcsecgss</ulink></para>
+    <bridgehead renderas="sect4">Facultatives pour GSS (support de Sécurité RPC)</bridgehead>
+    <para role="optional">
+      <xref linkend="mitkrb"/> or
+      <xref linkend="heimdal"/> or
+      <ulink url="http://www.citi.umich.edu/projects/nfsv4/linux/">libgssapi</ulink>, et
+      <ulink url="http://www.citi.umich.edu/projects/nfsv4/linux/">librpcsecgss</ulink>
+    </para>
 
     <bridgehead renderas="sect4">Facultatives for SPKM-3 Support</bridgehead>
-    <para><ulink url="http://www.citi.umich.edu/projects/nfsv4/linux/">SPKM-3</ulink></para>
+    <para>
+      <ulink url="http://www.citi.umich.edu/projects/nfsv4/linux/">SPKM-3</ulink>
+    </para>
 
+     <bridgehead renderas="sect4">Facultatives pour le Support SPKM-3</bridgehead>
+    <para>
+      <ulink url="http://www.citi.umich.edu/projects/nfsv4/linux/">SPKM-3</ulink>
+    </para>
+
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/nfs-utils"/></para>
 
@@ -201,7 +205,7 @@
       <filename class="directory">/home</filename> via le réseau local,
       vous pouvez ajouter la ligne suivante :</para>
 
-<screen role="root"><userinput>/home <replaceable><192.168.0.0/255.255.255.0></replaceable>(rw,subtree_check,anonuid=99,anongid=99)</userinput></screen>
+<screen role="root"><userinput>/home <replaceable><192.168.0.0/24></replaceable>(rw,subtree_check,anonuid=99,anongid=99)</userinput></screen>
 
       <indexterm zone="nfs-utils nfs-utils-server-config">
         <primary sortas="e-etc-exportfs">/etc/exportfs</primary>
@@ -230,6 +234,9 @@
 KILLDELAY="10"</literal>
 EOF</userinput></screen>
 
+        <note><para>Les paramètres ci-dessus peuvent être mis, éventuellement,
+        dans <filename>/etc/sysconfig/rc.site</filename>.</para></note>
+
         <indexterm zone="nfs-utils nfs-utils-server-init">
           <primary
           sortas="e-etc-sysconfig-nfs-server">/etc/sysconfig/nfs-server</primary>
@@ -243,7 +250,7 @@
         <para>Sf vous avez installé <xref linkend="tcpwrappers"/> et s'il y
         a un fichier <filename>/etc/hosts.deny</filename> correspondant, assurez-vous
         d'avoir une entrée dans le fichier <filename>/etc/hosts.allow</filename> 
-        pour un accès à partir du démon portmap. Voir la page de man dans la
+        pour un accès à partir du démon rpcbind. Voir la page de man dans la
         section 5 pour hosts_access pour des détails sur la création de
         règles adaptées.</para>
 
@@ -271,6 +278,9 @@
       <sect4  id="nfs-utils-client-init">
         <title>Script de démarrage</title>
 
+        <note><para>Le script de démarrage suivant n'est pas requis si vous avez
+        installé le script nfs-server.</para></note>
+
         <para>Installez le script de démarrage <filename>/etc/rc.d/init.d/nfs-client</filename>
         fourni dans le paquet <xref linkend="bootscripts"/> pour lancer les
         services clients au démarrage.</para>

Modified: trunk/blfs/networking/netprogs/rpcbind.xml
===================================================================
--- trunk/blfs/networking/netprogs/rpcbind.xml	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/networking/netprogs/rpcbind.xml	2011-12-03 01:28:14 UTC (rev 1472)
@@ -73,6 +73,12 @@
   <sect2 role="installation">
     <title>Installation de rpcbind</title>
 
+    <para>Pour faire fonctionner <application>rpcbind</application> correctement,
+    corrigez d'abord <filename>/etc/services</filename>. En tant qu'utilisatekr
+    <systemitem class="username">root</systemitem> :</para>
+
+<screen><userinput>sed -i 's/^sunrpc/rpcbind' /etc/services</userinput></screen>
+
     <para>Installez <application>rpcbind</application> en lançant les commandes
     suivantes :</para>
 

Modified: trunk/blfs/postlfs/security/cyrus-sasl.xml
===================================================================
--- trunk/blfs/postlfs/security/cyrus-sasl.xml	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/postlfs/security/cyrus-sasl.xml	2011-12-03 01:28:14 UTC (rev 1472)
@@ -92,6 +92,8 @@
 
 <screen><userinput>sed -i.bak 's/#elif WITH_DES/#elif defined(WITH_DES)/' \
     plugins/digestmd5.c &&
+sed -i 's#DB_VERSION_MAJOR == 4.*#(&) || DB_VERSION_MAJOR == 5#' \
+    {sasldb/db_berkeley.c,utils/dbconverter-2.c} &&
 ./configure --prefix=/usr \
             --sysconfdir=/etc \
             --with-dbpath=/var/lib/sasl/sasldb2 \
@@ -121,8 +123,10 @@
 
     <para><command>sed -i.bak ... plugins/digestmd5.c</command>>:nbsp;: Cela resoud un problème
     de construction causé par l'utilisation des compilateurs récents.</para>
+ 
+    <para><command>sed -i 's#DB_VERSION_MAJOR ...</command> : Ceci corrige
+    la compilation contre la version 5 de <xref linkend="db"/>.</para>
 
- 
     <para><parameter>--with-dbpath=/var/lib/sasl/sasldb2</parameter> : Ce
     paramètre oblige la base de données <command>sasldb</command> à se créer 
     dans <filename class='directory'>/var/lib/sasl</filename> au lieu de
@@ -150,7 +154,8 @@
     installent la documentation qui n'est pas installée par la commande
     <command>make install</command>.</para>
 
-    <para><command>install -v -m700 -d /var/lib/sasl ... -m711 /var/run/saslauthd</command> :
+    <para><command>install -v -m700 -d /var/lib/sasl ...
+    -m711 /var/run/saslauthd</command> :
     Ces répertoires doivent exister au démarrage de <command>saslauthd</command> ou
     pendant l'utilisation de l'extension sasldb. Si vous n'allez pas utiliser
     le démon ou les extensions, vous pouvez vous passer de la création de ce 

Modified: trunk/blfs/x/lib/xulrunner.xml
===================================================================
--- trunk/blfs/x/lib/xulrunner.xml	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/x/lib/xulrunner.xml	2011-12-03 01:28:14 UTC (rev 1472)
@@ -79,8 +79,7 @@
 
     <bridgehead renderas="sect4">Recommandées</bridgehead>
     <para role="recommended"><xref linkend="yasm"/> ou
-    <ulink url="http://www.webmproject.org/code/">libvpx</ulink>, qui exige
-    <application>Yasm</application>.</para>
+    <xref linkend="libvpx"/>.</para>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional"><xref linkend="dbus-glib"/>,

Modified: trunk/blfs/xsoft/graphweb/firefox.xml
===================================================================
--- trunk/blfs/xsoft/graphweb/firefox.xml	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/xsoft/graphweb/firefox.xml	2011-12-03 01:28:14 UTC (rev 1472)
@@ -82,8 +82,8 @@
  
     <bridgehead renderas="sect4">Recommandées</bridgehead>
     <para role="recommended"><ulink url="http://yasm.tortall.net/">Yasm</ulink>
-    ou <ulink url="http://www.webmproject.org/code/">libvpx</ulink>, qui exige
-    <application>Yasm</application>.</para>
+    ou <xref linkend="libvpx"/> (pour que <application>Firefox</application> 
+    lise des vidéos webm).</para>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
     <para role="optional"><xref linkend="dbus-glib"/>,
@@ -119,7 +119,7 @@
 
 <screen><?dbfo keep-together="auto"?><userinput>cat > mozconfig << "EOF"
 # Si vous avez une machine multic½urs, vous pouvez accélérer la
-# construction en lançant plusieurs tâches en même temps, mais vous n'avez qu'un
+# construction en lançant plusieurs tâches en même temps, mais si vous n'avez qu'un
 # coeur, effacez cette ligne :
 mk_add_options MOZ_MAKE_FLAGS="-j4"
 
@@ -255,6 +255,19 @@
 
   </sect2>
 
+  <sect2 role="configuration">
+    <title>Configuration de Firefox</title>
+
+    <para>Si vous avez enlevé l'option <option>--disable-webm</option> de votre
+    <filename>mozconfig</filename>, votre <application>Firefox</application>
+    lire la plupart des vidéos YouTube sans le plugin flash. Pour activer ceci,
+    allez sur <ulink
+    url="http://www.youtube.com/html5">http://www.youtube.com/html5</ulink>
+    et cliquez sur 'Rejoindre le test HTML5' (exige l'activation des
+    cookies).</para>
+
+  </sect2>
+
   <sect2 role="content">
     <title>Contenu</title>
 

Modified: trunk/blfs/xsoft/graphweb/seamonkey.xml
===================================================================
--- trunk/blfs/xsoft/graphweb/seamonkey.xml	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/xsoft/graphweb/seamonkey.xml	2011-12-03 01:28:14 UTC (rev 1472)
@@ -6,14 +6,10 @@
 
   <!ENTITY seamonkey-download-http      "http://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/&seamonkey-version;/source/seamonkey-&seamonkey-version;.source.tar.bz2">
   <!ENTITY seamonkey-download-ftp       "ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/&seamonkey-version;/source//seamonkey-&seamonkey-version;.source.tar.bz2">
-  <!ENTITY seamonkey-md5sum             "494608587e3ba4e4cc2e754d95154435">
+  <!ENTITY seamonkey-md5sum             "f0f0dd652ad5ee9458d86aeb626615bd">
   <!ENTITY seamonkey-size               "57.5 Mio">
-  <!ENTITY seamonkey-buildsize          "844 Mio">
-  <!ENTITY seamonkey-time               "10.8 SBU">
-<!--
-  <!ENTITY seamonkey-enigmail-version   "0.95.6">
-  <!ENTITY seamonkey-enigmail-download  "http://www.mozilla-enigmail.org/download/source/enigmail-&seamonkey-enigmail-version;.tar.gz">
-  <!ENTITY seamonkey-enigmail-md5sum    "cfbe6ff77f80a349b396829757ad952a"> -->
+  <!ENTITY seamonkey-buildsize          "3 Gio (46 Mio installés)">
+  <!ENTITY seamonkey-time               "23.7 SBU">
 ]>
 
 <sect1 id="seamonkey" xreflabel="SeaMonkey-&seamonkey-version;">
@@ -48,17 +44,9 @@
     et <ulink url="http://www.mozilla.com/thunderbird/">Mozilla
     Thunderbird</ulink>, (un client de messagerie/nouvelles/groupe autonome basé
     sur a le code source de
-    <application>Mozilla</application>). Les instructions pour ces deux
-    applications sont données dans des sections séparées :</para>
+    <application>Mozilla</application>).</para>
 
-    <itemizedlist>
-      <listitem>
-        <para><xref linkend="firefox"/></para>
-      </listitem>
-      <listitem>
-        <para><xref linkend="thunderbird"/></para>
-      </listitem>
-    </itemizedlist>
+    &lfs70_checked;
 
     <bridgehead renderas="sect3">Informations sur le paquet</bridgehead>
     <itemizedlist spacing="compact">
@@ -81,49 +69,39 @@
         <para>Estimation du temps de construction : &seamonkey-time;</para>
       </listitem>
     </itemizedlist>
-<!--
-    <para>Pour activer l'extension <application>Enigmail</application> du
-    client de messagerie <application>SeaMonkey</application>, vous devrez 
-    télécharger l'archive tar ci-dessous. L'extension <application>Enigmail</application> 
-    permet aux utilisateurs d'accéder aux fonctionnalitésd'authentication et
-    de chiffrement fournies par le paquet <application>GnuPG</application>.
-    L'extension <application>Enigmail</application> agira correctement sauf si
-    vous avez installé <xref linkend="gnupg"/> ou <xref linkend="gnupg2"/>.</para>
 
-    <itemizedlist spacing='compact'>
-      <listitem>
-        <para><ulink url="&seamonkey-enigmail-download;"/></para>
-      </listitem>
-      <listitem>
-        <para>Somme de contrôle MD5 du téléchargement  (Enigmail) : &seamonkey-enigmail-md5sum;</para>
-      </listitem>
-    </itemizedlist>
--->
     <bridgehead renderas="sect3">Dépendances de SeaMonkey</bridgehead>
 
     <bridgehead renderas="sect4">Requises</bridgehead>
-    <para role="required"><xref linkend="gtk2"/>,
-    <xref linkend="libidl"/> et
-    <xref linkend="zip"/></para>
+    <para role="required"><xref linkend="alsa-lib"/>, <xref linkend="gtk2"/>,
+    <xref linkend="libidl"/>, and <xref linkend="zip"/></para>
 
     <note>
-      <para>Vous devriez avoir installé <xref linkend="libjpeg"/> avant 
-      <application>GTK+</application> et il devrait exister sur votre système.
-      Si pour une raison quelconque, vous n'avez pas installé <application>libjpeg</application>,
-      vous devriez supprimer l'option <option>--with-system-jpeg</option> 
+      <para>Vous devriez avoir installé <application>libjpeg</application> et
+      <application>libpng</application> (corrigé pour le support apng)
+      <application>gdk-pixbuf</application> et il devrait exister sur votre système.
+      Si pour une raison quelconque, vous ne les avez pas installées,
+      vous devriez supprimer les options <option>--with-system-jpeg</option> et
+      <option>--with-system-png</option>
       du fichier <filename>.mozconfig</filename> créé ci-dessous.</para>
     </note>
 
     <bridgehead renderas="sect4">Recommandées</bridgehead>
-    <para role="recommended"><xref linkend="nss"/> (si vous installerez un autre
-    paquet qui utilise NSS/NSPR, tel que
-    <application>Firefox</application>, <application>Thunderbird</application>,
-    <application>Evolution</application>, ou
-    <application>OpenOffice</application>)</para>
+    <para role="recommended"><xref linkend="yasm"/> ou
+    <xref linkend="libvpx"/> (pour permettre à <application>Seamonkey</application> to
+    de lire des vidéos webm).</para>
 
     <bridgehead renderas="sect4">Facultatives</bridgehead>
-    <para role="optional"><xref linkend="unzip"/> et
-    <xref linkend="libgnomeui"/> (to build the gnomevfs extension)</para>
+    <para role="optional"><xref linkend="dbus-glib"/>,
+    <xref linkend="startup-notification"/>, <xref linkend="sqlite"/>,
+    <ulink url="http://www.webmproject.org/code/">libvpx</ulink>,
+    <ulink url="http://sourceforge.net/projects/hunspell/">Hunspell</ulink>,
+    <xref linkend="doxygen"/>, <xref linkend="gnome-vfs"/> et
+    <xref linkend="libgnomeui"/> (pour l'intégration dans gnome),
+    <xref linkend="libnotify"/>, <xref linkend="nspr"/>, <xref linkend="nss"/>,
+    <xref linkend="unzip"/>, <xref linkend="wireless_tools"/>,
+    <ulink url="http://www.valgrind.org/">Valgrind</ulink> (seulement pour
+    tester le code jemalloc) et <xref linkend="wget"/></para>
 
     <para condition="html" role="usernotes">Notes utilisateur :
     <ulink url="&blfs-wiki;/seamonkey"/></para>
@@ -134,266 +112,86 @@
     <title>Installation de SeaMonkey</title>
 
     <para>La configuration de <application>SeaMonkey</application> se fait en
-    créant un fichier <filename>.mozconfig</filename> contenant les options de
-    configuration désirées. Un fichier <filename>.mozconfig</filename> par défaut
+    créant un fichier <filename>mozconfig</filename> contenant les options de
+    configuration désirées. Un fichier <filename>mozconfig</filename> par défaut
     est créé ci-dessous. Pour voir toute la liste des options de configuration 
     disponibles (et une description abrégée de chacune), exécutez
-    <command>./configure --help</command>. Vous pouvez trouver des informations
-    supplémentaires ci-dessous, dans la section intitulée <xref linkend="add-mozconfig"/>.
-    Si vous allez utiliser les versions
-    installées sur le système des bibliothèques <application>NSS</application> et
-    <application>NSPR</application>, assurez-vous de décommenter les deux lignes
-    vers la fin du fichier. Si vous préférez
-    télécharger le fichier au lieu de le créer en tapant ou en copiant/collant
-    vous pouvez le trouver sur <ulink
-    url="&files-anduin;/seamonkey-&seamonkey-version;-mozconfig"/>
-    (il faut mettre le fichier à la racine de l'arborescence des sources du
-    répertoire <filename class='directory'>mozilla</filename>, et l'appeler
-    <filename>.mozconfig</filename>). Créez le fichier en exécutant la
-    commande suivante :</para> 
+    <command>./configure --help</command>. Il se peut que vous vouliez aussi 
+    relire tout le fichier et
+    décommenter d'autres options souhaitées. Créez le fichier en lançant la
+    commande suivante :</para>
 
 <screen><?dbfo keep-together="auto"?><userinput>cat > .mozconfig << "EOF"
-<literal># Ce fichier contient les options utilisées dans la construction de SeaMonkey
-# Utilisez les informations fournies par l'exécution de './configure --help' 
-# pour vous aider à déterminer si vous avez besoin d'ajouter des options
-# supplémentaires.
-# On peut ajouter des options supplémentaires en décommentant les exemples dans
-# ce fichier ou en ajoutant des options en insérant une ligne contenant 
-# 'ac_add_options --une-option-dont-vous-avez-besoin'.  
+# Si vous avez une machine multic½urs, vous pouvez accélérer la
+# construction en lançant plusieurs tâches en même temps, mais si vous n'avez qu'un
+# coeur, effacez cette ligne :
+mk_add_options MOZ_MAKE_FLAGS="-j4"
 
-# Crée un répertoire objet et spécifie de construire le paquet dans ce
-# répertoire. Si désiré, modifiez l'emplacement du répertoire objet pour un 
-# répertoire à l'intérieur de l'arborescence des sources en supprimant '../' 
-# de la ligne ci-dessous.
-mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../seamonkey-build
+# Si vous avez installé Yasm effacez cette option :
+ac_add_options --disable-webm
 
-# Cette option est utilisée pour spécifier que la suite SeaMonkey va être
-# construite et pour utiliser toutes les options par défaut pour SeaMonkey.
-ac_add_options --enable-application=suite
+# Si vous avez installé DBus-Glib effacez cette option :
+ac_add_options --disable-dbus
 
-# Spécifie le préfixe d'installation. Si vous préférez installer Xulrunner dans
-# un autre préfixe, modifiez la ligne ci-dessous pour l'adapter à vos besoins.
-# Vous devrez aussi modifier certaines des instructions du livre BLFS 
-# pour pointer vers le préfixe désiré.
-ac_add_options --prefix=/usr
+# Si vous avez installé wireless-tools effacez cette option :
+ac_add_options --disable-necko-wifi
 
-# Ces options sont utilisées pour que les binaires de Seamonkey soient
-# liés aux copies installées du système des bibliothèques spécifiées et non au
-# code source qui peut ne pas être les versions les plus récentes.
-ac_add_options --with-system-zlib
-ac_add_options --with-system-png
-ac_add_options --with-system-jpeg
-ac_add_options --enable-system-cairo
+# Si vous avez installé libnotify effacez cette option :
+ac_add_options --disable-libnotify
 
-# Cette option spécifie d'inclure le support pour afficher le tag HTML
-# <canvas></canvas> dans le navigateur SeaMonkey.
-ac_add_options --enable-canvas
+# Si vous avez installé nss et nspr, décommentez ces deux lignes:
+# ac_add_options --with-system-nspr
+# ac_add_options --with-system-nss
 
-# Cette option est utilisé pour que les symboles de débogage soient supprimés
-# des binaires installés lors du processus d'installation. Commentez cette
-# option s'il se peut que vous ayez besoin de garder les symboles de débogage
-# dans les binaires installés. Remarquez que cela peut augmenter 
-# substantiellement la taille des binaires installés.
-ac_add_options --enable-strip
+# Décommentez ceci si vous les avez installé :
+# ac_add_options --enable-system-sqlite
+# ac_add_options --enable-system-lcms
+# ac_add_options --with-system-libvpx
+# ac_add_options --enable-startup-notification
 
-# Cette option est ajoutée pour que les bibliothèques et les programmes de test
-# ne se construisent pas. Ils ne serviraient que pour du débogage.
-ac_add_options --disable-tests
-
-# Cette option est ajoutée pour que le programme d'installation de Mozilla 
-# ne soit pas construit ou installé. Le programme n'est pas nécessaire pour une
-# installation BLFS de SeaMonkey.
+mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/firefox-build-dir
+ac_add_options --enable-official-branding
+ac_add_options --enable-application=suite
+ac_add_options --enable-pthreads
+ac_add_options --enable-system-ffi
+ac_add_options --enable-system-jpeg
+ac_add_options --enable-system-png
+ac_add_options --enable-system-cairo
+ac_add_options --enable-system-zlib
+ac_add_options --enable-shared
+ac_add_options --disable-static
+ac_add_options --disable-debug
+ac_add_options --disable-crashreporter
 ac_add_options --disable-installer
-
-# Cette option est utilisée pour désactiver le support d'accessibilité dans les
-# binaires de Xulrunner. Commentez cette option si vous voulez le support 
-# d'accessibilité.
-ac_add_options --disable-accessibility
-
-# Cette option est utilisée pour activer le support de l'affichage des fichiers
-# SVG dans le navigateur SeaMonkey.
-ac_add_options --enable-svg
-
-# Cette option est utilisée pour activer dans les binaires SeaMonkey le support
-# LDAP inclus dans l'arborescence des sources.
-ac_add_options --enable-ldap
-
-# Ces deux options activent le support pour la construction de Xulrunner avec
-# les versions installées sur le système des bibliothèques du
-# Network Security Services (NSS) et Netscape Portable Runtime (NSPR).
-# Décommentez les deux lignes pour activer le support de NSS/NSPR installé
-# sur le système.
-#ac_add_options --with-system-nspr
-#ac_add_options --with-system-nss
-
-# Décommentez cette option si vous désirez le support de l'affichage sur deux
-# écrans en même temps en utilisant les bibliothèques Xinerama de X-Window.
-#ac_add_options --enable-xinerama
-
-# Des scripts complexes tels que Thai ne peuvent être pris en charge dans 
-# SeaMonkey qu'avec l'aide de Pango. Cette option ralentit beaucoup la prise en
-# charge, donc ne l'utilisez que si nécessaire.
-#ac_add_options --enable-pango
-
-# Cette option identifie le répertoire par défaut des binaires de l'installation
-# de Seamonkey et utilisé pour localiser les fichiers installés de Seamonkey.
-# Cette option n'est pas exigée pour la navigation de l'utilisateur final et
-# n'est utilisée que pour du développement.
-#ac_add_options --with-default-mozilla-five-home=/usr/lib/seamonkey-&seamonkey-version;</literal>
-
+ac_add_options --disable-updater
+ac_add_options --disable-tests
 EOF</userinput></screen>
 
     <para>Compilez <application>SeaMonkey</application> en lançant la commande
     suivante :</para>
 
-<screen><userinput> make -f client.mk build</userinput></screen>
-<!--
-    <para>Si vous construisez le client de messagerie/nouvelles/groupe 
-    <application>SeaMonkey</application> et si vous envisagez d'installer
-    l'extension <application>Enigmail</application>, lancez les commandes
-    suivantes :</para>
+<screen><userinput>make -f client.mk &&
+make -C moz-build-dir/suite/installer</userinput></screen>
 
-<screen><userinput>tar -xf ../enigmail-&seamonkey-enigmail-version;.tar.gz -C mailnews/extensions &&
-
-( cd mailnews/extensions/enigmail && ./makemake -r ) &&
-
-make -C ../seamonkey-build/mailnews/extensions/enigmail &&
-make -C ../seamonkey-build/mailnews/extensions/enigmail \
-        XPIFILE=enigmail-&seamonkey-enigmail-version;.xpi xpi</userinput></screen>
--->
     <para>Ce paquet n'est pas fourni avec une suite de tests. Néanmoins, on peut
     le lancer à partir du répertoire de construction avant de l'installer avec
     la ligne de commande :
-    <userinput>../seamonkey-build/mozilla/dist/seamonkey/seamonkey</userinput>.</para>
+    <userinput>moz-build-dir/mozilla/dist/seamonkey/seamonkey</userinput></para>
 
     <para>Installez <application>SeaMonkey</application> en lançant les
     commandes suivantes en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
 
-<screen role="root"><userinput>make -f client.mk install &&
+<screen role="root"><userinput>mkdir -p /usr/lib/seamonkey-&seamonkey-version; &&
+tar -xf moz-build-dir/mozilla/dist/seamonkey*.tar.bz2 \
+  -C /usr/lib/seamonkey-&seamonkey-version; --strip-components=1 &&
+mkdir -p /usr/lib/mozilla/plugins &&
+ln -s ../mozilla/plugins /usr/lib/seamonkey-&seamonkey-version; &&
+ln -sf ../lib/seamonkey-&seamonkey-version;/seamonkey /usr/bin &&
+cp moz-build-dir/mozilla/dist/man/man1/seamonkey.1 /usr/share/man/man1</userinput></screen>
 
-install -v -m644 ../seamonkey-build/mozilla/dist/public/ldap-private/* \
-    /usr/include/seamonkey-&seamonkey-version;/ldap</userinput></screen>
 
-    <para>Si vous avez construit <application>SeaMonkey</application> en
-    utilisant les bibliothèques NSS et NSPR installées sur le système, les 
-    fichiers <filename>seamonkey-ns*.pc</filename> de <application>pkgconfig</application>
-    sont cassés car ils pointent vers les mauvais répertoires où se trouve les 
-    bibliothèques et les en-têtes d'interface définitifs. Lancez les commandes
-    suivantes en tant qu'utilisateur <systemitem class="username">root</systemitem> 
-    pour remplacer les fichiers cassés par des liens symboliques vers les bons
-    fichiers connus :</para>
-
-<screen role="root"><userinput>ln -v -sf nss.pc /usr/lib/pkgconfig/seamonkey-nss.pc &&
-ln -v -sf nspr.pc /usr/lib/pkgconfig/seamonkey-nspr.pc</userinput></screen>
-
-    <para>Si vous <emphasis role="strong">N'avez PAS</emphasis> construit
-    <application>seamonkey</application> en utilisant les bibliothèques NSS et
-    NSPR installées sur le système, effectuez les commandes suivantes en tant
-    qu'utilisateur <systemitem class="username">root</systemitem> pour installer
-    les en-têtes d'interface NSS :</para>
-
-<screen role="root"><userinput>install -v -m755 -d /usr/include/seamonkey-&seamonkey-version;/nss &&
-cp -v -Lf ../seamonkey-build/mozilla/dist/{private,public}/nss/*.h \
-   /usr/include/seamonkey-&seamonkey-version;/nss</userinput></screen>
-<!--
-    <para>Si vous avez construit l'extension <application>Enigmail</application>,
-    lancez les commandes suivantes en tant qu'utilisateur <systemitem
-    class="username">root</systemitem> pour installer le fichier
-    <filename>.xpi</filename> dans le répertoire
-    <filename class='directory'>/usr/lib/seamonkey-&seamonkey-version;/xpi_store</filename> :</para>
-
-<screen role="root"><userinput>install -v -m644 -D ../seamonkey-build/dist/bin/enigmail-&seamonkey-enigmail-version;.xpi \
-    /usr/lib/seamonkey-&seamonkey-version;/xpi_store/enigmail-&seamonkey-enigmail-version;.xpi</userinput></screen>
-
-      <para>Vous pouvez utiliser deux méthodes pour installer l'extension
-      <application>Enigmail</application>. Les deux sont présentées ici et elles
-      offrent les mêmes fonctionnalités avec une différence majeure. La
-      première méthode installera les extensions de façon globale et tous les
-      utilisateurs de SeaMonkey auront un client de messagerie où Enigmail est
-      activé. La méthode présentée plus loin ne l'installe que sur une base
-      individuelle. Il faut pratiquer la première méthode maintenant (avant de
-      supprimer le répertoire objet) et utiliser la commande
-      <command>make install</command> command habituelle pour installer les
-      fichiers <application>Enigmail</application> directement depuis le 
-      répertoire de la distribution du répertoire objet. L'autre méthode est 
-      présentée car elle installe en utilisant le <filename class='extension'>.xpi</filename>
-      créé ci-dessus et on peut la pratiquer plus tard (quand vous le voudrez)
-      vu que le fichier utilisé pour installer <application>Enigmail</application> 
-      a été copié dans <filename
-      class='directory'>/usr/lib/seamonkey-&seamonkey-version;/xpi_store</filename>
-      à l'étape précédente. On peut utiliser cette méthode pour installer une
-      extension <application>Mozilla</application> téléchargée distribuée
-      dans un fichier <filename class='extension'>.xpi</filename>. Il y a
-      beaucoup d'extensions disponibles pour <application>SeaMonkey</application>. 
-      Vous pouvez trouver une liste qui en contient beaucoup sur
-      <ulink url="http://extensionroom.mozdev.org/"/>.</para>
-
-    <para>Si vous voulez installer maintenant l'extension de 
-    <application>Enigmail</application>, ce qui les rend globalement accessibles,
-    lancez la commande suivante en tant qu'utilisateur <systemitem class="username">root</systemitem> :</para>
-
-<screen role="root"><userinput>make -C ../seamonkey-build/mailnews/extensions/enigmail install</userinput></screen>
-
-    <para>Pour installer une extension à partir d'un fichier
-    <filename class='extension'>.xpi</filename> créé ou téléchargé, vous devez
-    simplement <quote>ouvrir</quote> le fichier <filename class='extension'>.xpi</filename>
-    en utilisant l'option <quote>Ouvrir un fichier</quote> du menu 
-    <quote>Fichier</quote> de la fenêtre du navigateur. Vous pouvez naviguer 
-    pour trouver le fichier (par exemple, le fichier
-    <filename class='extension'>.xpi</filename>
-    de <application>Enigmail</application> se trouve dans <filename
-    class='directory'>/usr/lib/seamonkey-&seamonkey-version;/xpi_store</filename>),
-    sélectionnez-le puis suivez ce qui s'affiche pour installer l'extension.</para>
--->
-    <note>
-      <para>Vous devriez lancer <command>/usr/bin/seamonkey</command> une
-      fois en tant qu'utilisateur
-      <systemitem class="username">root</systemitem> (ou qu'utilisateur ayant
-      les droits d'écriture) pour créer des fichiers supplémentaires nécessaires
-      dans la hiérarchie
-      <filename class='directory'>/usr</filename>. Faites également cela
-      à chaque fois que vous installez lesles extensions globales supplémentaires.</para>
-    </note>
-
   </sect2>
 
-  <sect2 role="commands" id="add-mozconfig"
-  xreflabel="Additional .mozconfig Options">
-
-    <title>Options .mozconfig supplémentaires</title>
-
-    <para>On vous présente ci-dessous des informations sur certaines des options
-    supplémentaires qui peuvent être ajoutées au fichier de configuration
-    <filename>.mozconfig</filename>. Remarquez qu'il ne s'agit que de 
-    quelques-unes des options. Vous pourriez vouloir lancer
-    <command>./configure --help</command> et regarder toutes les options listées
-    pour découvrir leur effet sur la construction. Libre à vous d'ajouter ou de
-    supprimer des options pour faire une construction sur mesure. Certaines 
-    options classiques listées ci-dessous ne figurent pas dans le fichier
-    <filename>.mozconfig</filename> par défaut mais on peut les ajouter pour
-    obtenir l'effet souhaité sur la compilation de SeaMonkey.</para>
-
-    <para><option>ac_add_options --enable-elf-dynstr-gc</option> : 
-    Supprime les chaînes non référencées des objets partagés ELF générés pendant
-    la construction. Remarquez que cette option casse la construction sur un
-    alpha.</para>
-
-    <para><option>ac_add_options --disable-mailnews</option> : Désactive
-    les clients de messagerie et de nouvelles.</para>
-
-    <para><option>ac_add_options --disable-ldap</option> : Désactive
-    le support de LDAP, recommandé si vous avez désactivé la messagerie.</para>
-
-    <para><option>ac_add_options --enable-xterm-updates</option> : Affiche
-    la commande actuelle dans le titre de la fenêtre <command>xterm</command>
-    pendant la compilation.</para>
-
-    <para><option>ac_add_options --enable-plaintext-editor-only</option> :
-    Désactive le support de l'édition HTML. N'utilisez pas ce paramètre si vous
-    construisez le composant de messagerie-nouvelles.</para>
-
-  </sect2>
-
   <sect2 role="commands">
     <title>Explications des options de .mozconfig</title>
 
@@ -428,85 +226,53 @@
 
   <sect2 role="commands">
     <title>Explication des commandes</title>
-<!--
-    <para><command>'EXTRA_DSO_LDOPTS' += -lX11 -lXrender ...</command> :
-    La construction du fond de présentation se cassera quand les éléments de
-    canvas sont activés sans ajouter ces deux bibliothèques requises.</para>
--->
-    <para><command>make -f client.mk ...</command> : Les produits Mozilla 
+
+    <para><command>make -f client.mk</command> : Les produits Mozilla 
     sont empaquetés pour permettre l'utilisation d'un fichier de configuration 
     utilisable pour passer les paramètres de configuration à la commande
     <command>configure</command>. <command>make</command> utilise le
     fichier <filename>client.mk</filename> pour récupérer les paramètres de 
-    configuration et de réglage initiaux, donc selon le paramètre cible
-    (<parameter>build</parameter> ou
-    <parameter>install</parameter>), soit lance le script
-    <command>configure</command> et compile le paquet ou installe le paquet.</para>
-<!--
-    <para><command>./makemake -r</command> : Cette commande est utilisée
-    pour créer de manière récursive <filename>Makefile</filename>s dans le bon
-    sous-répertoire de <filename class='directory'>seamonkey-build</filename>.</para>
+    configuration de départ et régler les paramètres.</para>
 
-    <para><command>make -C ... xpi</command> : Cette commande construit le
+    <para><command>make -C moz-build-dir/suite/installer</command> : Cette commande construit le
     fichier <filename class='extension'>.xpi</filename> de 
     <application>Enigmail</application> qu'on peut utiliser pour 
     installer <application>Enigmail</application>.</para>
 
     <para><command>install .../movemail.rdf ...</command> : Cette
-    commande est utilisée pour installer un fichier placé par inadvertance hors
-    du script d'installation.</para>
--->
+     commande crée une archive tar du <application>Seamonkey</application> que 
+     vous venez de compiler.</para>
+
+    <para><command>tar -xf moz-build-dir ...</command> : ceci déballe
+    <application>Seamonkey</application>. <option>-C
+    /usr/lib/seamonkey-2.5</option> dit à tar d'aller dans le répertoire <filename
+    class='directory'>/usr/lib/seamonkey-2.5</filename> avant de le déballer.
+    L'option <option>--strip-components=1</option> supprime la partie
+    seamonkey/ du nom de fichier/des chemins.</para>
+
+    <para><command>ln -s ../mozilla/plugins /usr/lib/seamonkey-2.5</command> :
+    ceci crée un lien symbolique vers
+    <filename class='directory'>/usr/lib/mozilla/plugins</filename> pour des
+    raisons de compatibilité, pour garder tous vos plugins là où se trouvent
+    en principe les plugins mozilla.</para>
+
   </sect2>
 
   <sect2 role="configuration">
     <title>Configuration de SeaMonkey</title>
 
-    <para>Aucune configuration spécifique n'est requise tant que le script
-    <command>seamonkey</command> est dans le path de l'utilisateur. Si
-    <application>SeaMonkey</application> est installé à un endroit non standard,
-    faites un lien symbolique vers le script <command>seamonkey</command> 
-    dans le répertoire <filename class="directory">/usr/bin</filename>.</para>
+    <para>Si vous avez enlevé l'option <option>--disable-webm</option> de
+    votre <filename>mozconfig</filename>, votre <application>Seamonkey</application>
+    peut lire la plupart des vidéos youtube sans plugin flash. Pour activer cela,
+    allez sur <ulink
+    url="http://www.youtube.com/html5">http://www.youtube.com/html5</ulink>
+    et cliquez sur 'Rejoindre le test HTML5' (exige l'activation des
+    cookies).</para>
 
-    <para>Certaines applications cherchent <command>netscape</command> quand
-    elles ont besoin d'ouvrir un navigateur. Vous pouvez créer le lien symbolique
-    suivant par commodité (en tant qu'utilisateur 
-    <systemitem class="username">root</systemitem>).</para>
-
-<screen role="root"><userinput>ln -v -sf seamonkey /usr/bin/netscape</userinput></screen>
-
     <para>Pour installer des plugins <application>SeaMonkey</application>,
     reportez-vous au <ulink url="http://plugindoc.mozdev.org/linux.html">Mozdev's
-    PluginDoc Project</ulink>. Si vous avez déjà installé <xref linkend="jdk"/>,
-    créez le lien suivant en tant qu'utilisateur
-    <systemitem class="username">root</systemitem> pour utiliser le plugin
-    <application>JAVA</application> : </para>
+    PluginDoc Project</ulink>.</para>
 
-<screen role="root"><userinput>ln -v -s $JAVA_HOME/jre/plugin/i386/ns7/libjavaplugin_oji.so \
-    /usr/lib/seamonkey-&seamonkey-version;/plugins</userinput></screen>
-
-    <para>Si vous avez installé <xref linkend="icedtea6"/> contrairement à
-    <xref linkend="jdk"/>, créer le lien suivant (de nouveau en tant que
-    <systemitem class="username">root</systemitem> ) pour utiliser le plugin 
-    <application>IcedTea6</application> > : </para>
-    
-<screen role="root"><userinput>ln -v -s $JAVA_HOME/jre/plugin/i386/IcedTeaPlugin.so \
-    /usr/lib/seamonkey-&seamonkey-version;/plugins</userinput></screen>
-
-    <para>Certains paquets installent des plugins SeaMonkey dans le 
-    répertoire global par défaut <filename class='directory'>/usr/lib/mozilla/plugins</filename>.
-    Si vous le désirez, créez des liens symboliques dans le répertoire des plugins
-    <filename class='directory'>/usr/lib/seamonkey-&seamonkey-version;/plugins</filename>
-    de <application>SeaMonkey</application> vers les fichiers dans le répertoire
-    par défaut des plugins (vous devriez lier aux fichiers définitifs et non
-    aux autres liens). Sinon, vous pouvez déplacer ou copier les fichiers dans
-    le répertoire des plugins par défaut vers le répertoire des plugins de
-    <application>SeaMonkey</application>. Un exemple de création d'un lien
-    symbolique est indiqué ci-dessous. Créez ces liens en tant qu'utilisateur
-    <systemitem class="username">root</systemitem> :</para>
-
-<screen role="root"><userinput>ln -v -s ../../mozilla/plugins/<replaceable><plugin.so></replaceable> \
-    /usr/lib/seamonkey-&seamonkey-version;/plugins</userinput></screen>
-
     <para>Tout en utilisant le menu <quote>Préférences</quote> pour configurer
     les options et les préférences de <application>SeaMonkey</application> pour
     les adapter à vos propres goûts, un contrôle bien plus approfondi de 
@@ -545,13 +311,12 @@
       <segtitle>Répertoires installés</segtitle>
 
       <seglistitem>
-        <seg>seamonkey et seamonkey-config</seg>
-        <seg>Numerous libraries, browser, et email/newsgroup components,
-        plugins, extensions, et helper modules installed in <filename
+        <seg>seamonkey</seg>
+        <seg>De nombreuses bibliothèques, le navigateur et les composants de
+        messagerie/nouvelles email/newsgroup components,
+        plugins, extensions, et modules d'aide installés dans <filename
         class='directory'>/usr/lib/seamonkey-&seamonkey-version;</filename></seg>
-        <seg>/usr/include/seamonkey-&seamonkey-version;,
-        /usr/lib/seamonkey-&seamonkey-version;, et
-        /usr/share/idl/seamonkey-&seamonkey-version;</seg>
+        <seg>/usr/lib/seamonkey-&seamonkey-version;</seg>
       </seglistitem>
     </segmentedlist>
 

Modified: trunk/blfs/xsoft/other/thunderbird.xml
===================================================================
--- trunk/blfs/xsoft/other/thunderbird.xml	2011-12-02 00:06:14 UTC (rev 1471)
+++ trunk/blfs/xsoft/other/thunderbird.xml	2011-12-03 01:28:14 UTC (rev 1472)
@@ -77,9 +77,7 @@
     <xref linkend="libgnomeui"/> (pour l'intégration de gnome),
     <xref linkend="libnotify"/>, <xref linkend="nss"/>, <xref linkend="nspr"/>,
     <xref linkend="startup-notification"/>, <xref linkend="sqlite"/>,
-    <xref linkend="yasm"/>,
-    (ou <ulink url="http://www.webmproject.org/code/">libvpx</ulink>, qui exige
-    <application>Yasm</application>),
+    <xref linkend="yasm"/> (ou <xref linkend="libvpx"/>),
     <ulink url="http://sourceforge.net/projects/hunspell/">Hunspell</ulink>,
     <ulink url="http://www.valgrind.org/">Valgrind</ulink> (seulement pour tester le code
     jemalloc), et <xref linkend="wget"/></para>




More information about the lfs-traducfr mailing list