[lfs-fr] r1166 - in trunk/lfs: . chapter01 chapter06 prologue

jmengual at linuxfromscratch.org jmengual at linuxfromscratch.org
Mer 2 Juin 10:24:48 PDT 2010


Author: jmengual
Date: 2010-06-02 19:24:47 +0200 (Wed, 02 Jun 2010)
New Revision: 1166

Modified:
   trunk/lfs/chapter01/changelog.xml
   trunk/lfs/chapter06/glibc.xml
   trunk/lfs/general.ent
   trunk/lfs/prologue/hostreqs.xml
Log:
Mise a jour par lfs des prerequis hote


Modified: trunk/lfs/chapter01/changelog.xml
===================================================================
--- trunk/lfs/chapter01/changelog.xml	2010-05-29 17:00:40 UTC (rev 1165)
+++ trunk/lfs/chapter01/changelog.xml	2010-06-02 17:24:47 UTC (rev 1166)
@@ -36,6 +36,16 @@
       </itemizedlist>
     </listitem>
 -->
+   <listitem>
+      <para>01-06-2010</para>
+      <itemizedlist>
+        <listitem>
+          <para>[bdubbs] - Mise à jour des prérequis de l'hôte vers les paquets
+          construits dans LFS-6.3.</para>
+        </listitem>
+      </itemizedlist>
+    </listitem>
+
     <listitem>
       <para>29-05-2010</para>
       <itemizedlist>

Modified: trunk/lfs/chapter06/glibc.xml
===================================================================
--- trunk/lfs/chapter06/glibc.xml	2010-05-29 17:00:40 UTC (rev 1165)
+++ trunk/lfs/chapter06/glibc.xml	2010-06-02 17:24:47 UTC (rev 1166)
@@ -110,7 +110,7 @@
 
 <screen><userinput remap="configure">../glibc-&glibc-version;/configure --prefix=/usr \
     --disable-profile --enable-add-ons \
-    --enable-kernel=2.6.18 --libexecdir=/usr/lib/glibc</userinput></screen>
+    --enable-kernel=2.6.22.5 --libexecdir=/usr/lib/glibc</userinput></screen>
 
     <variablelist>
       <title>Voici la signification des options de configure :</title>

Modified: trunk/lfs/general.ent
===================================================================
--- trunk/lfs/general.ent	2010-05-29 17:00:40 UTC (rev 1165)
+++ trunk/lfs/general.ent	2010-06-02 17:24:47 UTC (rev 1166)
@@ -1,7 +1,7 @@
 <?xml version="1.0" encoding="ISO-8859-1"?>
 
-<!ENTITY version "SVN-20100529">
-<!ENTITY releasedate "29 mai 2010">
+<!ENTITY version "SVN-20100601">
+<!ENTITY releasedate "1 juin 2010">
 <!ENTITY copyrightdate "1999–2010">
 <!ENTITY milestone "6.7">
 <!ENTITY generic-version "development"> <!-- Use "development", "testing", or "x.y[-pre{x}]" -->

Modified: trunk/lfs/prologue/hostreqs.xml
===================================================================
--- trunk/lfs/prologue/hostreqs.xml	2010-05-29 17:00:40 UTC (rev 1165)
+++ trunk/lfs/prologue/hostreqs.xml	2010-06-02 17:24:47 UTC (rev 1166)
@@ -19,85 +19,82 @@
     <quote><nom-du-paquet>-dev</quote>. Assurez-vous qu'ils sont
     installés si votre distribution les fournit.</para>
 
+    <para>Il se peut que les versions antérieures des paquets logiciels listés
+    fonctionnent mais elles n'ont pas été testées.</para>
+    
   <itemizedlist spacing="compact">
 
     <listitem>
-      <para><emphasis role="strong">Bash-2.05a</emphasis> (/bin/sh
+      <para><emphasis role="strong">Bash-3.2</emphasis> (/bin/sh
       devrait être un lien symbolique ou physique vers bash)</para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Binutils-2.12</emphasis> (les versions
+      <para><emphasis role="strong">Binutils-2.17</emphasis> (les versions
       supérieure à &binutils-version; ne sont pas recommandées car elles 
       n'ont pas été testées)</para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Bison-1.875</emphasis> (/usr/bin/yacc
+      <para><emphasis role="strong">Bison-2.3</emphasis> (/usr/bin/yacc
       devrait être un lien vers bison ou un petit script qui exécute bison)</para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Bzip2-1.0.2</emphasis></para>
+      <para><emphasis role="strong">Bzip2-1.0.4</emphasis></para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Coreutils-5.0</emphasis> (ou Sh-Utils-2.0,
-      Textutils-2.0 et Fileutils-4.1)</para>
+      <para><emphasis role="strong">Coreutils-6.9</emphasis></para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Diffutils-2.8</emphasis></para>
+      <para><emphasis role="strong">Diffutils-2.8.1</emphasis></para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Findutils-4.1.20</emphasis></para>
+      <para><emphasis role="strong">Findutils-4.2.31</emphasis></para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Gawk-3.0</emphasis> (/usr/bin/awk
+      <para><emphasis role="strong">Gawk-3.1.5</emphasis> (/usr/bin/awk
       devrait être un lien vers gawk)</para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Gcc-3.0.1</emphasis> (les versions
+      <para><emphasis role="strong">Gcc-4.1.2</emphasis> (les versions
       supérieures à &gcc-version; ne sont pas recommandées car elles n'ont
       pas été testées)</para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Glibc-2.2.5</emphasis> (les versions
+      <para><emphasis role="strong">Glibc-2.5.1</emphasis> (les versions
       supérieures à &glibc-version; ne sont pas recommandées car elles n'ont
       pas été testées)</para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Grep-2.5</emphasis></para>
+      <para><emphasis role="strong">Grep-2.5.1a</emphasis></para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Gzip-1.2.4</emphasis></para>
+      <para><emphasis role="strong">Gzip-1.3.12</emphasis></para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Noyau Linux 2.6.18</emphasis>
-      (compilé avec GCC-3.0 ou supérieur)</para>
+      <para><emphasis role="strong">Noyau Linux 2.6.22.5</emphasis>
+      (compilé avec GCC-4.12 ou supérieur)</para>
 
       <para>Cette version du noyau est requise car nous spécifions cette version-là lors de la construction de
-      <application>glibc</application> au chapitre 6, suivant ainsi une recommandation des développeurs. Vous pouvez éviter cela si vous le 
-      désirez mais un noyau au moins 2.6.0 est nécessaire car le support pour le
-      <quote>thread-local storage</quote> de Binutils ne sera pas compilé et la suite de
-      tests NPTL (<foreignphrase>Native POSIX Threading Library</foreignphrase>
-      produira une erreur de segmentation (segfault) si le noyau du système
-      hôte n'est pas au moins à la version 2.6.x, compilé avec une version 3.0
-      ou supérieure de GCC.</para>
+      <application>glibc</application> au chapitre 6, suivant ainsi une recommandation 
+      des développeurs.</para>
 
-      <para>Si le noyau hôte est plus ancien que le 2.6.18, ou s'il n'a pas
-      été compilé avec le compilateur GCC-3.0 (ou supérieur),
+      <para>Si le noyau hôte est plus ancien que le 2.6.22.5, ou s'il n'a pas
+      été compilé avec le compilateur GCC-4.12 (ou supérieur),
       vous devrez remplacer le noyau par un nouveau qui satisfait ces
       spécifications. Vous pouvez employer deux méthodes pour cela.
       Vous pouvez d'abord voir si votre distribution Linux fournit un paquet
-      pour le noyau 2.6.18 ou supérieur. Si tel est le cas, vous pouvez l'installer. Si
+      pour le noyau 2.6.22.5 ou supérieur. Si tel est le cas, vous pouvez l'installer. Si
       votre distribution n'offre pas un paquet acceptable pour le noyau, ou si vous
       préférez l'installer, vous pouvez compiler un noyau 2.6 vous-même.
       Les instructions pour la compilation du noyau et la configuration du
@@ -106,10 +103,10 @@
       
     </listitem>
     <listitem>
-      <para><emphasis role="strong">M4-1.4</emphasis></para>
+      <para><emphasis role="strong">M4-1.4.10</emphasis></para>
     </listitem>
     <listitem>
-      <para><emphasis role="strong">Make-3.79.1</emphasis></para>
+      <para><emphasis role="strong">Make-3.81</emphasis></para>
     </listitem>
 
     <listitem>
@@ -117,20 +114,20 @@
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Perl-5.6.0</emphasis></para>
+      <para><emphasis role="strong">Perl-5.8.8</emphasis></para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Sed-3.0.2</emphasis></para>
+      <para><emphasis role="strong">Sed-4.1.5</emphasis></para>
     </listitem>
 
     <listitem>
-      <para><emphasis role="strong">Tar-1.14</emphasis></para>
+      <para><emphasis role="strong">Tar-1.18</emphasis></para>
     </listitem>
 
     <!-- Needed by the apparently broken Binutils-2.18 -->
     <listitem>
-      <para><emphasis role="strong">Texinfo-4.8</emphasis></para>
+      <para><emphasis role="strong">Texinfo-4.9</emphasis></para>
     </listitem>
 
   </itemizedlist>




More information about the lfs-traducfr mailing list