[lfs-support] module shpchp

Dave daveaube at etcmail.com
Fri Aug 23 04:27:17 PDT 2019


Using an ASUS Pime B350 plus Motherboard, Ryzen-5.  I'm finding that the 
pause on wifi startup with an atheros wifi-PCI board seems to be caused 
by a missing module called shpchp. This driver is needed for a PCIe to 
PCI bridge. I have looked at Ubuntu, Arch, Mint, even systemrescuecd all 
have this module enabled.

This LFS system is system V, it was built from the 'in process 9-rc1", 
so I have caught packages being updated through the build. The kernel 
I'm using is the 5.2.1 version. I tried using the 5.2.8 kernel with the 
same results, so I'm back to the 5.2.1 version.  I know the kernel has 
the source code, I've seen it. I just have not stumbled across the 
proper combination in .config to make it use the module. I did continue 
building to the point that I have Xorg and the xlGears working, so 
everything works to this point, except the startup delay connecting the 
network card.

Does anyone know the config combo to make this module active?

After this gets solved, I'll try and figure out this Hi-Def audio chip, 
that uses 'verbs' to configure the chip, new territory there

Dave

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20190823/38870313/attachment.html>


More information about the lfs-support mailing list