[lfs-support] Lost sources directory

Jack Ditchburn jackplughd at gmail.com
Wed Aug 7 00:54:06 PDT 2019


List,

I need some more advice regarding LFS 8.4 build.

I have got past the stage of running the command to get rid of the "I have
no name!" prompt, and am now trying to compile the Linux headers as per
section 6.7. I got the below output:



*(lfs chroot) root:/# tar -xvf linux-4.20.12.tar.xztar:
linux-4.20.12.tar.xz: Cannot open: No such file or directorytar: Error is
not recoverable: exiting now*

Realising that I was not in the sources directory I ran the below and got
the output shown:







*(lfs chroot) root:/# cd $LFS/sourcesbash: cd: /mnt/lfs/sources: No such
file or directory(lfs chroot) root:/# lsbin  boot  dev etc  home  lib lib64
 lost+found  media  mnt  opt  proc  root run  sbin  sources  srv  sys  tmp
 tools  usr  var(lfs chroot) root:/# cd mnt(lfs chroot) root:/mnt# ls(lfs
chroot) root:/mnt#*

I previously ran the command to change ownership of the tools directory to
root from lfs. Should I run the same command on sources directory (my
thought is not to, as the book does not give this instruction)?

I would appreciate some advice at this point. Thanks.

Jack

-- 
Lightning, thunder, wind and rain. Ah bliss!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20190807/659502e0/attachment.html>


More information about the lfs-support mailing list