[lfs-support] 8.1-systemd Ch. 8.3 Linux-4.12.7: Error during make?

Hans Malissa hmalissa at me.com
Wed Sep 20 09:40:49 PDT 2017


Hi,

‘make defconfig’ did a very good job, thanks for the advice. My idea of using .config of the host distribution was completely wrong. LFS is up and running now, and booting is much faster than with my host distribution.
I still wonder where the error message came from - I was assuming that the kernel should compile in either case after using the standard configuration tools.
Regarding the (working) configuration that is a result of ‘make defconfig’ and customization with ‘make menuconfig’, I have two questions:
- How do I know if one or more modules/configuration settings are missing (even though the kernel runs)?
- How can I tell whether there are extra modules or options turned on that are not really used in my system?
Thanks a lot,

Hans

> On Sep 19, 2017, at 9:08 AM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
> 
> Hans Malissa wrote:
>> Hi,
>> 
>> I’m working my way through LFS 8.1-systemd. I got all the way to 8.3.1 Linux-4.12.7 without any problem, but now I’m stuck during kernel compilation.
>> After 'make mrproper’ and ‘make menuconfig', I run ‘make'. Compilation runs ok for quite some time, but eventually it fails with a message:
>> 
>> ...
>> Setup is 17532 bytes (padded to 17920 bytes).
>> System is 5281 kB
>> CRC ed1061fd
>> Kernel: arch/x86/boot/bzImage is ready (#1)
>>   Building modules, stage 2.
>>   MODPOST 3534 modules
>> ERROR: “__devm_regmap_init_mmio_clk” [sound/soc/codecs/snd-soc-msm8916-digital.ko] undefined!
>> make[1]: *** [scripts/Makefile.modpost:91: __modpost] Error 1
>> make: *** [Makefile:1217: modules] Error 2
>> 
>> I’ve tried a few times, starting from a clean source every time. I don’t understand what’s going wrong here. I was assuming that the .config created with ‘make menuconfig’ should work in any case?
>> I initially created .config by copying the config-file from the host distribution (debian), running ‘make oldconfig’, and then adjusting the .config to my liking, so it should work on my system. Most likely there are lots and lots of modules selected that I don’t really need. This should not be a problem, but if it’s some obscure module that I don’t need which causes the compile error, then I’d gladly remove it.
>> Thanks a lot,
> 
> Try running 'make defconfig'.  That should give you a generic build.  Then start looking at customization.   The dost distro assumes you you be using an initrd that we do not use.  It's not a good starting point.
> 
>  -- Bruce
> 
> 
> -- 
> http://lists.linuxfromscratch.org/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page
> 
> Do not top post on this list.
> 
> A: Because it messes up the order in which people normally read text.
> Q: Why is top-posting such a bad thing?
> A: Top-posting.
> Q: What is the most annoying thing in e-mail?
> 
> http://en.wikipedia.org/wiki/Posting_style

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20170920/80a9062e/attachment.html>


More information about the lfs-support mailing list