[lfs-support] shutting down systemd (was lfs-support Digest, Vol 500, Issue 1)

Thanos Baloukas baloukasthan at sch.gr
Sun May 29 05:47:58 PDT 2016


On 27/05/2016 11:43 μμ, Bruce Dubbs wrote:
> Thanos Baloukas wrote:
>> On 27/05/2016 10:36 μμ, Thef keo wrote:
>>> Hello,
>>>
>>> I followed LFS 7.9 Book.
>>> I finished installing the system and I tried to solve à problem :
>>> During the last command shutdown -r now, I get the following result:
>>> Failed to talk to init daemon .
>>>
>>> I tried several commands to correct this problem like systemctl poweroff
>>> but it returns : Failed to get D-Bus connection: Unknown error -1.
>>>
>>> I restarted the installation of systemd but this has not solved the
>>> problem.
>>>
>>> Do I have a problem with a package or is it something else ?
>>>
>> I would also check if something is wrong with the dbus installation.
>> Were the commands ran as root?
>> What's the output of
>> echo $DBUS_SESSION_BUS_ADDRESS
>
> I cannot help, but please make sure the message title is descriptive
> when posting.
>
> Yes, I ran the commands as root, and I even tried reinstalling dbus but
> it doesn't solve the problem.
>
> When I tried echo $DBUS_SESSION_BUS_ADDRESS, this is no message (the
> variable has an empty value)
>
> So what I need to do is to declare this variable ?
>
Hi Florent

You seem to missed that Bruce correctly changed the thread's subject.
His message is included, see above. Receiving the list's mails batched
makes it difficult to answer. Maybe you should go to your mailing list
account's preferences and disable that. On LFS mailing lists
bottom posting is preferred, so please use this style.

Now to your issue. DBUS_SESSION_BUS_ADDRESS should be set
automatically. When I login as root to a linux console, it is set to
unix:path=/run/user/0/bus

As a next step I suggest to run `ps -ef|grep dbus`
and then `journalctl -u dbus` and `journalctl --no-pager|grep dbus`
hopefully will give a clue on what's wrong.

-- 
Thanos


More information about the lfs-support mailing list