[lfs-support] error: /dev/sdc: No medium found

Ken Moffat zarniwhoop at ntlworld.com
Sat Mar 14 16:52:09 PDT 2015


On Sat, Mar 14, 2015 at 06:53:15PM -0300, Fernando de Oliveira wrote:
> Since yesterday, tying to go on starting BLFS and updating what I could
> in the way.
> 
> But this error has to be fixed.
> 
> Found several references in the web but not solution, most with sdb, not
> sdc. Most are related to systemd or udev, it has hit Ubuntu, and I think
> it is related to something in eudev.
> 
> It has to be fixed, because at the login prompt and after, it keeps
> inserting messages:
> 
> "error opening USB device 'descriptord' file".
> 
> Don't think has to do with static libraries, but if I don't find a
> solution until tomorrow, will dump this system and start an overnight
> jhalfs build.
> 
> # cat /mnt/LFS77/etc/lfs-release
> SVN-20150303
> 
Google says that the messages say 'descriptors', not 'descriptord'
(for anybody else grepping their log).  At least one thread suggests
it is triggered by _something_ usb connected to the machine.  An
external drive or printer ?  Another similar report suggests a
failing cable or failing connector on the USB device.  Looks as if
the message comes from eudev in this case.

Another thread, perhaps unrelated, mentions this message but reports
that external usb storage gets mounted only if the stick is
inserted, removed, and then reinserted (which sounds to me like
either a race, running things in the wrong order (somethng in
systemd, so irrelevant to you)  or a poor connection somewhere.

ĸen
-- 
Nanny Ogg usually went to bed early. After all, she was an old lady.
Sometimes she went to bed as early as 6 a.m.


More information about the lfs-support mailing list