[lfs-support] LFS 7.6 Ch. 6.17 GCC: make error

Ken Moffat zarniwhoop at ntlworld.com
Sun Mar 1 11:36:39 PST 2015


On Sun, Mar 01, 2015 at 06:49:42PM +0100, ZyaX wrote:
> Hi.
> 
> I get an error when I run make which seems to be related to the C
> preprocessor /lib/cpp, which does not exist.
> It suggests to inspect config.log, but it's very long and I'm not sure
> how to post it here.
> 
> I run Manjaro 64-bit(based on archlinux).
> 
> Thanks in advance.
> 
> checking how to run the C preprocessor... /lib/cpp
> configure: error: in `/sources/gcc-build/x86_64-unknown-linux-gnu/libgcc':
> configure: error: C preprocessor "/lib/cpp" fails sanity check
> See `config.log' for more details.
> Makefile:11546: recipe for target 'configure-target-libgcc' failed
> make[1]: *** [configure-target-libgcc] Error 1
> make[1]: Leaving directory '/sources/gcc-build'
> Makefile:863: recipe for target 'all' failed
> make: *** [all] Error 2

The best way to find the relevant part of config.log is to use
another term (as root on the host - that way, you have a full
toolkit) and cd to /mnt/lfs/sources/gcc-build.

Gcc is among the packages which run configure in many subdirectories,
each with its own config.log.  This one looks as if it is in the
top-level directory, but you could run 'find . -name config.log |
xargs ls -l' to check.

If there is more than one, grep them for 'fails sanity check'.  When
you know which config.log is the important one, open it in 'less'
and seach for 'fails sanity check', [ that will be
 /fails\ sanity\ check
if you are not aware ].

Then look at the lines above that.  You should see configure
creating a program fragment, trying to run it, getting one or more
errors, and then producing the 'fails sanity check' message.  It is
the error(s) which will point to what is wrong.

ĸen
-- 
Nanny Ogg usually went to bed early. After all, she was an old lady.
Sometimes she went to bed as early as 6 a.m.


More information about the lfs-support mailing list