[lfs-support] e2fsprogs make error

Thanos Baloukas baloukasthan at sch.gr
Mon Jun 22 11:39:49 PDT 2015


On 22/06/2015 08:43 μμ, Sandeep Singh wrote:
> Hello,
>
> I am using Arch linux as the host system and version 7.7 of the LFS
> book. The check commands after gcc build in 6.17 came out spot on.
> Now while making e2fsprogs I am getting this error
>
> ./../../lib/ext2fs/closefs.c:1:3: error: expected '=', ',', ';', 'asm'
> or '__attribute__' before '.' token
>   nt.*old_desc_blocks/s/int/blk64_t/
>     ^

It seems to me that you didn't apply correctly the sed command.
I'd suggest to remove the source dir, extract the tarball again,
copy and paste the sed carefully and proceed.

-- 
Thanos


More information about the lfs-support mailing list