[lfs-support] expr core dump

Armin K. krejzi at email.com
Sun Jun 21 11:09:18 PDT 2015


On 06/21/2015 07:45 PM, Bruce Dubbs wrote:
> Alexey Orishko wrote:
>> On Sun, Jun 21, 2015 at 6:54 PM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
>>>
>>> I tried that in several systems from the latest svn to one going back to
>>> 2012 and they all work properly.
>>
>> Have you tried it in chroot or on real systems?
>> I get 100% repeatable coredump in chroot.. Do you have any ideas what
>> could lead to such a result?
> 
> I just tried in chroot without the virtual file systems mounted (that should not make any difference), and it worked fine.
> 
> Are you trying it in a partial chroot or a complete one?  It's really a pretty simple program.
> 
> $ ldd /usr/bin/expr
>         linux-vdso.so.1 (0x00007ffdd7897000)
>         libgmp.so.10 => /usr/lib/libgmp.so.10 (0x00007fede2217000)
>         libc.so.6 => /lib/libc.so.6 (0x00007fede1e75000)
>         /lib64/ld-linux-x86-64.so.2 (0x00007fede248c000)
> 
>   -- Bruce
> 

Alexey, was your system built on a machine that has newer hardware
than the one you're trying to run this on?

-- 
Note: My last name is not Krejzi.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20150621/29ac3adb/attachment.sig>


More information about the lfs-support mailing list