[lfs-support] Boot Issues

Casey Daniels lfs at cd.kcfam.net
Thu Sep 26 14:43:51 PDT 2013

Thanks for the info,
  but followed the instructions and as usual I get the grub rescue 
prompt which is a total different issue and question.

But I tried what I have been trying to get the normal boot menu up

set prefix(hd0,??)
insmod normal

now its saying no such partition.
I ls at the rescue prompt and it shows the (HD0) but it gives no 
partitions to go along with it.

On 09/26/2013 10:39 AM, Dr.-Ing. Edgar Alwers wrote:
> On Thursday 26 September 2013 19:51:05 Geoff Swan wrote:
>>   I've tried to boot off a USB Thumb Drive, an SD Card, and when
>>   its running through the boot proccess it keeps telling me that there is
>>   an unknown partition type, and therefore can't mount the root fs.
> Read
> http://www.linux-archive.org/gentoo-user/481167-mounting-root-partition-uuid-no-initrd-needed.html
> The article refers to a different issue, but explains  what you are looking
> for.
> quote
> "I strongly suggest that you practice on a USB thumb drive before you
>   risk your real partition table !"
> unquote
> I used it. You do not need a PC with EFI support, however, your kernel must
> have " EFI GUID partition table support" compiled in. And you will need GPT (
> GUID partition tables ).
> Good luck,
> Edgar

More information about the lfs-support mailing list