[lfs-support] chroot into the temporary ...?

Ken Moffat zarniwhoop at ntlworld.com
Tue Sep 24 19:23:05 PDT 2013

On Wed, Sep 25, 2013 at 08:41:37AM +0800, Wiky wrote:
>  hi,
>     It reads 'That is, we chroot into the temporary mini Linux system, ..' in Section6.1 of LFS7.4.
>     but when i run 'sudo chroot /mnt/lfs',
 Why do you think that 'sudo' is the command to run here ?  Do we
build sudo in chapter 5 (/tools) ?
>     it returns 'chroot: failed to run command `/bin/bash': No such file or directory'. Of course /mnt/lfs/bin/bash not exists
> and then I tried 'sudo chroot /mnt/lfs/tools', it also 'chroot: failed to run command `/bin/bash': No such file or directory',but /mnt/lfs/tools/bin/bash exists.
>     I really have no idea with the problem,maybe I have missed something in Ch5?  Thanks in advance and sorry for my English.

 Apart from using sudo instead of su, why doesn't /bin/bash exist in
/mnt/lfs ?  If you are following the book, we create the
/mnt/lfs/bin/bash symlink in section 6.6 - and we enter chroot
*after* that, not in section 6.1.  I'm sure that reading the book is
*hard* for people who don't have English as a native language, but
you seem to be making false assumptions about what the book says.

das eine Mal als Tragödie, dieses Mal als Farce

More information about the lfs-support mailing list