[lfs-support] chroot into the temporary ...?

Wiky wiiiky at yeah.net
Tue Sep 24 18:56:34 PDT 2013

I got it, Thank you.

At 2013-09-25 09:49:36,"Aleksandar Kuktin" <akuktin at gmail.com> wrote:
>>On Wed, 25 Sep 2013 08:41:37 +0800 (CST)
>>Wiky <wiiiky at yeah.net> wrote:
>>  hi,
>>     It reads 'That is, we chroot into the temporary mini Linux
>> system, ..' in Section6.1 of LFS7.4. but when i run 'sudo
>> chroot /mnt/lfs', it returns 'chroot: failed to run command
>> `/bin/bash': No such file or directory'. Of course /mnt/lfs/bin/bash
>> not exists and then I tried 'sudo chroot /mnt/lfs/tools', it also
>> 'chroot: failed to run command `/bin/bash': No such file or
>> directory',but /mnt/lfs/tools/bin/bash exists. I really have no idea
>> with the problem,maybe I have missed something in Ch5?  Thanks in
>> advance and sorry for my English.
>You didn't specify which program should chroot exec() after it chroots
>itself, so it did the default: tried to execute /bin/bash. Since there
>is no such program (/mnt/lfs/bin/bash in the root filesystem), it
>To fix this, you should specify which program should be executed. Like
>chroot /mnt/lfs /tools/bin/bash
>But the full command is in Chapter 6.4. so look it up there.
>You don't need an AI for a robot uprising.
>Humans will do just fine.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20130925/eb206e4b/attachment.html>

More information about the lfs-support mailing list