[lfs-support] lfs7.0 5.7 installation glibc. configure: WARNING: using cross tools not prefixed with host triplet

andreas graeper agraeper at googlemail.com
Mon Sep 16 08:36:20 PDT 2013

2013/9/15 Bruce Dubbs <bruce.dubbs at gmail.com>

> andreas graeper wrote:
> > hi,
> > i was looking for mail-archives using the link
> >   linuxfromscratch.org/pipermail/lfs-support/
> > but got a 'page not found' ?
> They were turned off due to bandwidth/cost considerations.  You can
> search the archives on gmane though.
> > when gcc is build first time: languages=c (ch 5.5)
> I don't know what version of the book you are using, but Section 5.5
> clearly says:
> --enable-languages=c,c++
> > when glibc/configure (ch 5.7) cross-gcc is found, cross-g++ does not
> exists
> > but g++ is checked and the native one is found and i get that warning.
> >
> > do i have to configure gcc once again with support for c++, so that
> > cross-g++ is build and installed. or can i ignore that warning, cause g++
> > is not actually used to build glibc ?
> I suggest going back and rebuilding gcc.  It's only about 6 sbu.
>    -- Bruce
> --
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page

book-version is 7.0, see subject.
i did not add c++ till now. i read in configure-script g++ is needed for
tests only.
i tried to install glibc into root-filesystem (6.9) but got an error:

Use of uninitialized value in string ne at
scripts/test-installation.plline 163, <LDD> line 20.
Library libgcc_s is not correctly installed.
Please check your installation!
Offending line of ldd output:     libgcc_s.so.1 => /usr/lib/libgcc_s.so.1

The script has found some problems with your installation!
Please read the FAQ and the README file and check the following:
- Did you change the gcc specs file (necessary after upgrading from
  Linux libc5)?
- Are there any symbolic links of the form libXXX.so to old libraries?
  Links like libm.so -> libm.so.5 (where libm.so.5 is an old library) are
  libm.so should point to the newly installed glibc file - and there should
  only one such link (check e.g. /lib and /usr/lib)
You should restart this script from your build directory after you've
fixed all problems!
Btw. the script doesn't work if you're installing GNU libc not as your
primary library!

i put some prints into that perl script:

 soversions.mk : ( no lib 'gcc_s' )

 name='pthread' version='0'
  name='nss_nisplus' version='2'
  name='nss_hesiod' version='2'
  name='util' version='1'
  name='rt' version='1'
  name='nss_nis' version='2'
  name='nsl' version='1'
  name='cidn' version='1'
  name='nss_compat' version='2'
  name='resolv' version='2'
  name='nss_dns' version='2'
  name='dl' version='2'
  name='anl' version='1'
  name='c' version='6'
  name='m' version='6'
  name='BrokenLocale' version='1'
  name='nss_files' version='2'
  name='crypt' version='1'
(this libs are installed into /lib64 )

the testprogram is linked against /tools/lib/libgcc_s.so

libgcc_s and libstdc++ are linked from /usr/lib to /tools/lib

why libstdc++ was build ?
when it is build, is it done with c-compiler or with the wrong (host-)
g++-compiler ?

what is libgcc_s ? google shows only error messages ('not found' and so on)

could this problem get solved by 're-adjusting the toolchain' (6.10) before
this test (glibc make install in 6.9) ?

thanks in advance
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20130916/d873a6e1/attachment.html>

More information about the lfs-support mailing list