[lfs-support] ext4

Roger Koehler roger.koehler at gmail.com
Sun Sep 8 15:21:49 PDT 2013

I anxiously await each new release of LFS, and upon receiving the news
of the release of 7.4, I immediately began again to install a new
system. I learn something new every time. This time is proving to be
no different.

So far, the biggest change for me is adopting the change from ext3 to
ext4. I am building 7.4 using LFS 7.3.  I successfully created a new
partition and used the instructions to format it as ext4. So, here's
the sticky part. I can't mount it! I kept getting the following error:

mount: wrong fs type, bad option, bad superblock on /dev/sda5, missing
codepage or helper program, or other error

In some cases useful info is found in syslog - try dmesg | tail or so.

So, I looked at dmesg | tail:

[ 4946.062759] EXT4-fs (sda5): couldn't mount as ext3 due to feature
incompatibilities [ 4955.773590] EXT4-fs (sda5): Filesystem with huge
files cannot be mounted RDWR without CONFIG_LBDAF

I used the command as written:

mount -v -t ext4 /dev/sda5 $LFS

So, I'm not sure why the system thinks I'm mounting it as ext3.  My
kernel is configured to use ext4.  I tried reinstalling the latest
util-linux package, but I get the same error.

So, I'm stuck dead in the water before even getting past the Intro!
Any suggestions?


More information about the lfs-support mailing list