[lfs-support] ABOUT LFS

Pwn Me pwn_me18 at yahoo.com
Sat Sep 7 17:40:27 PDT 2013

i have a question.. 

how can i edit the PATH="tools/bin:/bin:/usr/bin" to PATH="tools/bin:/bin:/usr/bin:/tools/sbin:/sbin:/usr/sbin"?

'coz i tried to use "export" to edit this command and when i reboot the system, the "PATH" thing goes back to the original syntax.. :/

 From: David Brodie <lfs at aba.eclipse.co.uk>
To: Pwn Me <pwn_me18 at yahoo.com>; LFS Support List <lfs-support at linuxfromscratch.org> 
Sent: Saturday, September 7, 2013 7:27 PM
Subject: Re: [lfs-support] ABOUT LFS

On 07/09/13 03:29, Pwn Me wrote:
> guys i have another question.. i'm done with my LFS 7.3 and it actually
> works now but some commands like APT, REBOOT, HALT etc. have the same
> outputs when i typed them:
> "bash: command not found"

They are privileged programs, which LFS puts on /sbin or /usr/sbin, 
neither of which are on your PATH if you log in as a normal user. You 
need to log in as 'root' to use these commands. And 'apt' is the package 
management tool for Debian, Ubuntu, etc. You won't find it in LFS at 
all, unless you add it yourself.

> also i haven't edited my /etc/sysconfig/clock, /etc/resolv.conf and
> /etc/hosts..

I think you need to do some basic reading up about Linux and about using 
the standard shell and utilities, before you go much further - there're 
some good references on this page:


FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20130907/1f99cc5c/attachment.html>

More information about the lfs-support mailing list