5.6. Linux-2.6.30.2 API Headers

Suraj Linux suraj.embedded.linux at gmail.com
Sun Feb 28 20:38:44 PST 2010


Hi,

That mean. Am I executing the commands

    make mrproper

     make headers_check
     make INSTALL_HDR_PATH=dest headers_install
     cp -rv dest/include/* /tools/include


in the correct folder $LFS/sources/linux-2.6.30.2/   ???

Here is the output that I get after the ls in the folder you  requested.

lfs_suraj at robot-laptop:~$ ls -l
/home/disk3/sources/linux-2.6.30.2/scripts/basic/
total 32
-rw-rw-r-- 1 robot robot   726 Jul 19  2009 Makefile
-rw-rw-r-- 1 robot robot 11442 Jul 19  2009 docproc.c
-rw-rw-r-- 1 robot robot  9754 Jul 19  2009 fixdep.c
-rw-rw-r-- 1 robot robot  1090 Jul 19  2009 hash.c


The file was downloaded from the user robot. But now I am doing all the
procedure as  different user lfs_suraj.


Do I need to change the permissions for that specific folder.

I even tried changed the owner ship of the folder linux-2.60.30.2 to
lfs_suraj. But still I get similar output
lfs_suraj at robot-laptop:/home/disk3/sources$ ls -l
/home/disk3/sources/linux-2.6.30.2/scripts/basic/
total 32
-rw-rw-r-- 1 robot robot   726 Jul 19  2009 Makefile
-rw-rw-r-- 1 robot robot 11442 Jul 19  2009 docproc.c
-rw-rw-r-- 1 robot robot  9754 Jul 19  2009 fixdep.c
-rw-rw-r-- 1 robot robot  1090 Jul 19  2009 hash.c

And after changing the permission I get the following output.

lfs_suraj at robot-laptop:/home/disk3/sources/linux-2.6.30.2$ make mrproper

lfs_suraj at robot-laptop:/home/disk3/sources/linux-2.6.30.2$ make
headers_check

  CHK     include/linux/version.h
/bin/sh: cannot create include/linux/version.h.tmp: Permission denied
  UPD     include/linux/version.h
mv: cannot stat `include/linux/version.h.tmp': No such file or directory
make: *** [include/linux/version.h] Error 1


Thank you for the help.

Regards,
Suraj



On Sun, Feb 28, 2010 at 2:00 AM,
<lfs-support-request at linuxfromscratch.org>wrote:

> Send lfs-support mailing list submissions to
>        lfs-support at linuxfromscratch.org
>
>
> Message: 1
> Date: Sat, 27 Feb 2010 02:57:13 -0500
> From: Suraj Linux <suraj.embedded.linux at gmail.com>
> Subject: 5.6. Linux-2.6.30.2 API Headers
> To: lfs-support at linuxfromscratch.org
> Message-ID:
>        <9f266c561002262357g4046f903hff90802b7a487c91 at mail.gmail.com>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Hi,
>
> I have got a bit confused at this step. 5.6. Linux-2.6.30.2 API Headers . I
> am not sure in which I must run the following commands
>
>      make mrproper
>
>      make headers_check
>      make INSTALL_HDR_PATH=dest headers_install
>      cp -rv dest/include/* /tools/include
>
> I down any file named as Linux-2.6.30.2 API.
>
>
> I have installed the tar file linux-2.6.30 and when I run the above command
> in the folder extracted folder of linux-2.6.30 I get the following errors.
>
> HOSTCC  scripts/basic/fixdep
> scripts/basic/fixdep.c: In function 'traps':
> scripts/basic/fixdep.c:377: warning: dereferencing type-punned pointer will
> break strict-aliasing rules
> scripts/basic/fixdep.c:379: warning: dereferencing type-punned pointer will
> break strict-aliasing rules
> scripts/basic/fixdep.c: At top level:
> scripts/basic/fixdep.c:399: fatal error: opening dependency file
> scripts/basic/.fixdep.d: Permission denied
> compilation terminated.
> make[2]: *** [scripts/basic/fixdep] Error 1
> make[1]: *** [scripts_basic] Error 2
> make: *** No rule to make target `header_check'.  Stop.
>
>
> I am using the book LFS_6.5.
>
> Thank you.
>
>
> -Suraj Swami.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:
> http://linuxfromscratch.org/pipermail/lfs-support/attachments/20100227/b96d66bc/attachment-0001.html
>
> ------------------------------
>
> Message: 2
> Date: Sat, 27 Feb 2010 12:28:40 +0000
> From: Andrew Benton <b3nton at gmail.com>
> Subject: Re: 5.6. Linux-2.6.30.2 API Headers
> To: lfs-support at linuxfromscratch.org
> Message-ID: <4B890FF8.5060404 at gmail.com>
> Content-Type: text/plain; charset=UTF-8; format=flowed
>
> On 27/02/10 07:57, Suraj Linux wrote:
> > scripts/basic/fixdep.c:399: fatal error: opening dependency file
> scripts/basic/.fixdep.d: Permission denied
> > compilation terminated.
>
> What are the permissions of $LFS/linux-2.6.30?
>
> ls -l $LFS/linux-2.6.30/scripts/basic
>
> Andy
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20100228/1fb5c74d/attachment.html>


More information about the lfs-support mailing list