LFS-6.6 booting USB grub

Baho Utot baho-utot at columbus.rr.com
Thu Feb 25 16:57:18 PST 2010


Ken Moffat wrote:
> On 25 February 2010 21:38, Baho Utot <baho-utot at columbus.rr.com> wrote:
>
>   
>> I have since found out that UUID and LABEL are a redhat twist. Â THey
>> require an initrd and nash.
>> nash mounts the drives ( does the dirty work and passes the info to the
>> kernel ).
>>     
>
> Do you mean that (about UUID and LABEL), or perhaps you mean
> "when booting from an external disk" ?
>
>   

Doesn't matter internal or external.
See below.
 
> I've had LABEL= in the fstab on my server for about 2 years,
> ever since I had to start using libata on that box.  No initrds,
> no fedoras, and no substandard minimalist shells.
>   

I have used it as well for a number of years with different distros ( 
RH6.0 to Fedora 10 and  Arch).
That is why I tried it with LFS. 
Apparently it won't work with a "pure" gnu/grub environment.
It takes some tickling.

According to some info I found from a site while searching google it was 
redhat that started the UUID LABEL into grub stuff.
It also reported that some other distros picked it up as well, using 
their own implementation(s).
I will see if I can find the link again as I did not save it and post it.

>  Might not work on all filesystems, but should work for at
> least ext{2,3,4} - set it in tune2fs or e2label.
>   

I am using ext2 as I have it on a 2GB thumb drive.
On my raid arrays I use jfs and ext2 for the /boot partition. 
I need a separated boot partition because I have an encrypted root file 
system and all the /home file systems are encrypted as well.
The only thing not encrypted is the lone /boot partition.

>  But for explanations of your inability to boot from an external
> disk except by specifying /dev/sdXn I have no idea.  Are you
> sure you set it to what you put in grub.conf ?
>
>   

Yes, tried many times by modifying menu.lst and by using the cmd line in 
grub to change the kernel line.
When the kernel line is set to uuid or label you get the error Kernel 
panic - not syncing:VFS : unable to mount root fs on unknown block(2,0).
Meaning it can not digest the uuid or label params, it barfs and then I 
need to clean that up.

If I look up into the boot sequence I find that it doesn't know about 
the root=/dev/disk/by-uuid=<some stuff>
same with root=UUID=<stuff> or root=LABEL=:LFS-6.5".
It all fails.

When I use the root=/dev/sdX1 it works, so I know I have the drivers 
that I need compiled into the kernel etc.

>  If you were using "grub2" I would guess that using labels in
> grub is not yet implemented:
> http://groups.google.com/group/linux.debian.bugs.dist/browse_thread/thread/516ac0deccafb3af?pli=1
>
> ĸen
>   

I am not ready for grub2 yet....I have well enough trouble with 
grub-legacy. ;-)

Thanks




More information about the lfs-support mailing list