LFS-6.6 booting USB grub

Hans Kaper spakyelj at xs4all.nl
Thu Feb 25 12:03:02 PST 2010


Op Thu, 25 Feb 2010 17:23:58 +0100 schreef Baho Utot  
<baho-utot at columbus.rr.com>:

> I would like to boot LFS-6.5 on USB
>
> I have it working except that when I change from my desktop computer
> which has 3 drives to my laptop that only has one drive I must edit grub
> and change the kernel line to point to the prober /dev/sdx drive
>
> I would like to boot grub on the USB drive and have it come up without
> editing the kernel line for the drive
>
> I have searched the web looking for fixes and tried using UUID and  
> Labels.
>
> I have used e2label to set the label on the USB drive to LFS-6.5
>

> # The first entry is for LFS.
> title LFS 6.5-SDD1
> root (hd0,0)
> kernel /boot/lfskernel-2.6.30.2 root=/dev/sdd1 rootdelay=10
>
It surprises me that this works on your laptop with only one drive. Why  
should your USB-device on the laptop also be named sdd1 as it is on your  
desktop?

> title LFS 6.5-UUID
> root (hd0,0)
> kernel /boot/lfskernel-2.6.30.2
> root=UUID=6cb4887-1eb2-4180-9566-391a8b3f7b45 ro rootdelay=10
>
> title LFS 6.5-LABEL
> root (hd0,0)
> kernel /boot/lfskernel-2.6.30.2 root=LABEL=LFS-6.5 ro rootdelay=10
>
I tried these too, but did not succeed either. The succesful advice I got  
was to delete the root= option altogether when booting from the USB-device  
because the bootpartition is already defined with the root(hd0,0)  
Grub-entry.
I am curious to know what the experts have to say about why the UUID- and  
LABEL-options don't work.



Hans Kaper.



More information about the lfs-support mailing list