LFS 6.5 Boot USB

Baho Utot baho-utot at columbus.rr.com
Wed Feb 24 15:34:40 PST 2010

I have finished my LFS 6.5 build

I now want to boot it from USB thumb drive.

Here is what I did

fdisk usb drive changing the partition type to 83 (linux)

mkfs.ext2 /dev/sdd1 ---/dev/sdd1 is the usb drive

mount /dev/sdd1 /media/disk

rsync -var /mnt/lfs/ /media/disk/

changed the /boot/grub/menu.lst on the sata raid array ( main storage 
system connected to the computer )
there are three drives in a raid 5 array that make the usb drive hd3 to grub
added entry
title LFS USB
root (hd3,0)
kernel /boot/lfskernel- root=/dev/sdd1 ro

changed the /etc/fstab to
# Begin /etc/fstab

# file system  mount-point      type    options                 dump  fsck
/dev/sdd1        /                     ext2     
defaults                   1     1
proc               /proc               proc     
defaults                   0     0
sysfs              /sys                  sysfs    
defaults                   0     0
devpts            /dev/pts            devpts  gid=4,mode=620      0     0
tmpfs             /dev/shm          tmpfs   defaults                    
0     0
# End /etc/fstab

Booted computer

The grub part worked as the kernel started, then failed with
Kernel panic - not syncing:VFS: Unable to mount root fs on unknown 

I tried changing the fstab entry to
UUID=d6cb4887-1eb2-4180-9566-391a8b3f7b45       /                     
ext2     defaults                   1     1

Still barfs with the above error

The kernel has ext2 and ext3 built in and I set all the USB options

Any one have any hints or see something I missed?

More information about the lfs-support mailing list