glibc errors

Mike McCarty Mike.McCarty at sbcglobal.net
Wed Feb 24 12:42:46 PST 2010


Louis Davies wrote:
> Hi,
> I am trying to install LFS version 6.5 on a machine with a mainboard VIA
> EPIA-M and a CPU VIA C3 which the producer declares as X686 compatible and
> my goal is obtaining a very lean system.
> I have some doubts about the declared compatibility of the CPU because when
> I tried to install Slackware 12.2 the installation process blocked and I had
> to do the installation with the kernel huge.smp.
> 
> I followed all the instruction written in the book but when I perform the
> glibc check written in 6.9 I obtain the final response:
> 
> make[1]: Target 'check' not remade because of errors.
> make[1]: Leaving directory '/sources/glibc-2.10.1'.
> make: *** [check] Error 2
> 
> If I run the command      grep Error glibc-check-log    the response is:
> 
> make[2]: *** [/sources/glibc-build/math/test-float.out] Error 132
> make[2]: *** [/sources/glibc-build/math/test-double.out] Error 132
> make[2]: *** [/sources/glibc-build/math/test-ldouble.out] Error 132
> make[2]: *** [/sources/glibc-build/math/test-idoubl.out] Error 132
> make[2]: *** [/sources/glibc-build/math/test-ifloat.out] Error 132
> make[2]: *** [/sources/glibc-build/math/test-idouble.out] Error 132

This looks like perhaps an FP unit incompatibility. Have you
tried some of the CPU defect checking programs around?

These errors may not have any practical meaning for you.

Mike
-- 
p="p=%c%s%c;main(){printf(p,34,p,34);}";main(){printf(p,34,p,34);}
Oppose globalization and One World Governments like the UN.
This message made from 100% recycled bits.
You have found the bank of Larn.
I speak only for myself, and I am unanimous in that!



More information about the lfs-support mailing list