Help compiling Gcc (chap. 5.5)

Timothy Legg lfs at timothylegg.com
Sat Feb 13 21:06:20 PST 2010


Hello,

First, thanks for creating this project.  I have been looking for
something like this for some time now.  I am eager to show people this
project once I get this to work for myself.


* I am using version 6.5 of the book
* All the software packages used are exact MD5SUM matches as in the book.
* I am preparing this on a 32-bit i686 machine, hosted with Debian Lenny.
* I have followed the instructions exactly as stated.
* Step 5.4.1 was completed successfully.


I unpacked mpfr and gmp and then created gcc-build to build gcc in.  When
I try to 'configure' before compiling, it fails because "Building GCC
requires GMP 4.1+ and MPFR 2.3.2+".  This is consistent with what I read
in Chapter 5.5.1, but I am not told what is to be done about it.  I moved
the mpfr and gmp directories to gcc-build, and it still didn't see the
files.

Should I compile them first?  It never told me to do that though.

Or maybe it is because I might have been in the wrong directory.  You see
the path here in this line is relative to the path given by 'pwd'.

   tar -jxf ../mpfr-2.4.1.tar.bz2

I was never told which directory I was supposed to be in when I executed
this, but it might have been incorrect.

I am looking for ideas.  It has been over 10 years since I have done this.


Tim Legg






More information about the lfs-support mailing list