ifconfig.eth0/ipv4 or ifcfg-eth0 why the difference

stosss stosss at gmail.com
Tue Feb 9 19:45:33 PST 2010


On Tue, Feb 9, 2010 at 7:19 PM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
> stosss wrote:
>> On Tue, Feb 9, 2010 at 1:42 PM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
>
>>> I see what the problem is.  The gateway is OK for /8, but wrong for /24.
>>>  IN a /24 network, the .0 address is the network address, not a host
>>> address.  You've set it up incorrectly on the LiveCD.  Either change the
>>> gateway to .1 or the prefix to 8 on the LiveCD instance.
>>
>> That LFS LiveCD 6.3 r2160 is setting the config itself.
>>
>> route -n shows:
>> Kernel IP routing table
>> Destination Gateway  Genmask        Flags  Metric  Ref Use Iface
>> 10.0.2.0    0.0.0.0  255.255.255.0  U      0       0   0   eth0
>> 0.0.0.0     10.0.2.2 0.0.0.0        UG     0       0   0   eth0
>
> This is fine, but the system that it is communicating with should
> have the same network mask.
>
>  > This is also the same for all my other VMs. VirtualBox sets all VMs to
>  > this private network and each one is completely separate from the
>  > others. If I set PREFIX=24 in my LFS build the kernel complains with
>  > FAIL.
>
> The kernel is not complaining, but the program or script setting the ip
> address is doing the complaining.
>
> You always solve these types of problems by doing the steps manually,
> not by scripts.
>
>   ip addr add 10.0.2.15/24 broadcast 10.0.2.255 dev eth0
>   ip link set eth0 up
>
> The route seems to be set up, but you would do that manually with
>
>   ip route add default via 10.0.2.0 dev eth0
>
> Once you get it to work manually, then we can address the scripts.

I tried the commands above but I don't know if I did things right
because I don't have any known correct information to work with.
Meaning the information I was trying to use to begin with. I don't
know if I am being understand and being given correct information to
work with. I am totally confused. Its like I am trying to build a
house on shifting sand, that won't work. I have not been able to
establish that I have a good point of reference to work from. Also the
information in the routing table above is not from the LFS VM I built
but is from the LiveCD I downloaded from the LFS site. I had nothing
to do with the way the CD is working or setting itself up. I simply
fired it up in a VM to see what it showed me hoping I could mimic the
same information in my LFS VM to see if it would work. It did not.

I understand that things have to be done manually when trying to solve
a problem. What I don't understand is some of what you are talking
about because I can't tell if you are understanding me. You probably
are but it must be going right over my head.

I will try it this way. If I have a problem getting a computer to
connect to a router I just look at the settings that the router is
using and then adjust the settings on my computer so it will connect.

With my LFS VM that I built, I set the network settings according to
what I thought they were supposed to be. Apparently I was wrong. The
two problems that I know I have are, one I don't know what tools I
have on this LFS system because the ones I am able to use on other
computers don't work because they are not installed. Two I can't
figure out how to look at the router information that VirtualBox is
providing to the VM (I know this part of my problem needs to be solved
some where else).

When I built LFS on a real machine connected to a real router and not
in a virtual environment I did not have any problem establishing a
network connection. I know what my current problem is. I just can't
figure out how to get the necessary information I need so I can fix
the problem.



More information about the lfs-support mailing list