ifconfig.eth0/ipv4 or ifcfg-eth0 why the difference

stosss stosss at gmail.com
Mon Feb 8 23:54:41 PST 2010


On Tue, Feb 9, 2010 at 2:39 AM, stosss <stosss at gmail.com> wrote:
> On Tue, Feb 9, 2010 at 2:32 AM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
>> stosss wrote:
>>
>>> When looking at the VM settings for the VMs the network adapter is set
>>> to NAT and the adapter type is:
>>>
>>> PCnet-FAST III (Am79C973)
>>>
>>> so the VMs are seeing the same thing that was set.
>>>
>>> Doing a Gogle search revealed that this is some how related to AMD.
>>
>> http://www.thonix.net/oldpage/linux/kernel/nicdriver.php
>>
>>> I decided to re-configure and re-compile my kernel, making sure AMD
>>> (my hardware is Intel, I left all AMD support out of the LFS system I
>>> built on the real machine and it ran fine without AMD support complied
>>> in) support was compiled in.
>>
>>> I added some more network things that I
>>> thought might fix it, but no joy.
>>
>> You don't say specifically what you tried.
>>
>> I think you need the following for VirtualBox:
>>
>>    CONFIG_AMD8111_ETH
>>
>> That's
>>   -> Device Drivers
>>    -> Network Device Support
>>     -> Ethernet (10 or 100Mbit)
>>      -> EISA, VLB, and PCI on board controllers
>>       -> AMD 8111
>>
> Okay I am going to try that.
>
I am re-building the kernel now with this one you suggested and the
one above it the AMD PCnet32.

I'm learning, I did not realize I needed to open that path and look in it.



More information about the lfs-support mailing list