Making progress - until GCC pass 2

stosss stosss at gmail.com
Sun Feb 7 10:05:33 PST 2010


On Sun, Feb 7, 2010 at 12:19 PM, David Shaw <dj.shaw at btconnect.com> wrote:
> Well, I've given up on 6.3 as I cannot get glibc to compile and I'm
> having problems downloading all the files needed for 6.6-rc1, so I
> decided to persevere with 6.5.
>
> I solved the glibc problems I was having with 6.5 (my base installation
> uses mawk instead of gawk and, although I had installed gawk and thought
> I'd set the link up correctly, obviously I did something wrong as it
> still pointed to mawk.  I corrected this and glibc compiled just fine.
> I am feeling rather unreasonably pleased with myself for having worked
> this out on my own :-)  )
>
> However, I am now having problems with section 5.10 - GCC pass 2,
> specifically the bit "The following command will change the location of
> GCC's default dynamic linker to use the one installed in /tools. It also
> removes /usr/include from GCC's include search path. Doing this now
> rather than adjusting the specs file after installation ensures that the
> new dynamic linker is used during the actual build of GCC. That is, all
> of the binaries created during the build will link against the new
> Glibc. Issue:
>
> for file in \
>  $(find gcc/config -name linux64.h -o -name linux.h -o -name sysv4.h)..."
>
> etc.  I've tried typing these commands into my terminal and everything
> seems to go in OK, except that after typing 'done', instead of the
> command executing (as I expected), I continue to get the '>' prompt and
> can only get out with a ctrl-C.

Show us exactly what you are typing. If you have it like this it will work:

for file in \
 $(find gcc/config -name linux64.h -o -name linux.h -o -name sysv4.h)
do
  cp -uv $file{,.orig}
  sed -e 's@/lib\(64\)\?\(32\)\?/ld@/tools&@g' \
  -e 's@/usr@/tools at g' $file.orig > $file
  echo '
#undef STANDARD_INCLUDE_DIR
#define STANDARD_INCLUDE_DIR 0
#define STANDARD_STARTFILE_PREFIX_1 ""
#define STANDARD_STARTFILE_PREFIX_2 ""' >> $file
  touch $file.orig
done



More information about the lfs-support mailing list