OK, I stumbled again on glibc

Ken Moffat zarniwhoop73 at googlemail.com
Mon Feb 1 15:39:32 PST 2010


On 1 February 2010 18:42, brown wrap <gramos at yahoo.com> wrote:
>
> When I run configure it says critical programs are too old or missing. I am logged into that window as user lfs. I looked at the environament and compared it to root's env and the paths looks the same. But if I run configure as root, I get no complaints. Here is the error, it looks to me likes its complaining about as and/or ld, but the paths to each is the same for both users:
>
> /mnt/lfs/sources/6.4/glibc-build$ ../glibc-2.10.1/configure --prefix=/tools     --host=$LFS_TGT --build=$(../glibc-2.10.1/scripts/config.guess)     --disable-profile --enable-add-ons     --enable-kernel=2.6.18 --with-headers=/tools/include     libc_cv_forced_unwind=yes libc_cv_c_cleanup=yesq../glibcq LDFLAGS=-L/usr/local/lib

 if user LFS has that spurious q../glibcq that might be enough to throw it.
OTOH, maybe that's an artefact of pasting into yahoo.

 FWIW, the cross ld *doesn't* work until glibc has been installed, but
cross as should be adequate.  I don't like your LDFLAGS either.

ĸen
--
After tragedy, and farce, "OMG poneys!"



More information about the lfs-support mailing list