OK, I stumbled again on glibc

brown wrap gramos at yahoo.com
Mon Feb 1 12:32:33 PST 2010


OK, I see where as and ld was built and installed in /tools/bin, but thats not the exact name:

lfs:/mnt/lfs/sources/6.4$ ls -l /tools/bin
total 55160
-rwxr-xr-x 1 lfs lfs 3633288 Feb  1 12:27 x86_64-lfs-linux-gnu-addr2line
-rwxr-xr-x 2 lfs lfs 3785792 Feb  1 12:27 x86_64-lfs-linux-gnu-ar
-rwxr-xr-x 2 lfs lfs 5103634 Feb  1 12:28 x86_64-lfs-linux-gnu-as
-rwxr-xr-x 1 lfs lfs 3611120 Feb  1 12:27 x86_64-lfs-linux-gnu-c++filt
-rwxr-xr-x 1 lfs lfs  592152 Feb  1 07:35 x86_64-lfs-linux-gnu-cpp
-rwxr-xr-x 2 lfs lfs  586625 Feb  1 07:35 x86_64-lfs-linux-gnu-gcc
-rwxr-xr-x 2 lfs lfs  586625 Feb  1 07:35 x86_64-lfs-linux-gnu-gcc-4.4.3
-rwxr-xr-x 1 lfs lfs   16005 Feb  1 07:35 x86_64-lfs-linux-gnu-gccbug
-rwxr-xr-x 1 lfs lfs  106301 Feb  1 07:35 x86_64-lfs-linux-gnu-gcov
-rwxr-xr-x 1 lfs lfs 4044995 Feb  1 12:28 x86_64-lfs-linux-gnu-gprof
-rwxr-xr-x 2 lfs lfs 5009402 Feb  1 12:28 x86_64-lfs-linux-gnu-ld
-rwxr-xr-x 2 lfs lfs 3675910 Feb  1 12:27 x86_64-lfs-linux-gnu-nm
-rwxr-xr-x 2 lfs lfs 4363631 Feb  1 12:27 x86_64-lfs-linux-gnu-objcopy
-rwxr-xr-x 2 lfs lfs 5061883 Feb  1 12:27 x86_64-lfs-linux-gnu-objdump
-rwxr-xr-x 2 lfs lfs 3785791 Feb  1 12:27 x86_64-lfs-linux-gnu-ranlib
-rwxr-xr-x 1 lfs lfs  698949 Feb  1 12:27 x86_64-lfs-linux-gnu-readelf
-rwxr-xr-x 1 lfs lfs 3663131 Feb  1 12:27 x86_64-lfs-linux-gnu-size
-rwxr-xr-x 1 lfs lfs 3640610 Feb  1 12:27 x86_64-lfs-linux-gnu-strings
-rwxr-xr-x 2 lfs lfs 4363630 Feb  1 12:27 x86_64-lfs-linux-gnu-strip

--- On Mon, 2/1/10, brown wrap <gramos at yahoo.com> wrote:

From: brown wrap <gramos at yahoo.com>
Subject: Re: OK, I stumbled again on glibc
To: "LFS Support List" <lfs-support at linuxfromscratch.org>
Date: Monday, February 1, 2010, 11:58 AM

That is the environment for the lfs user. I think I set it up correctly, but I am going through it again.





--- On Mon, 2/1/10, stosss <stosss at gmail.com> wrote:

From: stosss <stosss at gmail.com>
Subject: Re: OK, I stumbled again on glibc
To: "LFS Support List" <lfs-support at linuxfromscratch.org>
Date: Monday, February 1, 2010, 11:10 AM

> I think I followed the setup steps. Here is my lfs environment:
>
>
> lfs:/mnt/lfs/sources/6.4/glibc-build$ env
> LDFLAGS=-L/usr/local/lib
> TERM=xterm
> OLDPWD=/mnt/lfs/sources/6.4/glibc-2.10.1
> LC_ALL=POSIX
> LD_LIBRARY_PATH=/usr/local/lib
> LFS=/mnt/lfs
>
 PATH=/tools/bin:/bin:/usr/bin
> PWD=/mnt/lfs/sources/6.4/glibc-build
> LFS_TGT=x86_64-lfs-linux-gnu
> PS1=\u:\w\$
> SHLVL=1
> HOME=/home/lfs
> _=/bin/env
> lfs:/mnt/lfs/sources/6.4/glibc-build$

I see you are building a 64 bit system I have only built a 32 bit system.

The reason I asked if you followed 4.3 and 4.4 (if those are the
correct chapter sections for 6.4) is because you said things work as
root but not as LFS user. It sounds like you have issues with your LFS
user account. I would check to make sure that account is set up
correctly. The other problem which I know nothing about is a 64 bit
system misbehaves in ways that a 32 bit system does not.
-- 
http://linuxfromscratch.org/mailman/listinfo/lfs-support
FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page



      
-----Inline Attachment Follows-----

-- 
http://linuxfromscratch.org/mailman/listinfo/lfs-support
FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20100201/25fa0eaf/attachment.html>


More information about the lfs-support mailing list