OK, I stumbled again on glibc

brown wrap gramos at yahoo.com
Mon Feb 1 11:58:03 PST 2010


That is the environment for the lfs user. I think I set it up correctly, but I am going through it again.





--- On Mon, 2/1/10, stosss <stosss at gmail.com> wrote:

From: stosss <stosss at gmail.com>
Subject: Re: OK, I stumbled again on glibc
To: "LFS Support List" <lfs-support at linuxfromscratch.org>
Date: Monday, February 1, 2010, 11:10 AM

> I think I followed the setup steps. Here is my lfs environment:
>
>
> lfs:/mnt/lfs/sources/6.4/glibc-build$ env
> LDFLAGS=-L/usr/local/lib
> TERM=xterm
> OLDPWD=/mnt/lfs/sources/6.4/glibc-2.10.1
> LC_ALL=POSIX
> LD_LIBRARY_PATH=/usr/local/lib
> LFS=/mnt/lfs
> PATH=/tools/bin:/bin:/usr/bin
> PWD=/mnt/lfs/sources/6.4/glibc-build
> LFS_TGT=x86_64-lfs-linux-gnu
> PS1=\u:\w\$
> SHLVL=1
> HOME=/home/lfs
> _=/bin/env
> lfs:/mnt/lfs/sources/6.4/glibc-build$

I see you are building a 64 bit system I have only built a 32 bit system.

The reason I asked if you followed 4.3 and 4.4 (if those are the
correct chapter sections for 6.4) is because you said things work as
root but not as LFS user. It sounds like you have issues with your LFS
user account. I would check to make sure that account is set up
correctly. The other problem which I know nothing about is a 64 bit
system misbehaves in ways that a 32 bit system does not.
-- 
http://linuxfromscratch.org/mailman/listinfo/lfs-support
FAQ: http://www.linuxfromscratch.org/lfs/faq.html
Unsubscribe: See the above information page



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20100201/031380e9/attachment.html>


More information about the lfs-support mailing list