OK, I stumbled again on glibc

brown wrap gramos at yahoo.com
Mon Feb 1 10:42:51 PST 2010


When I run configure it says critical programs are too old or missing. I am logged into that window as user lfs. I looked at the environament and compared it to root's env and the paths looks the same. But if I run configure as root, I get no complaints. Here is the error, it looks to me likes its complaining about as and/or ld, but the paths to each is the same for both users:

/mnt/lfs/sources/6.4/glibc-build$ ../glibc-2.10.1/configure --prefix=/tools     --host=$LFS_TGT --build=$(../glibc-2.10.1/scripts/config.guess)     --disable-profile --enable-add-ons     --enable-kernel=2.6.18 --with-headers=/tools/include     libc_cv_forced_unwind=yes libc_cv_c_cleanup=yesq../glibcq LDFLAGS=-L/usr/local/lib

checking whether autoconf works... yes
configure: error:
*** These critical programs are missing or too old: as ld
*** Check the INSTALL file for required versions.
lfs:/mnt/lfs/sources/6.4/glibc-build$ 






      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20100201/8a1e8437/attachment.html>


More information about the lfs-support mailing list