RTNETLINK answers: invalid argument

Ivan Stefanischin ivan at stefanischin.eu
Sat Oct 27 04:46:11 PDT 2007


Hello all,

After I have build my LFS-System completely according the documentations 
of version 6.3 I tried to boot it. The kernel was build with the "make 
defconfig" command, to provide only the default functionalities and 
modules. After entering the third runlevel my local IP address was set 
to "192.168.178.20". After that the bootscript tried to add my default 
gateway with the following IP address: "192.168.178.1". The script uses 
following command to do this: ip route add default via 192.168.178.1 dev 
eth0. This errror occurs: "RTNETLINK answers: invalid argument". I think 
that's an invironmental problem, may be I forgot to set an option in the 
kernel configuration or something linke that. However, I don't know how 
to configure the kernel so that RTNETLINK works properly. All 
funktionalities of the "ip" command are working fine, just when a 
combination with "via" is used it prints out this error.

Excuse my bad english, I'm just a german.

Please help me.



More information about the lfs-support mailing list