lfslivecd-x86_64-6.3-r2014 6.23. Perl-5.8.8 make fails

Ken Moffat ken at linuxfromscratch.org
Sat Oct 20 16:21:16 PDT 2007


On Sun, Oct 21, 2007 at 12:10:07AM +0200, Danny Engelbarts wrote:
> 
> I'm not sure why i got this error, searching it on google i only got 4 hits 
> which leades me to believe it's rather rare ... i must add that, allthough i 
> used gcc-4.1.2 for my toolchain, i decided to use 4.2.2 in step 6.12 hoping 
> that would save me the trouble of upgrading later. Might this have caused 
> perl to fail?
> 
 Well-known problem caused by the gcc change.  But, by using a
_different_ toolchain in the final system from what you used in the
temporary system, you've abandoned any ideas of of toolchain purity.

 Changing the version of gcc isn't always trivial.  If you are ready
to play with new versions of packages, consider following the
development book.  But, x86_64 isn't supported yet (except by clfs).
I would point you to the jh branch, which does cover x86_64, but you
would need the tools to download and render it (and at the moment it
doesn't cover bootloaders).

 Nobody here is building gcc-4.2.2 against the old binutils and
glibc, so you may encounter new problems when you come to build
whatever parts of blfs (or cblfs) you want.

 Testing builds with new versions of packages is good.  But if you
are going to do that, sometimes the resulting system will have
showstopper problems so keep a known good system.  And don't get
fixated on "newer must be better" - sometimes it is, but not always.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-support mailing list