lfslivecd-x86_64-6.3-r2014 6.23. Perl-5.8.8 make fails

Danny Engelbarts d.engelbarts at gmail.com
Sat Oct 20 15:10:07 PDT 2007


Hi,

While building perl on my system with the x86_64-6.3-r2014 livecd i got the 
following error:

make: *** No rule to make target `<command-line>', needed by `miniperlmain.o'.  
Stop.

I was able to resolve this error using the patch in this mail;

http://www.nntp.perl.org/group/perl.perl5.porters/2006/11/msg117738.html

I'm not sure why i got this error, searching it on google i only got 4 hits 
which leades me to believe it's rather rare ... i must add that, allthough i 
used gcc-4.1.2 for my toolchain, i decided to use 4.2.2 in step 6.12 hoping 
that would save me the trouble of upgrading later. Might this have caused 
perl to fail?

Regards, Danny.



More information about the lfs-support mailing list