Chapter 6 Glibc Make error (probably fixed)

Matthew Sewell matthewsewell at ojai.net
Sun Oct 14 19:24:45 PDT 2007


I believe I have discovered the problem.

When I built the perl binaries, I used an improper nomenclature.   
Rather than the correct name of '/tools/lib/perl5/5.8.8', I  
mistakenly named the directory '/tools/lib/perl5/perl5.8.8'.  It  
looks like I was so exited to be nearing the chroot environment that  
I became careless ;)



On Oct 14, 2007, at 3:30 PM, Bauke Jan Douma wrote:

> Matthew Sewell wrote on 14-10-07 21:54:
>> Please forgive me if this has already been discussed:
>>
>>
>> I just had an error attempting to build Glibs as per chapter 6.
>>
>> -----------------------------
>> no gen-translit.pl < C-translit.h.in > C-translit.h.tmp
>> /bin/sh: line 1: no: command not found
>> make[2]: *** [C-translit.h] Error 127
>> make[2]: Leaving directory `/root/libc/locale'
>> make[1]: *** [locale/subdir_lib] Error 2
>> make[1]: Leaving directory `/root/libc'
>> make: *** [all] Error 2
>> -------------------------------
>>
>> I worked around the problem by modifying the Makefile to point  gen-
>> translit.pl to /usr/bin/perl.  It had been pointed at $(PERL).
>>
>>
>> *Have I missed something crucial in previous instructions or is this
>> a bug?
>>
>> *Will this workaround cause other problems down the line?
>>
>> Thanks
>>
>> --matthew
>
> My glibc make.res log file has:
> /usr/bin/perl gen-translit.pl < C-translit.h.in > C-translit.h.tmp
>
> In glibc's configure you'll find this:
> test -z "$ac_cv_path_PERL" && ac_cv_path_PERL="no"
>
> Apparently it can't find the perl binary.  Did you configure
> glibc with some (incorrect) --with-perl=... parameter, or have
> an env. value PERL set (wrongly)?
>
> bjd
>
>
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page




More information about the lfs-support mailing list