LFS 6.0 Cp 6: perl 5.8.5 make failes

kaladen kaladen at cox.net
Sat Feb 26 22:51:09 PST 2005

Klaus Dimde wrote:
> Hi again,
> after a successful build till chapter 6.33 on an AMD64 machine, perl make 
> failes with:
> cc -L/usr/local/lib -o miniperl \
>     miniperlmain.o opmini.o libperl.a
> libperl.a(pp.o)(.text+0x2803): In function `Perl_pp_pow':
> : undefined reference to `pow'
> libperl.a(pp.o)(.text+0x357d): In function `Perl_pp_modulo':
> : undefined reference to `floor'
> [... some more undefined references to math functions...]
> collect2: ld returned 1 exit status
> make: *** [miniperl] Error 1
> I even tried to modify the patch for chapter 5 to point to /lib64 instead 
> of /lib and symlinked /lib to /lib64. But still the same error. Any ideas? 
> More infos:
> Host-System: Suse 9.1
> gcc, binutils were compiled with --without-multilib and --disable-multilib in 
> difference to the book and I used /lib64 wherever the boot said /lib.
> Need more infos?
> Greetings
> Klaus

It is a path problem, I ran into the same thing.  I am attaching a patch 
I used, altough it is not mine, I believe it is from Chris Lingard and 
Jeremy Utley.  There are several places that the path needs to be 
changed and this patch should cover it.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: perl-5.8.5-x86_64.patch
Type: text/x-patch
Size: 6434 bytes
Desc: not available
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20050227/b853ec74/attachment.bin>

More information about the lfs-support mailing list