Can't find /tools/bin/bash for initial chroot, and /tools/bin/bash is bad too.

Carsten Böcker lfs at
Sat Feb 19 23:30:23 PST 2005

Steven Pasternak wrote:

>Hi. I use LFS 6.0 with some slightly newer packages and have run into a few 
>problems. I just finished the test suite and when I go to use the chroot 
>thing (chapter 6) I get this:
>[root at localhost steven]# chroot "$LFS" /tools/bin/env -i \
>>    HOME=/root TERM="$TERM" PS1='\u:\w\$ ' \
>>    PATH=/bin:/usr/bin:/sbin:/usr/sbin:/tools/bin \
>>    /tools/bin/bash --login +h
>/tools/bin/env: /tools/bin/bash: No such file or directory
>[root at localhost steven]#
>I check and /tools/bin/bash is there, if /mnt/lfs is the root or if the 
>current root is being concidered the root for this. But that is not 
>all, /tools/bin/bash is bad too. If I open a shell with it, I can type 
>commands that are part of bash (if, case, etc.) and they work, but other 
>commands that are seperate files (ls, cp, gcc, etc.) do what they are 
>supposed to, but never return to the prompt. It looks like this:
>[root at localhost steven]# /tools/bin/bash
>[root at localhost steven]# ls
>bin/                       gstreamer-plugins-0.8.4-2mdk.src.rpm  src@
>cabextract-0.6-1.i386.rpm  ifplugd-0.25-1mdk.i586.rpm            tmp/
>dead.letter                initscripts-7.61.1-17mdk.i586.rpm     
>Desktop/                   kernel-   winetools/
>Documents/                 Mail/                                 
>*         mw-dictionary.src
>*        sound-scripts-0.07-1mdk.noarch.rpm
>but the prompt never returns, I have tried to rebuild it, re-downloaded the 
>source, and even tried bash 2.05b with no luck. I upgraded to glibc 2.3.4 
>(and the glibc-linuxthreads tarball that was next to it) and kernel 2.6.9 
>(linux-libc-headers- also), but haven't had a problem with that. If I 
>use the /bin/bash executable with my host distro (mandrake 10.0) it works 
>(not the chroot part, it is still blind, though). This is my first LFS and I 
>am stumped. Please Help!
I've got the same problem (bash hanging after typing in a command),
this one helped for me:

there is a patch to fix this - it is in the patches archive, and is called 

apply the patch to the bash sources, recompile, install, and you should be 

-- -
Steve Crosby

More information about the lfs-support mailing list