GCC Problems Installing LFS 5.1.1 on Sparc Ultra-5

Ken Moffat ken at kenmoffat.uklinux.net
Thu Feb 17 10:41:20 PST 2005

On Thu, 17 Feb 2005, Mike Liford wrote:

> I'm trying to install LFS 5.1.1 on an Sun Ultra-5 using Aurora 1.0 as
> the host distribution. Aurora 1.0 is just installed and clean. My only
> deviation from the book is that I'm using the same partition following
> the additional instructions for a side-by-side installation.
> GCC-Core-3.3.3 Pass 1 configure script output a message about this
> configuration not being supported as shown in the attached file
> configure.output. Don't understand and don't know if this is important.

it's hard to quote attachments, but it looked not unreasonable (yes,
I'm hedging my bets, the unsupported in libstdc++v3 might cause
problems later), other than that some unsupported messages are normal
on non x86.

> The rest of the configuration seemed to go fine. Compilation ended in an
> error as shown in the attached file gcc-core-3.3.3.error. Notice the
> multiple "mv: cannot stat" output lines about the middle of the file.

Some of these are totally unfamiliar to me, but for starters you should
check if you have installed everything you need from aurora,
particularly -static and -devel packages for binutils, gcc, glibc.

> Attempted to install the GCC-3.3.3 tarball with the Pass 1 instructions
> and with the same result as the above paragraph.

Don't try to install after the build fails :)  At best, you'll get the
same error, at worst the install will attempt to run and produce a lot
of spurious errors because some of the files never got built [ e.g.
glibc - I've done that when I missed an '&&' in a script ].

> Attempted to install the GCC-2.95.3 tarball with the Pass 1
> instructions. The resulting error is shown in the attached file
> gcc-2.95.3.error. Notice the architecture warnings and the many
> undefined references.

I wouldn't even try to build 2.95.3 at this point - unless the weird
error messages ring any bells with anybody, I doubt it will help.

You may be happy to ignore the 64-bit-kernel and 32-bit-userspace
issues, but I suspect they could be related to your problems.  A quick
look at the archives suggests your box has to have a 64-bit kernel, so
you'll need to build a 64-bit binutils and gcc before you are through.

I've taken a quick look at aurora - the 1.0 release is somewhat old, and
based on the abberant gcc-2.96.  Upgrading it to 1.92 is documented but
looks a lot of work and anyway it would leave you with a _newer_
toolchain than LFS-5.1, which would probably bring its own problems
since these are all RH or fedora based (e.g. search the archives for
problems building 5.1 on recent fedora).

 Possibly, you need to get the _source_ rpms for the 1.91 or 1.92
toolchain (or at least for binutils and gcc) and look to see what
compiler options are used (remembering, of course, that they aim to
install into /usr), and indeed looking for any platform-specific
patches.  You will gather I know nothing about sun boxes, so you might
want to treat all of this with the proverbial grain of salt. Oh, and
almost everybody except LFS used hjl binutils in the LFS-5.1 days - you
_might_ do better with instead of 2.14, but then you'd need
to add m4, bison, and flex (in that order) at the end of chapter 5.

OTOH, if you've already build other recent LFS systems, then maybe you
should search out Ryan's cross-lfs scripts.  There's a chunk of
sparc-specific stuff in some of those, although I don't know if it's
appropriate to ultrasparc.  I'm not suggesting you cross build from
sun, but that you treat your aurora as an unreliable host!

 das eine Mal als Tragödie, das andere Mal als Farce

More information about the lfs-support mailing list