Kernel panic problem and unable to chroot

Joe Ciccone jciccone at
Tue Feb 15 11:04:05 PST 2005

when running 2.9 adjusting the toolchain you need to update the spec
file on the toolchain and then use the compiled packages in the
toolchain to build the system. to accomplish this ammend the path as
   export PATH=/tools/bin:$PATH
then run the script in 5.9 adjusting the toolchain to change the
linker from /lib/ to /tools/lib/linux.ld.so2. from here
you need to recompile all of the packages past 5.9.

On Sat, 12 Feb 2005 05:39:14 -0800 (PST), senthil at
<senthil at> wrote:
> Hi List,
>           Thanks for responding to the /boot/grub/menu.lst issue. I
> resolved and got past it, and now when I was booting my LFS, I
> got the following messages:
> Freeing unused Kernel Memory: 184K Freed
> Warning: Unable to open an Intial Console
> Kernel Panic: No Init found. Try Passing init= option to the kernel
> -- I searched the archives for this problem and found Gerard's reply to
> same to check /mnt/lfs/dev/console.
> Yeah, I had to create a console file and I wanted to create that.
> So, I tried to chroot to create it:
> using section: 6.61
> chroot "$LFS" /usr/bin/env -i HOME=/root TERM="$TERM" PS1='\u:\w\$ '
>    PATH=/bin:/usr/bin:/sbin:/usr/sbin  /bin/bash --login
> But this gave me Error:
> chroot: Cannot Run Command '/usr/bin/env' : No such file or directory.
> I found this in FAQ, but it could not help me. I had done this step with
> the previous boot successfully where I changed menu.lst. Now this error is
> preventing me to proceed further.
> 1)export LFS=/mnt/lfs
> 2) ln -s $LFS/tools /
> were also tried. (I dont know if they were really neccessary)
> My Questions are:
> - How can chroot now so that I can create the console file?
> - What further steps needed to resolve Kernel Panic: No Init Found: Try
> passing init= option to Kernel
> I am using LFS 6.0 online version.
> Regards,
> Senthil
> --
> FAQ:
> Unsubscribe: See the above information page

More information about the lfs-support mailing list