Starter Problem with Binutils.

Knoppix User knoppix at
Sat Feb 5 22:37:38 PST 2005

spamtrap2 at wrote:
> Hi everyone:
> After a pause, I setup my system and decided to try LFS again. However, I am encountering some basic startup problems. I checked the FAQ and couldn't find assistance to my problem.
> Background Info.:
> a). My parent system is Damn Small Linux Version 8.4
> b) My Attempt: LFS Version 5.1.1
> Error 1
> lfs at 8[binutils-2.14]$ sudo time { ./configure ... && ... && ... && make install; }
> bash: syntax error near unexpected token `}'
> Error 2
> lfs at 5[binutils-build]$ ../binutils-2.14/configure --prefix=/tools --disable-nls
> loading cache ./config.cache
> checking host system type... i586-pc-linux-gnuoldld
> checking target system type... i586-pc-linux-gnuoldld
> checking build system type... i586-pc-linux-gnuoldld
> ../binutils-2.14/configure: line 2206: cc: command not found
> *** The command 'cc -o conftest -g conftest.c' failed.
> *** You must set the environment variable CC to a working compiler
> Solution Tried for Error 2:
> I tried gcc -v, it returned command not found. I also searched manually for gcc in /usr/bin and /usr/lib along with a fwe other directories. ALso tried the where is and find commands for /gcc. None helped to locate the /gcc .
> Please assist.
> Thanks.
> Vijay

Poorman's intall for Knoppix to HD solved this problem. This was also 
another good learning experience.

Thanks to all for the suggestions leading to this. :)

Now here are more new issues. Please assist.

lfs at ttyp0[binutils-build]$ { ./configure ... && ... && ... && make 
install; }
bash: ./configure: No such file or directory
lfs at ttyp0[binutils-build]$ ../binutils-2.14/configure --prefix=/tools 
bash: ../binutils-2.14/configure: No such file or directory
lfs at ttyp0[binutils-build]$ cd
lfs at ttyp0[~]$ cd /mnt/hdb5/lfs-packages/binutils-2.14
lfs at ttyp0[binutils-2.14]$ ../binutils-2.14/configure --prefix=/tools 
../binutils-2.14/configure: line 422: ./config.log: Read-only file system
lfs at ttyp0[binutils-2.14]$ make configure-host
make: *** No rule to make target `configure-host'.  Stop.
lfs at ttyp0[binutils-2.14]$ make LDFLAGS="-all-static"
make: *** No targets specified and no makefile found.  Stop.


More information about the lfs-support mailing list