Starter Problem with Binutils.

David Dombroski davedom at
Sat Feb 5 15:38:30 PST 2005

spamtrap2 at wrote:
> Hi everyone:
> After a pause, I setup my system and decided to try LFS again. However, I am encountering some basic startup problems. I checked the FAQ and couldn't find assistance to my problem.
> Background Info.:
> a). My parent system is Damn Small Linux Version 8.4
> b) My Attempt: LFS Version 5.1.1
> Error 1
> lfs at 8[binutils-2.14]$ sudo time { ./configure ... && ... && ... && make install; }
> bash: syntax error near unexpected token `}'
> Error 2
> lfs at 5[binutils-build]$ ../binutils-2.14/configure --prefix=/tools --disable-nls
> loading cache ./config.cache
> checking host system type... i586-pc-linux-gnuoldld
> checking target system type... i586-pc-linux-gnuoldld
> checking build system type... i586-pc-linux-gnuoldld
> ../binutils-2.14/configure: line 2206: cc: command not found
> *** The command 'cc -o conftest -g conftest.c' failed.
> *** You must set the environment variable CC to a working compiler
> Solution Tried for Error 2:
> I tried gcc -v, it returned command not found. I also searched manually for gcc in /usr/bin and /usr/lib along with a fwe other directories. ALso tried the where is and find commands for /gcc. None helped to locate the /gcc .
> Please assist.
> Thanks.
> Vijay

I didn't look into the first problem, but the second appears to be that 
Damn Small Linux doesn't include the GCC compiler. I'm not sure if there 
is a Live CD for LFS 5.1.1, but that might be the direction to look in :)

More information about the lfs-support mailing list