Maru Dubshinki marudubshinki at gmail.com
Thu Feb 3 17:20:30 PST 2005

'Lo all.
I am trying to install LFS on my laptop, from an up-to-date Ubuntu
'Warty Warthog' distribution, using yesterday's snapshot of LFS, and
the packages are testing.
I had no problems installing the first toolchain, although I did get
many error1s and 2s relating to travelling in directories, I don't
think they are relevant.
My problems start after I installed TCL, and tried to do Expect.  I
extracted the package to a separate directory in $LFS/source, and did
the ./configure command precisely as formatted.  It ran for a while
and the final output looked like this:

checking for timezone... yes
checking for siglongjmp... yes
checking for memcpy... yes
checking if WNOHANG requires _POSIX_SOURCE... no
checking if any value exists for WNOHANG... configure: error: Expect
can't be cross compiled

This deeply puzzled me as $_POSIX_SOURCE either doesn't exist on my
system, or is blank (echo $_POSIX_SOURCE returns a blank line.).  So,
I reextracted everything, and tried again, but this time I tried
commenting out the offending lines in the configure shell file that
dealt with WNOHANG.  This only resulted in several many errors saying
the command 'fi' is not recognized. And when I search-and-replaced
'fi' after a check of Apt and Google returned no recognizable Linux
commands like that, it just choked.
So I'm at a loss.
And yes, I did apply the expect-5.42.1-spawn-1.patch.

Microsoft delenda est.

More information about the lfs-support mailing list